18:04:15 <cait> #startmeeting
18:04:15 <huginn> Meeting started Tue Jun 14 18:04:15 2011 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:15 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:04:22 <wizzyrea> I also have them :)
18:04:37 <cait> let's start with introductions
18:04:38 <Waylon> OOOOO, huginn has had an upgrade... nice...
18:04:43 <cait> #topic introductions
18:04:56 * nengard Nicole C. Engard, Documentation Manager & ByWater Solutions
18:04:58 * wizzyrea Liz Rea, NEKLS (Kansas USA)
18:05:01 * slef MJ Ray, software engineering specialist, software.coop
18:05:01 * magnuse Magnus Enger, Libriotech, Norway (will have to run in an hour)
18:05:09 * cait Katrin Fischer, BSZ
18:05:22 <thd> Thomas Dukleth, Agogme, New York City
18:05:23 <drojf> Mirko Tietgen, Humboldt-Universität zu Berlin, Germany (first time lurker;)
18:05:29 <slef> err I'm going to get a kick... why don't we #info these?
18:05:38 <slef> then they'd appear in the minutes
18:05:53 <slef> #info MJ Ray, software engineering specialist, software.coop
18:05:54 <tajoli> Zeno Tajoli, CILEA, Italy
18:05:56 <magnuse> good idea, slef
18:05:57 <wizzyrea> #info Liz Rea, NEKLS, KS USA
18:05:58 <nengard> so you want us to put #info in front of our names?
18:06:02 <wizzyrea> why not
18:06:03 <ricmarques> Ricardo Dias Marques... from Portugal (occasional translator and patch submitter)
18:06:05 <slef> like that
18:06:09 <magnuse> #info Magnus Enger, Libriotech, Norway (will have to run in an hour)
18:06:10 <cait> #info Katrin Fischer, BSZ
18:06:10 <nengard> #info Nicole C. Engard, Documentation Manager & ByWater Solutions
18:06:14 <thd> #info Thomas Dukleth, Agogme, New York City
18:06:34 <drojf> #info Mirko Tietgen, Humboldt-Universität zu Berlin, Germany
18:06:36 <slef> one less job to do :)
18:06:40 <magnuse> welcome drojf ;-)
18:06:41 <thd> :)
18:06:44 <magnuse> yay
18:06:47 <cait> slef++ :)
18:06:50 <drojf> thx magnuse :)
18:06:55 <thd> slef++
18:07:14 <tajoli> #info Zeno Tajoli, Italy, translation and patch
18:07:15 <cait> ok, let's start with the first item on the agenda
18:07:20 <Waylon> #info Waylon, Mandumah.com (arabic digital library archive), based in Saudi Arabia... I am in New Zealand
18:07:24 <ricmarques> #info Ricardo Dias Marques... from Portugal (occasional translator and patch submitter)
18:07:40 <cait> ready?
18:07:50 <cait> #topic Formally Close 3.0?
18:07:58 <wizzyrea> do it
18:08:09 <cait> ok, i think hdl said he will not be able to attend the meeting
18:08:15 <magnuse> yup
18:08:20 <slef> Have there been any offers to adopt it?
18:08:26 <wizzyrea> he's gone on record stating it's his intention to close it
18:08:28 <nengard> +1 to closing
18:08:29 * magnuse has not seen any
18:08:37 <Waylon> How much work is involved in adopting it?
18:08:53 <slef> #link http://librarypolice.com/koha-meetings/2011/koha.2011-05-11-02.01.html "Should 3.0 not be adopted by an RM by next meeting, it will be a very dead parrot"
18:09:06 <cait> Waylon: I think another release only makes sense if you have people writing bug fixes for it
18:09:07 <wizzyrea> Waylon: you would want to consult any of the release maintainers
18:09:27 <ricmarques> Waylon: I would say ONLY to offer to fix / accept fixes for any outstanding bug that gets reported.
18:09:41 <slef> Waylon: depends how many bugs are reported against it, but I think a minimum would be backporting the security fixes from late 3.2
18:09:45 <cait> and we currently do 3.2.x and 3.4.x bugfix releases
18:10:27 <ricmarques> slef++
18:10:32 <paul_p> hello, sorry to be late, i've problems with my internet access
18:10:33 <slef> Waylon: difficulty/risk of having to rewrite things yourself would increase as current development gets further away
18:10:45 <slef> paul_p: welcome. Sorry to hear that.
18:10:46 <jwagner> Jane Wagner Liblime/PTFS (chiming in a bit late)
18:11:01 * paul_p Paul Poulain, BibLibre
18:11:16 <ricmarques> Welcome Paul... Jane
18:11:26 <Waylon> the digital library archive im working for, has used it as the base.. so i am quite familar with at least the auth, search, branches and member modules and scripts.
18:11:38 <thd> paul_p: add #info in front of your information
18:11:43 <Waylon> but.. yeah.. sounds like alot of work for a dead parrot.
18:11:50 <paul_p> #info Paul Poulain, BibLibre
18:12:23 <gmcharlt> Galen Charlton, Equinox
18:12:31 <cait> ok, so how can we proceed on this?
18:12:43 <ricmarques> I admit I'm still running a 3.0.x installation. That's the problem of having many other non-Koha related tasks where I work (few time to test / do an upgrade)
18:12:45 <ColinC> Colin Campbell, PTFS Europr
18:12:52 <thd> gmcharlt: add #info in front of your information for autominutes
18:12:57 <oakivil> #info Olli-Antti Kivilahti, Library of Joensuu, Open Library 2013
18:13:03 <slef> Waylon: do you need to fix security/serious bugs anyway? If so, it would be a great give-back to share
18:13:06 <gmcharlt> #info Galen Charlton, Equinox
18:13:07 <wizzyrea> I formally propose to close version 3.0, until such time as it has an adoptive RMaint
18:13:15 <nengard> +1
18:13:23 <gmcharlt> +1
18:13:26 <cait> Colin, jwagner: can you please do the #info too? for the minutes
18:13:30 <magnuse> the last minutes said "Should 3.0 not be adopted by an RM by next meeting, it will be a very dead parrot." there is no new RM so it's dead
18:13:32 <ColinC> #info Colin Campbell PTFS-Europe
18:13:33 <slef> Waylon: but planning an escape to 3.2 or 3.4 would be my advice.
18:13:47 <cait> wizzyrea: +1
18:13:56 <slef> magnuse: +1
18:14:28 <slef> so it's dead unless someone steps forwards to propose themselves in a future meeting
18:14:29 <cait> ok. so let's have a last vote - vote +1 for closing 3.0
18:14:32 <slef> +1
18:14:34 <Waylon> slef: agreed. as it is, im not up to date on security fixes and bugs and such. the git tree's been sawn in half and burned.
18:14:38 <ColinC> +1
18:14:38 <paul_p> +1
18:14:39 <magnuse> +1
18:14:40 <cait> +1
18:14:41 <drojf> +1
18:14:42 <thd> +1
18:14:42 <Waylon> +1
18:14:45 <ricmarques> I'd say "+1" (but I would like to have some link with some text to invite future Release Maintainers)
18:14:55 <tajoli> +1
18:15:00 <wizzyrea> ricmarques: that's easy enough.
18:15:01 <paul_p> (we still have a few libraries running 3.0, but plan to move them to 3.4 asap)
18:15:13 <slef> ricmarques: I think there was one
18:15:14 <thd> ricmarques++
18:15:19 <cait> #info Vote is to formally close 3.0
18:15:23 <ricmarques> thd: thanks :)
18:15:46 <slef> #link http://lists.koha-community.org/pipermail/koha-devel/2011-May/035542.html
18:15:55 <slef> "If anyone is interested in taking that action, please step in onlist and ask for access"
18:15:57 <cait> thx slef
18:15:58 <jwagner> #info Jane Wagner, LibLime/PTFS
18:16:01 <thd> This vote could never stop anyone from volunteering
18:16:16 <wizzyrea> safe to say no naysayers, vote carries?
18:16:26 <slef> move on cait! ;-)
18:16:28 <cait> ok
18:16:38 <wizzyrea> #info proposal to close 3.0 passed with no naysayers
18:16:40 <cait> #topic Update on Roadmap to 3.2
18:16:45 <cait> chris_n: ping
18:17:08 <ricmarques> wizzyrea: Yep...The text that hdl put seems in the Link slef put looks great to me ("If anyone is interested in taking that action, please step in onlist and ask for access.")
18:17:08 <cait> as chris_n seems not to be around, can someone else say something about this?
18:17:46 <slef> #link http://wiki.koha-community.org/wiki/Roadmap_to_3.2#Release
18:17:48 <cait> ok, I think there was a message on the translator's list
18:18:15 <cait> there is some translation work to do and a release can be postponed if necessary
18:18:16 <slef> Looking at that, I think there are 2 blockers still needing attention
18:18:21 <cait> does someone have the link to the mail perhaps?
18:18:29 <tajoli> In fact the last commit of 3.2 was done for a marc21 fix
18:18:37 <slef> bug 3624
18:18:37 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3624 blocker, PATCH-Sent, ---, paul.poulain, REOPENED , Basket group delivery place
18:18:48 <slef> bug 5449
18:18:48 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5449 blocker, PATCH-Sent, ---, brice.sanchez, ASSIGNED , JSON malformed in Koha - Blocker with jQuery 1.4.x
18:19:18 <tajoli> I sponsor the bug Bug 3013
18:19:18 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=3013 normal, PATCH-Sent, ---, salva, RESOLVED FIXED, Value builder for 006 and 008 need choices for all format types
18:19:45 <tajoli> is a feature of Amicus, not present in Koha
18:20:01 <wizzyrea> #link http://koha.1045719.n5.nabble.com/Koha-3-2-8-is-now-available-td4398256.html
18:20:04 <slef> cait: do you mean http://lists.koha-community.org/pipermail/koha-translate/2011-June/001584.html ?
18:20:25 <tajoli> The biggest italina Koha user is an ex-Amicus
18:20:27 <cait> hm no, it's ok
18:20:49 <wizzyrea> there was an announcement in the 3.2.8 release notes
18:20:57 <tajoli> But I have done the new translation, as I know
18:20:58 <wizzyrea> "Important announcement concerning 3.2.cx EOL
18:21:02 <wizzyrea> "
18:21:09 <wizzyrea> at the link I pasted above
18:21:17 <cait> #link http://lists.koha-community.org/pipermail/koha-translate/2011-June/001605.html
18:21:31 <slef> #link http://koha-community.org/koha-3-2-8/
18:21:32 <cait> ok
18:21:50 <slef> #info "After 3.2.10 or 04/15/2011, a motion will be made at the August 2011 general IRC meeting to officially announce EOL"
18:22:34 <ricmarques> Already near killing 3.2.x?! Gee... You move fast.
18:22:35 <slef> was repeated in
18:22:42 <slef> #link http://koha-community.org/koha-3-2-9/#more-2321
18:23:02 <slef> ricmarques: a motion. We can persist if enough people want it.
18:23:22 <slef> ricmarques: given the changes to templates, maybe there will be some libraries willing to fund life-support for 3.2?
18:23:30 <wizzyrea> ricmarques: with new versions coming every 6 mo, there seems little reason to keep a lot of back versions
18:23:35 <Waylon> wow. We just killed 3.0.. now we're killing 3.2?
18:23:42 <wizzyrea> in AUGUST.
18:23:58 <paul_p> Waylon, nope, we PLAN to "kill" 3.2 in AUGUST
18:24:16 <slef> no, we PLAN to PLAN killing 3.2 in AUGUST :)
18:24:23 <ricmarques> slef: LOL!
18:24:26 <paul_p> slef lol
18:24:33 <cait> ok, want to #info something?
18:24:38 <oakivil> but that bureucracy
18:24:48 <ricmarques> I admit I'm more of a fan of ... err... "longer-lived" releases
18:24:49 <wizzyrea> #info the plan is to plan to talk about possibly EOL'ing 3.2 in AUGUST.
18:24:50 <paul_p> cait, plan to plan is a good info I think ;-)
18:24:56 <cait> yep
18:24:59 <cait> ok. let's move on
18:25:01 <slef> wizzyrea: :P
18:25:02 <cait> #topic Update on Roadmap to 3.4
18:25:07 <Waylon> Close, and depreciate the RM for 3.2, or just cease active work on it?
18:25:08 <wizzyrea> slef ;)
18:25:24 <slef> #link http://wiki.koha-community.org/wiki/Commits_to_cherry-pick_for_3.4
18:25:29 <slef> Waylon: to be decided
18:25:33 <ricmarques> Waylon: No need to depreciate the RM for 3.2... He's a good fellow!  ;-)
18:25:40 <slef> Waylon: think about what you would prefer
18:25:43 <paul_p> as usual, if someone volunteer to be RMAint for 3.2, then no end
18:25:44 <wizzyrea> should there be a volunteer to rmaint, I imagine it could be managed
18:26:14 <cait> rangi: ping
18:26:33 <wizzyrea> #info As with 3.0, if there is a volunteer to take over RMaint for 3.2, that release can live on. Even so, that discussion will happen in August 2011.
18:26:49 <ricmarques> cait: I'm guessing rangi is still sleeping? Current time in NZ?
18:26:51 <rangi> hello
18:26:56 <cait> ah
18:26:58 <ricmarques> My mistake! :)
18:26:58 <cait> there he is
18:26:59 <Waylon> about 6:30..
18:27:00 <wizzyrea> nope
18:27:05 <library_systems_guy> cait are you back?
18:27:17 <ajmalkhan> hi meeting started?
18:27:25 <wizzyrea> yes
18:27:32 <cait> can you say something about 3.4?
18:27:36 <slef> ajmalkhan: hi yes. See http://librarypolice.com/koha-meetings/2011/koha.2011-06-14-18.04.log.txt
18:27:57 <rangi> wanna do the topic thing?
18:28:05 <rangi> or not bothering with that ?
18:28:06 <nengard> she already ddi
18:28:07 <nengard> did
18:28:25 <ajmalkhan> how to copy this link in this applet
18:28:25 <cait> for 3.4 - but we can move on to 3.6
18:28:41 <rangi> ahh, yeah 3.4 is chris_n
18:28:55 <cait> ok, let's talk about 3.6 zhrn
18:28:57 <cait> then..
18:29:02 <cait> #topic Update on Roadmap to 3.6
18:29:38 <rangi> its in progress,
18:29:47 <slef> #link http://koha-releasemanagement.branchable.com/posts/Work_for_3.6.x/
18:29:48 <rangi> you can track the progress at http://koha-releasemanagement.branchable.com/posts/Work_for_3.6.x/
18:29:49 <rhcl> sorry for late checkin - rhcl = Greg Lawson @ Rolling Hills Consolidated Library
18:29:51 <tcohen> Tomas Cohen, Universidad Nacional de Cordoba
18:30:03 <slef> #link http://bugs.koha-community.org/cgi-bin/progress.pl
18:30:31 <sekjal> Ian Walls, ByWater Solutions, 3.6 QA Manager (sorry I'm late, I'm on a bus)
18:30:53 <cait> late comers, plz use #info - thx :)
18:31:11 <rangi> if you want the raw data for that table
18:31:14 <rangi> http://bugs.koha-community.org/cgi-bin/progress.pl?type=json
18:31:15 <Waylon> Meeting attending... on a bus... incredible what the worlds done.
18:31:33 <slef> rangi: what is most helpful for others to do?
18:31:49 <sekjal> #info Ian Walls, ByWater Solutions, 3.6 QA Manager (sorry I'm late)
18:31:53 <rangi> marking bugs resolved and signing others off
18:32:10 <slef> Waylon: I'm sure I've done IRC meetings from sat on the sand in Miami Beach :)
18:32:19 <rhcl> #info Greg Lawson, Rolling Hills Consolidated Library
18:32:23 <cait> on this topic - we have planned a global sign off day for today/tomorrow june 15th
18:32:35 <slef> #info global sign-off day for today/tomorrow june 15th
18:32:48 <cait> #link http://wiki.koha-community.org/wiki/Global_sign_off_day,_2011-06-15
18:32:52 * paul_p think this global sign-off day is a GREAT idea.
18:33:01 <sekjal> I agree with paul_p
18:33:03 <ricmarques> paul_p++
18:33:16 <magnuse> #link http://wiki.koha-community.org/wiki/Global_sign_off_day,_2011-06-15
18:33:28 <magnuse> oops
18:33:32 <cait> ;)
18:33:33 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba, Argentina
18:33:44 <cait> we hope a lot of people will attend... I will once my laptop is talking to me again
18:33:46 <paul_p> I've already told here, and sent a mail to cait&magnus to say that BibLibre just wanted to announce that we will have half a day every 2 weeks where everybody at BibLibre will just work on community things.
18:33:57 <paul_p> we will start in july.
18:34:01 <magnuse> biblibre++
18:34:02 <cait> biblibre++
18:34:17 <slef> paul_p: community or koha-community?
18:34:17 <wizzyrea> biblibre++
18:34:26 <ricmarques> biblibre++ (I just can't resist jumping on the bandwagon!  ;-)
18:34:59 <paul_p> slef, community things, so sign-off or anything usefull for the koha community
18:35:07 <thd> paul_p++ I always assume that BibLibre works on community things all day every day :)
18:35:11 <paul_p> (not sure I understand the question in fact)
18:35:16 <library_systems_guy> #info Elliott Davis, University of Texas at Tyler
18:35:17 <slef> paul_p: yeah, but I mean just koha or all community projects?
18:35:21 <Waylon> is there a good test data for koha to be tested against, that everyone can use? Would like to, on occasion, bugfix/signoff, but have no full data
18:35:48 <magnuse> Waylon: i think most of us make it up as we go along...
18:35:48 <ricmarques> paul_p: More seriously, I applaud that great initiative from BibLibre :)
18:35:52 <ricmarques> Waylon++
18:35:52 <slef> Waylon: there are some test data sets linked on the wiki IIRC. I think it's fine to ask for test data if it doesn't fail with that.
18:36:00 <cait> Waylon: there are some sample files that can be installed with koha (patrons, item types, etc.), no records and items so far
18:36:36 <thd> slef: Your question makes a distinction for the ambiguity but I am assuming the Koha community in the context.
18:36:42 <paul_p> cait & waylon = on git.biblibre.com, there is a repo with a test database we used during april hackfest. feel free to download & use it
18:36:47 <Waylon> Hmm... there needs to be a complete data set, so people don't need to hunt..
18:36:55 <cait> paul_p: unimarc?
18:36:55 <wahanui> unimarc is, like, translated I think
18:36:57 <magnuse> #link http://git.biblibre.com/?p=data;a=summary
18:37:04 <cait> forget unimarc
18:37:04 <wahanui> cait: I forgot unimarc
18:37:05 <Waylon> Ah.. there we go, thankouy paul_p.
18:37:11 <paul_p> http://git.biblibre.com/?p=data;a=summary
18:37:17 <Waylon> paul_p++
18:37:19 <paul_p> cait, I think it's marc21
18:37:19 <sekjal> one of my goals for this release cycle is to get one or more VERY robust sets of test data built, so one can test all sorts of different aspects of the codebase
18:37:38 <slef> thd: assumption is the mother, sadly.
18:37:39 <paul_p> mmm... nope, it's unimarc
18:37:45 <cait> Waylon: for most thigns you can make up data as you go - create some items and records for the thing you test, sometimes you don't need any of that
18:37:49 <magnuse> sekjal: yay!
18:37:54 <ricmarques> sekjal++
18:38:07 <Waylon> sekjal++
18:38:21 <sekjal> we'd need at least marc21 and unimarc setups... multiple language support, as well
18:38:48 <sekjal> but we could manage the SQL data in a git repo, so as new database revisions came out, you could use the appropriate data set to match the code you're using
18:39:07 <cait> this calls for an #action ;)
18:39:09 <bgallagher> #info Brendan Gallagher, ByWater Solutions
18:39:18 <sekjal> also, making date's relative to the current date, not absolute (so overdues will always be "3 days over", not some specific date)
18:40:22 <tcohen> I'd like to ask on 'Work for 3.6.x' if bug 5166 is worth it or if I should abandon that work
18:40:22 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5166 enhancement, PATCH-Sent, ---, tomascohen, ASSIGNED , Refactor rebuild_zebra.pl into a library
18:40:37 <rangi> tcohen: its been signed off
18:40:49 <rangi> so its passed that
18:40:57 <rangi> its up to qa to check it now
18:41:04 <tcohen> ok, I get it
18:41:20 <thd> tcohen: That is important work for many people.
18:41:37 <sekjal> it's on my list to push through QA.
18:41:43 <sekjal> I apologize to everyone; I'm behind on that
18:41:44 <ricmarques> Newbie question: Doesn't  "Signed-Off"  (also) mean  "checked by QA"?
18:41:58 <tcohen> thd: its fine, i'm just asking in case something more is needed for it
18:42:08 <rangi> tcohen: no, passed qa means that
18:42:16 <sekjal> ricmarques:  no, they're different steps.
18:42:45 <rangi> sorry ricmarques :)
18:42:47 <rangi> http://bugs.koha-community.org/cgi-bin/progress.pl
18:43:00 <rangi> the headings are basically the life of a patch
18:43:02 <sekjal> ricmarques:  patch is written, then signed off my someone else, then QA'ed, then pushed (assuming everything works as expected)
18:43:12 <tcohen> #link http://wiki.koha-community.org/wiki/Bug-enhancement-patch_Workflow
18:43:13 <ricmarques> rangi / sekjal: Thanks... Is there some "git" entry in the Log for the QA? Or is it "just" an additional "Signed-Off"?
18:43:14 <rangi> (it could go, does not apply, or failed qa as well)
18:43:20 <ricmarques> tcohen: Thanks... Reading
18:43:33 <rangi> ricmarques: bug status changes, and an additional sign off
18:44:03 <sekjal> we can condense those steps for smaller patches... a simple, one-line template change is extremely easy to test, and doesn't need as many eyes on it
18:44:17 <ricmarques> rangi: "An additional sign-off"... Right, that's what I was thinking now. Who does that typically now? Sekjal?
18:44:20 <paul_p> sekjal++
18:44:31 <paul_p> (and rangi does that already, for trivial patches)
18:45:09 <margo> #info margo duncan, university of texas at tyler
18:45:38 <tcohen> sekjal: is there an rfc for relative dates proposal?
18:46:29 <sekjal> tcohen:  no, I was just proposing to use relative dates in the SQL dataset, instead of absolute ones
18:46:36 <rangi> ricmarques: yep sekjal is qa manager so thats him, and he is looking at coding guidelines, as well as does it work
18:47:04 <ricmarques> rangi: Right. Thanks :)
18:47:11 <cait> ok, ready to move on?
18:47:27 <sekjal> I also try to throw as many weirdo, fringe cases at a patch as I can, in the hopes of catching bugs before they're newly introduced
18:48:20 <rangi> cait: yep, thats all from me for 3.6, keep the patches coming
18:48:28 <ricmarques> sekjal: "Fringe cases"? That's cool. I guess we could call the next release of Koha "Olivia Dunham" - http://en.wikipedia.org/wiki/List_of_Fringe_characters#Olivia_Dunham  ;-)
18:48:28 <cait> next items are KohaCon11 and KohaCon12
18:48:35 <druthb> == D Ruth Bavousett, ByWater (apologies for the lateness.)
18:48:56 <cait> druthb: plz use #info for the minutes :)
18:49:11 <cait> #topic KohaCon11
18:49:12 <druthb> #info D Ruth Bavousett, ByWater
18:49:43 <paul_p> kmkale is not here, but I have some information I think I can give you about KohaCon11
18:50:11 <magnuse> "it will rock"? ;-)
18:50:15 <ricmarques> sekjal: (I'm joking of course... what you said is exactly what a good tester does :)
18:50:16 <paul_p> There are already 128 registered ppl from 19 countries
18:50:22 <rangi> #info chris cormack, 3.6 RM
18:50:53 <paul_p> There are 8 proposals for speaking so far.
18:51:04 <paul_p> and kmkale still hope to have rangi attending ;-)
18:51:29 <rangi> nope not gonna happen
18:51:34 <Waylon> ah, to attend a con... missed my chance when it was in NZ.
18:51:34 <paul_p> well, I make at least one proposal soon, so 9 (or 10) in fact
18:51:42 <rangi> im at 2 other conferences at the same time
18:51:53 <thd> :)
18:52:04 <thd> rangi: Which two?
18:52:06 <slef> Waylon: I suspect it will be back one day. Just need to keep going long enough.
18:52:16 <rangi> access in canada, then lianza in nz
18:52:18 <Waylon> con going to be streamed live?
18:52:24 <paul_p> rangi, 2 or 3, that's not a problem: if you can be divided in 2, you can be divided in 3 :D
18:52:26 <rangi> they both overlap slightly with kohacon11
18:52:32 <rangi> but not each other
18:52:34 <paul_p> (kidding)
18:52:45 <slef> #link http://lists.koha-community.org/pipermail/koha-devel/2011-June/035775.html
18:52:48 <rangi> i may try to 'phone' in a presentation though
18:52:58 <thd> rangi++
18:52:58 <slef> #info to vote for the time of the next kohacon11 volunteers meeting
18:53:05 <cait> rangi: +1 :)
18:53:07 <ricmarques> paul_p: LOL
18:53:13 <slef> err, that link doesn't work any more for me
18:53:39 <slef> ah, delete the . that the archive includes in the link
18:53:39 <paul_p> About the subject of proposed papers, I think we still lack things for complete newbies, like "what is OpenSource", "demo of Koha", "history of Koha"
18:54:01 <rangi> i could do the history remotely
18:54:04 <slef> #info oh and delete the . that the archive includes on the end of the link
18:54:07 <rangi> depending on the internet
18:54:36 <paul_p> rangi++ if you do the history, i could do the demo itself then.
18:55:07 <paul_p> (I plan to attend, with another person, depending on money...)
18:56:40 <rangi> my presentation at access kinda overlaps, and i have most of the history written down so it wont be too hard to do
18:57:34 <paul_p> rangi, I think the "10 years in 10 minuts" is definetly a "must show" !
18:57:46 <paul_p> (well, 11 years in 11 minuts for KohaCon11 ;-) )
18:57:59 <rangi> yup, andrew and I can remake it
18:58:11 <magnuse> cool
18:59:07 <paul_p> cait, ? anyone ? anything to add to KohaCon11 ?
18:59:13 <cait> not from me
18:59:13 <paul_p> s/to/about/
18:59:19 <cait> moving on?
18:59:45 <rangi> yeah
18:59:47 <cait> #topic KohaCon12
19:00:21 <cait> I see there is a link to a doodle poll
19:00:22 <ricmarques> cait: sure, move ahead (I'll consider attending a KohaCon if/when it takes place in Portugal  ;-)
19:00:45 <cait> #link http://doodle.com/n2ikfyxexc3ukb2d
19:01:32 <slef> #action Everyone fill out that poll for KohaCon12 timing, please!
19:01:34 <magnuse> 4 people have taken the poll, including me 5 seconds ago
19:01:40 <cait> #info Doodle poll to decide about dates for KohaCon12
19:01:48 <paul_p> well, I voted, but I think it's up to the organizer to decide.
19:02:11 <magnuse> you don't show, paul_p...
19:02:40 <nengard> i see him
19:02:41 <paul_p> magnuse, refresh ;)
19:03:13 <magnuse> i'd suggest opening up for proposals so places can put themselves forward, with preferred times
19:03:20 <magnuse> thanks, paul_p ;-)
19:03:30 <nengard> just like we did for kohacon11
19:03:41 <rhcl> I'd like to mention that many US libraries apply for grant money to attend conferences. That process can take months sometimes, so we need as much lead time as we can possibly get.
19:03:41 <nengard> proposals on the wiki with date suggestions
19:03:56 <magnuse> nengard: yeah
19:04:17 <slef> #link http://doodle.com/mobile/participation.html?pollId=n2ikfyxexc3ukb2d
19:04:28 <paul_p> rhcl, same thing for french libraries, and I think for most countries too
19:04:48 <magnuse> probably
19:05:15 <cait> ok, so we want to call for proposals?
19:05:30 <slef> from last meeting "IDEA: listserv eoi for KohaCon 2012"
19:05:32 <Waylon> Hmm.. to get my library to pay my way....
19:05:33 <slef> did that happen yet?
19:05:39 <magnuse> i don't think it's too early for proposals
19:05:49 <magnuse> eoi?
19:05:56 <slef> eoi is expressions of interest
19:05:56 <thd> All information may be helpful but sponsors need to find dates which work for the sponsor's proposal.
19:06:03 <magnuse> thanks, slef
19:06:07 <tcohen> I think ill pick my savings and attend kohacon12 on my own
19:06:07 <ricmarques> magnuse: Didn't know that one, as well
19:06:51 <cait> ok, should we vote? someone volunteering to start a wiki page / write an email to the list?
19:08:03 <cait> ?
19:08:15 <thd> slef: Considering the idea of a special listserv for KohaCon ...
19:08:19 <slef> I think we will bid again (probably with London or Edinburgh this time) so I don't want to volunteer.
19:08:31 <slef> thd: you trolling me? ;-)
19:08:38 <thd> A special listserv is too easy to ignore
19:08:47 <thd> slef no :)
19:08:47 <nengard> yeah, i don't want another list to watch
19:08:47 <magnuse> slef++
19:09:09 <slef> oh I thought that just mean "send a call for expressions of interest to the koha list"
19:09:15 <slef> s/mean/meant
19:09:16 <ricmarques> nengard++
19:09:19 <cait> slef: good to hear that
19:09:21 <magnuse> sorry folks, i gotta run, if noone else volunteers i can try to set the ball rolling
19:09:27 <slef> magnuse++
19:09:42 <thd> slef: sorry, I misunderstood.
19:09:49 <cait> #action magnuse volunteers to send a mail to the mailing list about proposals for KohaCon12
19:09:56 <slef> thd: hard to say. Brooke wrote it and she's not here to clarify.
19:10:42 <thd> slef:  Getting attention is the problem but still easiest on the koha mailing list.
19:10:59 <cait> yeah, I think koha mailing list has most subscribers
19:11:12 <cait> easy to miss another new mailing list
19:11:19 <thd> s/the/a major/
19:11:31 <ricmarques> cait++
19:12:17 <cait> let's move on, shall we?
19:12:24 <rangi> yep
19:12:25 <cait> #topic DB Documentation management
19:12:39 <cait> nengard?
19:12:39 <wahanui> nengard is fast
19:12:44 <nengard> I am?
19:12:51 <cait> obviously :)
19:12:58 <nengard> anyway, I just think we need to document the database
19:13:06 <nengard> I like the idea of commenting the SQL file for ease of use and reading
19:13:14 <nengard> I am willing to do what I can on this, just need the okay from you all
19:13:21 <nengard> I know we had a volunteer a while back - but nothing came of it
19:13:22 <rangi> i only like that if it db independent comments
19:13:27 <paul_p> nengard++
19:13:35 <paul_p> rangi, how to have db independant comments ?
19:13:37 <tcohen> could we maintain some schemaspy available online?
19:13:48 <rangi> thats up to someone to figure out
19:13:59 <rangi> what i dont want is adding more mysql dependencies
19:14:07 <nengard> the db is MySQL ...
19:14:09 <rhcl> rangi++
19:14:17 <rangi> until i can fix that
19:14:24 <ricmarques> nengard++  ... but, yeah... didn't someone already produce some kind of output for the Database documentation in the past? Maybe it was tajoli?
19:14:26 <rangi> and making it more mysql does not help
19:14:38 <tcohen> rangi++
19:14:48 <cait> I think normal comments in the file should be ok?
19:14:52 <thd> nengard: You always have my OK for doing more work :)
19:15:07 <rangi> as long as their are ansi sql compliant comments then yes
19:15:09 <cait> not being used for creating the database, only for reading
19:15:14 <rangi> their=they
19:15:19 <nengard> i don't know what that means
19:15:23 <cait> so something like /* */
19:15:39 <ricmarques> Yep, it seems it was tajoli (for 3.0.x):
19:16:03 <ricmarques> Koha - Dev - SQL schema of Koha 3.0.3
19:16:06 <ricmarques> http://koha.1045719.n5.nabble.com/SQL-schema-of-Koha-3-0-3-td3068617.html
19:16:24 <thd> nengard: Which meaning confuses you?
19:16:32 <nengard> yeah i remember that - it seemed like more work than was necessary
19:16:41 <nengard> thd the 'ansi sql compliant' part
19:17:06 <nengard> cait, yes i want them there for reading
19:17:38 <tajoli> sorry, I was out
19:17:39 <cait> iirc the schemaspy solution added some kind of comment into the database - I think that's what rangi doesn't want
19:17:48 <cait> normal comments should be ansi compliant afaik
19:17:57 <nengard> i think we want something in git on the sql file that says what each field is
19:18:06 <thd> nengard: Every database language has its own specific type of SQL.  ANSI compliant means it should work on MySQL, Postgres, etc.
19:18:07 <nengard> nothing fancy, just simple text somewhere that will make reporting easier
19:18:08 <rangi> -- is ANSI/ISO compliant
19:18:11 <tajoli> yes, with schemaspy you need comment in DB
19:18:17 <nengard> thanks thd
19:18:21 <rangi> /* */ is sql99
19:18:26 <cait> ah ok
19:18:35 <cait> sorry for that
19:18:41 <tcohen> tajoli: those comments qhere ansi right?
19:18:57 <tcohen> s/q/w/
19:19:10 <rangi> thats ok, most dbs will support sql-99, but more support ansi/iso
19:19:32 <thd> nengard: MySQL AB made an extra effort at being non-ANSI compliant to make some claim about licensing your SQL code.
19:19:32 <tajoli> the schemaspy comment are INSIDE the sql definiton of the fields and tables
19:19:38 <nengard> so is that how we want to do it? /* */
19:19:38 <wahanui> Hmm.  No matches for that, nengard.
19:19:43 <rangi> --
19:20:31 <cait> nengard: write -- comment at the end of the line
19:21:09 <rhcl> firebird++ "Firebird is a relational database offering many ANSI SQL standard features that runs on Linux..."  http://www.firebirdsql.org/en/about-firebird/
19:21:13 <nengard> cait so for example
19:21:30 <nengard> `borrowernumber` int(11) NOT NULL auto_increment, -- The primary key for identifiying all borrowers
19:21:35 <nengard> or some such comment?
19:21:38 <cait> rangi?
19:21:38 <wahanui> rangi is a proud Māori whose sense of humour matches his prowess in coding.
19:21:54 <rangi> yeah, and get rid of those `` would be nice too
19:21:59 <rangi> but one thing at a time
19:22:08 <cait> ok
19:22:13 <nengard> hehe - well i copied that from the file, but while editing i can remove them
19:22:13 <nengard> i don't mind
19:22:29 <cait> ok, so that's settled?
19:22:38 <cait> moving on
19:22:41 <cait> #topic Miscellaneous old business
19:22:46 <cait> do we have som old business?
19:23:04 <nengard> wait - was i just given the okay to edit the sql file and add comments?
19:23:10 <nengard> as long as i do it with --
19:23:15 <cait> I thought so
19:23:24 <nengard> heh
19:23:26 <tajoli> I can show an examnple of schemaspy comments
19:23:33 <ricmarques> tajoli++
19:23:34 <rangi> yep, i wont reject that
19:23:34 <tcohen> please
19:23:47 <nengard> there wasn't a vote, I just want to know what to do from here on out ...
19:23:59 <cait> ok
19:24:17 <cait> #topic DB Documentation management
19:24:45 <nengard> what's the syntax for calling for a vote?
19:24:58 <thd> nengard: That is what rangi and others of have said.
19:25:50 <cait> nengard: I think ther eis no special vote syntax
19:25:57 <cait> tajoli: the example?
19:26:03 <tajoli> ALTER TABLE borrower_attribute_types COMMENT '[pat] List of extended attribute types';
19:26:22 <tajoli> is an sql instruction,
19:26:25 <cait> ok, can someone verfiy if that is a mysqlism or ansi?
19:26:40 <tajoli> that insert commet in sql defintion
19:27:17 <nengard> which is what rangi doesn't want
19:27:33 <tcohen> postgresql tables don't have comments?
19:27:55 <thd> cait: if it works in both MySQL and Postgres then chances are good.
19:28:48 <tajoli> if the comment is inside SQL, schemaspy can use it
19:29:06 <ColinC> syntax is differemt for postgresql as its a mysqlism
19:29:09 <tcohen> Postgres1l COMMENT ON { TABLE ___ } IS 'text'
19:29:09 <nengard> I'm so confused now
19:29:29 <cait> ok
19:29:34 <cait> so normal comments are the safer option
19:29:48 <rangi> i dont want db specific comments
19:29:52 <cait> ok
19:29:52 <rangi> not mysql, not postgres
19:29:56 <paul_p> http://www.postgresql.org/docs/8.3/static/sql-comment.html  and http://www.postgresql.org/docs/8.1/static/sql-createtable.html
19:30:02 <cait> so I think we don't need a vote for that really - rm decides
19:30:22 <nengard> so then I call for a vote - all in favor of me editing the SQL file with comments using the -- syntax please vote
19:30:38 <cait> +1
19:30:39 <thd> 1+
19:30:47 <paul_p> no comment on create table it seems
19:30:54 <paul_p> so -- syntax +1
19:31:04 <thd> +1
19:31:34 <rhcl> +1   -- http://www.firebirdsql.org/file/documentation/reference_manuals/reference_material/html/langrefupd25-linecomment.html
19:31:39 <tcohen> +1 --
19:31:44 <margo> +1
19:32:01 <ricmarques> +1
19:32:18 <cait> ok
19:32:20 <cait> #info vote is to use -- style comments for db documentation
19:32:22 <nengard> okay one more question and then we're done - rangi you will approve of patches that put this syntax in?
19:32:36 <nengard> don't want to waste my time
19:33:08 <rangi> if its -- style comments then yes
19:33:21 <nengard> k we can move on - the doc manager will work on the db documentation
19:33:25 <nengard> and will be asking for help on list
19:33:27 <nengard> and here in irc
19:33:41 <thd> nengard: Ask if you are following the standard while you are working and you should be fine :)
19:33:48 <cait> #info doc manager (nengard) will work on the db documentation
19:33:54 * ricmarques was thinking that rangi would reply: "No... I'll promptly reject your patches with an Evil Laugh!" ;-)
19:34:02 <cait> lol
19:34:19 <cait> I am gonna skip old business if noone disagrees
19:34:24 <cait> let's start with misc
19:34:36 <cait> #topic Miscellaneous
19:34:56 <cait> quick vote for posting the minutes to the mailing list?
19:35:06 <ricmarques> cait++
19:35:19 <jwagner> +1
19:35:20 <cait> #link http://librarypolice.com/koha-meetings/2011/koha.2011-05-11-02.01.txt
19:35:21 <tcohen> +1
19:35:26 <cait> example minutes
19:35:28 <cait> +1
19:35:28 <oakivil> +1
19:35:30 <slef> +1
19:35:33 <drojf1> +1
19:35:34 <margo> +1
19:35:45 <Waylon> +1
19:35:47 <ricmarques> +1 (example minutes look great, even if automated :)
19:35:47 <sekjal> +1
19:35:49 <paul_p> +1
19:35:50 <rhcl> +1
19:35:52 <ColinC> +1
19:36:04 <cait> ah, fast decision :)
19:36:04 <nengard> +1
19:36:23 <cait> #info vote: meeting minutes from meetbot to be posted on the mailing list
19:36:31 <Waylon> needs link for roadmap to 3.0 ... to adopt a parrot.
19:36:32 <thd> I propose an amendment or clarification.
19:36:47 <cait> thd: ?
19:37:04 <ricmarques> Waylon: http://www.birdadoption.org/  ?  ;-)
19:37:13 <tcohen> thd: r u talking about vulnerabilities...?
19:37:28 <thd> Any posting of abbreviated minutes should include a link to the full minutes or better the wiki page for the meeting with the link to the full minutes.
19:37:40 <ricmarques> thd++
19:37:48 <thd> Sorry that was wriitten poorly.
19:37:48 <Waylon> sorry, i ment, adopt a dead parrot. :)
19:37:50 <slef> Waylon: that was just an example. This meeting's one will have a link I think.
19:38:12 <cait> #info thd: Any posting of abbreviated minutes should include a link to the full minutes or better the wiki page for the meeting with the link to the full minutes.
19:38:17 <thd> Any posting of minutes should include a link to the full log or better the wiki page for the meeting with the link to the full meeting log.
19:38:23 <cait> I think that is a good idea, we can add a #link at the end or to the mail
19:38:48 <thd> +1
19:38:51 <rangi> bbiab
19:39:02 <rangi> gotta feed the kids and catch my bus
19:39:18 <ricmarques> rangi: You'd better NOT get those two mixed up!  ;-)
19:39:27 <tcohen> bye rangi
19:39:44 <cait> ok, next item is
19:39:53 <cait> #topic Vulnerabilites management
19:39:53 <thd> This solves the problem of under informative autominutes.
19:40:07 <ricmarques> thd: agreed
19:40:30 <cait> there are some options listed on the wiki
19:40:45 <cait> 1) private mail to the RM
19:40:57 <cait> 2) dedicated mailing list
19:41:08 <cait> 3) hidden bugzilla entry
19:41:21 <tcohen> i think 1 and 3 should be used
19:41:38 <cait> I am not sure how the hidden bugzilla entries work - can someone explain?
19:41:41 <jwagner> I'd prefer a dedicated mailing list
19:42:01 <jwagner> I thought we discussed this a couple of months ago and agreed to set one up?
19:42:09 <slef> jwagner: got a link
19:42:10 <slef> ?
19:42:47 <jwagner> slef, looking....
19:43:22 <slef> http://librarypolice.com/koha-meetings/2011/koha.2011-03-02-17.56.html shows no ACTION
19:43:26 <jwagner> The March 2nd meeting -- http://wiki.koha-community.org/wiki/General_IRC_Meeting,_2_March_2011
19:43:34 <thd> jwagner: We did agree as I remember or at least to send a CC message to a select group of people who need to know and would not be exploiting the vulnerability.
19:43:48 <slef> reading the log
19:45:02 <slef> ok, so let me restate this
19:45:08 <slef> #action close koha-manage
19:45:24 <slef> #action create koha-security
19:45:37 <slef> #action gmcharlt to moderate it
19:45:49 <slef> err gmcharlt are you still willing to do that?
19:45:52 <cait> +1
19:46:00 <gmcharlt> slef: yes
19:46:05 <tcohen> +1 then
19:46:16 <thd> +1 again
19:46:23 <ColinC> +1
19:46:27 <paul_p> +1 for me
19:46:36 <Waylon> +1
19:46:54 <tajoli> +1
19:46:54 <jwagner> +1
19:47:05 <slef> but just to remind you I think this is a horrible idea
19:47:43 <slef> and does the failure to do it yet suggest it's not very important even to its supporters?
19:48:05 <tcohen> irc channel should serve for reporting sec vulnerabilities, but how do we manage them?
19:48:32 <Waylon> irc channel, not the best place... logbot.
19:48:35 <cait> tcohen: I think the question is if you want to make them public immediately or not
19:48:38 <jwagner> tcohen, anyone can log into the IRC and anyone can see the logs.  Not secure.
19:48:40 <cait> IRC is logged
19:48:45 <slef> [off] Waylon we can hide from logbot
19:49:05 <sekjal> there are also direct messages to people you trust
19:49:11 <jwagner> slef, the off command works if every person remembers to use it every time they say something.
19:49:12 <cait> but if you write on a page somewhere peole should report here, they will not use [off]
19:49:14 <slef> but no, not the best way. Your support co is the best way. Failing that, the RMs
19:49:39 <Waylon> that librarypolice log file... does not obey [off]
19:49:43 <slef> OK, I have to go away for a bit. Thanks cait for chairing and everyone else for participating.
19:49:46 <slef> Waylon: tee hee
19:49:47 <cait> I also like he idea of the list, because more people wll get to see it
19:49:48 <thd> tcohen: We discussed making a special mail box for reporting that would feed in to the security list.
19:50:03 <cait> not only those online or at the other end of a pm
19:50:17 <sekjal> I may have missed it, but did we ever discover what vulnerabilities that company that posted to the list had actually found?
19:50:20 <tcohen> thd: ok
19:50:38 <cait> sekjal: I think no - rangi will know. he wrote them another mail afaik
19:50:41 <slef> sekjal: not the recent one as far as we know.
19:50:55 <sekjal> that looked like an automated message to me
19:51:04 <slef> spam or what?
19:51:05 <cait> slef: thx for helping :)
19:51:21 <paul_p> I think the idea of a dedicated mailbox filling security ML is good : otherwise someone would have to subscribe to the list & be moderated before sending his report
19:51:47 <sekjal> either spam, or the code being run against a very limited set of standardized tests
19:52:01 <thd> Not to speak for slef, but In case anyone missed his argument.  slef favours being open about even the worst security bugs.
19:52:49 <cait> hm ok, are we ready for a vote?
19:52:50 <paul_p> thd, I had understood that, and disagree : full disclosure is fine, but after giving enough time to devs to provide a fix
19:52:55 <thd> I think it is important to report all security bugs openly after people have had time to patch systems with a fix.
19:52:58 <Waylon> for those with modified koha, who can't cope with security updates with an easy merge.. not a good idea.
19:53:17 <thd> paul_p :) we write the same sentence.
19:53:45 <paul_p> thd, right, but me 1st :D
19:53:56 <thd> :)
19:54:18 <oakivil> damn this security issues is so tricky
19:54:31 <oakivil> the more public the issues are the better fixes they get
19:55:03 <Waylon> vs the more possibility that they'll get used.
19:55:06 <cait> I think we got fixes very fast in the past
19:55:07 <oakivil> yeah
19:55:17 <tcohen> i'd vote for a security manager (perhaps the RM) to decide when to make it public, based on work on the koha-security list
19:55:20 <oakivil> you know better, I'm just observing :D
19:55:21 <cait> without going full public before the patch was ready
19:55:35 <thd> oakvil: I think that we are mostly concerned with the scariest security issues which could cause you to loose your database for example.
19:55:41 <cait> only my observation :)
19:55:53 <oakivil> ok
19:55:54 <paul_p> I think we can agree about the rule to follow
19:56:00 <oakivil> agreed
19:56:03 <oakivil> for the scariest issues
19:56:06 <oakivil> atleast
19:56:43 <thd> oakvil: There are many trivial security issues which are not scary enough to need secrecy.
19:56:54 <oakivil> but time is running away
19:57:13 <oakivil> i gotta go. Its 23:00 here and I still need to jog to clear my thoughts
19:57:24 <cait> yes, I think we should come to ane nd
19:57:27 <oakivil> +1 for security PM
19:57:32 <jwagner> I need to leave as well.  There was a vote -- we decided on the mailing list?
19:57:39 <cait> can we agree to create a mailbox that feeds a mailing list?
19:57:46 <atz_> thd: agreed
19:57:56 <cait> plz vote
19:57:57 <tcohen> +1
19:57:59 <paul_p> cait, +1
19:58:00 <jwagner> +1
19:58:04 <cait> +1
19:58:08 <ColinC> +1
19:58:11 <Waylon> cait, +1
19:58:13 <gmcharlt> +1
19:58:15 <drojf1> +1
19:58:20 <tajoli> -1
19:58:20 <thd> jwagner: We decided that previously as you reminded us :)
19:58:23 <thd> +1
19:58:26 <tajoli> no -
19:58:30 <tajoli> +1
19:58:40 <cait> ok
19:59:04 <cait> #info vote: create koha-security mailign list, fed by a mailbox
19:59:17 <cait> ok, last item for today, as we have previously talked about the global sign-off day!
19:59:26 <cait> please take the time to sign-off a patch!
19:59:39 <cait> #topic Date and time for next meeting
20:00:06 <cait> any suggestions?
20:00:12 <cait> I am not aware of the schedule we use right now
20:00:23 <tcohen> two weeks?
20:00:35 <rangi> monthly
20:00:36 <cait> normally about 4 - once every month I think
20:00:47 <rangi> shift time by 8 hours
20:00:49 <cait> wb rangi
20:00:57 <jwagner> It has normally been the first Wednesday of the month.  In July, that's right on the heels of a US holiday on Monday, folks might be on vacation.
20:01:08 <jwagner> Maybe 2nd week in July?
20:01:10 <tcohen> are there any topics for 3.6 that need to be discussed earlier?
20:01:33 <ricmarques> Sorry. I had to leave for a while and I have to go now. Take care! :)
20:01:39 <wizzyrea> meh, interested US parties would likely show up anyway
20:02:38 <rangi> tcohen: those can go on koha-devel meeting is more for summary
20:02:41 <thd> wizzyrea: Some people would prefer to show up but others may have an enforced holidy by relations whether they want one or not :)
20:02:58 <rangi> I agree with wizzyrea
20:03:02 <tcohen> rangi: ok
20:03:13 <wizzyrea> <laughing> i'd welcome the break from my relations </laughing>
20:03:27 <cait> so middle of july
20:03:47 <paul_p> mmm... between 11th & 18th, i'll be on holiday, afk
20:04:23 <rangi> I vote first wednesday
20:04:37 <wizzyrea> 6th
20:05:02 <thd> +1 6 July
20:05:11 <tcohen> +1 6th july
20:05:15 <cait> wednesday, 14th july
20:05:15 <cait> 4 am for europe?
20:05:15 <cait> 2:00 UTC? that right?
20:05:16 <cait> any objections?
20:05:20 <cait> 14 july 2011 02:00 UTC+0
20:05:31 <cait> ah, correction, we had 02.00 before
20:05:39 <cait> so shift 8 hours the other direction
20:05:50 <paul_p> jul 14th KO for me
20:05:52 <thd> 6 July is two days after the US holiday which should be enough to not miss paul_p
20:05:57 <cait> 14 July 2011 10:00 UTC+0
20:06:05 <paul_p> 6th ++
20:06:36 <wizzyrea> 6 july 2011 10:00 UTC+0
20:06:39 <jwagner> Gotta run, bye.
20:06:53 <rangi> 6 july ++
20:07:13 <rangi> yep 10 utc
20:07:13 <Waylon> okay, thankyou all. gotta go... maybe sleep more.
20:07:37 <cait> ok
20:07:53 <cait> #agreed next meeting is on 6 july 2011 10:00 UTC+0
20:08:04 <cait> #endmeeting