18:05:46 <druthb> #startmeeting
18:05:46 <huginn> Meeting started Wed Dec 5 18:05:46 2012 UTC. The chair is druthb. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:05:46 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:05:47 <wahanui> if there is a meeting then Brooke must want me
18:05:55 <talljoy> ^ ?
18:05:56 <wahanui> ^ is what I think too
18:06:05 <druthb> #info introductions
18:06:10 <libsysguy> #info Elliott Davis, ByWater Solutions: Houston Tx
18:06:12 <druthb> #topic introductions
18:06:12 <wahanui> #info wahanui, a bot that has become sentient
18:06:16 <thd> drojf: No< I merely have the unreasonable expectation of immunity from vaccines.
18:06:24 <druthb> #info D Ruth Bavousett, ByWater, Lawrence, KS, TM 3.12
18:06:27 <talljoy> #info Joy Nelson ByWater Solutions
18:06:28 <jcamins> #info Jared Camins-Esakov, C & P Bibliography Services, RM 3.12
18:06:32 <davidnind> #info David Nind, Wellington, NZ
18:06:33 <drojf> #info Mirko Tietgen, HU Berlin
18:06:40 <slef> #info MJ Ray, software.coop member, Norfolk, England, past RMaint
18:06:41 <thd> #info Thomas Dukleth, Agogme, New York City
18:06:44 <bag> #info Brendan Gallagher ByWater Solutions having THE FUN
18:06:56 * slef asks bag to pass a beer
18:06:57 <nancyk> #info Nancy Keener Reno
18:07:02 <rhcl> #info RHCL = Rolling Hills Consolidated Library - Greg
18:07:02 <bag> noice
18:07:05 * druthb wields her pointy stick and evil librarian glasses, putting her hair into a bun.
18:07:13 <gmcharlt> #info Galen CHarlton, Equinox Software
18:07:41 <druthb> #topic announcements not otherwise on the agenda, which is at http://wiki.koha-community.org/wiki/General_IRC_meeting,_5_December_2012
18:08:07 <druthb> #info There will be a newer, faster Pootle server in the next couple of days. Kudos and hugs to tcohen for help with that.
18:08:21 <talljoy> tcohen++
18:08:28 <jcamins> tcohen++
18:08:43 <libsysguy> @karma tcohen
18:08:43 <cait> tcohen++ druthb++ :)
18:08:43 <huginn> libsysguy: Karma for "tcohen" has been increased 51 times and decreased 0 times for a total karma of 51.
18:08:50 <druthb> Anyone else have short announcements of general interest to the Koha community?
18:08:52 <khall> #info Kyle M Hall, ByWater, Meadville, PA
18:08:55 <JDatTeTakere> #info jdattetakere
18:09:08 <drojf> for a second i thought i had seen cait
18:09:13 <cait> #info Katrin Fischer, BSZ
18:09:22 <cait> sorry, I thought the meeting started at 8!
18:09:25 <druthb> #topic 3.8 update
18:09:35 <drojf> its cet, not cest anymore :P
18:10:06 <druthb> News on 3.8? Probably the wrong time of day for those folks.
18:10:15 <jcamins> Chris is not here, but so far as I know there will be a string freeze on the fifteenth and 3.8.8 will be released on the twenty-second.
18:10:34 <cait> I can take over - or eat my dinner while druthb chairs :)
18:10:35 <libsysguy> if the world still stands :p
18:10:50 <talljoy> lol
18:10:55 <slef> It'd be nice if a short update could be put in the agenda just in case they're not here.
18:10:59 <druthb> eat your dinner, cait; I've already got my pointy stick out to poke things along with.
18:11:22 <druthb> #info jcamins reports that as far as he knows there will be a string freeze on the fifteenth and 3.8.8 will be released on the twenty-second.
18:11:31 <slef> druthb: just beat me to it!
18:11:34 <druthb> :P
18:11:37 * druthb is a fast typist.
18:11:49 * slef is doing 3 things at once :-/
18:11:51 <druthb> #topic 3.10 update
18:12:23 <druthb> 3.10, anyone?
18:12:26 <cait> RM?
18:12:27 <wahanui> somebody said RM was busy :) or paul_p
18:12:44 <jcamins> #info Koha 3.10.0 was released on November 23/24. 3.10.1 will be released on December 22.
18:13:05 <drojf> what's with the broken package installation? is there going to be a 3.10.0-1? (or -2 or how it is numbered?)
18:13:23 <slef> drojf: it would be 3.10.0-2
18:13:33 <slef> drojf: after the - is packaging version
18:13:36 <slef> drojf: broken? :)
18:13:41 <jcamins> drojf: yes, if the patch is signed off and QAed, which I believe we are still waiting on.
18:13:54 <slef> I missed this
18:13:54 <drojf> jcamins: ah i see
18:13:58 <slef> bug number please?
18:14:05 <drojf> slef: wrong path of some files makes OPAC broken
18:14:16 <jcamins> #info Bug 9052 should be signed off and QAed ASAP since it breaks the 3.10 packages.
18:14:16 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9052 blocker, P5 - low, ---, robin, Needs Signoff , YUI assets installed in the wrong place by packages
18:14:25 <druthb> jcamins++
18:14:27 <slef> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9052
18:14:27 <huginn> 04Bug 9052: blocker, P5 - low, ---, robin, Needs Signoff , YUI assets installed in the wrong place by packages
18:14:52 <druthb> Anything else about 3.10 out there to fret over?
18:15:03 <slef> I may be in a place to review that in a few minutes. Is there a QA who can follow me?
18:15:30 <druthb> Grooooovy. Moving right along:
18:15:37 <druthb> #topic 3.12
18:15:43 * druthb cues up "Hail to the Chief"
18:15:49 <jcamins> We'll get mtj to do it.
18:16:03 <jcamins> #info We are about two weeks into the release cycle of 3.12.
18:16:04 <cait> good plan
18:16:37 <jcamins> #info At this point there is no backlog of patches that have Passed QA, but there is a backlog of patches awaiting QA and awaiting sign off.
18:17:13 * cait agrees
18:17:16 <jcamins> #info I have written up guidelines on commit messages.
18:17:23 <jcamins> (looking now)
18:17:34 <jcamins> #link http://wiki.koha-community.org/wiki/Commit_messages
18:17:49 <jcamins> #info We have also updated the general coding guidelines somewhat.
18:17:52 <slef> jcamins: can that link be in the HACKING file in the repository, please?
18:17:58 <jcamins> #link http://wiki.koha-community.org/wiki/Coding_Guidelines
18:18:06 <cait> HACKING file?
18:18:13 <jcamins> I don't think we have a HACKING file.
18:18:26 <jcamins> #todo Add a HACKING file to the Koha repo.
18:18:29 <cait> slef: I tend to agree with jcamins, first time ever I heard about htat
18:18:33 <vfernandes> jcamins when you wrote this page?
18:18:35 <slef> we should. It's one of the GNU files, alongside README, INSTALL, Changelog
18:18:48 <jcamins> vfernandes: the commit message page?
18:18:51 <jcamins> Last week.
18:19:21 <vfernandes> ohh because I never know what to write when submitting a patch :)
18:19:24 <jcamins> If I am able to understand what's going on with a patch, I will not ask for it to be revised.
18:19:50 <cait> it also helps the QA team a lot - documentation++
18:19:51 <vfernandes> nice :)
18:20:08 <jcamins> However, if decrypting the commit message or divining the intent of the patch looks to be a time-consuming project, I will fail a patch for lack of commit message.
18:20:27 <vfernandes> that will help me in future a lot
18:20:31 <slef> hmm, I thought it was in http://www.gnu.org/prep/maintain/html_node/index.html but it's not
18:21:06 <jcamins> #info jcamins intends to continue updating and fleshing out the coding guidelines, so it is easier for new (and experienced) developers to figure out what to do.
18:21:34 <jcamins> I do intend to continue Paul's monthly RM newsletters.
18:21:44 <drojf> yeah!
18:21:45 <cait> jcamins++
18:21:50 <gmcharlt> newsletters++
18:21:55 <druthb> jcamins++
18:22:06 <vfernandes> in my next patches I will set the commit messages correctly... jcamins++
18:22:31 <druthb> Awesomeness. Anything else, jcamins?
18:22:37 <cait> maybe I can add a few things?
18:22:54 <jcamins> And I plan to roll tarballs of monthly previews, and talk to eythian about updating the packages at the same time so that if a non-developer wants to see what they can look forward to, they can do so easily.
18:22:57 <jcamins> And that's all from me.
18:23:06 <druthb> Great. cait?
18:23:09 <cait> unit tests for new routines are mandatory now - if you are not sure how to do it, I think there will be people to help you with it
18:23:16 <slef> jcamins: maybe README.developer is a better name?
18:23:23 * jcamins might be one of those people.
18:23:39 <cait> there is also a new 'rule' that qa and patch should be done by different parties, extending our existing set of rules a bit
18:24:36 <cait> we will try to stick to that, with being less strict for patches wiating for longer than 1 month
18:24:55 <cait> also my usual reminder to everyone: please remember that signing off is as important as providing patches
18:25:22 <cait> and fixing bugs is always more important than new features ;)
18:25:37 <jcamins> cait++
18:25:40 <slef> my usual worry is I don't like being mean and I'm afraid I will be, finding bugs in fixes :-/
18:25:41 <cait> ok, I think that's it from me :)
18:25:56 <jcamins> slef: this might put your mind at ease:
18:25:57 <druthb> All right. Anything else on 3.12?
18:26:05 <vfernandes> fixing bugs is more important, but new features are always welcome :P
18:26:09 <cait> I don't like being mean too - it's not nice to fail patches, but if you provide good reason it should be ok :)
18:26:14 <jcamins> if you don't fail it, I will.
18:26:31 <libsysguy> jcamins the gate keeper
18:26:43 <druthb> #topic KohaCon2013
18:26:49 <druthb> nancyk, you're up.
18:27:01 <nancyk> #info We are in the last stage of hotel negotiations. After that, I will be getting volunteers together to plan.
18:27:16 <nancyk> not much to tell yet
18:27:45 <vfernandes> when KohaCon2013 will be? sorry for don't know :/
18:27:46 <druthb> Still working October, yes? But dates remain un-firm at this point?
18:27:49 <cait> is the date set now?
18:28:03 <nancyk> looks like mid october
18:28:56 <druthb> All right. Anything else you'd like to mention, ask for, or rant about, nancyk?
18:29:08 <nancyk> Not yet.
18:29:20 <druthb> Okie dokie. Questions from the floor?
18:29:44 <druthb> I love easy meetings.
18:29:49 <slef> nope
18:29:54 <druthb> #topic Vote on license change.
18:29:58 <druthb> So much for an easy meeting.
18:30:02 <libsysguy> heh
18:30:04 <vfernandes> is there any schedule for koha 3.12 release?
18:30:05 <thd> Sorry that I had missed the recent mailing list discussion of the license upgrade issue admist all the systems needing repair after last month's storm.
18:30:06 <drojf> lol
18:30:07 <slef> ah this is why cait was hiding :)
18:30:14 <jcamins> vfernandes: yes, we remain on schedule for May 22, 2013.
18:30:28 <thd> Unfortunately, we cannot meaningfully pursue upgarding the license without resolving the issue over the OpenNCIP GPL 2 license invocation omission of an upgrade clause.
18:30:35 <jcamins> thd: but that has been resolved.
18:30:42 <slef> jcamins: got link?
18:30:45 <jcamins> OpenNCIP is licensed GPLv2+.
18:30:50 <thd> When was that resolved?
18:30:51 <jcamins> gmcharlt: do you have it handy?
18:30:55 <druthb> Okay, this has been *beaten to death* over the last couple of years on the mailing list. If you have something *new*, bring it. If you don't, keep your peace, please.
18:30:59 <jcamins> thd: six months ago?
18:31:14 <slef> druthb: can we allow tying up loose ends?
18:31:20 <druthb> certainly.
18:31:23 <jcamins> thd: http://lists.koha-community.org/pipermail/koha-devel/2011-April/035334.html
18:31:28 <gmcharlt> jcamins: yes, it's been resolved
18:31:33 <jcamins> #link http://lists.koha-community.org/pipermail/koha-devel/2011-April/035334.html
18:31:40 <gmcharlt> and that's indeed the link
18:31:41 <vfernandes> I have to go, bye :)
18:31:55 <slef> vfernandes: bye!
18:32:44 <druthb> Any other loose ends or new issues/concerns that haven't been flogged already?
18:33:11 <thd> gmcharlt: That message did not indicate to me that the issue had been resolved.
18:33:17 <cait> I think the currenct license is an issue for using bootstrap and maybe other things
18:33:25 <cait> so we need to decide how to decide it - for real this time
18:33:29 <jcamins> Yes.
18:33:43 <slef> anyone remember the last threads, for the record?
18:33:47 <gmcharlt> thd: I disagree -- but I suggest we take this on to the mailing list
18:34:06 <cait> could we agree to have a vote on this next meeting?
18:34:31 <thd> cait: We had an entire meeting on a license upgrade voting procedure.
18:34:40 <druthb> heck, I thought that's what we were gonna do *this* time, cait.
18:34:40 <slef> when would we be aiming to relicense by? 3.12.0?
18:34:48 <jcamins> Yes.
18:34:55 <libsysguy> tomorrow
18:34:55 <wahanui> i heard tomorrow was pizza friday! or the day after today.
18:35:08 <cait> hm could we already start working on things like bootstrap in the repo before release?
18:35:13 * druthb pokes libsysguy with the pointy stick.
18:35:52 <jcamins> thd: if you have actual concerns, I encourage you to bring them to the mailing list and *resolve* them.
18:36:05 <jcamins> Otherwise, we are just spending a half an hour every month doing nothing.
18:36:06 <slef> I'm not finding this on koha-devel in Sep or Oct, now trying Nov
18:36:29 <slef> ah found it!
18:36:31 <slef> #link http://lists.koha-community.org/pipermail/koha-devel/2012-November/038454.html
18:36:51 <druthb> slef++
18:36:58 <thd> The actual concern I have is that the license of OpenNCIP has not changed.
18:37:09 <thd> http://openncip.cvs.sourceforge.net/viewvc/openncip/src/
18:37:19 <oleonard> #info Owen Leonard, Athens County Public Libraries
18:37:20 <slef> #link http://koha.1045719.n5.nabble.com/Upgrading-Koha-s-license-td5732930.html
18:37:38 <slef> thd: a later statement from the licensor would take priority, no?
18:37:45 <thd> There is no file reflecting a change in the license invocation posted to the code repository.
18:38:27 <thd> slef: Yes, but that would need to actually be from the party holding copyright and not merely another interested party.
18:39:03 <jcamins> Okay, so what I'm hearing is that we're not making any progress. Mailing list, please?
18:39:15 <cait> can we still announce a vote on this next meeting?
18:39:26 <druthb> concur. We'll bump this *again*.
18:39:29 <slef> thd: true, so are you proposing an amendment that we'll change once the OpenNCIP project actually changes their published licence or we stop using OpenNCIP?
18:39:33 <gmcharlt> cait: perhaps a straw vote?
18:39:42 <oleonard> Are there actual objections to the upgrade in principle or just concerns over the details?
18:39:45 <cait> no, but given it is resolved by then, could we have a vote?
18:39:52 <cait> i fear we will bump this.. forever.
18:39:54 <thd> I will take my question about whether the openncip license has actually changed to the mailing list so we can discuss what to do if it has in fact changed properly.
18:39:57 <cait> without setting deadlines
18:40:15 <slef> I'd rather vote now, with an amendment making it conditional on resolving OpenNCIP one way or the other.
18:40:19 <jcamins> slef++
18:40:20 <druthb> slef++
18:40:24 <gmcharlt> agreed
18:40:25 <talljoy> slef++
18:40:26 <libsysguy> slef++
18:40:27 <druthb> Suits me. Objection?
18:40:27 <oleonard> slef++
18:40:30 <thd> cait: We had a procedure for upgrading the license which is documented in the wiki.
18:40:43 <cait> slef++
18:40:44 <druthb> link?
18:40:49 <cait> thd: and it didn't work
18:41:16 <oleonard> http://wiki.koha-community.org/wiki/Koha_copyright_license?
18:41:23 <thd> cait: It could not be put forward because the issue was moot in consequence of openncip.
18:41:45 <slef> #link http://wiki.koha-community.org/wiki/Koha_copyright_license
18:41:46 <thd> oleonard ++
18:41:55 * slef arrives at the same point at oleonard
18:42:02 <druthb> Holy shmoley--that's forever and a week ago.
18:42:05 <slef> huginn: query openncip
18:42:07 <cait> i think what we are talking now is different than before too
18:42:07 <huginn> slef: No results for "openncip."
18:42:12 <cait> we just want to switch from 2 to 3
18:42:14 <cait> as I see it
18:42:21 <slef> ok, can someone report openncip to bugs.koha-community.org please?
18:42:24 <cait> and are not discussing different licenses
18:42:42 <slef> (thd? report openncip to bugs.koha-community.org?)
18:42:50 <oleonard> Yeah I don't think anyone is lobbying for AGPL3+ this time around
18:42:53 <cait> so we can make this a simpler process
18:43:02 <thd> oleonard: I am
18:43:19 <slef> thd: that's not the published proposal this time.
18:43:24 <libsysguy> of course
18:43:27 <jcamins> Let's focus on one step at a time, and just upgrade to GPLv3+?
18:43:32 <cait> +1
18:43:35 <oleonard> +1
18:43:36 <talljoy> +1
18:43:37 <druthb> Okay, I'm gonna bring this around, right now--it's beyond past time. Let's vote. It's been moved that we move to GPL 3+, with two amenedments in the agenda, plus the one that this is dependent on resolution of the openncip issue.
18:43:39 <jcamins> Per the proposal that has been mooted.
18:43:42 <rangi> +1
18:43:46 <slef> so maybe the openncip thing can wait and block a later upgrade.
18:43:47 <libsysguy> +1
18:43:48 <oleonard> Doing so does not prevent us from arguing over AGPL3+ later
18:43:48 <jcamins> +1
18:43:49 <drojf> +1
18:43:56 <druthb> +1
18:44:00 * slef thinks about this a moment
18:44:10 <davidnind> +1
18:44:11 <thd> +1 However, should there not be a community wide vote?
18:44:12 <khall> +1
18:44:24 <talljoy> isn't this that?
18:44:25 <bag> +1
18:44:26 <edveal> +1
18:44:29 <talljoy> +1
18:44:38 <slef> hehehe
18:44:48 <druthb> Community wide meeting, published agenda. If they care, they should be here.
18:44:51 <cait> i think if we advertise this, anyone intersted can show up next meeting
18:45:00 <gmcharlt> +1
18:45:15 <druthb> Any nays?
18:45:32 <slef> oh drat
18:45:42 <thd> Am I reconnected?
18:45:47 <cait> yes
18:45:57 <slef> my question in http://lists.koha-community.org/pipermail/koha-devel/2012-November/038484.html remains unanswer
18:46:15 <slef> ed - basically, is the upgrade even necessary? ;-)
18:46:28 <druthb> #agreed GPLv3+, as of 3.12.0, with two exceptions, and pending the openncip issue.
18:46:43 <jcamins> slef: yes, because we are upgrading the distribution license.
18:46:48 <slef> -1
18:47:33 <druthb> #topic Actions from general IRC meeting last month
18:47:45 <druthb> "libsysguy to publish repo of his mechanized testing suite" ?
18:48:10 * libsysguy has changed his mind and is instead pursuing Selenium tests
18:48:17 * druthb snorts.
18:48:20 <rhcl> +1
18:48:23 <libsysguy> but will publish those as they are written
18:48:30 <druthb> Awesome.
18:48:35 <druthb> "Find out if we can set Bugzilla permissions so that only the QA team can mark things "Passed QA"" ?
18:48:36 <libsysguy> also, I would like to welcome anyone else to write them as well
18:48:57 <jcamins> druthb: doesn't seem to be doable, so we'll survive without.
18:49:04 <druthb> all righty then.
18:49:21 <druthb> #topic Miscellaneous -- Wiki spam
18:49:25 <cait> I think any test is good, whatever you use for writing them
18:49:38 <cait> that was me - I noticed we still got a big spam problem
18:49:43 <cait> and people spend a lot of time cleaning up
18:49:45 * gmcharlt jumps in with a proposal -- a call for volunteers to manually approve wiki user registrations
18:49:47 <cait> that could be much better used
18:50:11 <cait> and I support gmcharlt's proposal for that reason :)
18:50:12 * oleonard hopes to start writing tests for JavaScript if he can integrate what he learned over the last couple of days
18:50:16 <rangi> Me too
18:50:19 <slef> gmcharlt: me, as long as we can do it without mailbombing me :)
18:50:36 <rangi> Having deleted 116 pages
18:50:37 <cait> would be nice to get people from different timezones
18:50:41 <gmcharlt> slef: indeed - *multiple* volunteers, I should point out :)
18:50:44 <rangi> In the last month
18:50:46 <druthb> gmcharlt has made a proposal--does anyone *not* like that idea?
18:51:06 <cait> how do you see if it's a real person? form the chosen user name?
18:51:09 <druthb> ...anyone think they have a *better* idea?
18:51:13 <rangi> And of quit doing that so vote yes
18:51:22 <rangi> Or clean it urself
18:51:35 <rangi> :)
18:51:46 <cait> rangi: I think we are not voting, we just silently agreed :P
18:51:49 <thd> Do we not have automation to better assist with the problem?
18:51:53 <gmcharlt> cait: yeah, that's one of the ways
18:52:19 <cait> gmcharlt: as it was my idea... sign me up
18:52:20 <gmcharlt> thd: what mediawiki provides has thus far been insufficient without imposing draconian captchas
18:52:21 <slef> oh, could we add something like "please put a message for the moderators here saying what you'll do" and a message to the thank-you saying to ask on-list if moderators are very very slow ;-)
18:52:22 <thd> There are antispam extensions.
18:52:32 <slef> thd: got links?
18:52:38 <cait> well your solution really, I only wondered about the spam :)
18:52:43 <rangi> Look
18:52:50 <talljoy> o.o
18:53:03 <rangi> Can we just do the moderation
18:53:15 * jcamins moves that if there are antispam extensions we could use, they should be considered for later, and in the meantime we should take advantage of the people willing to do moderation.
18:53:17 <slef> far too many mediawiki "antispam" extensions I've seen have little to do with testing spamminess and :-/
18:53:20 <rangi> You guys can then argue for months after that
18:53:24 <druthb> #agreed the wiki will be set to moderate registration--and cait and slef have volunteered to help with that. Other vols are welcome.
18:53:32 <rangi> About automation
18:53:41 <oleonard> I volunteer as well
18:53:46 <rangi> It's been 2 years already
18:53:53 <thd> rangi: By moderation do you mean that all updates would by pending approval?
18:53:54 <cait> druthb: now we only got 'europe' covered
18:53:59 <druthb> beats nothing.
18:54:04 <cait> oleonard++
18:54:10 <druthb> oleonard++
18:54:13 <thd> s/by/be/
18:54:13 <rangi> I volunteer
18:54:18 * gmcharlt volunteers
18:54:19 <davidnind> I volunteer to help as well
18:54:23 <rangi> No just users thd
18:54:24 <slef> thd: "moderate registration"
18:54:27 <druthb> rangi++ davidnind++
18:54:44 <cait> rangi++ gmcharlt++ and davidnind++
18:54:45 <druthb> #info davidnind, rangi, oleonard volunteered as well. Kudos to all of 'em.
18:54:56 <druthb> All right, moving along.
18:55:09 <druthb> #topic Miscellaneous --disabled features review
18:55:19 <jcamins> That's mine.
18:55:24 <jcamins> This does not require a vote, nor discussion.
18:55:27 <druthb> jcamins has the floor.
18:55:27 <jcamins> (nice, huh?)
18:55:31 <oleonard> I vote yes!
18:55:35 <drojf> -1
18:55:36 <drojf> :P
18:55:41 <druthb> jcamins++
18:55:42 <cait> sorry, what does it mean?
18:55:54 <jcamins> I wanted to suggest that people start thinking about if we have disabled any features by default that shouldn't be.
18:56:06 <jcamins> For example, ExtendedPatronAttributes is disabled by default.
18:56:07 <cait> aah
18:56:13 <cait> enhancedmessaging
18:56:20 <rangi> Case by case basis
18:56:22 <slef> #action people start thinking about if we have disabled any features by default that shouldn't be
18:56:25 <jcamins> However, even if you enable it, it doesn't do anything without further consideration.
18:56:30 <jcamins> *configuration
18:56:37 <gmcharlt> good thought -- for example, I'd been in favor of enabling both mentioned by default
18:56:40 <rangi> Yep and open bugs to change then?
18:56:50 <slef> does enhancedmessaging still email you every day if it's enabled and not configured correctly?
18:56:59 <rangi> Yes
18:56:59 <jcamins> So I wanted people to think about things that shouldn't be disabled, and file bugs (and provide patches) about them.
18:57:12 <jcamins> slef: so that would be one that shouldn't be enabled by default.
18:57:13 <druthb> rangi++ #these are minor annoyances when setting up a box, nothing more. A bug and patch to fix them should do.
18:57:18 <rangi> (to slef)
18:57:24 <slef> rangi: I thing that behaviour would need changing then.
18:57:31 <rangi> Yep
18:57:35 <jcamins> Or we leave it disabled. Which is fine.
18:57:39 <jcamins> Disabled features are not a bad thing.
18:57:40 <slef> !!:s/thing/think
18:57:52 <jcamins> It's just pointlessly disabling features which is pointless.
18:57:55 <jcamins> And that's all I had.
18:57:56 <rangi> So bug would fail :-)
18:57:59 <rangi> Easy peasy
18:58:05 <cait> it mails without any configuration for patron categories?
18:58:19 <druthb> Awesomeness. Okay, we're at the end of the agenda for this meeting, other than fixing the time for our next.
18:58:25 <druthb> #topic next meeting time?
18:58:30 <rangi> Cait: discuss on bug :)
18:58:36 <cait> ok :)
18:58:49 <oleonard> January 9?
18:58:53 <slef> 9th at 10 UTC?
18:59:00 <rangi> Wfm
18:59:03 <slef> if it's the usual pattern
18:59:06 <rangi> Yep
18:59:10 * slef checks his calendar ;)
18:59:11 <drojf> i think it is
18:59:11 <jcamins> +1
18:59:18 <drojf> and it's 11 for cait :P
18:59:25 <druthb> January 9, 2013, at 10:00 UTC, it is.
18:59:32 * cait ignores drojf
18:59:33 <druthb> Thank you all for your participation.
18:59:41 <druthb> #endmeeting