18:11:47 <davidnind> #startmeeting IRC General Meeting 4 December 2013
18:11:47 <huginn> Meeting started Wed Dec  4 18:11:47 2013 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:11:47 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:11:47 <huginn> The meeting name has been set to 'irc_general_meeting_4_december_2013'
18:12:07 <davidnind> #topic Introductions
18:12:08 <wahanui> #info wahanui, a bot that has become sentient
18:12:31 <davidnind> #info David Nind, Wellington NZ
18:12:44 <gmcharlt> #info gmcharlt = Galen Charlton, ESI, Seattle, USA; 3.16 release manager
18:12:57 <Bruce_> ?info Bruce Metcalf, Augustan Society Library, Orlando FL US
18:13:05 <jwagner> #info Jane Wagner, LibLime/PTFS
18:13:05 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba, Argentina
18:13:27 <joels68> #info Joel Sasse, Plum Creek Library system, Minnesota
18:13:47 <thd> #info Thomas Dukleth, Agogme, New York City - not dead yet
18:14:02 <nancyk> #info Nancy Keener Washoe County Library System
18:14:18 <JesseM> #info Jesse Maseto ByWater Solutions
18:14:39 <bag> #info Brendan Gallagher ByWater
18:14:48 <nengard> #info Nicole Engard, ByWater Solutions
18:15:25 <davidnind> Whew! We do have some people here.
18:15:41 <davidnind> #topic Announcements
18:16:06 <davidnind> Does anyone one have any announcements they wish to make?
18:17:57 <davidnind> The videos that are available from KohaCon13 are now online at https://archive.org/search.php?query=subject%3A%22kohacon13%22
18:18:07 <nengard> KohaCon14 will be held in C?rdoba, Argentina on October 6th through 13.
18:18:23 <bag> agenda?
18:18:24 <wahanui> i heard agenda was a wiki
18:18:37 <nengard> And I would add that not the entire conference was recorded - so what's on the internet archive is all I got from the conference organizers
18:18:48 <gmcharlt> #link http://wiki.koha-community.org/wiki/General_IRC_meeting,_4_December_2013
18:18:57 <bag> thanks gmcharlt
18:19:59 <khall> #info Kyle M Hall, ByWater Solutions
18:20:02 <davidnind> #info KohaCon14 will be held in Cordoba, Argentina on October 6th through 13
18:20:12 <davidnind> #info he videos that are available from KohaCon13 are now online at https://archive.org/search.php?query=subject%3A%22kohacon13%22
18:20:29 <barton> #info barton
18:20:30 <davidnind> #topic Update on 3.8
18:20:49 <davidnind> Is anyone able to provide an update on 3.8?
18:21:51 <barton> #info Barton Chittenden, ByWater Solutions
18:22:09 <davidnind> 3.8.20 released on 30 November
18:22:22 <davidnind> On agenda to discuss
18:22:51 <magnuse> #info Magnus Enger, Libriotech, Norway
18:22:57 <davidnind> #topic Update on 3.10
18:23:02 <talljoy> #info joy Nelson ByWater
18:23:25 <davidnind> Anyone able to provide an update on 3.10?
18:24:46 <bag> guess not
18:24:50 <davidnind> Okay, moving right along to the next item....
18:24:59 <davidnind> #topic Update on 3.12
18:25:44 <davidnind> Anyone able to provide an update on 3.12?
18:27:19 <davidnind> Okay, moving right along ....
18:27:42 <bag> are all the maints on much different timezones?
18:27:48 <bag> I guess os
18:27:51 <bag> so*
18:28:03 <davidnind> Not sure..ah well
18:28:19 <davidnind> 3.12.7 released on 22 November
18:28:51 <davidnind> #topic Update on 3.14
18:29:24 <gmcharlt> I've communicated with Fridolin and expect that he'll start to push patches into 3.14.x soon
18:29:59 <bag> sweet
18:31:10 <davidnind> Great! Also least we forget 3.14 was released in November - thanks to everyone involved @gmcharlt++
18:31:29 <gmcharlt> details, details ;)
18:31:34 <tcohen> i'm sorry i was absent a few minutes ago
18:31:37 <nengard> gmcharlt++
18:31:50 <davidnind> gmcharlt++
18:31:51 <tcohen> gmcharlt++
18:32:02 <talljoy> gmcharlt++
18:32:05 <joels68> gmcharlt++
18:32:24 <JesseM> gmcharlt++
18:32:42 <Bruce_> gmcharlt++ 3.14 has features I didn't know I desperately needed!
18:33:11 <gmcharlt> all_you_all++ # without everybody else, I would have nothing to do
18:33:24 <thd> gmcharlt++; Fridolin++;
18:33:25 <davidnind> #info Congrats and a big thankyou to everyone involved in the 3.14 release
18:33:40 <bag> gmcharlt++
18:33:46 <davidnind> I'm sure you would have thought of something....
18:34:24 <davidnind> #topic Update on 3.16
18:34:45 <gmcharlt> #info Patches have started being pushed to master for 3.16
18:35:23 <gmcharlt> #info Galen will be outlining various changes to coding guidlines in the next two weeks for developer consideration -- having to do with things like implications of of DBIx::Class support
18:35:32 <nengard> #info I'll create a branch for the 3.16 manual probably after the .1 release (and after i finalize the 3.14 manual)
18:36:05 <davidnind> nengard++
18:36:44 <gmcharlt> any questions?
18:37:01 <bag> any movement on module maintainers?
18:37:57 <gmcharlt> not yet, but it's on my list
18:38:04 <bag> ok thanks :)
18:39:31 <bag> that's it from me for questions (for now :P )
18:39:41 <tcohen> will it be mandatory to use  DBIx::Class for 3.16 patches?
18:40:04 * bag is looking forward for the developer docs gmcharlt speaks of :)
18:40:24 <gmcharlt> tcohen: it will be strongly encouraged
18:40:31 <tcohen> thx gmcharlt
18:41:14 <davidnind> Thanks gmcharlt
18:41:27 <davidnind> #topic Extra elections for 3.16
18:41:47 <davidnind> We have two nominations, will do one at a time
18:42:11 <davidnind> The previous general meeting left it open for additional people to be nominated
18:42:46 <davidnind> First up is Magnus Enger volunteering as a Bug Wrangler
18:42:51 <bag> +1
18:42:54 <gmcharlt> +1
18:42:56 <nengard> +1
18:42:58 <JesseM> +1
18:42:59 <davidnind> +1
18:43:00 <Bruce_> +1
18:43:03 <barton> +1
18:43:07 <thd> +1
18:43:22 * magnuse bows
18:43:32 <gmcharlt> magnuse++ # you're stuck with us now!
18:43:33 <tcohen> +1
18:43:37 <khall> +1
18:43:56 <magnuse> gmcharlt: couldn't imagine a better buch to be stuck with
18:44:07 <davidnind> #agreed Magnus Enger is now a Bug Wrangler
18:44:12 <magnuse> yay!
18:44:33 <JesseM> magnuse++
18:44:50 <magnuse> thanks, i'll try to live up to my own expectations this time...
18:45:08 <bag> awesome
18:45:39 <davidnind> Next up is Brendan Gallagher volunteering as part of the QA team
18:45:43 <nengard> hmmmmm
18:45:45 <magnuse> +1
18:45:46 <nengard> not sure about that one
18:45:48 <nengard> :)
18:45:53 <Bruce_> +1
18:45:54 <nengard> +1
18:45:55 <JesseM> +1
18:45:58 <talljoy> +1
18:46:03 <barton> +1
18:46:04 <davidnind> +1
18:46:04 <gmcharlt> +1
18:46:07 <khall> +1
18:46:09 <thd> +1
18:46:41 * bag follows magnuse's excellent lead and bows
18:46:56 <davidnind> #agreed Brendan Gallagher is now on the Quality Assurance team
18:47:09 <bag> thanks :)
18:47:14 <davidnind> Thanks everyone for volunteering for these roles
18:47:50 <davidnind> #topic Decision on maintaining 3.8.x and electing Release Maintainer for 3.8.x
18:48:49 <davidnind> Note that Kyle Hall has been added as release maintainer  http://wiki.koha-community.org/wiki/Roles_for_3.16
18:48:50 <magnuse> do we have a volunteer?
18:49:34 <davidnind> The last meeting left it open -  whether to continue the 3.8.x branch and elected an rmaint for it to be decided  by the December IRC meeting
18:50:14 <davidnind> I assume that if someone is willing to be a Release Maintainer then we will continue supporting?
18:50:15 <bag> 3.8 is 2+ years old now?
18:50:38 <Bruce_> What is our policy on the duration of support?
18:51:10 <bag> Bruce_: I don't think there is a hard oneā€¦  mainly what davidnind said to a certain extent
18:51:11 <khall> As far as I know, as long as there is a volunteer, a release may continue to be maintained
18:51:29 <Bruce_> One is moved to wonder if infinite support is wise.
18:51:32 <gmcharlt> however, there is a point of dminishing returns, of course
18:51:32 <barton> how long did we support 3.4?
18:51:56 * gmcharlt proposes that we announce that 3.8.x will be EOLed upon the release of 3.16.x
18:52:03 <gmcharlt> er, 3.16.0
18:52:12 <bag> +1
18:52:18 <davidnind> +1
18:52:19 <barton> +1
18:52:27 <nengard> +1
18:52:27 <magnuse> +1
18:52:30 <Bruce_> So... we're going to spread ourselves thin enough to support 5 releases at once?
18:52:31 <Bruce_> -1
18:52:36 <bag> which means we would need a 3.8 RMaint
18:53:30 <gmcharlt> Bruce_: are you favoring an immediate EOL for 3.8?
18:53:36 <tcohen> 3.8 is maintained by Chris Hall right now, right?
18:53:47 * gmcharlt wouldn't mind that, but there's at least one library that has expressed a desire to have it kept going
18:54:07 <bag> What's the amount of patches that we being written for 3.8?
18:54:11 <khall> yes, Chris Hall was interested in continuing to maintain 3.8
18:54:19 <Bruce_> I am favoring our adopting some policy about how many simultaneous releases we support so that we aren't spread too thin.
18:54:23 <khall> I volunteered to take up the reighns
18:54:26 <davidnind> That would be the next item - to elect Kyle Hall
18:54:31 <davidnind> Oops
18:54:42 <Bruce_> ... but Kyle's offer moots my point for the moment.
18:54:57 <khall> 2 years of maintainence seems reasonable
18:55:00 <gmcharlt> Bruce_: I think discussing a policy is a good idea; probably for koha-devel first, though
18:55:08 <magnuse> +1
18:55:09 <thd> Releases should be maintained as long as there is a maintainer willing to maintain them.  Recommending maintenance of an old release is a different question entirely.
18:55:24 <Bruce_> Right. I'll see if I can find the right venue for my thoughts.
18:55:49 <gmcharlt> thd: in principle, yeah, if somebody wants to do it, we don't necessarily want to say no -- but on the other hand, there are real costs tot he community if folks don't stay reasonably current
18:56:12 * gmcharlt is putting aside security releases for the moment
18:56:49 <davidnind> Okay.  As we have volunteer we should now vote on khall (Kyle Hall) volunteering as release maintainer for 3.8
18:56:58 <Bruce_> +1
18:57:01 <JesseM> +1
18:57:02 <nengard> +1
18:57:03 <gmcharlt> +1
18:57:07 <davidnind> +1
18:57:08 <thd> We should definitely encourage people to upgrade but they are allowed not to do so for whatever reasons they may choose, however unwisely over time.
18:57:11 <barton> +1
18:57:17 <thd> +1
18:57:22 <edveal> +1
18:57:30 <talljoy> +1
18:57:53 <bag> +1
18:58:11 <tcohen> +1
18:58:35 <davidnind> #agreed khall (Kyle Hall) is now Release Maintainer for 3.8
18:58:44 <gmcharlt> khall++
18:59:04 * khall bows with a flourish
18:59:12 <magnuse> khall++
18:59:16 <tcohen> khall++
18:59:50 <bag> khall++
19:00:04 <talljoy> khall++
19:00:17 <davidnind> #agreed To discuss in other forums the policy around supporting older releases (unless it is already documented elsewhere)
19:00:25 <davidnind> khall++
19:00:46 <davidnind> #topic KohaCon14
19:00:52 <joels68> khall++
19:01:09 <davidnind> Is anyone here able to talk about this?
19:01:15 <tcohen> briefly
19:01:29 <davidnind> Great!
19:02:02 <tcohen> KohaCon14 will be held in Cordoba, on october 6th through 13th
19:02:28 <tcohen> we are about to set a wiki page for it, and arrange things for calling for presentations and volunteers
19:02:44 <tcohen> now we have set the dates we will start searching for local sponsors
19:03:02 <nengard> tcohen I can set up the call for presenters form again if need be
19:03:09 <tcohen> the conference will be held in the university campus
19:03:25 <magnuse> 3 days conference, 1 day rest, 4 days hackfest?
19:03:29 <tcohen> i was thinking of reusing our OCS setup
19:03:39 <davidnind> OCS?
19:03:50 <tcohen> 3 days conference, a couple of days for hackfest
19:04:01 <tcohen> some trips within Cordoba on the weekend
19:04:13 <tcohen> and more hackfest for those who want to stay longer
19:04:23 <tcohen> PKP Open Conference System
19:05:07 <tcohen> we will try to make a more precise proposal to put into consideration to the community
19:05:16 <tcohen> ASAP
19:05:42 <bag> :)
19:06:13 <tcohen> any thoughts on the dates? are they ok?
19:06:20 <nengard> they work for me
19:06:24 <thd> tcohen++ 4 day hackfest
19:06:43 <JesseM> I like the dates as well
19:06:45 <tcohen> do we need two weekend days for traveling around? is one enough like it was in Reno?
19:06:53 <Bruce_> I think the dates should be determined locally, as shifting by a week can make a great difference in the cost of hotels and meeting space.
19:07:08 <nengard> Well I'll note that the following week I have another conference
19:07:13 <nengard> so shifting it that way is a bad idea for me :)
19:07:43 <barton> nengard is going to be busy in October
19:07:48 <Bruce_> ... with due consideration for other major conferences.
19:07:54 * nengard is always busy
19:08:07 <thd> nengard: Which conference is held the following week?
19:08:12 <nengard> But I do have those dates blocked off Oct 6-13th for KohaCon :)
19:08:26 <nengard> thd internet librarian - I was wrong it's the 27th - but still a week of rest is good
19:08:26 <davidnind> I think it is great that the dates are known now - so that people can plan around it (it is what community members asked for)
19:08:32 <nengard> yup
19:08:35 * nengard is happy :)
19:08:37 <tcohen> yes
19:08:42 <tcohen> we too :-D
19:08:59 <davidnind> Unless there is a major reason to change these I think we should stick with what the organisers have announced...
19:09:00 <bag> yup dates set are a good thing
19:09:07 <nengard> +1
19:09:14 <bag> +1
19:09:46 <tcohen> we are going to need your advise in several areas nengard :-D
19:09:53 <nengard> no problem at all
19:09:55 <davidnind> Thanks for the update tcohen
19:10:08 <davidnind> tcohen++
19:10:11 <tcohen> np
19:10:11 <nengard> tcohen++
19:10:15 <davidnind> #info KohaCon14 will be be held in Cordoba, 6-13th October
19:10:23 <davidnind> #info Wiki page being setup, along with calling for presentations and volunteers
19:10:28 <davidnind> #info Will be held in university campus
19:10:34 <davidnind> #info More details will be made available soon on proposed format, etc
19:11:06 <davidnind> #topic Actions from General IRC meeting, 6 November 2013
19:11:46 <gmcharlt> #info the 3.14 beta, was, in fact, tested -- thanks to the folks who participated
19:11:57 <magnuse> the_folks++
19:12:10 <nengard> hehe
19:12:50 <davidnind> Now furiously trying to find any actions list from the last meeting ... http://meetings.koha-community.org/2013/general_irc_meeting__6_november_2013.2013-11-06-02.02.html
19:14:01 <davidnind> Only action point I can see: all people will test the beta!
19:14:47 <davidnind> #info Thanks to all those who tested the beta for 3.14
19:15:48 <davidnind> #topic general business
19:16:17 <davidnind> Does any one have any general business? If not will set the next meeting date..
19:17:48 <davidnind> #topic Next meeting
19:18:40 <davidnind> Next in the sequence is 10:00 UTC - date proposed either 1st January or 8th January
19:18:59 <Bruce_> One suspects that the latter date will gather greater attendance.
19:19:41 <davidnind> Proposal is for 8 January 2014 at 10:00 UTC
19:19:53 <magnuse> +1
19:19:58 <davidnind> +1
19:20:01 <thd> +1
19:20:04 <barton> +1
19:20:07 <JesseM> +1
19:20:18 <tcohen> +1
19:21:16 <Bruce_> 0  Not gonna be online at 5am anyway.
19:21:46 <davidnind> #info Next general IRC meeting is 8 January 2014 at 10:00 UTC
19:22:04 <davidnind> Thanks everyone for attending, and putting up with me chairing...
19:22:09 <davidnind> #endmeeting