02:04:54 <wizzyrea> #startmeeting Koha General IRC Meeting, 7 May 2013
02:04:54 <huginn`> Meeting started Tue May  7 02:04:54 2013 UTC.  The chair is wizzyrea. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:04:54 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
02:04:54 <huginn`> The meeting name has been set to 'koha_general_irc_meeting__7_may_2013'
02:05:04 <wizzyrea> there we go, please introduce yourselves using #info
02:05:12 <jcamins> #topic Introductions
02:05:13 <wahanui> #info wahanui, a bot that has become sentient
02:05:24 <druthb> #info D Ruth Bavousett, TM 3.12
02:05:35 <jcamins> #info jcamins = Jared Camins-Esakov, C & P Bibliography Services; RM for 3.12
02:05:37 <wizzyrea> #info Liz Rea, Catalyst IT, NZ
02:05:38 <jwagner> #info Jane Wagner, LibLime/PTFS
02:05:44 <BobB> #info Bob Birchall, Calyx, Australia
02:05:47 <trea> #info Thatcher Rea, ByWater Solutions
02:06:14 <mtj> #info Mason James, NZ
02:06:18 <wizzyrea> anyone else?
02:06:27 * mtj waves to all
02:06:36 <BobB> hi mtj
02:06:41 <mtj> ooh, could be a quicky
02:06:41 <wizzyrea> #topic Announcements
02:06:49 <wizzyrea> does anyone have any?
02:07:04 <wizzyrea> going once
02:07:06 <wizzyrea> going twice
02:07:11 <wizzyrea> Right
02:07:24 <wizzyrea> #Discussion on candidates to be the 3.14 Translation Manager
02:07:37 <wizzyrea> #topic Discussion on candidates to be the 3.14 Translation Manager
02:07:49 <jcamins> The only person who put a name forward was Bernardo Gonzalez Kriegel (bgkriegel).
02:07:50 <wizzyrea> Right, do we have any candidates?
02:07:58 <jcamins> #link http://wiki.koha-community.org/wiki/Roles_for_3.14
02:07:59 <wizzyrea> bgkriegel, about?
02:08:04 <druthb> bgkriegel++
02:08:19 <eythian> #info Robin Sheat, Catalyst IT, NZ
02:08:20 <wizzyrea> I feel weird having a vote to elect him when he's not around
02:08:23 <mtj> #info -> http://wiki.koha-community.org/wiki/General_IRC_meeting,_7_May_2013
02:08:42 <BobB> We could elect him subject to his acceptance
02:08:47 <wizzyrea> There we go I like that
02:08:54 <druthb> BobB++
02:09:04 <jcamins> wizzyrea: he added himself to the docket and sent an e-mail outlining his platform, so I think we can move forward.
02:09:29 <wizzyrea> Ok, all in favor of electing bgkriegel (Bernardo Gonzalez Kriegel) TM for 3.14 subject to his acceptance of the role, please +1
02:09:34 <jcamins> +1
02:09:42 <wizzyrea> +1
02:09:43 <druthb> +1
02:09:50 <eythian> +1
02:10:04 <BobB> +1
02:10:09 * druthb presses the "easy" button.
02:10:27 * wizzyrea offhandedly wonders if we need to define the corpus necessary to create a quorum
02:10:32 <wizzyrea> :P
02:10:42 <wizzyrea> because that's not a lot of people and this meeting was not well advertised.
02:10:55 <wizzyrea> HOWEVER. I think it doesn't matter for this particular vote.
02:11:30 <jcamins> Agreed.
02:11:37 <wizzyrea> #decided Bernardo Gonzalez Kriegel elected as 3.14 Translation Manager
02:11:46 <wizzyrea> Right, so updates
02:11:55 <BobB> we are eight (plus Wahanui) I reckon that's a quorum
02:11:56 <wizzyrea> #topic Updates on currently maintained releases
02:12:02 <BobB> #info Formal thanks to Ruth for excellent work as outgoing Koha Translation Manager
02:12:12 <wizzyrea> cjh, do you have anything to note regarding 3.8?
02:12:21 <wizzyrea> (if you're about)
02:12:32 <cjh> #info Chris Hall, Catalyst IT, NZ
02:12:50 <cjh> wizzyrea: sorry, was distracted. 3.8 isnt mine yet afaik.
02:13:10 <wizzyrea> k, and rangi is not here so - on to the 3.12 updates
02:13:25 <wizzyrea> jcamins?
02:13:26 <wahanui> somebody said jcamins was brilliant
02:13:28 <jcamins> #info Koha 3.12.0 will be released on or about May 22.
02:13:53 <jcamins> #info Translation updates will be pulled from Pootle on or about May 19, so get your translations finished before then.
02:13:56 <wizzyrea> how are you feeling generally about 3.12
02:14:21 <wizzyrea> ?
02:14:33 <jcamins> #info As of beta3, Koha 3.12 had 21 features, 159 enhancements and 399 bugfixes
02:14:50 <jcamins> Since then I have pushed several more bugfixes, with more yet to come.
02:14:57 <BobB> Wow, that's huge
02:15:16 <cjh> awesome work everyone
02:15:23 <wizzyrea> yep, jcamins++
02:15:25 <cjh> 399 bugfixes is impressive
02:15:26 <wizzyrea> and everybody
02:15:27 <wahanui> everybody is so enthusiastic today :)
02:15:34 <jcamins> #info I plan on releasing one more beta and at least one Release Candidate prior to May 22, subject to the number of applicable bugfixes that are written, signed off, and passed QA.
02:16:17 <jcamins> Any bugfixes that do not make any string changes are candidates for 3.12.0, though obviously I will not push anything that seems dangerous.
02:16:43 <jcamins> Anything that I decline to push to 3.12 will be bumped back to 3.14 for gmcharlt to push to master.
02:16:54 <jcamins> And I think that's about it.
02:17:13 <jcamins> 3.12 seems pretty stable, but there are lots of bugs that could use fixing, and there is a desperate need for more testing.
02:17:20 <jcamins> #todo Test all the things!
02:17:35 <jcamins> No, that's wrong.
02:17:38 <jcamins> #action Test all the things!
02:17:42 <jcamins> Any questions?
02:18:11 <wizzyrea> are there specific areas that you feel ought to be focussed on?
02:18:14 <wizzyrea> in terms of testing?
02:18:15 <jcamins> Hmmm...
02:18:26 <wizzyrea> areas with massive change that really need some going over?
02:18:55 <jcamins> I'd love to see more testing in search, because of the QueryParser work, and Acquisitions has seen a lot of flux in this latest release cycle as well.
02:19:25 <jcamins> And...
02:19:30 <jcamins> let me check the release notes.
02:19:43 <wizzyrea> 3.10 had a hold queue rewrite that is causing some issues, it might be worth going over reserves
02:19:46 <dcook> #info David Cook, Prosentient Systems, Australia
02:20:00 <jcamins> Yeah, good call.
02:20:16 <jcamins> We're definitely still seeing problems in reserves, so concerted testing would be a very good thing.
02:20:49 <wizzyrea> Hourly loans seems decently stable finally
02:20:54 <jcamins> Owen has been checking for regressions in the OPAC due to the patron self-registration, but more eyes make all bugs shallow.
02:21:00 <BobB> #action Test the Reserves functionality
02:21:27 <wizzyrea> (specifically, multi branches with transfers)
02:22:00 <wizzyrea> anything else anyone would like to bring up regarding 3.12
02:22:23 <jcamins> Before we move on to Kohacon2013, I have something about 3.14.
02:22:34 <wizzyrea> Right, then we are in the final countdown to 3.12 - I'm looking forward to it
02:22:37 <wizzyrea> http://www.youtube.com/watch?v=9jK-NcRmVcw
02:22:54 <druthb> wizzyrea++
02:22:55 <wizzyrea> Thanks jcamins for all of his hard work
02:23:11 <wizzyrea> and bravo to everybody for all of their work
02:23:28 <wizzyrea> onwards
02:23:30 <jcamins> #info If the QA team is interested in working on patches for 3.14, that would not be a problem for the 3.12 release. Just set the target release version to 3.14 and get to QAing!
02:23:37 <wizzyrea> #topic Kohacon2013
02:23:42 <wizzyrea> is anyone here who can give an update?
02:24:29 <wizzyrea> last I heard things were ticking along nicely
02:24:48 <wizzyrea> right then
02:24:51 <BobB> Is there a deadline for booking rooms, to help get the free A-V etc?
02:25:29 <wizzyrea> I would pose that to the list bobb, none of the kohacon people seem to be here
02:25:38 <BobB> cool, thx
02:25:49 <dcook> Mmm, good question
02:25:54 * dcook still has to book flights/rooms...
02:26:15 <wizzyrea> #topic Vote on proposal to increment major version number for every feature release after 3.14 Pi
02:26:16 <BobB> dcook QF has a sale on - get cracking
02:26:36 <wizzyrea> I'm not certain I feel comfortable voting on this with so few
02:26:37 <dcook> BobB: I think I'll be going AC but thanks :)
02:26:47 <BobB> :)
02:26:49 <jcamins> wizzyrea: especially since we're all just going to abstain?
02:26:56 <jcamins> Yeah...
02:27:06 <dcook> wizzyrea: Agreed
02:27:57 <wizzyrea> Can we agree to postpone this question to the next meeting, or set up an alternative voting mechanism
02:27:58 <wizzyrea> ?
02:28:01 <jcamins> +1
02:28:23 <BobB> postpone to next meeting +1
02:28:30 <jwagner> +1
02:28:40 <dcook> +1
02:28:47 <druthb> +1
02:29:15 <wizzyrea> anyone else?
02:29:26 <mtj> erm, +1 :)
02:29:32 <wizzyrea> lol.
02:29:57 <wizzyrea> #decided we will postpone the vote regarding numbering schemes to the next meeting, which will be better advertised.
02:30:38 <wizzyrea> next up - things from last meeting
02:30:39 <mtj> #agreed we will postpone the vote regarding numbering schemes to the next meeting, which will be better advertised.
02:31:13 <mtj> (meetbot command is #agreed)
02:31:22 <jcamins> I don't see any actions for last meeting.
02:31:35 <wizzyrea> yep, I'm not seeing much of anything there really
02:31:36 <jcamins> *from
02:31:58 <wizzyrea> so time to set the time for the next meeting
02:32:01 <mtj> ah, #agreed only works for chair… :/
02:33:12 * BobB didn't know that
02:33:52 <jcamins> First Wednesday at... 18:00 UTC?
02:34:21 <wizzyrea> it's going to be June 5, 1800 UTC? is my math
02:34:22 <jcamins> 6 June 2013, 18:00 UTC
02:34:27 <wizzyrea> 6 june even.
02:34:28 <jcamins> 5 June, yes.
02:34:32 <jcamins> No, you were right.
02:34:45 <jcamins> My left hand was a key over.
02:34:52 <wizzyrea> right, next meeting is at 1800 UTC 5 june
02:34:59 <wizzyrea> anything else?
02:34:59 <wahanui> anything else is a guess
02:35:29 <wizzyrea> #agreed we will postpone the vote regarding numbering schemes to the next meeting, which will be better advertised.
02:35:34 <BobB> err, that will be 4am in Sydney - I reckon I'll be an apology
02:35:53 <wizzyrea> bobb - if you want, you could leave your apology with your vote on the wiki
02:36:00 <wizzyrea> that seems fair
02:36:07 <jcamins> BobB: no worries, I probably will be too.
02:36:18 <jcamins> And it'll be the middle of the day here.
02:36:24 <BobB> :)
02:37:22 <wizzyrea> okie dokie
02:37:35 <wizzyrea> well I thank you all for your participation in today's gathering of community minded people
02:37:38 <mtj> #info next meeting is at 1800 UTC 5 june
02:37:55 <wizzyrea> Minutes will be available on the wiki
02:38:02 <wizzyrea> have a lovely rest of your day/night
02:38:07 <wizzyrea> #endmeeting