22:00:12 <rangi> #startmeeting Developer Meeting
22:00:12 <huginn> Meeting started Wed May 21 22:00:12 2014 UTC.  The chair is rangi. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:12 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:12 <huginn> The meeting name has been set to 'developer_meeting'
22:00:28 <rangi> #topic Introductions
22:00:29 <wahanui> #info wahanui, a bot that has become sentient
22:00:40 <cait> #info Katrin Fischer, BSZ
22:00:42 <rangi> #info Chris Cormack, Catalyst, NZ
22:00:52 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
22:01:07 <bgkriegel> #info Bernardo Gonzalez Kriegel, Córdoba, Argentina
22:01:33 <rangi> anyone else?
22:01:53 <rangi> #topic RM 3.18 comments
22:01:58 <rangi> over to you tcohen
22:02:30 <tcohen> As I said earlier, my main concern is coorindating efforts
22:02:43 <rangi> seems like a good concern to have :)
22:02:46 <tcohen> and find bottlenecks that prevent people's work
22:02:57 <tcohen> to get in
22:03:14 <rangi> what i tried to maintain (not very well) when i was RM was a blog/wiki
22:03:18 <bag> #info Brendan Gallagher Bywater
22:03:22 <tcohen> i.e. if someone needs feedback on an aPI definition, I'll try to make that feedback appear
22:03:28 <rangi> cool
22:03:49 <rangi> maybe if we could try to get a one page summary, (with links out) of the big things people are working on
22:03:57 <rangi> like a taskboard
22:04:01 <tcohen> yeha
22:04:12 <tcohen> I've tried with a Trello board
22:04:19 <rangi> i can look into doing something with bugzilla to pull that info out
22:04:24 <tcohen> we'll see what serves the purpose
22:04:35 <rangi> cool
22:04:51 <tcohen> i hope to have something to show the MM's next week
22:04:56 <rangi> sweet
22:05:24 <cait> QA is curious :)
22:05:48 <bag> :)
22:05:55 <rangi> im happy to make a RM page, and a MM page and a QA page on the dashboard too
22:06:04 <rangi> with the info people need for them
22:06:25 <rangi> ok
22:06:31 <rangi> #topic Additions to Coding Guidelines
22:06:32 <tcohen> QA people will be there of course
22:06:50 <rangi> i see that in the last meeting
22:07:03 <rangi> #info Deprecate C4::SQLHelper
22:07:27 <eythian> #info Robin Sheat, Catalyst, NZ
22:07:33 <rangi> anyone think that is a bad idea, or are we all happy working towards deprecating that?
22:07:39 <tcohen> i'm sorry i have to leave
22:07:40 <cait> +1 deprecating
22:07:43 <tcohen> +1
22:07:47 <tcohen> bye #koha
22:07:48 <cait> bye tcohen :)
22:07:50 <rangi> no probelm tcohen thanks for the update
22:08:00 <rangi> +1
22:08:15 <bag> +1
22:08:37 <eythian> oh yes, let it die
22:08:42 <bag> ha
22:09:08 <rangi> #agreed we will work towards deprecating  C4::SQLHelper (Bug 11385)
22:09:09 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11385 enhancement, P5 - low, ---, gmcharlt, NEW , C4::SQLHelper should be removed
22:09:29 <rangi> #topic Koha and utf8
22:09:31 <rangi> http://wiki.koha-community.org/wiki/Development_IRC_meeting,_21_May_2014
22:09:36 <rangi> if you have a look here
22:09:53 <rangi> you will see 3 suggestions about how we can work on getting bug 11944 in
22:09:54 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, gmcharlt, Needs Signoff , Cleanup Koha UTF-8
22:10:07 <rangi> does anyone have any other ideas they want to suggest?
22:11:33 <cait> mine is one on the wiki :)
22:11:51 <cait> i'd like to try and have us work through bigger enhancements with a group testig things
22:11:52 <bag> no other ideas
22:12:08 <rangi> in that case i think we'll just leave those for now and let people think a bit more
22:12:17 <bag> rangi: I only see two
22:12:22 <cait> so I think a gbsd trying that approach would be nice
22:12:33 <bag> one is cait's and the other is magnuse's
22:12:47 <cait> it looks like gmcharlt volunteered during the first meeting to help organize something
22:12:50 <rangi> there is get former rms
22:12:58 <rangi> there is get a group effort
22:13:09 <bag> right I see those two :)
22:13:14 <rangi> and there is push it early and get people to use more diacritics
22:13:26 <cait> hm that was suppoesd to happen after the group effort
22:13:35 <cait> well that's what i meant... try to make it happen early
22:13:44 <rangi> right you might want to edit the wiki :)
22:14:07 <rangi> i have no more ideas
22:14:10 <bag> oh I thought get former rms and push it early was all the same one
22:14:21 <cait> me too
22:14:30 <bag> yeah semantics - the important thing is new ideas and I'm out of ideas :)
22:14:56 <rangi> #topic what are people working on?
22:15:10 <rangi> #info elasticsearch and plack fixes
22:15:13 <bag> SPEED!
22:15:37 <bag> rangi I'd add RDF to that too
22:15:48 <bag> once we've got elastic - I'm going to be pushing for RDF
22:15:53 <rangi> cool
22:16:03 <rangi> #info RDF/linked data
22:16:04 <eythian> bag: talk to magnuse about that, he had some interest too
22:16:17 <bag> yeah I have talked and will continue to talk with him :)
22:16:17 <cait> wiki updated
22:16:20 <bag> magnuse HI
22:16:52 <cait> :)
22:16:57 <bag> #info RESTful API's and angluarjs circ client
22:16:58 <cait> nothing big from us
22:17:13 <cait> but i'd like to help get some of the big things others do moving :)
22:17:28 <bag> that above one is from a group of college students from Colorado school of mines
22:17:59 <eythian> cait: sounds like you want to help work on elasticsearch to me ;)
22:18:00 <bag> they are doing a 6 week development class - and I volunteered up an idea - and some students chose it
22:18:03 <cait> hm can you explain a bit?
22:18:41 <rangi> cait: yeah, the index table .. you could certainly help with that for elasticsearch :)
22:18:52 <cait> um...
22:19:01 <cait> :)
22:19:37 <cait> well tell me what you need to know.. and it might need to wait until after library conference
22:20:24 <eythian> that's OK, it'll take us a little bit to really settle on the form of data we need.
22:21:58 <bag> that's it from me rangi
22:22:03 <rangi> cool
22:22:10 <rangi> #topic meeting dates
22:22:20 <rangi> the next development meeting will be on 11 June at 15 and 22 UTC
22:22:24 <rangi> from the last meeting
22:22:28 <rangi> any objections?
22:22:32 <cait> no
22:23:28 <bag> nope - I'll be in maine enjoying some lobster :D
22:26:09 <rangi> #agreed the next development meeting will be on 11 June at 15 and 22 UTC
22:26:20 <rangi> #endmeeting