15:10:35 <tcohen> #startmeeting Development IRC meeting
15:10:35 <huginn> Meeting started Wed Jun  4 15:10:35 2014 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:35 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:10:35 <huginn> The meeting name has been set to 'development_irc_meeting'
15:10:37 <ashimema> or there's the in depth manual at: http://meetbot.debian.net/Manual.html
15:10:43 <slef> tcohen: I can if you prefer and hope my conn... never mind :)
15:11:00 <tcohen> slef: thanks
15:11:01 <ashimema> :)
15:11:18 <tcohen> #info Tomas Cohen Arazi, UNC
15:11:21 <thd> tcohen: Is this the development meeting or the general meeting?
15:11:37 <slef> tcohen: I think you want #topic Introductions
15:11:44 <slef> thd: got agenda link handy?
15:11:55 <oleonard> http://wiki.koha-community.org/wiki/General_IRC_meeting_3_and_4_June_2014
15:12:15 <tcohen> can anyone take the role for me?
15:13:00 <slef> tcohen: yes, say #chair NICKNAME
15:13:14 <ashimema> you'll need to add them as a chair with '#chair nick'
15:13:19 <ashimema> ;)
15:13:20 <tcohen> #chair slef
15:13:20 <huginn> Current chairs: slef tcohen
15:13:24 <slef> #topic Introductions
15:13:25 <tcohen> :-P
15:13:25 <wahanui> #info wahanui, a bot that has become sentient
15:13:32 <slef> Hello and welcome. Please use "#info" in front of your introduction to have it show up in the automatic minutes
15:13:39 <tcohen> #info Tomas Cohen Arazi, UNC
15:13:40 <slef> #info MJ Ray, software.coop, England
15:13:43 <ashimema> #info Martin Renvoize, PTFS Europe
15:13:44 <thd> tcohen: You should set topics in the agenda with #topic Introductions, etc.
15:13:45 <oleonard> #info Owen Leonard, Athens County Public Libraries
15:13:54 <tcohen> thanks thd
15:14:33 <thd> #info Thomas Dukleth, Agogme, New York City
15:15:24 <ashimema> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_3_and_4_June_2014 for agenda
15:15:27 <slef> other introductions will need to happen as we move on
15:15:30 <slef> thanks ashimema
15:15:49 <slef> #topic Announcements
15:15:51 <ashimema> ;)
15:15:56 <slef> #info The NZ TM has been registered and is being held in trust by HLT (rangi, 22:08:38)
15:16:16 * oleonard cheers
15:16:21 <slef> I think I saw a blog post about that earlier if anyone would like more details?
15:16:24 <slef> Any other announcements?
15:16:47 <slef> #link http://koha-community.org/nz-koha-trademark-update/
15:16:59 <oleonard> #link http://koha-community.org/nz-koha-trademark-update/
15:17:02 <oleonard> jinx
15:17:05 <ashimema> 3.16 released since last meeting wasn't it?
15:17:11 <ashimema> that a worthy one?
15:17:26 <slef> ashimema: we've release updates next
15:17:34 <ashimema> lol.. yup.
15:17:35 <ashimema> my bad
15:17:37 <slef> so let's move to that
15:17:48 <slef> #topic Update on releases
15:18:13 <slef> ashimema: can you up arrow a few times, Home and add #info to that? ;-)
15:18:46 <thd> slef: arrow?
15:18:55 <slef> #info 3.16.1 will be released in mid-June; there will be some important bugfixes in it (gmcharlt, 22:11:08)
15:19:15 <slef> thd: yeah yeah my keyboard doesn't have arrows on it
15:19:58 <slef> Any RMs in?
15:20:05 <slef> Or RMaints
15:20:14 * gmcharlt is here, but well, nothing more to say about 3.16.1
15:20:16 <tcohen> I had an announcement, and a few comments on 3.18
15:20:19 <thd> slef: What mini device is that with no arrows?
15:20:25 <jwagner> #info Jane Wagner LibLime/PTFS
15:20:30 <slef> tcohen: go for it
15:20:39 <gmcharlt> #info Galen Charlton, ESI
15:20:51 * tcohen is concerned about Perl 5.18 compatibility
15:21:04 <tcohen> specifically the hash keys randomization
15:21:27 <gmcharlt> QueryParser has some issues with it; I'm planning to look at it
15:21:32 <tcohen> and am evaluating discouraging people from using distributions that ship Perl 5.18 for now
15:21:41 <ashimema> colin highlighted it some time ago if i remember rightly.
15:22:00 <ashimema> we agree.. we should be working toward newer perl compatability
15:22:01 <slef> #link http://www.perlmonks.org/?node_id=1005122 is a description from late 2012
15:22:10 <thd> Is it random or merely inscrutable efficiency?
15:22:20 <slef> #info tcohen is concerned about Perl 5.18 compatibility and specifically the hash keys randomization
15:22:31 <tcohen> thd: each thread has its own seed
15:22:52 <oleonard> Sufficiently inscrutable efficiency is indistinguishable from random?
15:23:30 <slef> #link http://perldoc.perl.org/perl581delta.html#Hash-Randomisation is a more authoritative source
15:23:41 <tcohen> gmcharlt: I've been into QueryParser yesterday and it seems that it is related to the unit tests, and that the effects doesnt affect the semantics/results
15:23:42 <slef> "the ordering has already changed several times during the lifetime of Perl 5"
15:23:54 <tcohen> but i'm glad to hear that you're stepping in
15:24:09 <thd> tcohen: What is the actual issue, multithreaded behaviour or hash keys lack of recognisable orderliness?
15:24:28 <gmcharlt> tcohen: I disagree; the tests show that the hash-order randomization somehow leads to a given query being translated into different PQF queries
15:24:37 <tcohen> there is code that relies in things like grabbing the first element of a results hash
15:24:54 <slef> Should we be worried about the UTF-8-related changes on there?
15:25:10 <gmcharlt> IOW, it's pretty clearly an issue if you can't count on a given query being translated into the same base Z39.50 query
15:25:15 <slef> Do we rely on locale to set UTF-8 on filehandles at all?
15:25:18 <tcohen> gmcharlt: i agree, what i meant to say is that both PQF queries mean (ultimately) the same
15:27:19 <tcohen> gmcharlt: should we report QueryParser stuff to upstream or just patch our copy?
15:27:25 <slef> ashimema: any idea where colin highlighted it? I'm not finding it by searching yet.
15:27:39 <gmcharlt> tcohen: I intend to tackle both ends
15:27:51 <tcohen> bug 12343
15:27:52 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12343 normal, P5 - low, ---, abl, Needs Signoff , TransformKohaToMarc() is adding MARC subfields in random order
15:27:53 <ashimema> pass.. I'll see if I can dig it out..
15:28:14 <ashimema> but i do remember the conversation coming up some time ago.. believe it was highlighted to jcamins..
15:28:21 <ashimema> I am talking like a year or so though..
15:28:21 <slef> tcohen++
15:28:23 <gmcharlt> and possibly, if tuits permit (but I make no promises) see about factoring QP out into an independent CPAN module that both Koha and Evergreen can use
15:28:36 <tcohen> gmcharlt++
15:28:41 <ashimema> Colin run's koha on his fedora machine.. so tends to pick up new perl issues pretty wuick
15:28:48 <slef> ok, any more #info we'd like to minute about this?
15:28:53 <tcohen> yes
15:29:05 <slef> tcohen: go ahead, please.
15:29:21 <ashimema> gmcharlt++
15:29:45 <tcohen> UNC is about to provide 4 virtual machines, running Debian {6|7} and Ubuntu {12.04|14.04}
15:30:04 <gmcharlt> UNC++
15:30:05 <tcohen> we'll need one more running Debian testing
15:30:10 <ashimema> #info UNC is about to provide 4 virtual machines, running Debian {6|7} and Ubuntu {12.04|14.04}
15:30:23 <tcohen> to have the master branch tested on all of them
15:30:47 <ashimema> UNC++
15:30:51 <slef> cool
15:30:53 <tcohen> they will of course be jenkins nodes
15:31:49 <tcohen> who are the jenkins admins to coordinate this? rangi and gmcharlt?
15:31:54 <gmcharlt> tcohen: yep
15:31:59 <tcohen> awesome
15:32:24 <tcohen> ok, done
15:32:29 <slef> ok, moving on
15:32:39 <slef> #topic Code of Conduct
15:32:43 <slef> #link http://paste.koha-community.org/24
15:33:25 <slef> I think this is overdue and I suspect action has been inspired by #slutgate2014
15:33:58 <slef> Do people generally support the idea of adopting a code of conduct?
15:34:01 <thd> Is that an actual nick?
15:34:10 <slef> thd: it was a twitter hashtag I think
15:34:31 <jwagner> With regard to the wording "at any Koha event" -- does that mean it's limited to conferences, etc.?  What about online meetings, general IRC or listserv?
15:35:40 <thd> We should be fostering an environment for which no one would ever think of behaving in a manner for which a code of conduct would ever need to be used.
15:35:52 <tcohen> jwagner: i'd agree to make general, but we should find a way to define how can it be enforced
15:35:55 <gmcharlt> jwagner: with respect to the Evergreen policy, the wording is intended to refer to physical events
15:36:00 <slef> I'd expect it to apply more widely, but I don't know if online already has its own policies.
15:36:07 <gmcharlt> however, the ultimate goal is to have it apply to online fora
15:36:18 <gmcharlt> similar to (say) the Code4Lib code of conduct
15:36:26 <gmcharlt> which explicitly includes the IRC channel and mailing list
15:36:33 <jwagner> I think it would be useful to find some wording to extend to online presences -- harassment can just as easily occur in virtual as well as physical
15:36:44 <gmcharlt> I would be in favor of having Koha's code of conduct extended to online
15:37:10 <thd> gmchart: If that is intended, then the word "posting" should be qualified.
15:37:15 <ashimema> ++
15:37:40 <slef> I would prefer the wording to be more like Debian's, but I don't think we're debating detailed wording yet.
15:37:49 <tcohen> could we vote the code of conduct, and in a next meeting vote again on how it would be applied to online ?
15:38:06 <slef> Please can I have a show of +1 0 or -1 on the general idea of the code of conduct, not that exact wording?
15:38:21 <thd> The first use of the word "posting" is part of an overly broad statement which could have unintended consequences.
15:38:37 <jwagner> +1
15:38:42 <ashimema> +1
15:38:49 <tcohen> +1 # having a code of conduct
15:38:50 <gmcharlt> +1
15:39:10 <oleonard> +1
15:39:21 <slef> #link https://www.debian.org/vote/2014/vote_002#amendmenttexta includes debian's recent code just below that point
15:39:28 <thd> +1 # Only after some modest additional amendment.
15:39:34 <slef> and +1 from me, so...
15:39:53 <slef> #agreed the general idea of adopting a code of conduct, not that exact wording
15:40:17 <slef> Can those interested take the discussion/development of the wording to the email lists, please?
15:40:32 <slef> OK to move on?
15:40:47 <jwagner> slef, I'd suggest setting a deadline for coming up with wording, or it will drag on forever
15:41:10 <gmcharlt> shall we say by the July meeting for a final draft to vote on?
15:41:15 <slef> jwagner: would kohacon14 be a suitable deadline?
15:41:29 <jwagner> I don't really care -- whatever gives people time to work on it
15:41:33 <gmcharlt> it would be better to have it be approved prior to the conference
15:41:36 <jwagner> but open-ended discussions never get finished
15:41:49 <tcohen> +1 # deadline before conference
15:42:02 <slef> gmcharlt: agreed. When is it? ;-)
15:42:30 <slef> 6-13 October
15:42:33 <slef> says my calendar
15:42:37 <slef> which might be wrong
15:42:42 <tcohen> that's correct slef
15:42:55 <gmcharlt> http://koha-community.org/kohacon/kohacon14/schedule/
15:43:13 <slef> #agreed we would like this approved before kohacon14
15:43:21 <slef> OK to move on?
15:43:26 <tcohen> can we say that the current wording is approved
15:43:37 <tcohen> with a timeframe for ammendments?
15:43:38 <slef> tcohen: I'm not comfortable with it.
15:43:41 <tcohen> ok
15:44:05 <slef> as in, I'm sure it got ripped to shreds by one community I'm involved with, but I don't have it handy right now
15:44:16 <slef> they could be wrong or my memory may be wrong ;-)
15:44:19 <thd> tcohen: We should discuss the wording on the mailing list.  I think a few people including myself have a problem with the language.
15:44:28 <slef> but I'd like to check and I apologise for not spotting the paste before now
15:44:43 * gmcharlt will start a thread on the general mailing list
15:44:49 <tcohen> gmcharlt++
15:44:59 <slef> #action gmcharlt will start a thread on the general mailing list
15:45:05 <slef> #topic Kohacon14
15:45:35 <tcohen> We'll be calling for sponsorship the next week
15:45:36 <slef> tcohen: do you know about this?
15:45:40 <slef> heh
15:45:53 <slef> #info call for sponsorship expected next week
15:45:54 <tcohen> we have most of the stuff covered by UNC
15:46:10 <tcohen> we need funding for the spanish -> english translators
15:46:33 <tcohen> ^^^^^^ that'd be our main need
15:46:42 <slef> ¿Donde estan los elephantes?
15:46:58 <tcohen> as there are some latin-american speakers signed already
15:47:34 <slef> interpreters rather than translators, I assume?
15:47:40 <tcohen> exactly
15:48:01 <tcohen> that's it
15:48:16 <slef> right... I read from last meeting that a few presentations have been submitted
15:48:31 <slef> please let the community know if there is anything we can do to help
15:48:39 <slef> #topic kohacon15
15:49:02 <tcohen> i'm currently struggling to get hands to work on the conference site
15:49:07 <slef> There's a proposal from Nigeria and an expression of interest from Zambia.
15:49:14 <slef> #action mtj_ is going to repost the call for conference organisers for kohacon15
15:49:14 <wahanui> i already had it that way, slef.
15:49:26 <slef> wahanui: forget #action mtj_
15:49:27 <wahanui> slef: I forgot #action mtj_
15:50:09 <slef> tcohen: the conference website, or the physical site?
15:50:22 <slef> Anyone have other comments on kohacon15?
15:50:26 <tcohen> the website
15:50:27 <wahanui> i guess the website is http://www.koha-community.org
15:51:35 <slef> #info Can anyone help with the kohacon14 conference website, please? Contact tcohen
15:51:44 <slef> #topic Actions from the last meeting
15:51:45 <tcohen> thanks slef
15:51:57 <slef> afaik there are none - anyone want to correct me?
15:52:50 <slef> guessing not
15:53:02 <slef> #topic date and time of next meeting
15:53:13 <slef> how about july 2nd and 3rd same times 22 UTC and 15 UTC?
15:53:58 <tcohen> +1
15:54:06 <slef> is it just me, or is that sliding a day later?
15:54:09 <oleonard> Is that what was voted on in the previous session?
15:54:14 <slef> yeah
15:54:22 <slef> but rangi said we could unagree it if we wannt
15:54:27 <thd> Those dates are a problem in the US.
15:54:36 <oleonard> Not for me.
15:54:50 <slef> thd: howso?
15:55:00 <thd> The occur at the end of ALA and just before the US independence holiday.
15:55:10 * slef checks ALA
15:56:25 <slef> hrm, it's not on http://digital-conferences-calendar.info/
15:56:40 <slef> http://ala14.ala.org/
15:56:46 <gmcharlt> ALA runs from 26 June though 1 July
15:57:08 <gmcharlt> FWIW, I have no problem with 2/3 July for the next meeting
15:57:28 <slef> right - that's probably why it's slid a day then... seems OK to me... not great, but it's difficult to give everything a margin of several days
15:57:31 <thd> Some people would be returning from ALA on the 2 and 3 of July.
15:57:32 <slef> at least we don't overlap
15:58:21 <slef> thd: do you have a suggested alternative?
15:58:38 <thd> I would suggest adding a week.
15:59:21 <slef> Anyone mind adding a week?
15:59:48 <thd> s/adding a week/a week later/
16:00:03 <oleonard> Fine with me
16:00:08 <gmcharlt> no objection
16:00:16 <slef> how about 9th and 10th July same times 22 UTC and 15 UTC?  +1 0 or -1 please
16:00:24 <oleonard> +1
16:00:37 <slef> 0
16:00:44 <thd> +1
16:01:18 <gmcharlt> +1
16:01:32 <tcohen> +1
16:01:45 <slef> #agreed 9th and 10th July same times 22 UTC and 15 UTC
16:01:54 <slef> the earlier meeting can flame us if they want ;-)
16:02:03 <slef> Thank you all for taking part
16:02:04 <slef> #endmeeting