15:00:13 <gmcharlt> #startmeeting Development IRC meeting, 11 June 2014, part 1
15:00:13 <huginn> Meeting started Wed Jun 11 15:00:13 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:13 <huginn> The meeting name has been set to 'development_irc_meeting__11_june_2014__part_1'
15:00:23 <gmcharlt> #info Agenda is wiki.koha-community.org/wiki/Development_IRC_meeting,_11_June_2014
15:00:35 <gmcharlt> #topic Introductions
15:00:36 <wahanui> #info wahanui, a bot that has become sentient
15:00:44 <oleonard> #info Owen Leonard, Athens County Public Libraries
15:00:49 <gmcharlt> #info Galen Charlton, ESI
15:00:54 <phasefx> #info Jason Etheridge, ESI
15:00:54 <cait> #info Katrin Fischer, BSZ
15:01:06 <slef> #info MJ Ray, software.coop, England
15:01:09 <thd> #info Thomas Dukleth, Agogme, New York City
15:01:40 <bgkriegel> #info Bernardo Gonzalez Kriegel, Cordoba, Argentina
15:02:12 <Joubu> #info Jonathan Druart, BibLibre
15:02:58 <gmcharlt> ok, thanks
15:03:13 <gmcharlt> tcohen is not here, so I'll skip the RM 3.18 update
15:03:27 <gmcharlt> #topic Deprecate the OPAC prog theme officially
15:03:49 <gmcharlt> so, we have a proposal to update the coding guidelines to officially deprecate the prog theme
15:03:54 <gmcharlt> and by extension, CCSR
15:04:11 <cait> ah yes, good point, also ccsr :)
15:04:38 <cait> I think we already decided that we will do it, but we should also add a note to the coding guidelines
15:04:52 <cait> and maybe we should decide when we will remove the files?
15:05:23 <pastebot> "gmcharlt" at 127.0.0.1 pasted "Proposed wording" (5 lines) at http://paste.koha-community.org/39
15:05:50 <cait> +1 #wording
15:05:53 <slef> it'll take me a mo to open that
15:06:34 <gmcharlt> cait: IMO, ASAP
15:06:35 <mtompset> #info Mark Tompsett
15:06:48 <gmcharlt> and no new patches meant for master should touch those two themes
15:07:13 <Joubu> yes, I completely agree. Actually I think it is already the case.
15:07:17 <slef> welding seems OK
15:07:25 <cait> gmcharlt: I think the sooner the better too - it will help enforcing the coding guideline :)
15:07:31 <gmcharlt> Joubu: yeah, folks have already started with updating only Bootstrap
15:07:35 <gmcharlt> doesn't hurt to make it official
15:07:46 <gmcharlt> OK, any further comments on the wording before we vote?
15:08:04 <cait> I think by maintaining the coding guidelines better we make it easier for new developers not falling into traps
15:08:08 <mtompset> +1 # agreed on the nice wording
15:08:19 <cait> also people that have been out for a while or are not hanging around in irc all the time :)
15:08:28 <gmcharlt> *gasp*
15:08:30 <Joubu> There is a problem with the votes on paste.k-c.org, they won't be accessible in the future
15:08:31 <gmcharlt> is that possible?!?!?
15:08:33 <gmcharlt> ;)
15:08:49 <Joubu> But maybe should we c/p on the wiki after the meeting
15:08:50 <gmcharlt> Joubu: I'll update the wiki ASAP tonight, assume that the change is approved
15:09:05 <Joubu> +1
15:09:25 <bgkriegel> +1
15:09:27 <slef> 0
15:09:34 <cait> gmcharlt: keep the paste safe somewhere? just in case rangi restarts the server
15:10:15 <thd> +0.5
15:10:29 <gmcharlt> #startvote Shall the change to the coding guidelines to deprecate OPAC and CCSR be approved (http://paste.lisp.org/display/142855)? Yes, No, Abstain
15:10:29 <huginn> Begin voting on: Shall the change to the coding guidelines to deprecate OPAC and CCSR be approved (http://paste.lisp.org/display/142855)? Valid vote options are Yes, No, Abstain.
15:10:29 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
15:10:44 <gmcharlt> (note the paste.lisp.org version, which won't expire)
15:10:47 <gmcharlt> #vote Yes
15:10:50 <oleonard> #vote Yes
15:10:59 <drojf> #info Mirko Tietgen, lurking ^^
15:11:01 <Joubu> #vote Yes
15:11:02 <slef> #vote abstain
15:11:07 <bgkriegel> #vote Yes
15:11:08 <drojf> #vote Yes
15:11:09 <thd> #vote Yes
15:11:21 <phasefx> #vote abstain
15:11:50 <cait> #vote yes
15:12:17 <cait> is it case sensitive?
15:12:21 <cait> #vote Yes
15:12:36 <gmcharlt> I don't think it is
15:12:41 * oleonard jails cait for voting twice
15:12:52 <cait> only the last vote counts - i read the instructions :)
15:12:53 <thd> #comment Do not like outsourcing to a project created by Twitter.
15:13:01 <drojf> we do that in europe ^^
15:13:06 * gmcharlt rouses the Chicago zombie electorate
15:15:03 <gmcharlt> thd: it's licensed under the Apache License, and there's been no serious proposal to make any other way of having a responsive theme
15:15:42 <gmcharlt> one minute warning for closing the vote
15:16:57 <gmcharlt> #endvote
15:16:57 <huginn> Voted on "Shall the change to the coding guidelines to deprecate OPAC and CCSR be approved (http://paste.lisp.org/display/142855)?" Results are
15:16:57 <huginn> Yes (7): Joubu, cait, oleonard, gmcharlt, bgkriegel, thd, drojf
15:16:57 <huginn> Abstain (2): phasefx, slef
15:17:49 <gmcharlt> #agreed (pending confirmation) the coding guidelines will be updated per http://paste.lisp.org/display/142855 to discourage future patches from updating the prog and CCSR OPAC themes
15:17:56 <thd> gmcharlt: Yes, I know.  I am not claiming a necessarily better alternatiive would be easily produced.
15:18:19 <gmcharlt> #topic UTF-8 Clean-up - Bug 11944
15:18:20 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, jonathan.druart, Needs Signoff , Cleanup Koha UTF-8
15:18:22 <mtompset> oleonard: She voted on my behalf? ;)
15:18:49 <gmcharlt> so where I'm at personally with this is I'm spending the next 1.5 weeks reviewing the patches
15:19:04 <gmcharlt> and working on some search issues that Joubu identified
15:19:07 <Joubu> \o/
15:19:11 <cait> :)
15:19:14 <Joubu> gmcharlt++
15:19:15 <cait> Joubu++ and gmcharlt++
15:19:18 <gmcharlt> my goal is to (1) get it ready for signoff by the end of the month
15:19:28 <cait> let us know if there is help needed testing
15:19:43 <cait> i really want to see this patch series go in soon... and then we can move on to the next big problem :)
15:19:54 <gmcharlt> and schedule a GBSD in early July for as an opportunity for folks to run it throug its paces
15:20:24 <gmcharlt> at some point, I will be calling for volunteers (possibly including ESI) to host a test database or two
15:20:49 <gmcharlt> Joubu: and apropos of that, as far as the sandboxes are concerned, I anticipate at least one addition that may be relevant
15:21:22 <Joubu> gmcharlt: I can add the patches on 1 or 2 sandboxes. But I don't have a good DB to test
15:21:41 <gmcharlt> specifically, changing the default collation used by Koha MySQL database to utf8_unicode_ci
15:22:07 <gmcharlt> Joubu: see the last couple comments in bug 11811 for context on that
15:22:09 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11811 major, P1 - high, ---, dpavlin, In Discussion , tools/import_borrowers.pl doesn't support utf-8 encoded CSV
15:22:50 <Joubu> gmcharlt: ok, I note that
15:22:55 <gmcharlt> #action gmcharlt to review the patches and ready theme for signoff by end of June
15:23:07 <gmcharlt> #action gmcharlt to schedule a GBSD in early July for general testing
15:23:28 <Joubu> #action Joubu change the default collation to utf8_unicode_ci on sandboxes
15:23:33 <thd> *++
15:23:47 <Joubu> #action Joubu take a look at bug 11811
15:24:23 <cait> :)
15:24:44 <gmcharlt> any other comments on the UTF8 stuff before we move on?
15:25:35 <bgkriegel> possibility to backport to 3.16, 3.14...? (when it's ready)
15:25:35 <Joubu> I think we are close to have a good utf8 support into Koha :)
15:25:58 <gmcharlt> bgkriegel: maybe; I'm not sure at the moment
15:26:02 <Joubu> bgkriegel: outch...
15:26:27 <bgkriegel> Ok
15:26:42 <thd> Joubu: Yes, except that some of the problem is a regression from where we had already been.
15:27:15 <mtompset> Has any testing been added to prevent this type of regression again?
15:27:51 <gmcharlt> mtompset: I think you can rest assure that I'm not going to sign off without making sure that there's sufficient regressions tests
15:28:10 * cait likes regression tests :)
15:28:11 <Joubu> Currently there is no tests
15:28:15 <thd> Joubu: We will have good UTF-8 support when UTF-8 is the native character encoding for the multiverse.
15:28:20 <mtompset> And that was the problem. :)
15:28:34 <gmcharlt> Joubu: indeed; I fully expect to write a bunch
15:28:35 <Joubu> But look at the patches
15:28:42 <mtompset> Good to hear it will be rectified.
15:28:53 <Joubu> when you look at the code after the patches, you understand it is the way to do
15:29:08 <cait> i think it will put us in a cleaner state of things hopefully
15:29:17 <Joubu> the code is much more easy, no decode/encode everywhere
15:29:56 <Joubu> and the unit tests are not easy to write since the problem does not exist in a specific routine
15:30:20 <gmcharlt> nonetheless, /me will write tests :)
15:30:40 <gmcharlt> ok, moving on
15:30:46 <gmcharlt> #topic Big stuff we are working on
15:30:52 <gmcharlt> so, to get us started
15:31:01 <gmcharlt> Joubu: what big stuff is BibLibre working on nowadays?
15:31:47 <Joubu> Hum, not really. We have some big stuffs, already submitted on bz
15:32:04 <Joubu> we plan to rewrite the ACQ vat/gst management
15:32:25 <Joubu> Laurence wrote a rfc, in french at the moment
15:32:53 <Joubu> no code will be written without communication and feedback on this rfc
15:33:22 <gmcharlt> is there a link to the French version of the RFC?
15:33:34 <Joubu> no
15:33:53 <cait> Joubu: cool :) it would be good i think to get some different countries involved, i think france and germany are probably similar
15:34:03 <cait> but i seem to remember that nz/hlt had some different expectations
15:34:52 <cait> would be good to get this settled and have everyone on the same page on how it shoudl work
15:35:06 <Joubu> yes, that why we need to communicate before writing any code
15:35:19 <Joubu> Same in Italy with talljoy
15:35:36 <Joubu> And I really need to see the batch modification for biblios (and all fixes for marc modification template) tested. It a very big work, very powerful. And that fixes critical problems with the existing feature.
15:35:48 <thd> cait: NZ/HLT had standard expectations which were not different to what anyone anywhere who actually worked in a real world acquisitions process would expect.
15:35:53 <mtompset> bug report number, Joubu?
15:36:06 <cait> thd: i didn't mean to imply that their expectations weren't correct
15:36:06 <talljoy> did i transport to italy?
15:36:14 <talljoy> i wish i was in italy....
15:36:17 <talljoy> :-)
15:36:21 <cait> i think it just works differently in different countries - and it's good to communicate
15:36:33 <cait> so we don't miss something important redoing it
15:36:37 <Joubu> bugs 11413, 11319 and 11395
15:36:46 <gmcharlt> and that includes hearing from the folks actually involved
15:36:55 <gmcharlt> fortunately, that's why we have a second part of this meeting :)
15:37:02 <thd> cait: rangi had once implied in error that NZ had special expectations which were not in fact special.
15:37:34 <Joubu> talljoy: Sorry, I think you were Zeno :)
15:37:41 <talljoy> :-D
15:38:12 <gmcharlt> thd: I think we can wait for rangi to provide input directly
15:38:38 <cait> Joubu: thx a lot for taking this on :)
15:38:51 <thd> gmcharlt: I am merely identifying the issue historically as a reminder.
15:39:06 <mtompset> 11395 looks like something I may try to get around to testing.
15:39:11 <Joubu> The RFC looks complex, so I think all cases are possibles :)
15:39:48 <gmcharlt> #info A project to revamp tax calculation in acquisitions is being considered by BibLibre; an RFC will be published
15:39:57 <gmcharlt> ok, any other big projects?
15:40:09 <Joubu> mtompset: yes, bug 11395 is the sexy one. The others one are important too, they fixes some important issues
15:40:10 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11395 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Batch modifications for records
15:40:11 <thd> Joubu: I believe that BibLibre would not be proposing something counter to what rangi had once identified as how acquisitions would be expected to work in NZ.
15:41:32 <cait> so other big projects? :)
15:41:53 <Joubu> gmcharlt: I think the column configuration for tables should be pushed soon, in order to adapt enough table before the 3.18 release
15:41:56 <thd> Joubu: If you consult with people who do a real world acquisitions job, even without computer automation you will avoid going astray :)
15:42:10 <Joubu> bug 10212
15:42:10 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=10212 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Columns configuration for tables
15:42:18 <cait> Joubu: i am currently working through the patron search improvements, i hope to tackle that next (if noone else is faster :) )
15:42:38 <gmcharlt> thd: and I think that point needs to be emphasized - we need folks who are *actually* dealing with the relevant tax processes in each country to provide input directly
15:42:42 <gmcharlt> with as few proxies as possible
15:42:53 <gmcharlt> Joubu: I'll take a look
15:43:18 <Joubu> thd: not sure to understand. rangi is starting to develop something?
15:44:20 <thd> Joubu: no, my comment merely refers to what had been a problem with some development from long ago.
15:44:35 <Joubu> I think the discussion around a gst rewrite could be started after we will suggest a rfc
15:44:40 <gmcharlt> agreed
15:44:41 <thd> Joubu: My comment was historical.
15:45:06 <thd> gmcharlt++
15:45:07 <Joubu> the idea is not to break anything, just understand the code. I develop the multi VAT management, I don't understand anything at the code... And I'm sorry about that.
15:45:24 <Joubu> my first big dev on Koha...
15:45:48 <cait> :)
15:46:19 <cait> always remember quote 123... it#s hard to keep up with libraries and their ideas :)
15:46:26 <gmcharlt> @quote get 123
15:46:26 <wahanui> http://xkcd.com/1172/
15:46:26 <huginn> gmcharlt: Quote #123: "rangi: #thingsihavelearnt if there is a mad scheme a library somewhere will be doing it ... except madder" (added by wizzyrea at 09:20 PM, March 30, 2011)
15:46:36 <Joubu> :)
15:46:45 <gmcharlt> ok, moving on
15:46:54 <gmcharlt> re action items from the previosu meeting
15:46:59 <Joubu> nobody else has "big stuffs" ?
15:47:08 <gmcharlt> basically, they concerned the UTF8 stuff and are underway
15:47:10 <thd> Joubu: If you understand the task that the code performs or should perform even without understanding the existing code, then you are way ahead :)
15:47:13 <mtompset> Actually...
15:47:16 <cait> bag khall ping
15:47:33 <mtompset> I don't have a project I'm working on... but what about the random test failure problem because of hashes?
15:47:56 <cait> i have to leave - bye all :)
15:48:02 <mtompset> Bye, cait.
15:48:14 <gmcharlt> mtompset: tcohen and I have been kicking it around
15:48:21 <gmcharlt> nothing to reprot yet, but soonish hopefully
15:48:40 <mtompset> Okay. Just thought I'd ask about it. :)
15:48:50 <Joubu> I QAed a patch this morning about random hashes
15:49:55 <Joubu> bug 12343
15:49:56 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12343 normal, P5 - low, ---, abl, Passed QA , TransformKohaToMarc() is adding MARC subfields in random order
15:50:08 <gmcharlt> Joubu++
15:50:17 <Joubu> mtompset: Is it the same thing you are talking about?
15:50:26 <gmcharlt> different one, with QueryParser
15:50:35 <Joubu> Ho yes! I forgot that
15:50:52 <mtompset> No, I was thinking the QueryParser one.
15:50:55 <Joubu> I had a look but looks quite complex
15:52:03 <gmcharlt> as far as setting the next meeting time is concerned, I propose that we punt that to koha-devel for a time when tcohen is back home
15:52:15 <Joubu> yep
15:53:49 <gmcharlt> ok
15:53:59 <gmcharlt> thanks, everybody
15:54:02 <gmcharlt> #endmeeting