15:04:25 <tcohen> #startmeeting Development IRC meeting, 5 August 2014 (part 1)
15:04:25 <huginn> Meeting started Tue Aug  5 15:04:25 2014 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:25 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:25 <huginn> The meeting name has been set to 'development_irc_meeting__5_august_2014__part_1_'
15:04:56 <tcohen> #topic Introductions (please use "#info" in front of your introduction to have it show up in the automatic minutes)
15:05:20 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
15:05:35 <tcohen> please, don't flood the IRC with your presentations
15:05:36 <cait> #info Katrin Fischer, BSZ - not quite here
15:05:47 <thd> #info Thomas Dukleth, Agogme, New York City - [dead drive today]
15:06:24 <Guest4884> #info Jane Wagner, LibLime/PTFS
15:06:27 <tcohen> ok, two T{h}omas and a Katrina :-D
15:06:55 <oleonard> #info Owen Leonard, Athens County Public Libraries
15:06:58 <tcohen> hi Jane
15:07:22 <tcohen> ok, moving on
15:07:31 <tcohen> #topic RM 3.18 comments
15:07:39 <tcohen> tcohen: all yours
15:07:43 <tcohen> thanks
15:08:20 <tcohen> #info tcohen asked Chris Cormack to take care of integrating PROG/CCSR deprecation patches
15:08:39 <cait> rangi++
15:09:14 <tcohen> #info tcohen provided a first approach to unit tests for LDAP-related code on bug 8148
15:09:15 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8148 critical, P5 - low, ---, fcapovilla, Signed Off , ldap authentication should FAIL if ldap contains NEW password, and user types the PREVIOUS password
15:09:32 <tcohen> #info feedback on that is needed, urgently
15:09:48 <cait> tcohen++ too :)
15:10:41 <tcohen> #info RM is concerned about the lack of unit tests in some important bugs, he will continue to help write those tests for people not used to it
15:10:50 <JesseM> #info Jesse Maseto, ByWater Solutions
15:11:18 <tcohen> questions? comments?
15:11:31 <tcohen> feedback on how to deal with this is really welcome
15:12:35 <tcohen> ok, moving on
15:13:10 <tcohen> i'll add a topic that is not in the agenda, but is small
15:13:25 <tcohen> #topic KohaCon14 update
15:13:47 <tcohen> #info the kohacon page will be updated tomorrow with more information
15:13:56 <NateC> #info Nate Curulla ByWater
15:14:25 <tcohen> #info tcohen makes a call for atendees and people making presentqations on kohacon
15:14:49 <cait> just about 2 monhts now :)
15:15:12 <tcohen> #info tcohen makes a call for people to register
15:15:18 <tcohen> ^^^^ that was
15:15:23 <tcohen> ok, moving on
15:15:38 <tcohen> #topic Additions to Coding Guidelines
15:15:41 <bgkriegel> #info Bernardo Gonzalez Kriegel, late
15:16:43 <tcohen> the idea was to discuss an addition to coding guidelines asking new dependencies (like jquery plugins) to be added to the about section
15:16:54 <tcohen> cait?
15:16:54 <wahanui> cait: go to bed
15:17:37 <cait> ah sorry
15:17:50 <tcohen> can u comment on the proposal for the coding guidelines?
15:17:51 <cait> not sure it has to go into the coding guidelines
15:17:54 <cait> but maybe a small reminder
15:18:05 <cait> if we add a new jquery library/plugin or similar
15:18:11 <tcohen> ok
15:18:14 <cait> we should also add a line to about.pl with the license
15:18:34 <edveal> #info Ed Veal ByWater
15:18:40 <cait> i think some might be missing currently
15:19:06 <tcohen> cait: is there a bug report for that?
15:19:26 <cait> not yet - i am not sure there are, it's more a guess right now
15:20:05 <tcohen> #action Katrin volunteers to fill a bug on missing lines in about.pl for external libs
15:20:14 <cait> hey...
15:20:17 <cait> :)
15:20:19 <tcohen> :-P
15:20:34 <tcohen> ok, moving on
15:20:39 <cait> if i find one that is, i will
15:20:49 <tcohen> great
15:20:58 <tcohen> #topic DBIC
15:21:31 <tcohen> The key point on discussing DBIC is that people has expressed some lack of information on how to use
15:21:54 <tcohen> I personally find it relevant, as we are promoting its wide adoption
15:22:44 <tcohen> #link Example usage of DBIC http://wiki.koha-community.org/wiki/Examples_of_DBIC_in_Koha
15:23:07 <tcohen> if anyone finds some time to contribute to that, we will all benefit
15:23:35 <tcohen> some "best practices" should be discussed and added there
15:23:51 <tcohen> maybe some things that should be avoided when coding using DBIC
15:23:54 <cait> i think one of the poitns people are unsure about
15:24:01 <cait> is if we can use DBIC in pl files
15:24:07 <cait> or only in .pm
15:24:40 <tcohen> in my opinion, we should only use it on .pm
15:26:27 <tcohen> another thing that confuses people is what is the workflow for adding new relations to Koha::Schema::Result:*
15:26:41 <tcohen> it happened to me, and Joubu asked the same a while ago
15:27:12 <tcohen> when you need to make a JOIN operation on tables that don't have explicit foreign key constrains, you cannot do it on DBIC
15:27:22 <tcohen> unless you define a new relation
15:28:12 <tcohen> those should be added to the bottom of the files (the rest of the file is auto-generated)
15:28:31 <tcohen> it'd be great to have galen or kyle to discuss this
15:28:59 <tcohen> but, it is possible that in that situation we should evaluate if the constrain should be defined, instead of adding the new relation
15:29:45 <tcohen> an example where there aren't some foreign key constrains is on deleted_* tables
15:30:00 <tcohen> if you want to make a join on those tables, DBIC fails
15:30:23 <tcohen> #action tcohen will promote this discussion on the development list
15:30:30 <tcohen> ok, moving on?
15:30:34 <cait> khall_away gmcharlt ... :)
15:30:56 <cait> maybe we could have a dbic tutorial?
15:31:09 <tcohen> maybe on the hackfest?
15:31:33 <cait> that's an idea too :)
15:31:57 <tcohen> ok, moving on (lunch time approaching)
15:32:06 <tcohen> #topic Bugs
15:32:15 <thd> maybe someone could record such things even in the hackfest for those of us who may be unable to afford the fare to Argentina.
15:32:43 <tcohen> thd: that's a great idea
15:32:45 <bgkriegel> good idea
15:32:56 <tcohen> i'll try to make it happen with bgkriegel
15:34:09 <tcohen> any comment about specific bugs?
15:34:22 <tcohen> bgkriegel? cait? jwagner? NateC?
15:34:37 <tcohen> oleonard?
15:34:39 <wahanui> oleonard is, like, still here, if you just wish hard enough. or Koha's master UI designer
15:34:48 <tcohen> we know wahanui
15:34:51 <bgkriegel> not for me
15:35:06 <cait> tcohen: not right now
15:35:06 <oleonard> Nothing from me
15:36:26 <jwagner> sorry, nothing from me
15:36:27 <tcohen> oleonard: do u need help on the PROG/CCSR deprecation patches?
15:37:19 <tcohen> i'd like to mention bug 12716, for which I'd like to hear comments
15:37:20 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12716 enhancement, P5 - low, ---, gmcharlt, NEW , Import patrons form should have drop-downs for some values
15:38:10 <tcohen> i wanted to make it possible to have dropdowns for values that have foreign key constrains, and would fail an import
15:38:31 <tcohen> should it be still possible to type on those?
15:38:41 <tcohen> i have a working patch about to be attached
15:38:50 <tcohen> objections?
15:39:15 * tcohen hoped nicole was around
15:39:23 <cait> no objections from me
15:39:28 <cait> pull downs should be ok
15:40:07 <bag> morning
15:40:07 <wahanui> rumour has it morning is a state of the cait
15:40:11 <tcohen> hi bag+
15:40:12 <bag> nengard is right here
15:40:38 <bag> tcohen: grabbing nengard right now
15:40:44 <tcohen> i wanted some feedback from the end-user pov, that's why i mentioned nengard
15:41:37 <nengard> #info Nicole C. Engard, ByWater Solutions
15:41:52 <khall> #info Kyle Hall, ByWater Solutions
15:41:53 <bag> #info Brendan Gallagher ByWater
15:41:54 <nengard> I like the idea of bug 12716 it will eliminate errors
15:41:59 <bag> sorry we are late :)
15:42:11 <nengard> allowing people to type in fields that have to be exact matches to codes can be problematic
15:42:30 <nengard> most end users like the idea of pull downs over the freedom to type (and make mistakes)
15:43:06 * oleonard wishes the stage MARC import tool reported errors related to invalid authorized values
15:43:20 <tcohen> oleonard: fill abug for that!
15:43:28 <tcohen> nengard: http://snag.gy/mLZhO.jpg
15:43:55 <tcohen> i added datepickers to dates, and dropdown to those two fields
15:44:11 <nengard> tcohen me likey!
15:44:13 <tcohen> it is wip, and the visualization would be that with the greyed table column
15:44:24 <bag> tcohen: that’s a lot of open tabs there
15:44:52 <cait> tcohen: there is one for invaid branchcodes i think
15:45:04 <tcohen> bag: hell yeah, need to work on that with the shrink
15:45:52 <bag> :)
15:45:55 <thd> Dropdowns should not need to depend on JavaScript where invoking yet more JavaScript can be avoided.
15:46:18 <tcohen> thd: they don't in my implementation
15:46:19 * oleonard sprinkles JavaScript liberally over the staff client
15:47:02 <tcohen> ^^^^ that's also true
15:47:11 * thd hopes for the day that the staff client will work well in lynx.
15:47:45 <tcohen> thd: links2 has javascript :-P
15:49:27 <tcohen> ok, moving on
15:49:45 <tcohen> #topic Big stuff we are working on
15:49:51 <thd> tcohen: JavaScript was removed from even links2 because the implementation had too many bugs for too many use cases.
15:50:07 <tcohen> oh
15:50:42 <tcohen> anyone wants to comment on their current projects right now?
15:51:41 <tcohen> ok, skipped then :-d
15:51:50 <tcohen> #topic Set time of next meeting
15:53:00 <tcohen> i propose next meeting is August 19th, same time (part 1 15:00 UTC, part 2 22:00 UTC)
15:53:24 <thd> +1
15:53:36 <tcohen> as it is vacation in several places there might not be many atendees
15:54:21 <tcohen> if there are no objections, i will put it as agreed
15:54:26 <jwagner> +1
15:54:31 <tcohen> +1
15:54:41 <bag> +1
15:55:16 <tcohen> ok
15:55:51 <tcohen> #agreed if part 2 agrees, next dev meeting is August 19th (part 1 15:00 UTC, part 2 22:00 UTC)
15:56:08 <tcohen> ok, that's all folks
15:56:13 <tcohen> #endmeeting