21:09:58 <BobB> #startmeeting General IRC Meeting #2 17 December 2014
21:09:58 <huginn> Meeting started Wed Dec 17 21:09:58 2014 UTC.  The chair is BobB. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:09:58 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:09:58 <huginn> The meeting name has been set to 'general_irc_meeting__2_17_december_2014'
21:10:03 <cait> right :)
21:10:31 <BobB> #topic Introductions
21:10:32 <wahanui> #info wahanui, a bot that has become sentient
21:10:35 <rangi> #info chris c, catalyst, sorta here
21:10:39 <JesseM> #info Jesse Maseto BWS, USA
21:10:47 <edveal> #info edveal BWS, USA
21:10:55 <BobB> #info Bob Birchall, Calyx Australia
21:10:58 <cait> #info Katrin Fischer BSZ - might fall asleep
21:11:23 <cbrannon> #info Chrisopher Brannon, Coeur d'Alene, ID
21:11:28 <jmsasse> #info Joel Sasse Plum Creek USA
21:11:43 <barton> #info Barton Chittenden, Bywater Solutions, Louisville, KY, USA
21:11:56 <rohdechris> Chris Rohde, Roseville, USA
21:12:38 <BobB> hi all, any more?
21:13:01 <BobB> #topic Announcements
21:13:42 <BobB> #info This has been added to the agenda:
21:13:52 <BobB> #info Please vote up this Library::Callnumber::LC bug which is related to these Koha callnumber symptoms.
21:14:05 <BobB> any comments?
21:14:10 <bag> #info Brendan Gallagher ByWater Solutions
21:14:31 <drojf> #info Mirko Tietgen, Berlin
21:14:36 * barton scrolls back and finds adgenda wiki link.
21:14:56 <cait> I think the bug has been integrated now, so voting might no longer be necessary
21:15:17 <BobB> cool, thx cait
21:15:36 <BobB> any other announcements?
21:16:20 <BobB> #topic Update on Releases
21:16:34 <BobB> Any Release Maintainers here?
21:16:41 <talljoy> #info Joy Nelson ByWater Solutions
21:17:04 <rangi> i am
21:17:13 <rangi> 3.18.x is in string freeze
21:17:24 <rangi> on course for an ontime release of 3.18.2 on the 22nd
21:17:27 <bag> I just added a section to the wiki page for the meeting “Proposal for fund raising for Koha - to discuss/vote “
21:17:44 <bag> (sorry that is for later)
21:17:50 <BobB> ok bag, will come to that
21:18:21 <rohdechris> #info Chris Rohde, Roseville, CA USA
21:18:22 <BobB> I haven't read the minutes of today's first meeting ...
21:18:36 <BobB> there may be info there about the releases
21:18:41 <drojf> nope
21:18:46 <cait> none of the RMaints were around
21:18:49 <drojf> we were about 5 people
21:18:54 <BobB> ah ok
21:18:59 <cait> I speculated the releases were still planned for 22nd :)
21:19:06 <rangi> yep
21:19:16 <rangi> mtj and fridolin have said in email they are releasing on the 22nd
21:19:22 <BobB> so rangi 3.18.1 was a Security Release?
21:19:30 <rangi> yep so was 3.16.5
21:19:41 <rangi> 3.18.2 wont have much different to 3.18.1
21:19:47 <rangi> but will have updated translations
21:19:59 <rangi> (dont get time do those for a security release)
21:20:04 <BobB> And 3.14 is still being maintained?
21:20:31 <rangi> yes thats fridolin
21:20:35 <rangi> but it wasnt vulnerable
21:20:44 <BobB> ok
21:21:12 <BobB> #info Security releases of 3.16 and 3.18 have been made; 3.14 was not vulnerable
21:21:40 <BobB> #info afawk, we are on track for next releases on 22 Dec
21:21:59 <BobB> any more on Releases?
21:22:56 <BobB> Changing topic:
21:23:41 <BobB> #topic Road Map for Koha
21:24:18 <BobB> Can anyone remember where we are up to on this?
21:24:21 <cait> I think we discussed that the way it could be published mostly
21:24:24 <cait> at the first meeting
21:24:47 <cait> wiki or website, linking them or summarizing
21:24:52 <cait> not much about the content so far I think
21:24:59 <cait> drojf: ?
21:25:26 <drojf> that is all i remember, yes
21:25:37 <BobB> can anyone find the link to last meeting minutes (November)?
21:25:43 <drojf> having it in the wiki, summarizing on the website
21:26:22 <drojf> http://wiki.koha-community.org/wiki/General_IRC_meeting_19_November_2014
21:26:46 <BobB> found it too, no actions, just ideas
21:27:28 <BobB> IDEA: use the next meeting to have more discussion, past and future on the road map
21:27:45 <BobB> so, any further thoughts since?
21:28:00 <bag> We could throw some thoughts out now
21:28:09 <BobB> yep
21:28:10 <bag> Like I want to see the OPAC really take a step forward
21:28:20 <bag> So what am I going to do
21:29:25 <bag> Starting with integratation of more Econtent into Koha OPAC ;)  like gutenburg, overdrive, openlibrary etc etc - make it so that you can ingest all that into the search engine (and not via marc records)
21:29:36 <bag> Also Elastic Search - lets get that in
21:29:39 <bag> :D
21:29:56 <TGoat> Yea, we need elastic search
21:30:01 <bag> or do I still have to wait to throw ideas out there - until the next general meeting?
21:30:02 <cait> is there a plan to follow up on the pazpar2 patch ot integrate z39.50 searches?
21:30:23 <cait> sometimes you can't get the data itself, i liked the idea of that one :)
21:30:34 <cait> or it's just too much data to include in your catalog
21:30:37 <bag> cait for now we’ve abandon that since pazpar2 wasn’t stable with the way we did it
21:31:10 <bag> basically pianohacker came back and said he’d like to rewrite pazpar2 (and I said we don’t have time for that
21:31:11 <BobB> hmm, too bad
21:31:19 <bag> but anyone anywhere can pick that up
21:32:12 <bag> but I really feel that the OPAC needs the next jump up
21:32:13 <BobB> ok, so for the Road Map, the next steps would be ...
21:32:25 <bag> RDF linked data - we should all be pushing for that
21:32:38 <bag> I think we need a spot to list ideas BobB
21:32:47 <bag> someone create that spot and call to list ideas
21:32:49 <BobB> to create the wiki page and start to populate it with these great ideas
21:33:10 <bag> then have someone curate it
21:33:41 <BobB> so brainstorm possible contents, then have some discernment about what actually goes in, bag?
21:34:12 <bag> cait I’d like to bring that Z3950 one back up - it’s just that pianohacker currently has such limited Koha time (because of school)
21:34:27 <bag> but maybe a little more time on it and we’d be able to do something different with it
21:34:40 <bag> make it more stable
21:34:52 <cait> ok
21:35:35 <BobB> bag I think you are suggesting a level of control on Road Map content that maybe won't be there always?
21:35:59 <bag> could be or not - but someone to organize it
21:36:00 <BobB> If the Road Map exists, can't anyone update it for their new ideas?
21:36:22 <bag> so that way I’m not putting the same thing up there that rangi is (just using english versus new-zealand english)
21:36:40 <bag> everyone should be able to update it - I think someone should organize it
21:36:41 <bag> ;)
21:36:42 <BobB> but sure a curator would be good to get rid of dead stuff and so on
21:37:05 <BobB> Could that be the general Wiki Curator, if we get one?
21:37:14 <bag> yes please
21:37:46 <BobB> ok, so why don't we create the Road Map page and get people to list stuff ....
21:38:27 <BobB> there can then be discussions about the value or otherwise of what gets put forward
21:39:11 <BobB> any contrary thoughts?
21:39:26 <bag> +1
21:39:47 <rangi> +1
21:40:00 <cbrannon> +1
21:40:07 <BobB> those votes are in favour of creating the page?
21:40:10 <jmsasse> +1
21:40:23 <cbrannon> yes
21:40:27 <BobB> (I'll assume so unless someone speaks otherwise)
21:41:02 <BobB> so continue voting pls
21:41:04 <drojf> +1
21:41:30 <rohdechris> +1
21:41:37 <edveal> +1
21:42:14 <TGoat> +1
21:42:27 <BobB> all done?
21:42:34 <BobB> #agreed In accordance with discussion at the November meeting, a wiki page for a Koha Road Map should be created
21:42:51 <BobB> So is there a volunteer to do that?
21:43:25 <cbrannon> who knows wiki?
21:44:15 <BobB> I'll ask Magnus, else I can do it, ok?
21:44:32 <bag> works for me
21:44:55 <BobB> #action BobB to find someone to create a Road Map wiki page, else do it himself
21:44:57 <cbrannon> thank you
21:45:12 <BobB> blah
21:45:19 <BobB> next topic?
21:45:19 <wahanui> next topic is a tricky one...
21:46:02 <BobB> #topic  Proposal for fund raising for Koha - to discuss/vote
21:46:14 <BobB> bag?
21:46:15 <wahanui> I LIKE BASEBALL
21:46:19 <BobB> LOL
21:46:31 <bag> I LOVE BASEBALL
21:46:42 <bag> ok here is most of it
21:46:43 <bag> http://koha.1045719.n5.nabble.com/Proposal-for-fund-raising-for-Koha-to-discuss-vote-at-December-General-Meeting-td5821688.html
21:46:44 <BobB> what about fundraising?
21:47:00 <bag> I’m just really looking for a — YES go for it - NO don’t do it
21:47:27 <BobB> so is the question 'that the  meeting endorses the discussion paper'?
21:47:31 <bag> Right now we’ve got the HLT ready to be the place that can accept donations (NPO)
21:47:44 <bag> yes BobB that’s really the gist of it
21:48:13 <BobB> any questions folks?
21:48:24 <BobB> or I'll take it to a vote
21:48:29 <rangi> my main thing is we should try to avoid people scope creeping it
21:48:32 <bag> So YES do it - then I think me and some others (I need help).  Will really have to write a full spec/proposal
21:48:34 <rangi> lets start small
21:48:37 <bag> and then come back to it
21:48:49 <cait> +1
21:49:00 <jmsasse> +1
21:49:03 <rangi> and just a place to accept donations .. before we start adding a pile of complexity like targeting donations etc
21:49:11 <BobB> rangi, you don't want a Mellon applicaton next week?
21:49:13 <rangi> if its that then im +1
21:49:18 <bag> agreed
21:49:30 <cbrannon> +1
21:49:33 <rangi> BobB: not if they get to tell the community how it has to be spent :)
21:49:46 <BobB> ok hold those votes just a mo'
21:49:55 <rangi> so
21:49:57 <BobB> rangi: agreed
21:50:12 <BobB> OK, the question is:
21:50:15 <rangi> +1 #for starting a small no strings attached donation/distribution idea
21:50:36 <bag> I think first let’s get the structure in place (IE click here to donate)…
21:50:41 <rangi> yep
21:50:57 <drojf> +1 for full spec/proposal
21:51:04 <bag> 2. pursue a few koha support companies for some monies
21:51:25 <bag> 3. use money for sign-offs from a non-support company person
21:51:49 <BobB> that is what your paper sets out bag, iirc
21:52:04 <bag> build more structure after that - while working with the community
21:52:08 <bag> yes BobB
21:52:09 <bag> ;)
21:52:22 <BobB> so we are saying one step at a time, then go for it
21:52:33 <bag> ok I’m going to pull back for a bit and let you all talk  (I’m not voting either)
21:52:53 <rangi> yep
21:53:02 <rangi> +1 for the paper/spec
21:53:32 <BobB> So I'll call for the vote: that the meeting endorses Brendan's paper on fund raising
21:53:47 <BobB> Vote now please
21:53:48 <rangi> +1
21:53:49 <drojf> +1
21:53:57 <cbrannon> +1
21:54:00 <barton> +1
21:54:01 <jmsasse> +1
21:54:02 <rohdechris> +1
21:54:41 <BobB> all done?
21:55:18 <BobB> #agreed The meeting endorsed the paper by Brendan on Fund Raising for the Koha project
21:55:28 <bag> sweet :D
21:55:45 <BobB> #action bag to implement step 1 of the proposed strategy
21:55:52 <BobB> OK?
21:55:59 <bag> hey Jo we have some work to bring back to the community ;)  BobB you’re up too ;)
21:56:00 <bag> heh
21:56:14 <BobB> :)
21:56:58 <BobB> done on that topic?
21:57:13 <BobB> I'm going to combine the next two topics
21:57:33 <BobB> #topic Wiki Curator and Communications Manager
21:57:45 <BobB> right, but I'm sorry, the dog ate my homework
21:58:02 <rangi> i think thd wrote a proposal
21:58:14 <rangi> http://wiki.koha-community.org/wiki/Proposal_for_Wiki_Curator_3.20_Thomas_Dukleth
21:58:27 <rangi> but no bites for coms
21:59:18 <drojf> there is also some kind of objection in the discussion http://wiki.koha-community.org/wiki/Talk:Proposal_for_Wiki_Curator_3.20_Thomas_Dukleth
21:59:27 <BobB> #link http://wiki.koha-community.org/wiki/Proposal_for_Wiki_Curator_3.20_Thomas_Dukleth
21:59:29 <bag> hmm no bits for coms :(  can we try for one more month?
21:59:49 <rangi> i think would need to send a new email
22:00:07 <drojf> (that was most of this mornings meeting)
22:00:28 <drojf> or, like, first part of the meeting, not necessarily morning for you ^^
22:00:38 <BobB> #link http://wiki.koha-community.org/wiki/Talk:Proposal_for_Wiki_Curator_3.20_Thomas_Dukleth
22:00:49 <BobB> (just getting those links into the minutes)
22:01:53 <BobB> ok, I think from the Nov. meeting I had actions about advertising those roles,, let me check
22:02:32 <bag> BobB: I just asked nengard_afk to do a blast to our partners
22:02:33 <BobB> confirmed
22:02:34 <cbrannon> yes, that is correct
22:03:18 <BobB> well, if the role is controversial, its just as well I haven't done that
22:03:23 <bag> hmm MRenvoize comments don’t seem that bad to me - perhaps we should give sometime for thd to comment back?  I move to not vote on this at this time
22:03:38 <BobB> sounds right bag
22:04:03 <BobB> I propose we defer this till next meeting, to allow the discussion to progress
22:04:14 <bag> and perhaps some more volunteers
22:04:16 <drojf> they (and all of us) agreed to a group approach for the wiki. that is as far as we could get
22:04:49 <rangi> i do think it needs an upgrade and get back to stock, then figure out what extensions we need, i agree with ashimema there
22:05:11 <drojf> as for the technical side… i think we should … yep what rangi says ^^
22:06:00 <BobB> I am suggesting the January meeting could make that decision, then we advertise
22:06:21 <cait> yeah agreeing with rangi
22:06:38 <cait> i think simplifying, getting back to stock, would help us maintaining long term
22:07:24 <BobB> ok, I am at a disadvantage here, as I've not read either submission
22:07:35 <BobB> does someone want to propose a motion?
22:07:42 <bag> can we vote on upgrade now?  OR do we not have anyone that could do the upgrade?
22:08:05 <bag> I see two BobB
22:08:06 <rangi> i dont think we have anyone who has the time to do it at the moment
22:08:13 <drojf> as far as i understood upgrading as it is is rather complicated
22:08:33 <bag> 1 - move vote/more discussion to next meeting and Ask for more volunteers now (re advertise)
22:08:34 <drojf> as in takes time
22:08:45 <bag> 2 - upgrade now - but who does it?
22:10:07 <BobB> bag,clarifying motion 1: you say re-advertise, but it hasn't been advertised yet?
22:10:21 <bag> ok take out the RE part
22:10:22 <bag> ;)
22:10:32 <BobB> I think Thomas is interested, but he was in the discussion in Nov
22:10:40 <rangi> i thought there was an email
22:10:43 <rangi> but i might be wrong
22:10:54 <bag> I think cbrannon said there was an email
22:11:03 <BobB> not from me, and I had carriage from the last meeting
22:11:13 <bag> cbrannon: if you have the subject of the email we can find it in nabble
22:11:16 <cbrannon> @bag: that was something else
22:11:16 <huginn> cbrannon: I suck
22:11:37 <rangi> http://comments.gmane.org/gmane.comp.misc.koha/36732
22:12:39 <BobB> #link http://comments.gmane.org/gmane.comp.misc.koha/36732
22:12:56 <BobB> that wasn't meant to be an advert, at the time
22:13:38 <BobB> ok, so this does not become too long tonight:
22:14:06 <bag> BobB: can you advertise this?
22:14:28 <BobB> I propose an amendment to bag's first motion:
22:14:45 <BobB> 1 - move vote/more discussion to next meeting and Ask for more volunteers now: then advertise the role on the mailing list
22:15:22 <cbrannon> +1
22:15:24 <BobB> Pls vote (+1 or -1)
22:15:39 <bag> +1
22:15:51 <rohdechris> +1
22:16:08 <rangi> +1
22:16:33 <BobB> any more?
22:16:54 <drojf> +1
22:17:26 <BobB> #agreed To move discussion of wiki curation to next meeting and to call for volunteers now
22:17:53 <BobB> by the 'role' we're talking about a coordinator of a team of volunteers
22:18:11 <BobB> so we're saying ask volunteers to come forward,
22:18:45 <BobB> and we'll sort out who the coordinator will be and exactly what the role is at/after the next meeting
22:18:54 <BobB> Done?
22:19:02 <rangi> i think so
22:19:11 <cbrannon> yes
22:19:36 <BobB> Re the Comms Manager, I want to liaise with the newsletter editors to make sure they understand they are not being made redundant ...
22:20:02 <rangi> yeah good idea
22:20:08 <BobB> before that role is advertised, so can we kick that to January meeting also?
22:20:14 <rangi> sounds good
22:21:03 <BobB> #action BobB to prepare ground for decisions to be taken in January re wiki curation and Comms Manager
22:21:43 <BobB> #topic KohaCon15
22:21:53 <BobB> I think Olug is not here?
22:22:08 <BobB> any updates anyone?
22:22:13 <rangi> yep
22:22:34 <rangi> they are working on the costings of food/lodging etc and will update us all when they know
22:22:49 <rangi> they are already getting lots of nigerian librarians asking when can they register
22:23:20 <rangi> so things sound on track
22:23:47 <BobB> thanks rangi
22:23:52 <drojf> nice
22:24:54 <BobB> #topic Actions from Nov meeting
22:25:31 <BobB> can someone check the minutes of meeting #1 in Nov?
22:25:50 <BobB> there was only one action from meeting #2 and we've dealt with it
22:26:19 <rangi> BobB will email the mailing list about the new roles
22:26:26 <rangi> thats the only one from meeting 1
22:26:42 <rangi> adding a note/link to the kc website about kohacon15
22:26:45 <BobB> and we've dealt with that
22:26:52 <rangi> is the only other one
22:27:08 <BobB> Is that one done, re Koha Con?
22:27:29 <rangi> i think so
22:27:37 <BobB> cool, thx
22:27:38 <rangi> http://koha-community.org/kohacon/kohacon15/
22:27:39 <rangi> yes
22:27:47 <BobB> #topic Next Meeting
22:28:17 <drojf> it seems that splitting the meeting does not work very well
22:28:58 <drojf> the first meeting is kind of a lesser one, with lots of "well we have to see about the second meeting", second meeting attendees don't read the minutes of the first
22:29:17 <drojf> and strange people like myself end up having the meeting twice
22:29:48 <rangi> yeah i think maybe going back to rotating the time might be better
22:30:10 <drojf> +1 for rotating, maybe leaving out the 3rd "evil" time that did not attract many people
22:30:11 <BobB> the idea was to enable more people to attend, but the benefit is maybe marginal
22:30:13 <bag> I agree with that
22:30:14 <drojf> i think 2utc
22:30:21 <bag> +1 for rotating
22:30:43 <BobB> ok hold on, let me put the question
22:31:19 <BobB> Does the meeting agree to revert to rotating times and to have only one meeting per month?
22:31:24 <BobB> Vote now pls
22:31:27 <drojf> +1
22:31:41 <rangi> +1
22:31:48 <jmsasse> +1
22:32:03 <tcohen> +1
22:32:41 <BobB> any more?
22:33:30 <BobB> #agreed There will be only one meeting per month: times will be rotated to promote best possible attendance
22:33:49 <BobB> so is January 14th too soon for next meeting?
22:34:00 <BobB> Jan 21 is near a release date
22:34:10 <tcohen> 14th is fine
22:34:26 <drojf> +1 for 14th
22:34:31 <BobB> who wants to suggest the time?
22:34:36 <bag> +1
22:35:10 <tcohen> +
22:35:13 <rangi> how about 20UTC ?
22:35:32 <rangi> actually
22:35:43 <rangi> 10UTC
22:36:00 <BobB> Vote please on next meeting is January 14th at 10 UTC
22:36:10 <rangi> hmm that might be too late for the americans, i dunno
22:36:20 * bag checking timesw
22:36:23 <tcohen> you mean 10 P;¡
22:36:26 <tcohen> PM?
22:36:35 <BobB> hold the vote please while bag checks
22:36:57 <BobB> tcohen the proposal is 10 UTC
22:37:02 <drojf> http://www.timeanddate.com/worldclock/fixedtime.html?msg=Koha+IRC+General+Meeting&iso=20150114T10
22:37:38 <BobB> it'll be a civilised after dinner time for me
22:37:59 <bag> yeah it’s a bit early but that’s cool I love getting up early :)  and the ginny pie can join me
22:38:06 <tcohen> thanks drojf
22:38:13 <tcohen> I think I can get up that early once a month
22:38:14 <cbrannon> -1
22:38:15 <tcohen> :-D
22:38:23 <BobB> No objections?  Then the proposal is 14 January 2015 at 10 UTC
22:38:24 <huginn> New commit(s) kohagit: Bug 13362: translate script creates dirs on update <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=0edebb12b4aa9bb0532eb574aaaeee201a61f595> / Bug 13375: Syspref search highlight styling broken in Chrome <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=6c23ef54a32bbdfcc04e59b96ae9936240c46e41> / BUG 13468: Overdue notice lists all checked out books <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=6413eb9949956b899d4049bf53cb5a6dff15154f> / Bug 13451: Holidays.t assumes default data <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=d37dee3ddf97a028cc42ef15fd9f938d9b7bd89a> / Bug 13398: rotating collections scripts are skipped on install <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=99f3121ff874fdc38aa607ca0db5b16436dd16ca> / Bug 13428: Fix regression on deleting facets <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=1c3b98e146df0cdd1976c6bf51840ac2103b24cf>
22:38:29 <BobB> Vote no w please
22:38:34 <rangi> +1
22:38:39 <tcohen> +1
22:38:55 <cbrannon> -1
22:39:11 <drojf> +1
22:39:32 <BobB> #agreed The next meeting will be held on 14 January 2015 at 10 UTC
22:39:33 <tcohen> where do u live cbrannon ?
22:39:42 <bag> -1
22:39:47 <BobB> anything else?
22:39:48 <cbrannon> North Idaho.  That's 2am for me.
22:39:59 <bag> but just cause I say no - doesn’t mean it’s not possible ;)
22:40:01 <bag> heh
22:40:36 <rohdechris> would Feb meeting be at a better PST time?
22:40:37 <BobB> oh dear, any motion for recission of that last agreement?
22:40:50 <rangi> rohdechris: yeah we rotate it
22:41:08 <BobB> It is of course not possible to ahve a time convenient world wide
22:41:17 <rangi> the next one most likely around 18UTC
22:41:32 <rangi> in feb
22:41:38 <cbrannon> perhaps if we all syncronized our clocks to one time?  ;)
22:41:46 <BobB> If there is no motion for recission I will close the meeting
22:42:03 <rohdechris> that makes feb 10 am PST--sounds fair to me
22:42:25 <BobB> #endmeeting