15:00:27 <gmcharlt> #startmeeting General meeting, 9 April 2014, part 1
15:00:27 <huginn> Meeting started Wed Apr  9 15:00:27 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:27 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:27 <huginn> The meeting name has been set to 'general_meeting__9_april_2014__part_1'
15:00:37 <gmcharlt> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_9_April_2014 Agenda
15:00:44 <gmcharlt> #topic Introductions
15:00:45 <wahanui> #info wahanui, a bot that has become sentient
15:00:51 <oleonard> #info Owen Leonard, Athens County Public Libraries
15:00:54 <gmcharlt> #info Galen Charlton, 3.16 RM, Equinox Software, USA
15:01:00 <cait> #info Katrin Fischer, BSZ, Germany
15:01:11 <jwagner> #info Jane Wagner, LibLime/PTFS
15:01:20 <ColinC> #info Colin Campbelll, PTFS Europe Ltd
15:01:23 <Joubu> #info Jonathan Druart, BibLibre, France
15:01:28 <thd> #info Thomas Dukleth, Agogme, New York City
15:02:23 <mduncan> #info Margo Duncan, UT Tyler, USA
15:03:12 <slef> #info MJ Ray, software.coop, England
15:03:26 <peggy> #info Peggy Thrasher, NH USA
15:04:17 <indradg> #info Indranil Das Gupta, L2C2, India
15:04:57 <gmcharlt> thanks
15:05:07 <gmcharlt> I'm going to merge the next few agenda items, thus:
15:05:16 <gmcharlt> #topic Updates on 3.8, 3.10, 3.12, 3.14, and 3.16
15:05:29 <gmcharlt> #topic Updates on 3.8, 3.10, 3.12, 3.14
15:05:43 <gmcharlt> any RMaints around to give updates?
15:05:56 <cait> #info today's agenda: http://wiki.koha-community.org/wiki/General_IRC_meeting_9_April_2014
15:06:22 <gmcharlt> #info Koha 3.12.12 was released on 24 March 2014
15:06:34 <gmcharlt> #info Koha 3.14.5 was released on 26 March 2014
15:06:35 <slef> cait++
15:07:18 <gmcharlt> ok, guess that's it
15:07:28 <gmcharlt> #topic Update on 3.16
15:07:36 <gmcharlt> #link http://lists.koha-community.org/pipermail/koha-devel/2014-April/040419.html Release schedule
15:07:55 <gmcharlt> #info Alpha release scheduled for Wednesday, 23 April - RM will clear PQA queue by then
15:07:59 <cait> gmcharlt++
15:08:31 <gmcharlt> #info Feature freeze scheduled for Monday, 28 April - new features & enhancements must have reached PQA by then to be considered, with leeway giving to the new cataloging editor
15:08:50 <gmcharlt> #info Beta release will be cut on Wednesday, 30 April; soft string freeze starts then as well
15:09:03 <gmcharlt> #info Firm string freeze starts on Monday, 5 April
15:09:08 <gmcharlt> #info RC will be cut on Monday, 19 May
15:09:17 <gmcharlt> #info General release will occur on Thursday, 22 May
15:09:17 <slef> PQA is Passed Quality Assurance
15:09:25 <slef> RC is Release Candidate
15:09:26 <gmcharlt> correct
15:09:39 <slef> gmcharlt: I know, just making sure wahanui is uptodate
15:09:46 <gmcharlt> ah, gotcha
15:10:10 <gmcharlt> questions for me?
15:10:20 <Bruce_> translations are appreciated
15:10:33 <gmcharlt> slef++
15:11:18 <cait> There are still a lot of things waiting for sign off that would be nice additions to 3.16... and the new cataloguing editor needs testing I think?
15:11:28 <slef> ok, I'm not seeing stats on the dashboard so I'm grubbing around
15:11:42 <slef> oh my bad, scroll down
15:11:47 <gmcharlt> yep
15:12:13 <cait> #info 170 needs signoff, 68 signed off currently
15:12:29 <slef> #info 170+52 needs signoff, 68+21 waiting for QA, 180 failed QA, 36 Patch Does Not Apply
15:12:47 <cait> slef: 170 is including the 52 :)
15:12:48 <slef> oh is that "170, 52 of which"?
15:12:51 <slef> gotcha
15:13:02 <slef> #info correction: 170 needs signoff, 68 waiting for QA, 180 failed QA, 36 Patch Does Not Apply
15:13:32 <gmcharlt> magnuse: is a GBSD in the works, perchance?
15:13:36 <slef> Need Signoff needs ad-hoc developers to get off our lazy backsides and do some initial reviewing
15:13:49 <slef> What's the plan for those 180 and 36?
15:14:17 <cait> slef: hoping for someone to gett of their backsides? ;)
15:14:50 <slef> cait: sure, but the original developers or is it open season?
15:14:59 <cait> i am not sure there is a plan, we had it down to around a 100 after the hackfest, but it came back up quickly
15:15:25 <gmcharlt> no
15:15:40 <gmcharlt> perhaps that's a project role to consider: Official Kitten Rescuer
15:15:50 <oleonard> I don't see why another dev couldn't fix conflicts if they really wanted to
15:15:55 <cait> oh sorry, confused the queues
15:16:05 <gmcharlt> thought at the moment I'm not sure whether we have mroe than a title to offer
15:16:10 <cait> i was talking about the 170 signed off
15:16:18 <gmcharlt> yeah, I'm thinking more about the failed QA, not the patch-does-not-apply
15:16:50 <thd> The time between RC and general release seems very short for testing , although, it may be based on some similar time having been passed and no stopping bugs found.
15:16:51 <gmcharlt> although there are probably at least a few useful contributions from casual contributors in that status that just need somebody to deal with the merge conflict
15:16:51 <slef> might be worth RM or similar to declare "I am particularly keen to see the following list fixed by anyone:"
15:17:10 <gmcharlt> slef: yes, that's a thought I'll take up
15:17:21 <oleonard> Whatever happened to the patch-applying bot?
15:17:43 <slef> #idea it might be worth RM or similar to declare "I am particularly keen to see the following list fixed by anyone:"
15:17:44 <cait> I think someone complained it was turned off
15:17:44 <gmcharlt> thd: to be clear, extensive testing should being with the beta release, and I'll make an announcement to that effect
15:17:56 * slef wonders if he can declare #idea
15:17:57 <cait> I'd like to see it back in action actually, and even improved to run qa script and tests automatically
15:17:57 <gmcharlt> testing of the RC is mostly just to verify that there aren't stupid errors
15:18:00 <thd> Yes of course.
15:18:28 <gmcharlt> cait: something to discuss with rangi, I imagine
15:18:37 <gmcharlt> and/or bribe with cookies and chocolate
15:18:46 <cait> yeah, but i think having a few votes for starting it again could help persuade him
15:18:47 <slef> would people prefer me to work on needs signoff or does not apply?
15:19:00 <gmcharlt> slef: yes, everybody can use #idea
15:19:15 <oleonard> slef: I would think needs signoff
15:19:31 <gmcharlt> slef: my preference would be for you to glance at does not apply to see if there are any obvious wins, but to focus on needs signoff
15:19:35 <cait> slef: I am torn there - i think both have gems
15:19:54 <Joubu> Are you sure someone test beta versions?
15:20:17 <cait> Joubu: we can't really force people to - maybe we could reserve a sandbox?
15:20:30 <slef> Just for context, I think I've up to 7 hours available to get back up to speed on koha-community this month, less the time in this meeting.
15:20:57 <gmcharlt> Joubu: to be blunt,  I'm pretty sure that folks don't in general test as much as we would like them to, but I'll try to encourage people to test the beta
15:20:59 <cait> to make it easier? but some of the demos arealso running master
15:21:22 <gmcharlt> but yeah, beta sandboxes would be nice, and highlighting some of the master demos
15:21:31 <cait> maybe when you write the email - include some links to demos or a setup sandbox?
15:21:36 <cait> :)
15:21:49 <cait> #idea highlight sandboxes and demos running the beta for testers
15:21:52 <Joubu> I think the only person to test pre release versions are developpers
15:22:05 <Joubu> but maybe I am wrong, I don't know
15:22:26 <Bruce_> Would an additional (funded) sandbox help?
15:22:39 <gmcharlt> by and large, although I thik most of us have at least a couple customers apiece who are engaged enough to respond to a request to test a beta
15:22:46 <slef> I'm happy to mail our libraries asking for testing if there's a beta sandbox available.
15:23:29 * gmcharlt will also specifically request beta testing to be done by a couple of our customers who are generally willing to do that sort of thing
15:25:18 <gmcharlt> OK, time to move on in the agenda
15:25:33 <gmcharlt> #topic Nominations for roles for 3.18
15:25:41 <gmcharlt> #link http://wiki.koha-community.org/wiki/Roles_for_3.18 Current 3.18 nominations
15:26:07 <gmcharlt> as it stands now, we have candidates for RM and RMaints for the two most recent stable branches
15:26:19 <Joubu> slef: all sandboxes listed on http://wiki.koha-community.org/wiki/Sandboxes#Available_Sandboxes are available
15:26:20 <gmcharlt> as well as translation manager, doc manager, QA manager, and QA team members
15:26:44 <gmcharlt> so a couple things I'd like to point out
15:26:55 <gmcharlt> first -- is there interesting in maintaining 3.12 further?
15:27:06 <gmcharlt> and if so, is there somebody interested in being RMaint for that release?
15:27:43 <slef> NAFAIK but I will ask what I think is our last 3.12 library if they're going to agree an upgrade date with us or if they want to fund maintenance ;-)
15:27:44 <cait> we are still running it... probably for a bit longer... so I would be happy if we got someone
15:29:16 <slef> Joubu: Sorry, I've been away. Don't they run master rather than a beta or RC?
15:29:28 <slef> cait: got any funding? ;-)
15:29:30 <gmcharlt> I'm incilned to write an email to koha-devel, then, specifically asking for somebody to step up, or for us to declare EOL of 3.12
15:29:47 <gmcharlt> (and the same for 3.10 and 3.8, though more likely it would be EOL for those)
15:29:52 <Joubu> slef: yes, they run master.
15:30:15 <gmcharlt> Joubu: is it easy to pin a couple of them to a beta tag when the time comes?
15:30:37 <cait> slef: shouldn't hurt if they run on master instead of beta - testing master after beta cut would also be helpful
15:30:50 <Joubu> gmcharlt: yep, we can remove the reset --hard origin/master at midnight :)
15:31:06 <gmcharlt> cool
15:31:15 <slef> cait: ok, I bow to you
15:31:21 <cait> hm?
15:31:27 <gmcharlt> #action Galen will send a query to koha-devel regarding status of 3.12, 3.10, and 3.8
15:31:57 <gmcharlt> next thing - a new type of role is being discussed more seriously
15:32:00 <gmcharlt> specifically, a module maintainer
15:32:18 <gmcharlt> some discussion about it has occurred here
15:32:19 <gmcharlt> http://wiki.koha-community.org/wiki/Talk:What_does_a_module_maintainer_do
15:32:26 <gmcharlt> #link http://wiki.koha-community.org/wiki/Talk:What_does_a_module_maintainer_do module maintainer discussion
15:32:37 <gmcharlt> though I'm inclined to move that over to koha-devel
15:33:16 <slef> I'd appreciate that because I rarely have my wiki login handy now we don't have openid
15:34:04 <slef> Isn't it largely up to the RM to organise the team as he wants, though?
15:34:04 <gmcharlt> I think the developing consensus so far as that MMs are folks who take responsibility for certain areas, have the authority (in conjunction with the RM) to push to master for those areas, but do not bypass the review and QA requirements
15:34:09 <slef> he/she/it
15:34:19 * slef leaves the option of wahanui as RM open
15:34:45 <gmcharlt> slef: yes, I think RM oversight is key -- specifically, an RM should have the right to tell an MM to back off or switch to using pull rqeuests rather than pushing directly
15:35:32 <cait> +1
15:35:33 <gmcharlt> but overall, I think the MM concept has value, *provided* that it doesn't become an excuse to bypass QA
15:35:59 <oleonard> How would the process be different between MM and standard QA workflow?
15:36:20 <cait> the MM can also work on patches in PQA
15:36:37 <cait> so hopefully taking some of the weight from the RM - that's how i understand
15:36:56 <gmcharlt> right
15:37:00 <gmcharlt> to restate another way
15:37:05 <gmcharlt> patch passes QA
15:37:12 <gmcharlt> old behavior: only the RM can review and push it
15:37:32 <gmcharlt> new behavior: the RM can review and push it, or the relevant MM can review and push it, but MM and RM must communicate
15:37:55 <gmcharlt> in addition, I think it would be good for MMs to actively manage pre-QA patches
15:38:04 <gmcharlt> e.g., rescue failed-QA patches, do code cleanup, and the like
15:39:04 <gmcharlt> #action Galen will move the MM discussion to koha-devel
15:39:16 <gmcharlt> a quick straw poll
15:39:28 <gmcharlt> +1/0/-1 on the general idea of having module maintainers?
15:39:33 <Bruce_> +1
15:39:36 <cait> +1
15:39:37 <ColinC> +1
15:39:42 <Joubu> +1
15:39:42 <oleonard> +1
15:39:43 <jwagner> +1
15:39:51 <peggy> +1
15:39:58 <slef> 0
15:40:09 <thd> +1
15:40:59 <gmcharlt> OK, the final topic relating to project roles... when/how do we want to hold the formal elecctions?
15:41:19 * cait suggests a date next week - only topic elections?
15:41:24 <gmcharlt> I don't think today is really an option given (a) lack of notice and (b) the potential need for at least one more RMaint
15:41:40 <gmcharlt> cait: sounds reasonable to me
15:42:10 <Joubu> Maybe should we wait for Tomas?
15:42:19 <thd> However, we have in the  past filled seats for which there were candidates on the designated day.
15:43:12 <gmcharlt> do we know when tcohen will be back?
15:43:14 <cait> I am not sure when he returns - but I think we have voted for people not being present in the past. And the situation didn't change since he left
15:43:19 <cait> no other candidate
15:43:42 <cait> quite sure he told me, but I can't remember :(
15:43:43 <gmcharlt> right
15:43:50 <Bruce_> Does anyone expect another candidate to appear in the next week?
15:43:50 <ColinC> ls -al
15:44:07 <Joubu> he left for 3 weeks I think
15:44:08 <gmcharlt> I don't see that we have any contested elections; I think it's just a matter of formalizing the selection
15:46:09 <Joubu> It could be great to know how he defines a MM
15:47:12 <gmcharlt> agreed, he should weight in
15:47:15 <gmcharlt> *weigh in
15:47:18 <reiveune> bye
15:47:35 <gmcharlt> regardless, I think part of that can be deferred, as the MMs don't need to be in place right away
15:47:53 <gmcharlt> so to that idea, I propose that we hold an IRC meeting next Wednesday to vote
15:48:01 <gmcharlt> alternatively, we could just do an email thread
15:48:04 <gmcharlt> what do folks prefer?
15:49:21 <cait> I think i have a slight preference for irc - but that might just be me :)
15:49:37 <Bruce_> I'm hearing a great roar of indifference.
15:49:48 <gmcharlt> indeed
15:50:05 <slef> either is OK with me
15:50:18 <gmcharlt> actually, I have a thought on how to be more efficent
15:50:19 <druthb> http://gaspull.geeksaresexytech.netdna-cdn.com/wp-content/uploads/2014/01/Grey-Lantern.jpg
15:50:28 <gmcharlt> to wit: schedule the next dev meeting for Wednesday the 23rd
15:50:41 <gmcharlt> with the two-part schedule, and as a (small) agenda item, hold the vote then
15:50:55 <peggy> Sounds good
15:51:08 <Bruce_> +1
15:51:24 <cait> +1
15:51:36 <gmcharlt> +1
15:52:00 <gmcharlt> #agreed (pending confirmation) the next dev meeting will be scheduled for 23 April. Project roles for 3.18 will be voted on then.
15:52:21 <gmcharlt> moving on
15:52:27 <gmcharlt> #topic KohaCon 14 update
15:52:29 <thd> +1
15:52:52 <gmcharlt> which I think will be short since neither tcohen or bgkriegel are here
15:52:59 <gmcharlt> so
15:53:03 <gmcharlt> #topic KohaCon 15
15:53:20 <gmcharlt> it's probably time to start the site selection process
15:53:34 <gmcharlt> do we have a volunteer to kick it of?
15:53:37 <gmcharlt> *off
15:54:32 <thd> What does "kicking off" entail?
15:55:03 <gmcharlt> thd: at least initially, sending an email to the list soliciting bids, and managing the wiki pages related to site selection
15:56:44 <gmcharlt> OK - I'll ask again at the second part of the meeting
15:56:49 <thd> s done by next month, then I volunteer, but unfortunately I am severely overcommitted this month.
15:57:02 <gmcharlt> and bug people via email if no volunteer shows up (thd, we'll keep your offer in mind)
15:57:21 <gmcharlt> OK, we've set a date for the enxt developer meeting
15:57:22 <gmcharlt> so
15:57:34 <gmcharlt> #topic Set time and date of the next General IRC meeting
15:57:45 <thd> gremlins swallowed some of my words there.
15:57:54 <gmcharlt> how does 7 May soudn to folks?
15:58:40 <cait> ok for me
15:58:41 <thd> What hours?
15:58:54 <oleonard> Same two times?
15:59:02 <cait> ΓΌ1
15:59:04 <cait> +1
15:59:06 <peggy> +1
15:59:13 <Bruce_> -1
15:59:29 <gmcharlt> oleonard: indeed - I'm proposing 15:00 UTC and 21:00 UTC
15:59:41 <thd> +1
15:59:42 <oleonard> +1
15:59:54 <cait> Bruce_: just interested - you don't want the plit meetings are are both times inconvenient?
16:00:03 <gmcharlt> or is it the date?
16:00:08 <cait> :)
16:00:28 <Bruce_> Sorry, wrong fingers. Make that a 0.
16:00:47 <Bruce_> My calendar just books up more than a month ahead.
16:00:47 <slef> +1
16:01:46 <gmcharlt> #agreed (pending confirmation) the next general meeting will be on 7 May at 15:00 / 21:00 UTC
16:01:47 <thd> Bruce_: as a future guide there has been a preference for the first or early Wednesday in a month.
16:01:54 <gmcharlt> any last minute topics?
16:02:09 <Bruce_> I'll try to clear first Wednesdays then.
16:02:18 <Joubu> gmcharlt: yep
16:02:23 <gmcharlt> Joubu: go for it
16:02:26 <Joubu> does someone copied the 2 "AGREED" from last meeting?
16:02:40 <Joubu> the paste is not accessible anymore :-/
16:02:47 <Joubu> http://meetings.koha-community.org/2014/dev_meeting__12_march_2014__part_2.2014-03-12-21.25.html
16:02:50 <Joubu> 3d, 3e
16:03:10 <gmcharlt> Joubu: ah
16:03:15 <gmcharlt> I'll see if I can recover them
16:03:41 <Joubu> k thanks. Maybe should we put them on the wiki
16:03:46 <gmcharlt> agreed
16:04:45 <gmcharlt> thanks, everybody
16:04:48 <gmcharlt> #endmeeting