22:05:51 <tcohen> #startmeeting Koha Developer IRC meeting, 2 September 2014 - part 2
22:05:51 <huginn> Meeting started Tue Sep  2 22:05:51 2014 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:05:51 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:05:51 <huginn> The meeting name has been set to 'koha_developer_irc_meeting__2_september_2014___part_2'
22:06:33 <rangi> #info Chris Cormack, Catalyst IT
22:06:44 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
22:07:31 <tcohen> #info agenda is http://wiki.koha-community.org/wiki/Development_IRC_meeting,_2_September_2014
22:07:55 <tcohen> #topic RM 3.18 comments
22:08:23 <rangi> kinda on topic
22:08:23 <tcohen> As I said earlier, i've started pushing new features that are already on PQA queue
22:08:28 <tcohen> heh
22:08:30 <tcohen> yeah
22:08:31 <rangi> there are still 2 patches that need sign off
22:08:38 <rangi> 12655 12657
22:08:44 <rangi> for the prog/ccsr deprecation
22:08:57 <rangi> the rest are pushed on the MM_OPAC/theme_dep
22:09:08 <tcohen> i'll put them on my todo list for tomorrow, thanks rangi
22:10:02 <tcohen> ok, I also mentioned that i was working to win a bet
22:10:11 <rangi> i think after those two and a couple more days testing we should be ready to merge that
22:10:14 <rangi> cool
22:10:20 <tcohen> i mean, making facets get retrieved from zebra
22:10:25 <rangi> excellent
22:10:32 <tcohen> it is already functional
22:10:53 <tcohen> code can be checked here https://github.com/tomascohen/koha/tree/bug_11232_facets_from_zebra
22:11:10 <tcohen> i'm working on having unit tests for it
22:11:25 <rangi> sweet
22:11:26 <tcohen> not that difficult, just need time to sit and do it
22:11:46 <tcohen> and there's a regression regarding IncludeSeeFromInSearches
22:12:01 <tcohen> that has me writing awful stuff (i.e. xsl)
22:12:28 <tcohen> ok, that's it, moving on
22:12:46 <tcohen> #topic Cleanup Koha UTF-8
22:13:20 <tcohen> Joubu, dpavlin and zeno have been working on doing things right regarding encoding handling
22:13:38 <rangi> cool
22:13:47 <tcohen> they made CGI use -utf8, the templates to be set to UTF8, etc
22:13:59 <rangi> yep
22:14:14 <tcohen> #link http://wiki.koha-community.org/wiki/Handling_UTF8_in_development
22:14:25 <tcohen> they've set a wiki with what they've reached so far
22:14:29 <tcohen> and it is complete now
22:14:34 <rangi> excellent
22:14:49 <rangi> what id do
22:14:54 <rangi> and this might be a dumb idea
22:14:55 <tcohen> the only missing piece is having a good framework for catching regressions
22:15:30 <rangi> is branch master, push the utf8 stuff to master .. push the other branch up
22:15:42 <rangi> and apply patches to both branches from now on
22:16:11 <rangi> then if we get close to the release and realise the utf8 stuff cant go in .. you dont have to try to revert it all out, you just replace master with the other branch
22:16:37 <rangi> because unfortunately
22:16:48 <rangi> i dont believe developers will catch all the problems
22:17:12 <rangi> so i would be too scared to push it to master without a way to get it back out .. if that makes sense?
22:17:32 <tcohen> it makes sense, i'd let us go back
22:17:48 <tcohen> on part 1, we have set a deadline to have regression tests
22:17:54 <rangi> excellent
22:18:09 <tcohen> gmcharlt proposed an approach and I volunteered to help him
22:18:49 <rangi> sweet
22:18:50 <tcohen> so, until that deadline (19/09)
22:18:59 <tcohen> we might put your proposal on hold?
22:19:09 <rangi> yeah i wouldnt push it until after the tests
22:19:29 <tcohen> btw, any advise/help is welcome
22:19:49 <tcohen> ok, moving on?
22:19:53 <rangi> yep
22:20:03 <tcohen> #topic Additions to Coding Guidelines
22:20:15 <tcohen> do u have any coding guideline you'd like to add?
22:20:39 <rangi> hmmm not off the top of my head
22:21:05 <tcohen> ok, next
22:21:12 <tcohen> #topic Bugs
22:21:30 <tcohen> #info rangi mentioned bugs 12655 12657
22:22:22 <tcohen> #info they need to get tested so we finally push the CCSR/prog deprecation
22:22:50 <tcohen> ok, moving on
22:23:19 <tcohen> #topic "Big stuff we are working on"
22:23:39 <tcohen> you're working on ES, comments on that?
22:24:06 <rangi> thats pretty much all eythian now, and he just arrived
22:24:10 <rangi> so he might have some comments
22:24:19 <tcohen> ok
22:24:43 <eythian> hi
22:24:44 <wahanui> privet, eythian
22:25:09 <eythian> Yeah, ES is back working. Refactoring it to work with authorities at the moment
22:25:27 <eythian> i.e. allowing them to be indexed and searched.
22:25:47 <eythian> one of these days I'll put up a demo server for experimentation.
22:30:35 <tcohen> #info eythian will put a demo server for people to test ES
22:30:40 <tcohen> some day :-D
22:32:21 <tcohen> ok, next meeting is scheduled next week same day/time
22:32:24 <tcohen> agreed?
22:32:30 <tcohen> we ahve a big agenda
22:33:09 <rangi> yep, sounds good
22:34:38 <tcohen> end meeting then
22:34:53 <tcohen> #agreed next meeting is scheduled for next weke
22:34:59 <tcohen> #endmeeting