#koha: Koha Developer IRC meeting, 9 September 2014 - part 1

Meeting started by tcohen at 15:07:58 UTC (full logs).

Meeting summary

  1. Introductions (tcohen, 15:08:11)
    1. wahanui, a bot that has become sentient (wahanui, 15:08:12)
    2. Owen Leonard, Athens County Public Libraries (oleonard, 15:08:19)
    3. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 15:08:44)
    4. Claire Hernandez, developments manager at BibLibre (clrh, 15:08:47)
    5. Thomas Dukleth, Agogme, New York City (thd, 15:08:48)
    6. Jonathan Druart, BibLibre (Joubu, 15:09:22)

  2. RM 3.18 comments (tcohen, 15:10:14)
    1. facet retrieval from Zebra is complete, feedback is needed (tcohen, 15:10:46)
    2. Zeno Tajoli, Cineca (Italy)รน (ztajoli, 15:11:16)
    3. Kyle M Hall, ByWater Solutions (khall, 15:12:14)
    4. Martin Renvoize, PTFS Europe (ashimema, 15:12:28)
    5. facets from zebra is needs sign off, bug 11232 (tcohen, 15:12:29)
    6. Nicole Engard, ByWater Solutions (nengard, 15:13:23)
    7. https://github.com/tomascohen/koha/commit/5b0b36895bad75052e8a0e362e561a8631f103f2 (tcohen, 15:13:38)
    8. Barton Chittenden, ByWater Solutions, Louisville, KY, USA (barton, 15:15:56)
    9. Alex Sassmannshausen, PTFS Europe, UK (atheia, 15:16:08)

  3. General technical discussion (tcohen, 15:17:21)
    1. Brendan Gallagher ByWater (bag, 15:29:42)
    2. we are voting the inclusion of TestBuilder next meeting (tcohen, 15:49:07)
    3. GST rewrite http://wiki.koha-community.org/wiki/GST_Rewrite_RFC (tcohen, 15:56:27)
    4. feedback is needed urgently (tcohen, 15:56:57)
    5. Jonathan needs feedback on bugs 12830 and 12896. Specifically his approach to Class::Accessor and DBIc (tcohen, 16:04:58)

  4. Additions to Coding Guidelines (tcohen, 16:06:36)
    1. https://trello.com/c/8d7pELLj/28-coding-guidelines-koha-preference (Joubu, 16:07:21)
    2. AGREED: (subject to votes from part 2) https://trello.com/c/8d7pELLj/28-coding-guidelines-koha-preference will be added to Coding guidelines (tcohen, 16:11:46)
    3. ACTION: Kyle will start a discussion on the koha-dev list on taking advantage of DBIc in our code base. We will discuss where to use DBIc, and how to properly test our ResultSet classes (tcohen, 16:26:21)

  5. Naming of database columns (ashimema, 16:29:49)
    1. column_names made up of multiple words should be joined with underscore to maintain dbic standards (ashimema, 16:32:53)
    2. AGREED: To add a rule to the coding guidelines that mimicks that of the dbic conventions for column_names pending this evening meeting (ashimema, 16:37:06)
    3. exact wording of guidline to be decided (after looking up dbic specifics) (ashimema, 16:37:52)

  6. Requirements for CLI scripts (ashimema, 16:39:22)
    1. AGREED: To add requirement for new CLI scripts to guidlines (ashimema, 17:00:51)
    2. Pod::Usage, GetOpt::Long, pod2usage, POD at end of file and --confirm (where lack of display help test) (ashimema, 17:01:40)

  7. Wording of bug 10860 (ashimema, 17:04:02)
    1. Agreed that 'on-site' was a better wording than 'in-house' (ashimema, 17:10:01)

  8. Big Stuff we're working on?! (ashimema, 17:11:01)
    1. hea.koha-community.org is coming :) (ashimema, 17:12:01)
    2. account rewrite is getting there.. wohoo (ashimema, 17:12:51)
    3. hea is bug 11926 (ashimema, 17:13:58)
    4. bug 11944 is working it's way through QA (ashimema, 17:17:02)

  9. Actions from last meeting (ashimema, 17:17:56)
    1. ashimema added a note to the wiki to encourage use of columns stuff for datatables (ashimema, 17:18:25)
    2. ashimema has started qa for UTF8 bug.. minimal comments left already (ashimema, 17:18:58)
    3. Waiting to hear from gmcharlt, tcohen regarding utf8 tests (ashimema, 17:19:33)

  10. Next Meeting? (ashimema, 17:20:40)
    1. AGREED: Same time next week.. assuming that's ok with the guys this evening (ashimema, 17:22:09)
    2. AGREED: meeting needs to be kept shorter (ashimema, 17:22:19)
    3. more chat on the trello board before the meeting.. try to limit the meeting to agreements and assignments of work. (ashimema, 17:23:18)


Meeting ended at 17:23:39 UTC (full logs).

Action items

  1. Kyle will start a discussion on the koha-dev list on taking advantage of DBIc in our code base. We will discuss where to use DBIc, and how to properly test our ResultSet classes


People present (lines said)

  1. ashimema (161)
  2. tcohen (108)
  3. Joubu (106)
  4. khall (59)
  5. thd (47)
  6. atheia (33)
  7. ztajoli (20)
  8. barton (14)
  9. huginn (13)
  10. oleonard (9)
  11. wahanui (7)
  12. jcamins (5)
  13. clrh (4)
  14. bag (3)
  15. nengard (3)
  16. indradg (2)
  17. pastebot (1)


Generated by MeetBot 0.1.4.