15:02:01 <gmcharlt> #startmeeting Koha Development Meeting, 21 May 2014, part 1
15:02:01 <huginn> Meeting started Wed May 21 15:02:01 2014 UTC.  The chair is gmcharlt. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:01 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:01 <huginn> The meeting name has been set to 'koha_development_meeting__21_may_2014__part_1'
15:02:15 <gmcharlt> #info Agenda is http://wiki.koha-community.org/wiki/Development_IRC_meeting,_21_May_2014
15:02:20 <gmcharlt> #topic Introductions
15:02:22 <wahanui> #info wahanui, a bot that has become sentient
15:02:23 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
15:02:27 <oleonard> #info Owen Leonard, Athens County Public Libraries
15:02:33 <gmcharlt> #info Galen Charlton, 3.16 RM
15:03:10 <phasefx> #info Jason Etheridge, Equinox
15:04:00 <thd> #info Thomas Dukleth, Agogme, New York City
15:04:20 <ashimema> #info Martin Renvoize, PTFS Europe
15:04:21 <bgkriegel> #info Bernardo Gonzalez Kriegel, Córdoba Argentina
15:05:11 <wosch> #info Wolfram Schneider, IndexData
15:05:13 <ztajoli> hi
15:05:14 <wahanui> hola, ztajoli
15:05:55 <gmcharlt> ok, let's get started
15:06:00 <gmcharlt> #topic Announcements
15:06:07 <gmcharlt> #info Koha 3.16.0 will be released tomorrow
15:06:17 <tcohen> gmcharlt++
15:06:19 * oleonard cheers
15:06:30 <gmcharlt> #info Galen will continue to push patches to master through Sunday; tcohen will take over the master branch on Monday
15:06:55 <gmcharlt> any other quick announcements?
15:07:14 <ashimema> gmcharlt++
15:07:23 <gmcharlt> oh, one more
15:07:23 <wahanui> i think one more is better than one less but yeah they should be the same
15:07:31 <gmcharlt> #info 3.16.x will be branched tomorrow
15:07:48 <gmcharlt> ok,  moving
15:07:53 <gmcharlt> #topic RM 3.18 comments
15:07:57 <gmcharlt> tcohen: you have the floor
15:08:08 <tcohen> hi every1
15:08:23 <tcohen> i wanted to say a few words on how i expect to do my RM work
15:09:02 <tcohen> I'd like to set a dashboard of the current "big" developments you are all involved in, or at least worried about
15:09:23 <tcohen> and I'll commit to find all the bottlenecks so everything goes as smooth as we can
15:09:52 <tcohen> I'll set (for now) a Trello board for that, and I expect to get some feedback from MMs
15:10:17 <tcohen> I also hope we can make dev meetings from frecquently
15:10:43 <tcohen> not as we need them, but something like twice a month
15:10:52 <tcohen> to catch up with everyone's works
15:11:19 <tcohen> I want all of you know I'm open to comments on all this
15:12:49 <ashimema> so far so good tcohen.. sounds promising.
15:12:51 <gmcharlt> tcohen: sounds good to me
15:12:53 <tcohen> that's it, I'll take notes of the "big things" you are all working on
15:13:19 <tcohen> (sorry, my boss came to my desk with a chatty attitude
15:14:04 <ztajoli> Well, as CINECA, we will try test/sign-off as much as possible on UFT-8 ( bug 11944)
15:14:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, gmcharlt, Needs Signoff , Cleanup Koha UTF-8
15:14:33 <ztajoli> And on ACQ
15:15:10 <thd> tcohen: Ensure that the subject of discussion for development meetings motivate widespread interest and you should have sufficient participation.
15:15:33 <tcohen> thanks thd
15:15:35 <ztajoli> We also probably send an RFC on ACQ, but also test/sign-off of others patch
15:15:52 <gmcharlt> I agree with thd ... I suggest making sure that the agenda for the dev meetings doesn't get too rote if you run them as frequently as twice a month
15:15:55 <ashimema> I like gmcharlt's two stage meetings to catch timezones.. do you intend on following suit tcohen?
15:15:58 <reiveune> bye
15:16:10 <tcohen> ashimema: yes
15:16:17 <ashimema> :)
15:16:42 <gmcharlt> one suggestion is (as often as possible) getting somebody to do a 10-15 minute presentation on some aspect of Koha development each emeeting
15:16:58 <ashimema> agree with the two above.. keep the agenda's tight, especially as they're going to be more frequent
15:17:01 <gmcharlt> (and I volunteer to do that at least a couple times)
15:17:20 <tcohen> my ultimate goal is that we share our problems with implementing stuff
15:17:35 <ashimema> sounds good to me.. also happy to volunteer from here (wether that be me, or me getting Colin to step up ;) )
15:17:46 <tcohen> and that if (for example) we need to agree on an API definition so people can start coding, we can do it on the meeting
15:18:01 <gmcharlt> ashimema: there is a fine tradition of volun-telling folks who don't bother to attend the meeting ;)
15:20:37 <ashimema> ;)
15:20:53 <gmcharlt> tcohen: anything more you want to say?
15:20:54 <wosch> Hi, I'm wondering what the status of the Koha plugin system is in 3.16. Can I run plugins on the opac site, and not only on the staff site?
15:20:59 <ashimema> Colin's working on EDI at the minute.. so I didn't fancy reminding him about the meeting ;)
15:21:02 <tcohen> ok, lets move to the tasty part
15:22:26 <gmcharlt> wosch: Koha's plugins currently support only staff-side functionality, in particular new items under the Tools and Reprts page
15:22:39 <gmcharlt> #topic Additions to Coding Guidelines
15:23:06 <gmcharlt> #info There is a proposal  by cait to deprecate C4::SQLHelper now that DBIx::Class is available
15:23:11 <gmcharlt> #info more info on bug 11385
15:23:12 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11385 enhancement, P5 - low, ---, gmcharlt, NEW , C4::SQLHelper should be removed
15:23:34 <ashimema> cait++
15:24:01 <gmcharlt> deprecation is easy enough in the sense of "no new code that uses SQLHelper"
15:24:19 <gmcharlt> I may poke at 11385 during the 3.18 cycle to work towards replacing it
15:24:30 <ztajoli> for me ++
15:24:35 <wosch> gmcharlt: thanks for the clarification!
15:25:04 <tcohen> I'd adopt this coding guideline
15:25:23 <gmcharlt> +1 as well
15:25:36 <tcohen> and I hope the QA team agrees to enforce it for submissions
15:26:00 <thd> gmcharlt +1 for bringing all code to conform to current guidelines.
15:29:43 <gmcharlt> #agreed (pending confirmation) the coding guidelines will be revised to deprecate C4::SQLHelper
15:29:54 <gmcharlt> #topic How can we get "Bug 11944 - Cleanup Koha UTF-8" into Koha?
15:29:55 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, gmcharlt, Needs Signoff , Cleanup Koha UTF-8
15:30:41 <tcohen> Joubu?
15:30:42 <wahanui> Joubu is, like, not his irc name
15:30:55 <gmcharlt> regarding magnuse's suggestion, though I am NOT old ;), I will volunteer to review the code and approach during the next few weeks
15:31:15 <gmcharlt> I also suggest the following - that a special sandbox be set up running the code
15:31:30 <gmcharlt> and I also suggest adopting magnuse's proposal of a GBSD solely for this bug
15:31:41 <ztajoli> we do the best to test it (Paola Rossi)
15:32:46 <jwagner> #info Jane Wagner, LibLime/PTFS
15:32:50 <jwagner> apologies for being late
15:33:29 <gmcharlt> actually, cait's proposal of a dedicated GBSD
15:33:34 <tcohen> I think we need to have unit tests for encoding issues
15:33:43 <gmcharlt> agreed
15:33:56 <thd> Are there a unified set of patches for the bug which must all stand or fall together?
15:34:37 <gmcharlt> thd: many of the patches look like they need to stand together, but it also lokos like there are a few that could be split off and applied separately
15:34:51 <gmcharlt> so yeah, splitting those out would be good
15:35:46 <thd> Are there any current issues from which affect the character encoding storage or editing of bibliographic or authority records?
15:36:14 <tcohen> as far as I can tell, we have only ackknowledged visualization issues
15:36:19 <ztajoli> and no others entry of bugzilla blocks it
15:36:50 <ztajoli> The problem is on display/visualization, not store in DB o Zebra
15:37:39 <gmcharlt> ztajoli: though speaking of storage, you may find this to be of interest: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11811#c13
15:37:40 <huginn> 04Bug 11811: major, P1 - high, ---, dpavlin, In Discussion , tools/import_borrowers.pl doesn't support utf-8 encoded CSV
15:37:41 <thd> tchohen: There are past reports for the bug of problems with passwords and some other peripheral data storage issues.
15:37:46 <ztajoli> For authority records, unimarc eng default setup gives problem
15:38:37 <ztajoli> probably we need only to transfer french unimarc setup into eng
15:38:54 <gmcharlt> out of curiosity... who actively uses the English UNIMARC setup?
15:39:26 <thd> ztajoli: Does UNIMARC English setting affect the character encoding stored in the database?
15:39:45 <ztajoli> And there the problems with pdf generation, label templating
15:40:16 <ztajoli> Storing in database no
15:40:31 <ztajoli> for unimarc default setup
15:40:44 <ztajoli> but impossibile to use, so to input data
15:41:16 <gmcharlt> have we come to any conclusion regarding the proposals?
15:41:27 <ztajoli> Probably no one use  English UNIMARC authority setup.
15:42:07 <ztajoli> But it is the default, so it used to test from Paola Rossi. So we find problems
15:42:12 <thd> tcohen: Do you have a simple test for automatically determining when character encoding is displaying incorrectly?
15:42:13 <tcohen> Who are actively working on this?
15:43:19 <ztajoli> For test we use to insert Japanese kana and greek letters. No authomatic tests
15:43:22 <gmcharlt> unless somebody has any objections, I'm willing to volunteer to review the effort and to schedule a GBSD for it
15:43:31 <gmcharlt> (and to see about writing tests)
15:43:49 <tcohen> thd: the main issues IMHO are not explicitly decoding/encoding stuff as needed, or setting the proper config for the IO layer
15:44:31 <tcohen> there are places we can check for properly formed UTF-8 strings
15:44:44 <tcohen> gmcharlt: +1
15:45:25 <gmcharlt> #action gmcharlt will review the work for bug 11944 and organize a testing environment and a GBSD for some time in June
15:45:26 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11944 major, P5 - low, ---, gmcharlt, Needs Signoff , Cleanup Koha UTF-8
15:45:35 <gmcharlt> #topic Big stuff we are working on
15:46:15 <tcohen> gmcharlt: before that, who are working on 11944?
15:46:53 <gmcharlt> tcohen: I've said what I'm planning to do; at at this point, I think others need to step up to test as well
15:47:04 <tcohen> ok
15:47:38 <thd> tcohen: I should have some time to work on it in July.
15:49:01 <gmcharlt> any big projects to announce?
15:50:23 <ashimema> back again.. sorry got called away.
15:50:30 <tcohen> what is the status of ElasticSearch integration?
15:50:49 <gmcharlt> there's an effort underway for funding to work on it more
15:50:57 <gmcharlt> as I understand it, it's nealry 100% funded
15:51:12 <gmcharlt> so I'd expect updates from Catalyst at some point
15:51:15 <ashimema> eythian has been on alot of mornings (uk mornings that is) this week
15:51:25 <tcohen> maybe on part 2
15:51:26 <ashimema> he's been making inroads into it.
15:51:26 <ztajoli> The main developer of 11944 is Jonathan Druart
15:51:59 <ashimema> he's probably best explaining state of affairs.. but I know he's looking for people to start testing now.
15:53:14 <gmcharlt> ok
15:53:23 <tcohen> we will all review what's been done
15:53:24 <gmcharlt> #topic Actions from previous dev meeting
15:53:30 <gmcharlt> #info there were no action items ;)
15:53:31 <tcohen> to make sure nothing breaks badly
15:53:36 <gmcharlt> #topic Set time of next meeting
15:53:46 <gmcharlt> tcohen: thoughts?
15:53:56 <tcohen> talking about UTF-8 cleanup
15:54:08 <tcohen> will we have those sandboxes set?
15:54:14 <gmcharlt> no, I mean about tsetting a date for the next meeting
15:54:33 <tcohen> June 4?
15:55:02 <gmcharlt> tcohen: there's a general meeting scheduled that day IIRC
15:55:15 <gmcharlt> yes
15:55:19 * tcohen is searching at the wiki
15:55:26 <ashimema> dug out ES progress git: http://git.catalyst.net.nz/gw?p=koha.git;a=shortlog;h=refs/heads/elastic_search
15:55:49 <tcohen> ok, next week then
15:56:06 <tcohen> June 11
15:56:21 <gmcharlt> +1
15:56:22 <thd> +1
15:56:25 <ashimema> +1
15:56:35 <ztajoli> +1
15:57:09 <gmcharlt> same times?
15:57:23 <tcohen> yes
15:57:48 <ztajoli> yes
15:57:55 <gmcharlt> #agreed (pending confirmation) the next development meeting will be on 11 June at 15 and 22 UTC
15:58:06 <gmcharlt> thanks, everybody
15:58:09 <gmcharlt> #endmeeting