#koha: Koha IRC Developer meeting, July 23rd, part 1

Meeting started by cait at 15:00:27 UTC (full logs).

Meeting summary

  1. Introductions (cait, 15:00:34)
    1. wahanui, a bot that has become sentient (wahanui, 15:00:34)
    2. Owen Leonard, Athens County Public Libraries (oleonard, 15:01:00)
    3. Katrin Fischer, BSZ, Germany (cait, 15:01:02)
    4. Zeno Tajoli, CINECA (Italy) (ztajoli, 15:01:03)
    5. Brendan Gallagher, ByWater (bag, 15:01:12)
    6. Kyle Hall, ByWater (khall, 15:01:15)
    7. Colin Campbell ptfs-europe (UK) (ColinC, 15:01:16)
    8. Barton Chittenden, ByWater (barton, 15:01:25)
    9. Jonathan Druart, BibLibre (Joubu, 15:01:26)
    10. Jane Wagner, LibLime/PTFS (jwagner, 15:01:33)
    11. Galen Charlton, ESI (gmcharlt, 15:02:29)
    12. http://wiki.koha-community.org/wiki/Development_IRC_meeting,_23_July_2014 (cait, 15:03:04)

  2. RM 3.18 comments (cait, 15:03:37)
    1. Make tests pass for UNIMARC - needed: help with mappings and test records (cait, 15:05:21)
    2. Work on bug 11586 could help (cait, 15:05:46)

  3. Additions to Coding Guidelines (cait, 15:06:29)
    1. Greg Lawson (rhcl, 15:11:00)
    2. removing GRS-1 indexing in favor of DOM, first steps: coding guideline, omnibus bug for tracking what needs to be done (remaining issues, needed changes, etc.) (cait, 15:11:49)
    3. AGREED: move towards removing of GRS-1 in favor of DOM (cait, 15:12:44)
    4. Dobrica Pavlinusic, FFZG (dpavlin, 15:17:06)
    5. proposed wording for new coding guideline: http://paste.lisp.org/display/143215 (cait, 15:19:07)
    6. AGREED: coding guideline about deprecating GRS-1 in favor of DOM, wording suggested by gmcharlt (cait, 15:20:00)
    7. Jacek Ablewicz, Cracow Univ. of Technology (abl, 15:21:10)
    8. coding guideline about indentation i perl scripts http://wiki.koha-community.org/wiki/Coding_Guidelines#PERL6:_Indentation (cait, 15:24:50)
    9. http://splitter.koha-community.org/ (gmcharlt, 15:35:40)
    10. 6ocS88DLK6u7vtw9 (cait, 15:36:07)
    11. http://splitter.koha-community.org/ (cait, 15:36:29)
    12. IDEA: automated tidy at begin/end of release cycle (cait, 15:40:20)
    13. IDEA: don't spend time on it :) (cait, 15:40:27)
    14. IDEA: nightly tidy (cait, 15:40:41)
    15. IDEA: no periodic tidying at all (cait, 15:41:10)

  4. DBIC (cait, 15:43:39)
    1. MJ Ray, software.coop, England (slef, 15:43:51)

  5. Bugs (cait, 15:47:24)
    1. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12608 (khall, 15:47:25)
    2. Yohann is working on replacing SQLHelper with DBIC and simplifying unit test writing (cait, 15:56:03)
    3. Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12603 (cait, 15:56:13)

  6. New status/field for bugzilla - abandoned/for adoption (cait, 16:02:25)
    1. AGREED: encourage use of the assigned field - no assignee = open for adoption (cait, 16:07:12)
    2. IDEA: automate 'unassigning' in some way, batch change, warning email or similar (cait, 16:07:49)

  7. Big stuff we are working on (cait, 16:07:59)
    1. spec for GST/tax rewrite in acq: http://wiki.koha-community.org/wiki/GST_Rewrite_RFC (cait, 16:09:03)
    2. Please add comments before end of August! (cait, 16:09:12)
    3. Please test TestBuilder patches/give feedback on them first - bit higher prio then SQLHelper for now (cait, 16:15:04)
    4. ACTION: from last meeting (cait, 16:16:26)
    5. ACTION: khall volunteers to work on rss.pl (cait, 16:20:37)
    6. khall also needs feedback on bug 12632 (cait, 16:20:53)

  8. Set time of next meeting (cait, 16:22:13)
    1. AGREED: Next meeting will be (pending agreement from part 2) August, 5th, 15:00 + 22:00 UTC (cait, 16:25:57)


Meeting ended at 16:26:16 UTC (full logs).

Action items

  1. from last meeting
  2. khall volunteers to work on rss.pl


Action items, by person

  1. khall
    1. khall volunteers to work on rss.pl


People present (lines said)

  1. cait (189)
  2. Joubu (58)
  3. khall (55)
  4. gmcharlt (36)
  5. ashimema (17)
  6. oleonard (16)
  7. ColinC (15)
  8. barton (13)
  9. huginn (12)
  10. ztajoli (11)
  11. fridolin (9)
  12. wahanui (7)
  13. dpavlin (4)
  14. tubaclarinet (3)
  15. phasefx2 (1)
  16. bag (1)
  17. abl (1)
  18. jcamins (1)
  19. rhcl (1)
  20. slef (1)
  21. jwagner (1)


Generated by MeetBot 0.1.4.