#koha: Development IRC meeting 26 August 2015 - part 1

Meeting started by tcohen at 14:14:18 UTC (full logs).

Meeting summary

  1. Introductions (tcohen, 14:14:25)
    1. wahanui, a bot that has become sentient (wahanui, 14:14:25)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 14:14:42)
    3. Jonathan Druart, UK (Joubu, 14:14:46)
    4. Marcel (marcelr, 14:14:57)
    5. Julian Maurice, BibLibre (jajm, 14:14:58)
    6. Nicole Engard, ByWater Solutions (nengard, 14:15:16)
    7. Zeno Tajoli, Cineca, Italy (tajoli, 14:16:42)
    8. mirko tietgen, berlin, germany (drojf, 14:16:49)
    9. Kyle M Hall, ByWater Solutions (khall_dnd, 14:18:51)

  2. RM 3.22 comments (tcohen, 14:19:20)
    1. some important sutff has been pushed recently, notably plack integration for packages and the sitemap building tool contributed by Tamil (tcohen, 14:20:24)
    2. I hope all of you have the chance to take a look to the plack integrating scripts, so we have them tuned for the release (tcohen, 14:21:05)
    3. ACTION: the RM will send a pull request for kohadevbox to be adapted to this new scripts (tcohen, 14:21:55)
    4. Koha::Logger has been pushed too, and it is expected that new devs use it, while we don't enforce such things. (tcohen, 14:23:18)
    5. ACTION: Kyle will write a proposal for adding the use of Koha::Logger to the coding guidelines (tcohen, 14:27:34)

  3. RESTful API Implementation (tcohen, 14:36:17)
    1. http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=41958 (tcohen, 14:54:12)
    2. https://github.com/tomascohen/koha/commit/812a53f41681dc01833915240079d259f24d4694 (tcohen, 15:28:57)
    3. ACTION: Julian/Biblibre will refactor his REST API implementation so it does session cookie authentication, and API-key mechanism implementation/discussion will be dealt with on a separate bug (tcohen, 16:09:18)
    4. ACTION: Tomas will help if needed on integrating it to the packages and kohadevbox so testing it is easier for anyone (tcohen, 16:10:03)
    5. ACTION: Jonathan will bring the belgian beer we all miss (tcohen, 16:10:22)
    6. ACTION: Tomas will ask Olli when he can be available to attend a dev meeting to discuss his Auth rewrite (tcohen, 16:11:46)
    7. ACTION: Kyle and pianohacker will be looking into this rewrite of the REST api to base their AJAX circulation work on it (tcohen, 16:13:50)

  4. 'Big stuff we are working on' (tcohen, 16:16:05)
    1. Kyle has been working on a document delivery / article request feature (tcohen, 16:17:21)
    2. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14610 (tcohen, 16:18:56)
    3. Tomas is starting to work on some better abstraction using Koha::MetadataRecord for easier handling of different serialization formats and better code modularity (i.e. rewriting C4::Search, specially the code that deals with filtering record data) (tcohen, 16:28:30)
    4. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14645 (tcohen, 16:28:41)
    5. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14639 (tcohen, 16:28:48)

  5. GBSD - Reminder, things that need to be done (tcohen, 16:29:10)
    1. Remember we have a Global Bug Squashing Day (GBSD) planned for September 3 2015 (tcohen, 16:30:01)
    2. if you have something you think might be interesting for that day, please check here http://wiki.koha-community.org/wiki/2015-09-03_Global_bug_squashing_day (tcohen, 16:30:42)

  6. Set time of next meeting (tcohen, 16:31:17)
    1. ACTION: Tomas will post on koha-devel with a proposal for the next meeting (tcohen, 16:31:33)


Meeting ended at 16:32:13 UTC (full logs).

Action items

  1. the RM will send a pull request for kohadevbox to be adapted to this new scripts
  2. Kyle will write a proposal for adding the use of Koha::Logger to the coding guidelines
  3. Julian/Biblibre will refactor his REST API implementation so it does session cookie authentication, and API-key mechanism implementation/discussion will be dealt with on a separate bug
  4. Tomas will help if needed on integrating it to the packages and kohadevbox so testing it is easier for anyone
  5. Jonathan will bring the belgian beer we all miss
  6. Tomas will ask Olli when he can be available to attend a dev meeting to discuss his Auth rewrite
  7. Kyle and pianohacker will be looking into this rewrite of the REST api to base their AJAX circulation work on it
  8. Tomas will post on koha-devel with a proposal for the next meeting


People present (lines said)

  1. tcohen (184)
  2. ashimema (75)
  3. Joubu (38)
  4. khall (32)
  5. jajm (28)
  6. huginn (17)
  7. tajoli (10)
  8. marcelr (7)
  9. wahanui (4)
  10. t4nk493 (3)
  11. bag (3)
  12. fridolin (2)
  13. drojf (2)
  14. khall_dnd (1)
  15. grharry (1)
  16. nengard (1)


Generated by MeetBot 0.1.4.