21:34:19 <pianohacker> #startmeeting Development IRC meeting 26 August 2015 - part 2
21:34:19 <huginn> Meeting started Wed Aug 26 21:34:19 2015 UTC. The chair is pianohacker. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:34:19 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:34:19 <huginn> The meeting name has been set to 'development_irc_meeting_26_august_2015___part_2'
21:34:41 <pianohacker> #topic Introductions
21:34:41 <wahanui> #info wahanui, a bot that has become sentient
21:34:51 <pianohacker> Please introduce yourself with #info
21:35:17 <pianohacker> #info Jesse Weaver, ByWater Solutions
21:35:35 <barton> #info barton, bws, Louisville Ky, USA
21:35:43 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
21:36:50 <pianohacker> will leave introductions open until :40
21:36:57 <tcohen> great
21:37:00 <tcohen> eythian?
21:37:00 <wahanui> go back to bed, eythian
21:37:11 <tcohen> it must be beer o'clock
21:38:22 <wizzyrea> #info Liz Rea, Catalyst IT
21:38:28 <barton> tcohen: it's always beer o'clock for wahanui.
21:39:27 <pianohacker> cait or cdickinson?
21:40:08 <cait> not really here
21:40:10 <pianohacker> kk
21:40:15 <cait> sorry
21:40:20 <pianohacker> no worries
21:41:01 <pianohacker> moving on
21:41:08 <bag> #info brendan gallagher bywater
21:41:27 <pianohacker> #topic Summary from part 1
21:41:41 <pianohacker> #link http://meetings.koha-community.org/2015/development_irc_meeting_26_august_2015___part_1.2015-08-26-14.14.html
21:42:17 <pianohacker> Things of note:
21:42:28 <pianohacker> Plack integration in 3.22
21:42:45 <pianohacker> Possibility of adding Koha::Logger to coding guidelines
21:43:22 <pianohacker> Work on REST API to simplify auth and integrate into packages
21:43:54 <pianohacker> anything else I should mention?
21:44:32 <tcohen> i asked everyone to test the plack integration for the packages
21:44:55 <tcohen> and promised to send a pull request for kohadevbox so it makes use of the new scripts and we can test this
21:45:10 <pianohacker> excellent
21:45:15 <bag> yes
21:45:21 <wizzyrea> yep, good stuff
21:46:02 <tcohen> that's it from me
21:46:13 <pianohacker> tcohen: would you like to add any RM comments?
21:46:42 <tcohen> i forgot to mention that using plack the way I proposed poses some challenges while trying to solve another ones :-D
21:46:54 <wizzyrea> such as?
21:47:03 <pianohacker> #topic RM 3.22 comments
21:47:23 <tcohen> as i said yesterday here, the apache docs lie about what is supported in which version
21:47:56 <tcohen> so running this as-is requires backporting apache from 14.10 on ubuntu 14.04, and enabling the backports component of Debian 7
21:48:10 <wizzyrea> Ah
21:48:18 <tcohen> for ubuntu there is a ppa doing it, and for debian it just works adding wheezy-backports
21:48:39 <tcohen> we have enough time to test this, and fix it however we find more siutable
21:48:42 <pianohacker> is there no other way to connect to plack? running it directly with mod-fcgid, for instance?
21:49:19 <tcohen> the current approach relied on finding free TCP socket ports for running each plack process
21:49:38 <pianohacker> #info Current proposed method for integrating Plack into packages requires a version of Apache only present in Ubuntu 14.10 and wheezy-backports
21:49:44 <tcohen> i shortcircuited that issue, by using Unix Domain sockets instead, taking advantage of apache 2.4's capabilities
21:50:06 <tcohen> pianohacker: i would add that Debian 8 works out of the box
21:50:11 <tcohen> so it sounds less bad :-D
21:50:20 <pianohacker> that's Jessie, right?
21:50:29 <tcohen> rigt
21:50:43 <tcohen> i'll talk about this on the list
21:50:54 <pianohacker> #info addition to above: also included in Debian 8 (Jessie)
21:51:03 <wizzyrea> these things sound fixable
21:51:06 <pianohacker> yup
21:51:10 <wizzyrea> or roundaboutable
21:51:18 * wizzyrea is not sure that's a word
21:51:27 <pianohacker> round abou table?
21:51:30 <pianohacker> :)
21:51:49 <tcohen> wizzyrea: if you don't have the right apache version, it just doesn't use plack, no breakage
21:51:54 <tcohen> (at least :-D)
21:52:22 <tcohen> i have to add (rangi reminded me) that this approach is also suitable for using with nginx
21:52:22 <wizzyrea> yep, that's what I was picking up, thanks :)
21:52:33 <tcohen> which is yet another integration challenge
21:52:51 <tcohen> anyway, lets move on :-D
21:52:59 <wizzyrea> zoom.
21:53:02 <pianohacker> And that's not really a blocker, IMO; you only get easy plack integration if you have the latest distro version or do a tiny bit of extra work
21:53:15 <pianohacker> tcohen: no other comments?
21:53:54 <wizzyrea> and we'll be moving towards better support, not away, over time.
21:53:59 <tcohen> nope, and that's pretty much all my participation, gotta pick manuel
21:54:00 <tcohen> bye!
21:54:01 <pianohacker> #topic RESTful API Implementation
21:54:05 <pianohacker> bye tcohen
21:54:09 <wizzyrea> bye
21:54:14 <pianohacker> wizzyrea: agreed
21:55:00 <pianohacker> Two main bugs:
21:55:15 <pianohacker> http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13799
21:55:16 <huginn> 04Bug 13799: new feature, P5 - low, ---, julian.maurice, Needs Signoff , Add base for building RESTful API
21:55:17 <pianohacker> and
21:55:27 <pianohacker> http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13920
21:55:27 <huginn> 04Bug 13920: new feature, P5 - low, ---, julian.maurice, RESOLVED DUPLICATE, API authentication system - proposal
21:56:06 <wizzyrea> regarding this api - rangi asked me to convey the following (he's away from his desk) : I much prefer a lighter approach like Koha::Service that pianohacker has been doing, or the svc/ system However if there is a way to do it without needing an Auth rewrite and a new daemon running, I could live with it.
21:56:47 <wizzyrea> so I think he's not totally on board with the current approach
21:56:49 <pianohacker> as far as moving that proposal forward, the strategy from the earlier meeting was to simplify the authentication system so that it could move forward without a rewrite for now
21:57:04 <pianohacker> wizzyrea: agreed, and I think there are a lot of reservations about its complexity
21:57:37 <pianohacker> one big question I have is whether this is at least testable without requiring a separate server for mojo
21:58:08 <cait> I am all for simplifying - the harder we make it, the slower we will move forward - becuase people are too scared to test, try, activate...
21:58:23 <bag> I think this mornings things adressed those wizzyrea - simple auth - no rewrite and tcohen said he’d help with the techinical integration
21:58:52 <pianohacker> I'd like to propose that we add a CGI script based on http://search.cpan.org/~mramberg/Mojolicious-4.60/lib/Mojo/Server/CGI.pm
21:58:57 <pianohacker> at /api
21:58:58 <bag> a challenge on the daemon part - but I think everyone felt like it could be possible
21:58:59 <cait> simple auth sounds good - but i still have no idea how to set it up
21:59:09 <cait> basically pianohacker's question probably
21:59:24 <pianohacker> It would be hidden by an apache rewrite if the daemon is set up, but would work (if slowly) otherwise
21:59:27 <pianohacker> thoughts?
21:59:57 <cait> pianohacker: can you explain a bit more?
22:00:07 <cait> it sounds good, but not sure i understand :)
22:00:10 <wizzyrea> ^
22:00:39 <pianohacker> my idea is that we create a CGI script literally called api (without a .pl, like the scripts in svc)
22:00:57 <pianohacker> that launches the API using Mojo::Server::CGI
22:01:22 <pianohacker> it would have to set up everything on every single request, but would allow far easier testing
22:01:44 <pianohacker> (this is all on the assumption that the paths for the api are under /api/ ; is that true?)
22:03:12 <cait> pianohacker: easier testing sounds good - what would you not need to set up in that case?
22:03:37 <pianohacker> the mojo daemon or the apache reconfiguration
22:04:04 <wizzyrea> ah yeah it would fire one up for each request, and not be daemonised I think I understand.
22:04:08 <pianohacker> ^
22:04:29 <cait> so a compromise, having both ways with advantages/disadvantages
22:04:32 <wizzyrea> that would be poky, but testable
22:04:59 <pianohacker> and honestly, my initial thought is also that it would be poky, but we should test and see how terrible it is
22:06:01 <pianohacker> because heck, if it's only as slow as any other CGI script, we could just say that to speed up the REST API, set up plack :)
22:06:53 <bag> that was a thought that I have heard pianohacker - plack
22:08:15 <bag> and plack integration into packages now - that’s nice and simple
22:08:22 <pianohacker> #action pianohacker will investigate feasibility of running API as CGI script
22:08:28 <wizzyrea> if there is urgency on this bug, and I think that there is, making it testable would definitely help.
22:08:42 <pianohacker> bag: has anyone run the API as part of a general Plack install?
22:08:43 <bag> yes urgency :)
22:08:57 <bag> don’t know the answer of yes/no for that question
22:09:10 <pianohacker> yeah, we're looking at doing ajax circ using this, and there's, uh, interest in that
22:09:13 <wizzyrea> (but I don't think that those people who have reservations [smarter people than me] will probably come around to this approach)
22:09:51 <wizzyrea> that's just your hazard warning.
22:10:16 <bag> I’d recommend for anyone/everyone from the above comment - to read the logs from this morning
22:10:20 <bag> there was good discussion there
22:10:27 <bag> and to speak up :)
22:10:51 <pianohacker> I have a massive pile of reservations about this, mostly related to its complexity, the difficulty and boilerplate of adding new API endpoints, testing difficulties, etc
22:11:16 <pianohacker> but I think we've got it okay enough that we should try to polish this thing up as much as we can so we don't lose it
22:12:46 <pianohacker> any other thoughts about the API for now?
22:13:04 <wizzyrea> what are the alternatives, if any?
22:13:24 <pianohacker> I'm not really counting C4::Service, that's old and silly
22:14:20 <pianohacker> There's Koha::Service, which represents the polar opposite approach, but which I don't push much for reasons of conflict of interest:
22:14:23 <pianohacker> http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12272
22:14:23 <huginn> 04Bug 12272: enhancement, P5 - low, ---, jweaver, NEW , Refactor C4::Service API into Koha::Service class
22:15:05 <pianohacker> that's mostly a cleaner way of doing the old style of service, though
22:16:11 <pianohacker> my understanding is that the reasoning behind the new API was starting fresh with a style of API that's a little more internally structured
22:17:07 <wizzyrea> (I'm still here, just pondering)
22:17:41 <wizzyrea> What are the absolute most basic things we need out of this?
22:18:03 <wizzyrea> what is the minimum necessary
22:18:08 <bag> api?
22:18:09 <wahanui> rumour has it api is expected to be flexible enough to let us add other search engines later
22:18:12 <pianohacker> RESTful, versioned API
22:18:13 <bag> wiki?
22:18:13 <wahanui> wiki is http://wiki.koha-community.org
22:19:24 <pianohacker> #link http://wiki.koha-community.org/wiki/New_REST_API_RFC
22:20:48 <wizzyrea> so doing stuff with borrowers, and searching serial items?
22:21:28 <pianohacker> that's the thrust of the RFC, though Kyle or I will be shortly adding checkin/checkout
22:21:51 <eythian> hi
22:21:51 <wahanui> bonjour, eythian
22:22:05 <bag> this are the minimums
22:22:22 <bag> typing give me a sec
22:22:25 <bag> 1. Auth
22:22:30 <bag> 2 get patron status
22:22:41 <bag> 3. get checkout infromation
22:22:45 <bag> 4. get hold information
22:22:51 <bag> 5 get fine information
22:22:56 <bag> 6 renew checkout
22:23:05 <bag> 7 create edit delete hold
22:23:12 <bag> 8 get pickup location
22:24:01 <bag> <finished>
22:24:59 <bag> That’s a summary - of course each area has a lot more to them - but that’s the heading :D
22:25:17 <wizzyrea> Is there an actual specification document anywhere?
22:25:20 <wizzyrea> public
22:25:35 <bag> I thought it was on the wiki that’s why I first said wiki
22:25:39 <bag> :D
22:25:46 <pianohacker> wizzyrea: I think the above is the closest
22:25:50 <bag> but yes it’s been passed around
22:25:57 <bag> publicly
22:26:21 <pianohacker> #link http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=37413
22:26:54 <pianohacker> #info see above for an example of adding the necessary objects, API endpoints and tests for a new API piece
22:27:17 <eythian> also patron creation
22:27:20 <wizzyrea> righto
22:27:37 <eythian> because that's already been written, but got blocked waiting for the API.
22:29:29 <wizzyrea> yes, patron creation would be an important one to add
22:30:01 <bag> I added a goggle doc to the wiki link that shows the full thing for you wizzyrea
22:30:03 <bag> https://docs.google.com/document/d/1rWP0RAcYmdlukdacFHremN9TmaKQVtkuEaqpv2i8OHw/edit?usp=sharing
22:30:07 <wizzyrea> yay thanks!
22:30:49 <pianohacker> I think we should send something to the list asking for comments/additions and vote on what the v1 api should include
22:31:14 <bag> pianohacker: I feel like we decided that at the hackfest
22:31:29 * rangi wanders past
22:31:36 <rangi> 5 min break
22:31:38 <pianohacker> bag: some of that is on the wiki link I posted above
22:31:47 <bag> cool thanks pianohacker
22:31:52 <pianohacker> but it sounds like there are a lot of missing pieces
22:32:36 <pianohacker> rangi: if you have a sec, see what I proposed at :00 about mojo-in-irc
22:32:41 <pianohacker> you may have comments on the tech side
22:32:44 <wizzyrea> So, basically we need this asap because EBSCO is wanting it for their discovery layer, ya?
22:32:45 <rangi> its worth a try
22:33:00 <pianohacker> and because of ajax circ
22:33:06 <rangi> also, we need to know how to hook it into plack, without emulating cgi
22:33:07 <bag> next release wizzyrea
22:33:16 <wizzyrea> (speaking of that, I'm pretty excited about the angular circ)
22:33:31 <bag> so for part one - that’s in the works - no auth rewrite
22:33:49 <rangi> ie, i dont want to be running plack and mojo side by side
22:34:08 <bag> part two - that’s were something needs to be creative
22:34:12 <pianohacker> http://stefanorodighiero.net/posts/2014-03-30-managing_multiple_mojolicious_app_with_plack.html ?
22:34:13 <rangi> also i share all the same reservations, this way overcomplicated and way undertestedable
22:35:03 <bag> valid :)
22:35:14 <rangi> the only reason im not flipping out more, is that without the auth rewrite, it doesnt have the propensity to break everything, in the same way that the rushed hourly loans, or first ajax circ did
22:35:15 <bag> hoping it’s testable
22:35:32 <rangi> it will just break itself, hopefully
22:35:39 <rangi> right, back to angular training i go
22:35:46 <pianohacker> bye
22:35:57 <bag> let’s see what 1 brings - then talk with tomas about part 2 - he said this morning that he has ideas there
22:36:13 <pianohacker> all right, I think we need to see what the stuff from the earlier meeting brings before we can make more decisions
22:36:16 <pianohacker> agreed?
22:36:19 <cait> what's 1 and 2?
22:36:32 <bag> 1. no auth rewrite
22:36:37 <bag> 2 no daemons
22:36:40 <bag> :D
22:36:47 <wizzyrea> #info Plenty of reservations about the REST API functions, but we can't make any decisions yet because work is still in progress
22:37:12 <pianohacker> does that work from non-chairs?
22:37:28 <bag> yes to what wizzyrea said
22:37:30 <pianohacker> ah, yes, https://wiki.debian.org/MeetBot implies so
22:37:39 <pianohacker> all right, I'm closing that topic then
22:37:46 <bag> maybe add to it pianohacker - we need at least 4 weeks to really test this
22:37:47 <wizzyrea> https://algonquincollegesocialmedia.files.wordpress.com/2014/04/tumblr_m7gj9qivt51rxdvy7o1_500.gif
22:37:52 <bag> so time is a huge matter here
22:38:06 <pianohacker> bag: throw on an #info
22:38:29 <wizzyrea> #info the API will need at least 4 weeks testing
22:38:32 <bag> #info we need at least 4 weeks to really test this - so time really inmportant… I can help with funds - if needed
22:38:43 <bag> nice typo bag
22:38:44 <pianohacker> double coverage!
22:38:49 <pianohacker> bag++
22:39:04 <pianohacker> ytpos++
22:39:23 <pianohacker> #topic Big stuff we are working on
22:40:00 <bag> ES needs testing
22:40:03 <pianohacker> eythian: anything to add about elastic search?
22:40:55 <eythian> I might do a writeup some time soon on it. But essentially: ES is mostly working, there are a goodly number of rough burrs to file down, and bits of integration etc.
22:41:03 <eythian> but at its core, it's doing mostly the right things.
22:41:16 <eythian> the browse side of it is also working.
22:41:19 <wizzyrea> So. It is not a big thing, but it is a thing - I'm working on tidying up/standardising some of the interfaces, mostly in my own time. Just alerting you all that it is happening and that you'll see some patches every now and then doing that.
22:41:44 <wizzyrea> staff interface
22:41:45 <wahanui> staff interface is different, of coruse
22:41:54 <bag> I am talking daily with Elastic trying to get them to do training for all the developers - but they can’t get their mind around the fact that I can’t get all the koha developers into the same room
22:42:06 <eythian> heh
22:42:12 <eythian> i though they did webinars
22:42:17 <pianohacker> you just need a biiiiiig room, bag
22:42:43 <bag> I should think they do webinars eythian
22:43:27 <eythian> https://www.elastic.co/webinars/get-started-with-elasticsearch <-- in fact, they do
22:45:01 <bag> I even met with them in person at oscon eythian and they still were not able to answer my questions
22:45:40 <eythian> ah right. Keep nagging them, I'm sure they'll get the idea :)
22:45:55 <eythian> At some stage I should write up a big thing saying how I'm using it all, too.
22:47:17 <bag> that would be cool - I could hand that to them - and say - hey guys - I’d like a custom webinar that helps us with this…
22:47:30 <pianohacker> eythian: mind if I add a #action?
22:47:41 <eythian> pianohacker: if you like :)
22:48:07 <pianohacker> #action eythian to make a writeup showing how he's using ElasticSearch
22:48:17 <wizzyrea> https://twitter.com/ZacharyTong < here's the guy who does the webinars #imhelping
22:49:14 <eythian> #imhelping isn't an IRC channel, wizzyrea
22:49:19 <wizzyrea> zip it
22:49:21 <wizzyrea> :D
22:49:30 <wizzyrea> it is now because you clicked it.
22:50:32 <pianohacker> unrelated tidbit: I have not been able to convince freshmen in CS that #include is not pronounced "hashtag include"
22:50:48 <eythian> ...
22:50:49 <eythian> I
22:50:51 <eythian> ..
22:50:54 <eythian> ug
22:50:57 <bag> pianohacker: try this one —> it’s prounouced me-me - not meme
22:50:58 <eythian> aren't guns legal there?
22:51:01 <pianohacker> hahahaha
22:51:37 <pianohacker> as a teacher, I strongly disapprove of that idea
22:51:59 <pianohacker> strongly
22:52:18 <wizzyrea> ok right
22:52:40 <pianohacker> anyway. Not much on the bywater front. Kyle and I will be sending an RFC in the coming weeks to work on an overhaul of the circ rules interface and frontend
22:53:14 <pianohacker> to allow for setting rules piecemeal as opposed to the current supertable that requires setting every value for every situation
22:53:15 <wizzyrea> what are the problems there you are hoping to solve?
22:53:36 <pianohacker> wizzyrea: The current system has the following issues:
22:53:50 <pianohacker> 1) The current interface, with the superwide table, is intimidating and confusing
22:54:19 <pianohacker> 2) the frontend and backend require that you set every value for every branch/itemtype/categorycode combination
22:54:57 <pianohacker> 3) The fallback order from specific branch/itemtype/categorycode all the way back to default branch/itemtype/categorycode is confusing as hell
22:55:54 <pianohacker> I wrote that verbose list at the top of smart-rules.tt, and I don't remember it!
22:56:02 <wizzyrea> :)
22:56:29 <pianohacker> we have ideas for a new UI and database structure that will make things a lot clearer and more flexible for librarians
22:56:48 <pianohacker> and how to do this overhaul piecemeal and not as one huge bug
22:57:22 <pianohacker> this is not something that's happening now, but it's on the radar and we're looking for feedback. The RFC will include UI and DB mockups
22:57:24 <wizzyrea> yeah, I was just wondering how you would split that up into testable bits
22:58:01 <bag> gotta run
22:58:04 <pianohacker> bye bag
22:58:05 <wizzyrea> later bag
22:58:15 <eythian> bye bag
22:58:45 <pianohacker> #info ElasticSearch is moving forward, the basics are working. Just needs some refining
22:59:10 <wizzyrea> #info ByWater have a circ rules revamp on their roadmap
22:59:17 <pianohacker> thank you, was just writing that :)
22:59:35 <pianohacker> all right! Anything else?
23:00:02 <wizzyrea> I don't have anything
23:00:25 <wizzyrea> oh, um, 3.18 is coming along, but there are a few 3.18 only bugs that need poking
23:00:44 <pianohacker> wizzyrea: topic 3.18 RM comments?
23:00:57 <eythian> pianohacker: she's furiously looking things up
23:01:11 <pianohacker> I'll take that as a yes :)
23:01:24 <pianohacker> #topic 3.18 RMaint comments
23:01:40 <eythian> pianohacker: btw, make sure your students call it "octothorpe include" for the future.
23:02:07 <wizzyrea> oh, well, it's not specifically 3.18 but we have a couple of bugs that are waiting on bug 13618 - and they really ought to have interim solutions
23:02:08 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13618 normal, P5 - low, ---, jonathan.druart, Needs Signoff , Prevent XSS in the Staff Client and the OPAC
23:02:25 <wizzyrea> bug 14691 and bug 14505
23:02:27 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14691 enhancement, P5 - low, ---, koha-bugs, Needs Signoff , Can't delete patron with ' character in cardnumber
23:02:28 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14505 normal, P5 - low, ---, j.kylmala, Needs Signoff , single quotes in journal number cause print routing list window to not appear
23:02:32 <pianohacker> ha! That's my course coordinator's preferred pronunciation as well
23:02:39 <wizzyrea> but we can't decide on a solution
23:02:56 <wizzyrea> please put your comments on the bug(s) if you have a preferred solution.
23:03:31 <pianohacker> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13618
23:03:32 <huginn> 04Bug 13618: normal, P5 - low, ---, jonathan.druart, Needs Signoff , Prevent XSS in the Staff Client and the OPAC
23:03:52 <pianohacker> #info the above is preventing progress on the following bugs; please comment with any ideas
23:03:58 <pianohacker> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14691
23:03:59 <huginn> 04Bug 14691: enhancement, P5 - low, ---, koha-bugs, Needs Signoff , Can't delete patron with ' character in cardnumber
23:04:04 <pianohacker> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14505
23:04:05 <huginn> 04Bug 14505: normal, P5 - low, ---, j.kylmala, Needs Signoff , single quotes in journal number cause print routing list window to not appear
23:04:06 <wizzyrea> that concludes my concerns I think.
23:04:22 <pianohacker> all righty.
23:04:26 <pianohacker> #topic GBSD
23:04:34 <rangi> its pretty vitally important, more important than pretty much everything else that we get that bug 13618 into 3.22
23:04:54 <wizzyrea> yeah, that bug I'd really like to see tested.
23:05:03 <wizzyrea> it will solve and prevent so many future problems.
23:05:04 <pianohacker> rangi: worth marking it as a blocker?
23:05:17 <rangi> its a blocker to not being hacked yes
23:05:22 <pianohacker> :) well yes
23:05:24 <cait> it needs testing i think
23:05:30 <wizzyrea> all the testing. so much testing
23:05:33 <wizzyrea> it will break lots of things
23:05:38 <cait> maybe smeting for a dedicated sandbox/gbsd?
23:05:39 <wizzyrea> there is still time to fix most of them though
23:05:50 <pianohacker> I'd say that's an excellent segue into the GBSD
23:06:18 <wizzyrea> #info Bug 13618 would be a great one for global bug squashing day, it is vitally important
23:06:36 <pianohacker> #info Reminder, there is a Global Bug Squashing Day on Thursday, September 3
23:06:43 <pianohacker> #link http://wiki.koha-community.org/wiki/2015-09-03_Global_bug_squashing_day
23:06:58 <pianohacker> #info Please add any bugs/topics of interest to that page
23:07:06 <cait> thx pianohacker++
23:08:05 <cait> ... and also. please everyone test the new professional cataloguing editor
23:08:10 <pianohacker> please!
23:08:30 <pianohacker> I'm going to be fixing the most recent set of feedback ASAP, things have been crazy here at bws
23:08:43 <cait> we already got some nice feedback there - but need a little more
23:09:04 <wizzyrea> I think you really want librarians looking at it eh
23:09:09 <pianohacker> #action pianohacker to post google doc to allow per-test-plan-item feedback for Rancor (bug 11559)
23:09:10 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11559 enhancement, P5 - low, ---, jweaver, In Discussion , Professional cataloger's interface
23:09:23 <wizzyrea> do you have a test instance set up that we can point librarians at?
23:09:27 <cait> wizzyrea: there is a demo installation for everyone to poke :)
23:09:32 <wizzyrea> excellent
23:09:36 <pianohacker> yup, it's on the bug and the end of the GBSD page
23:09:41 <wizzyrea> sweet
23:10:02 <pianohacker> http://staff-bz11559.bwsdev.bywatersolutions.com/ (login bywater / bywater)
23:10:07 <pianohacker> test it test it test iiiiiit
23:10:22 <pianohacker> ^ channelling bag since he's gone
23:11:55 <pianohacker> I think that's it. Tomas posted in part 1 that he'd post on koha-devel to figure out the time of the next meeting
23:12:00 <pianohacker> anything I've forgotten?
23:12:55 <wizzyrea> naw
23:13:55 <pianohacker> givin' til :15
23:16:01 <pianohacker> #endmeeting