19:24:15 <BobB> #startmeeting General IRC Meeting 11 Feb 2015
19:24:15 <huginn> Meeting started Wed Feb 11 19:24:15 2015 UTC.  The chair is BobB. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:24:15 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:24:15 <huginn> The meeting name has been set to 'general_irc_meeting_11_feb_2015'
19:24:36 <BobB> The agenda is here:
19:24:47 <BobB> http://wiki.koha-community.org/wiki/General_IRC_meeting_14_January_2015
19:24:51 <tcohen> - topic introductions
19:25:12 <BobB> #topic introductions
19:25:13 <wahanui1> #info wahanui, a bot that has become sentient
19:25:28 <BobB> #info Bob Birchall, Calyx, Australia
19:25:28 <tcohen> #info Tomas Cohen Arazi, Universidad Nacional de Cordoba
19:25:35 <thd> #info Thomas Dukleth, Agogme, New York
19:26:02 <tcohen> cait?
19:26:02 <wahanui1> cait is just silly on a train again
19:26:07 <jwagner> #info Jane Wagner, PTFS
19:26:24 <BobB> bag about?
19:26:39 <bag> hi
19:26:41 <BobB> mtompset about?
19:26:52 <bag> #info Brendan Gallagher ByWater
19:26:57 <mtompset> Not really?
19:27:02 <mtompset> #info Mark Tompsett
19:27:30 <talljoy> #info Joy Nelson BWS
19:27:31 <BobB> I'm trying to stump up a quorum here  :)
19:27:50 <bag> heh - how many do you need?
19:28:00 <tcohen> we are enough
19:28:02 <BobB> ok, is that all?
19:28:11 <tcohen> w eare not making any votes or something
19:28:18 <BobB> #topic announcements
19:28:37 <BobB> Any announcements?
19:29:20 <tcohen> there's been a pre-Marseille meeting today
19:29:28 <BobB> #topic update on releases
19:29:32 <tcohen> we spoke about possible stuff
19:29:38 <tcohen> to work on during the hackfest
19:30:07 <tcohen> #info tcohen is almost back to his RM daily tasks
19:30:27 <barton> #info Barton Chittenden, BWS, Louisville, KY
19:30:30 <tcohen> so far we have pushed the UTF-8 patches and a lot of the VAT/GST rewrite
19:30:55 <bag> yes - sounds like it’s going to be an awesome hackfest - good stuff going on
19:30:58 * mtompset cheers. :)
19:31:09 <tcohen> there have been reported several issues on 3.18
19:31:34 <tcohen> performance (Jonathan did a good job finding DBIx is to blame, somehow)
19:31:50 <tcohen> zebra facets
19:31:50 <wahanui1> zebra facets are all done with Koha perl code anyway, not zebra itself.
19:32:18 <tcohen> we are working on both
19:32:23 <BobB> hi cait, please join the meeting
19:32:33 <tcohen> the DBIx issue has several implications
19:32:35 <cait> oh
19:32:39 <cait> missed a meeting?
19:32:46 <cait> #info Katrin Fischer, Germany
19:33:02 <tcohen> if we get full out-of-the-box Plack support
19:33:20 <tcohen> we could take advantage of several DBIx::Class options
19:33:38 <tcohen> so we are very excited to work on that during the hackfest
19:34:45 <BobB> tcohen, do you expect the 3.18 performance problem to be resolved for the next  maintenance release?
19:35:00 <tcohen> #info tcohen is happy to know there hasn't been many reports on UTF-8 problems on master since the big push
19:35:07 <tcohen> BobB: yes
19:35:28 <BobB> cool
19:35:42 <tcohen> JOnathan has a proof-of-concept fix, and I'm waiting for Galen as he was about to propose another idea
19:35:50 <thd> I posted a meeting page just now at http://wiki.koha-community.org/wiki/General_IRC_meeting_11_February_2015 .
19:35:57 <tcohen> not strictly about performance (at all) but one that has its implications
19:36:15 <BobB> #info a performance problem in 3.18 caused by DBixis likely to be resolved for the next maintenance release
19:36:54 <BobB> are any other RMs here?
19:37:30 <BobB> or is there anything else on 3.18 tcohen?
19:37:39 <tcohen> nope
19:37:47 <BobB> changing topic then
19:38:17 <BobB> #topic KohaCon15
19:38:37 <BobB> olug is not here, I think
19:38:50 <BobB> does anyone else have any update?
19:39:46 <thd> I have an update on the wiki.
19:40:20 <thd> Maybe wiki maintenance goes in old business by the agenda.
19:40:43 <BobB> sorry thd I meant on KohaCon
19:40:52 <BobB> I'll change topic again
19:41:04 <thd> Sorry for missing the context :)
19:41:35 <BobB> #topic Actions from General IRC Meetings Dec/Jan
19:42:13 <BobB> #info the Roadmap for Koha page has been created on the wiki
19:42:37 <BobB> #info there is not a lot on it yet - further contributions are encouraged
19:45:02 <BobB> I think the HEA info was posted?  Not sure if it was back-ported to 3.16 though?
19:45:47 <drojf> oops a eeting
19:45:50 <drojf> meeting even
19:46:00 <drojf> #info Mirko Tietgen, Berlin, Germany
19:46:41 <BobB> #info Previous discussions about roles of Wiki Maintainer and Communications Manager/Coordinator need to be continued at some point
19:46:52 <BobB> maybe not now?
19:47:15 <thd> I have a helpful comment to make about the issues raised by ashimema.
19:47:46 <BobB> go ahead thd
19:47:47 <thd> I agree for the maybe not now for voting, etc.
19:48:25 <thd> Last month I had a telephone conversation with ahimema about the issues which he raised.
19:49:02 <thd> I have added some comment to the discussion page for my proposal following that conversation.
19:49:07 <tcohen> which issues specifically?
19:49:17 <thd> I will modify my proposal accordingly.
19:50:21 <BobB> thd could you post the link to that again, after you've updated it?
19:50:24 <thd> The big issue is that when we started using MediaWiki without a proper testing period in consequence of PTFS taking down the former wiki we used Postgres.
19:50:41 <thd> BobB: Yes of course.
19:51:44 <thd> ashimema informed me that some aspects of Semantic MediaWiki or the set of related extensions have been known to not work properly in Postgres.
19:52:21 <thd> That maybe why command line tests failed in 2010.
19:52:40 <thd> Migrating to MySQL may be possible but tricky.
19:53:05 <BobB> that's a big problem, then
19:53:36 <thd> We may need to postpone upgrading MediaWiki until after migrating to MySQL to make best use of the one set of migration scripts which exists.
19:54:08 <thd> However, we may find that migrating works better after upgrading MediaWiki.
19:54:48 <thd> In any case, careful testing needs to be done with a copy of the Koha instance of MediaWiki first.
19:55:17 <thd> We do not want to go the wrong way and find that we cannot migrate well to MySQL.
19:55:36 <BobB> yes indeed
19:55:53 <BobB> thd a mediawiki upgrade is not essential however to the curation task on the wiki?
19:56:02 <thd> ashimema and I agreed that the first step should be a more general cleanup.
19:56:09 <BobB> stuff can be moved around now?
19:56:20 <BobB> oh, we're agreeing I think
19:56:21 <thd> BobB: Yes, exactly.
19:56:39 <thd> Also, testing migration will require more time.
19:56:50 <BobB> ok
19:57:10 <thd> I expect my time to increase from around now as previously reported.
19:57:44 <thd> I am just coming off what had become a large project wrangling years of bad user data.
19:58:48 <BobB> #action thd to update discussion of wiki curation/upgrade and post the link
19:58:57 <thd> Sadly, my project was not library related so I could not leverage all my advantages.
19:59:01 <BobB> ok, hope that's meaningful
20:00:05 <BobB> well then, we might list both those roles for resolution at the next meeting?
20:00:36 <BobB> I'll change topic?
20:01:01 <tcohen_> networking issues...
20:01:06 <BobB> #topic Time and Date of Next Meeting
20:02:33 <BobB> Should the next meeting be on 11 March?
20:02:50 <BobB> or is that during hackfest?
20:03:21 <thd> Does anyone have a link for hackfest dates?
20:04:16 <thd> The Hackfest is 2 to 6 March.
20:04:25 <BobB> hackfest is 2 to 6
20:04:40 <BobB> So our meeting can be on 11 March
20:04:44 <BobB> what time now?
20:05:56 <thd> What was the previous meeting time, 10 UTC?
20:06:41 <thd> I think that we would have had a better turnout at this hour if there had been a reminder to the mailing list.
20:07:22 <BobB> 10 UTC is a good time, but is very early on east coast USA
20:07:26 <thd> I think 10 UTC also works OK even if it maybe too late for bag and too early for nengard.
20:08:16 <thd> 2 UTC or similar times have historically had terrible turnout even if not terrible for the whole US.
20:08:17 <BobB> I think if we revert between 10UTC and 19UTC it mostly works
20:08:25 <thd> Yes.
20:08:26 <BobB> so 10 UTC next time?
20:08:32 <thd> +1
20:09:02 <BobB> #info the next meeting will be on Wednesday 11 March 2015 at 10.00 UTC
20:09:17 <BobB> if we all agree
20:09:53 <BobB> thanks thd, the silence of others is taken as consent :)
20:09:59 <talljoy> +1
20:10:14 <thd> BobB: You seem more awake than most others who are not having networking problems :)
20:10:17 <BobB> thx talljoy
20:10:32 <BobB> :)
20:10:44 <BobB> i think we are all done?
20:11:09 <BobB> #endmeeting