#koha: IRC Development Meeting 5 February, part 1

Meeting started by cait at 15:03:52 UTC (full logs).

Meeting summary

    1. Tomas Cohen Arazi, Universidad Nacional de Cordoba (tcohen, 15:04:11)
    2. (NateC, 15:04:17)
    3. Barton Chittenden, Bywater Solutions, Louisville KY, USA (barton, 15:04:25)
    4. Benjamin Rokseth, Oslo Public Library (bensinober, 15:04:27)
    5. the agenda for today's meeting can be found at http://wiki.koha-community.org/wiki/Development_IRC_meeting_5_February_2015 (cait, 15:04:28)
    6. Brendan Gallagher ByWater Solutions (bag, 15:04:34)
    7. Katrin Fischer, BSZ (cait, 15:04:38)
    8. Owen Leonard, Athens County Public Libraries, Ohio (oleonard, 15:04:41)
    9. Nate Curulla ByWater Solutions (NateC, 15:04:44)
    10. Ed Veal, ByWater Solutions (edveal, 15:04:47)
    11. Jared Camins-Esakov, C & P Bibliography Services (jcamins, 15:04:58)
    12. Coffee: |=============>|.....| 75 % (barton, 15:04:59)

  1. RM 3.18 comments (cait, 15:05:33)
  2. RM 3.20 comments (cait, 15:06:08)
    1. Hi Zeno Tajoli, Cineca (Italy) (tajoli, 15:08:52)
    2. Kyle M Hall, ByWater Solutions (khall, 15:12:09)
    3. Jonathan Druart, BibLibre (Joubu, 15:13:37)

  3. REST API RFC (cait, 15:14:10)
    1. http://wiki.koha-community.org/wiki/New_REST_API_RFC (cait, 15:14:32)
    2. Joy Nelson ByWater Solutions (talljoy, 15:15:00)
    3. Martin Renvoize, PTFS Europe (ashimema, 15:15:14)
    4. Jeff Godin, Traverse Area District Library (TADL) (jeff, 15:18:04)
    5. https://github.com/pianohacker/koha/commit/40908d6e58c40e6ffaa488266a70ef5233fe9642 (ashimema, 15:25:46)
    6. https://github.com/pianohacker/koha/commit/40908d6e58c40e6ffaa488266a70ef5233fe9642 (cait, 15:26:03)
    7. ACTION: ashimema to submit patches for the new restful API - core + a sample (cait, 15:28:36)
    8. ACTION: khall volunteers helping out with the RFC and writing up some guidelines (cait, 15:30:16)

  4. Zebra / Facet issues (cait, 15:32:03)
  5. Non-XSLT removal (cait, 15:45:56)
    1. ACTION: people that have issues with zebra facets, contact tcohen who will be looking at those (tcohen, 15:45:57)
    2. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12561 (tcohen, 15:47:17)
    3. ACTION: cait volunteers again to look into creating a better list of features missing from XSLT view (cait, 15:55:51)
    4. voting results on code removal of non-XSLT views: 3x 0, 5x yes (cait, 15:59:10)

  6. GRS-1 removal (cait, 15:59:37)
    1. bug 12641 (cait, 16:02:57)
    2. GRS-1 has been deprecated on July 7 2014 (cait, 16:03:27)
    3. UNIMARC and all other users are encouraged to report any issues with DOM indexing (cait, 16:04:37)
    4. please report before first week in march, so problems can be fixed at the hackfest in marseille (cait, 16:05:54)

  7. Coding syntax preferences: $a->{b}{c} vs. $a->{b}->{c} (cait, 16:06:19)
    1. bug 13240 for discussion (cait, 16:06:34)
    2. voting results 1) 0 2) 3 3) 1 4) 2 (cait, 16:13:19)
    3. ACTION: tcohen to set date and time for next meeting - email to dev list (cait, 16:18:09)


Meeting ended at 16:18:15 UTC (full logs).

Action items

  1. ashimema to submit patches for the new restful API - core + a sample
  2. khall volunteers helping out with the RFC and writing up some guidelines
  3. people that have issues with zebra facets, contact tcohen who will be looking at those
  4. cait volunteers again to look into creating a better list of features missing from XSLT view
  5. tcohen to set date and time for next meeting - email to dev list


Action items, by person

  1. ashimema
    1. ashimema to submit patches for the new restful API - core + a sample
  2. cait
    1. cait volunteers again to look into creating a better list of features missing from XSLT view
  3. khall
    1. khall volunteers helping out with the RFC and writing up some guidelines
  4. tcohen
    1. people that have issues with zebra facets, contact tcohen who will be looking at those
    2. tcohen to set date and time for next meeting - email to dev list


People present (lines said)

  1. cait (118)
  2. tcohen (113)
  3. ashimema (34)
  4. Joubu (33)
  5. khall (28)
  6. barton (11)
  7. huginn (11)
  8. bensinober (10)
  9. tajoli (7)
  10. oleonard (5)
  11. NateC (4)
  12. bag (3)
  13. magnuse (2)
  14. wahanui (2)
  15. jeff (2)
  16. ablj (2)
  17. edveal (1)
  18. jcamins (1)
  19. talljoy (1)
  20. TGoat (1)


Generated by MeetBot 0.1.4.