#koha: Developer IRC Meeting, 2 February 2016

Meeting started by cait at 15:01:10 UTC (full logs).

Meeting summary

  1. Introductions (cait, 15:01:18)
    1. wahanui, a bot that has become sentient (wahanui, 15:01:18)
    2. Katrin Fischer, BSZ, Germany (cait, 15:01:39)
    3. Owen Leonard, Athens County Public Libraries (oleonard, 15:01:46)
    4. Jesse Weaver, ByWater Solutions, USA (pianohacker, 15:01:52)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_2_February_2016 (cait, 15:02:02)
    6. Joy Nelson, ByWater Solutions, USA (talljoy, 15:02:05)
    7. Julian Maurice, BibLibre, France (jajm, 15:02:16)
    8. Jonathan Druart (Joubu, 15:02:18)
    9. Matthias Meusburger, Biblibre, France (matts, 15:02:25)
    10. Marcel de Rooy, Rijksmuseum, Netherlands (marcelr, 15:02:32)
    11. Andreas Hedström Mace, Stockholm University Library (andreashm, 15:02:35)
    12. Brendan Gallagher ByWater (bag, 15:02:50)
    13. Colin Campbell, PTFS-Europe (cc, 15:03:03)
    14. Nick Clemens, ByWater Solutions, USA (kidclamp, 15:03:30)
    15. mirko tietgen, not really here (drojf2, 15:03:37)
    16. Tomas Cohen Arazi, Theke (tcohen, 15:03:55)
    17. Kyle M Hall, Bywater Solutions (khall, 15:04:28)
    18. Nate Curulla, BWS (NateC, 15:04:29)
    19. XSS patches were pushed, please test and help to find any remaining problems (cait, 15:06:23)
    20. Indranil Das Gupta, L2C2 Technologies (indradg, 15:07:20)
    21. Elastic search needs testing as well - please use the branch on the main repository (cait, 15:07:31)
    22. https://wiki.koha-community.org/wiki/Elasticsearch (cait, 15:08:31)
    23. Elastic search branch: remotes/origin/new_12478_elasticsearch (cait, 15:08:54)

  2. Review of Coding guidelines (cait, 15:09:30)
    1. [marcelr] In relation to Plack: Should we add a PERL rule that prohibits defining lexical variables (my $var) in MODULES at the outermost block (file level), and also prohibits directly accessing file level lexicals in subroutines of SCRIPTS. (cait, 15:11:04)
    2. Martin Renvoize, PTFS Europe (ashimema, 15:11:50)
    3. Barton Chittenden, bws, Louisville, KY, USA (barton, 15:15:56)
    4. ACTION: pianohacker will draw up a draft of a coding guideline regarding global variables in modules/CGI scripts, see https://perl.apache.org/docs/general/perl_reference/perl_reference.html#my____Scoped_Variable_in_Nested_Subroutines for context (pianohacker, 15:22:12)
    5. Zeno Tajoli, CINECA, Italy (tajoli, 15:25:05)
    6. AGREED: PERL18 and PERL19 to be removed, as the deprecated modules are no longer part of the codebase (C4::Dates and SQLHelper) (cait, 15:30:08)
    7. AGREED: PERL16 - Modules in the Koha namespace should be object oriented when possible, using Koha::Object(s) as a preferred base. PERL16.1 - If an Koha::Object already exists, use it instead of other methods of table CRUD. (cait, 15:53:24)
    8. AGREED: Grandfather clause: XXX - Patches submitted before the introduction of a new rule may pass QA even if they do not meet the current coding guideline requirements after consulting with the QA team members. ? (cait, 15:59:12)
    9. AGREED: Grandfather clause: XXX - Patches submitted before the introduction of a new rule may pass QA even if they do not meet the current coding guideline requirements of the discretion of the QA team member. (cait, 16:07:50)
    10. AGREED: PERLXX: CGI scripts that handle CRUD operatiosn ( Create, Rad, Update, Delete ) should all be handled in the same script when possible. (cait, 16:15:47)
    11. PERLXX shoudl link to admin/cities.pl for a good example (cait, 16:16:06)
    12. ACTION: pianohacker to suggest a possible guideline for handling disagreements (cait, 16:24:37)
    13. AGREED: PERL XXX: New modules should be added to the Koha namespace as C4 is deprecated. (cait, 16:28:19)
    14. AGREED: to remove PERL11: No CVS - Development has moved from CVS to git. Therefore the use of CVS keywords $Id$ and $Revision$ should be discontinued. (cait, 16:35:50)
    15. AGREED: to remove HTML5: Deprecation of the 'prog' and 'CCSR' OPAC themes.' Templats are long gone (cait, 16:36:02)
    16. ACTION: cait to apply agreed to changes on the wiki (cait, 16:38:08)


Meeting ended at 20:47:20 UTC (full logs).

Action items

  1. pianohacker will draw up a draft of a coding guideline regarding global variables in modules/CGI scripts, see https://perl.apache.org/docs/general/perl_reference/perl_reference.html#my____Scoped_Variable_in_Nested_Subroutines for context
  2. pianohacker to suggest a possible guideline for handling disagreements
  3. cait to apply agreed to changes on the wiki


Action items, by person

  1. cait
    1. cait to apply agreed to changes on the wiki
  2. pianohacker
    1. pianohacker will draw up a draft of a coding guideline regarding global variables in modules/CGI scripts, see https://perl.apache.org/docs/general/perl_reference/perl_reference.html#my____Scoped_Variable_in_Nested_Subroutines for context
    2. pianohacker to suggest a possible guideline for handling disagreements


People present (lines said)

  1. cait (209)
  2. khall (79)
  3. pianohacker (72)
  4. Joubu (61)
  5. marcelr (36)
  6. bag (31)
  7. tcohen (21)
  8. cc (20)
  9. barton (18)
  10. huginn` (7)
  11. wahanui (7)
  12. jajm (6)
  13. tajoli (6)
  14. kidclamp (5)
  15. gmcharlt (5)
  16. talljoy (5)
  17. ashimema (4)
  18. oleonard (4)
  19. indradg (3)
  20. huginn (3)
  21. matts (1)
  22. oleonard_ (1)
  23. NateC (1)
  24. drojf2 (1)
  25. gaetan_B (1)
  26. andreashm (1)


Generated by MeetBot 0.1.4.