#koha: Development IRC meeting 14 December 2016

Meeting started by kidclamp at 13:01:09 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 13:01:23)
    1. wahanui, a bot that has become sentient (wahanui, 13:01:23)
    2. Kyle M Hall, ByWater Solutions (khall, 13:01:27)
    3. Marcel de Rooy, Rijksmuseum, Netherlands (marcelr, 13:01:31)
    4. Nick Clemens, ByWater Solutions (kidclamp, 13:01:34)
    5. Jonathan Druart (Joubu, 13:01:41)
    6. Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic (josef_moravec_, 13:01:49)
    7. Colin Campbell, PTFS Europe Ltd (cc_, 13:01:52)
    8. Claire Gravely, BSZ, Germany (LibraryClaire, 13:01:53)
    9. Dimitris Antonakis, Athens, Greece (d_antonakis, 13:01:58)
    10. Mirko Tietgen, Berlin, Germany (drojf, 13:02:01)
    11. Owen Leonard, Athens County Public Libraries, USA (oleonard, 13:02:14)
    12. Petter Åsen, Oslo Public Library, Norway (petter, 13:03:18)
    13. Andrew Isherwood, PTFS Europe Ltd (AndrewIsh, 13:03:24)

  2. Announcements (kidclamp, 13:03:45)
    1. George Veranis Thessaloniki, Greece (gveranis_, 13:04:02)
    2. Tomas Cohen Arazi, Theke (tcohen, 13:04:51)
    3. https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=16846 (Joubu, 13:06:53)
    4. Koha Patron bugs should be helped along (kidclamp, 13:08:09)
    5. https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=16846 Dependencies and progress (kidclamp, 13:08:30)
    6. http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17554 Bug 17554 (kidclamp, 13:08:49)
    7. Barton Chittenden, BWS, Louisville, KY, USA (barton, 13:09:32)
    8. Magnus Enger, Libriotech, Norway (magnuse, 13:10:48)
    9. ACTION: Joubu will remove Mozilla Persona and rebase his work on top (kidclamp, 13:11:26)

  3. Review of coding guidelines (kidclamp, 13:12:54)
  4. General development discussion (trends, ideas, ...) (kidclamp, 13:15:42)
    1. The QA queue is growing and Joubu needs help (kidclamp, 13:16:00)
    2. ACTION: kidclamp and tcohen will be looking at bug 17196 (kidclamp, 13:21:24)
    3. https://perldoc.koha-community.org/ keep in mind it goes here too, so the code may not be immediately visible. (eythian, 13:26:28)
    4. POD coverage should be checked during QA per coding guideline PERL13 (kidclamp, 13:26:48)
    5. https://perldoc.koha-community.org/ In perldoc even simple code could benefit form POD (kidclamp, 13:28:15)
    6. ACTION: Barton volunteers to write POD for existing docs, brief POD (kidclamp, 13:34:16)
    7. ACTION: kidclamp will send a call out to the list for POD guidelines and draft for a vote next meeting (kidclamp, 13:38:51)
    8. tcohen is working on moving code to use Koha::Object (kidclamp, 13:42:32)
    9. QA and interested parties should look at Koha::Object::Limit::Library on bug 17755 (kidclamp, 13:44:38)
    10. see work on using Koha::Object for uploads on bug 17501 (kidclamp, 13:45:35)
    11. https://www.bugzilla.org/docs/4.0/en/html/voting.html (kidclamp, 13:48:38)
    12. kidclamp proposes to add voting to Bigzilla (kidclamp, 13:52:40)
    13. https://www.bugzilla.org/docs/4.0/en/html/voting.html Bugzilla voting (kidclamp, 13:52:45)

  5. Updates from the QA team (kidclamp, 13:56:05)
    1. LDAP and shib may not be entirely plack safe (kidclamp, 14:00:18)

  6. Progress on next release (16.11) (kidclamp, 14:00:42)
    1. there are lots of open bug reports waiting for patches - please also take a look at those (kidclamp, 14:00:51)
    2. string freeze on the 22nd (kidclamp, 14:00:59)
    3. bug 17692 and bug 17764 are high priority for 16.11.1 (kidclamp, 14:01:34)
    4. ACTION: cait will compile a list of bugs wanted/needed for 16.11.1 (kidclamp, 14:03:24)

  7. Set time of next meeting (kidclamp, 14:05:44)
    1. ACTION: tcohen proposes to hold a second dev meeting - he will chair (kidclamp, 14:09:37)
    2. next meeting 11 January 2016, 20 UTC (kidclamp, 14:10:51)


Meeting ended at 14:11:02 UTC (full logs).

Action items

  1. Joubu will remove Mozilla Persona and rebase his work on top
  2. kidclamp and tcohen will be looking at bug 17196
  3. Barton volunteers to write POD for existing docs, brief POD
  4. kidclamp will send a call out to the list for POD guidelines and draft for a vote next meeting
  5. cait will compile a list of bugs wanted/needed for 16.11.1
  6. tcohen proposes to hold a second dev meeting - he will chair


Action items, by person

  1. barton
    1. Barton volunteers to write POD for existing docs, brief POD
  2. cait
    1. cait will compile a list of bugs wanted/needed for 16.11.1
  3. Joubu
    1. Joubu will remove Mozilla Persona and rebase his work on top
  4. kidclamp
    1. kidclamp and tcohen will be looking at bug 17196
    2. kidclamp will send a call out to the list for POD guidelines and draft for a vote next meeting
  5. tcohen
    1. kidclamp and tcohen will be looking at bug 17196
    2. tcohen proposes to hold a second dev meeting - he will chair


People present (lines said)

  1. kidclamp (92)
  2. tcohen (60)
  3. Joubu (46)
  4. marcelr (32)
  5. khall (27)
  6. barton (20)
  7. cait (20)
  8. huginn (13)
  9. drojf (8)
  10. oleonard (7)
  11. ashimema (5)
  12. cc_ (3)
  13. LibraryClaire (2)
  14. gveranis_ (2)
  15. AndrewIsh (2)
  16. josef_moravec_ (2)
  17. eythian (2)
  18. wahanui (1)
  19. magnuse (1)
  20. d_antonakis (1)
  21. petter (1)


Generated by MeetBot 0.1.4.