#koha: Development IRC Meeting 16 February 2016

Meeting started by cait at 19:02:59 UTC (full logs).

Meeting summary

  1. Introductions (cait, 19:03:03)
    1. wahanui, a bot that has become sentient (wahanui, 19:03:04)
    2. Tomas Cohen Arazi, Theke Solutions (tcohen, 19:03:07)
    3. Owen Leonard, Athens County Public Libraries (oleonard, 19:03:18)
    4. Nicole Engard, ByWater Solutions (nengard, 19:03:18)
    5. Brendan Gallagher, ByWater (bag, 19:03:26)
    6. Magnus Enger, Libriotech, Norway (magnuse, 19:03:32)
    7. Julian Maurice, BibLibre (jajm, 19:03:34)
    8. Barton Chittenden, Bywater, Louisville, KY, USA (barton, 19:03:41)
    9. https://wiki.koha-community.org/wiki/Development_IRC_meeting_16_February_2016 (cait, 19:03:45)
    10. JOy Nelson ByWater Solutions USA (talljoy, 19:03:58)
    11. JEsse Weaver ByWater Solutions USA (pianohacker, 19:04:25)
    12. Mark Tompsett (mtompset, 19:04:52)
    13. Katrin Fischer, BSZ, Germany (cait, 19:05:06)
    14. Indranil Das Gupta, L2C2 Technologies, India (indradg, 19:05:34)
    15. Philippe Blouin, Solutions inLibro (blou, 19:06:42)

  2. Announcements and news (cait, 19:07:40)
    1. Nick Clemens, ByWater Solutions (kidclamp, 19:09:18)
    2. tcohen is woring on classes for handling Koha instances (cait, 19:09:33)
    3. IDEA: make maintenance mode a flag, like for email (cait, 19:12:21)
    4. ACTION: tcohen to write up a wiki page (cait, 19:14:38)
    5. ACTION: tcohen to write up a wiki page ... about using classes for handling Koha instances (cait, 19:15:11)
    6. People needed for testing Elastic search! (cait, 19:15:48)
    7. Frédéric Demians, Tamil (passing through) (fredericd, 19:17:33)
    8. http://elasticsearch.koha.catalystdemo.net.nz/ (bag, 19:19:35)

  3. Review Coding Guidelines (cait, 19:19:51)
    1. https://wiki.koha-community.org/wiki/Coding_Guidelines (cait, 19:20:08)
    2. AGREED: New coding guideline "Code Plack friendly". Wording: Forbid global state variables in modules and CGI scripts, and discourage their use elsewhere. (see https://perl.apache.org/docs/general/perl_reference/perl_reference.html#my____Scoped_Variable_in_Nested_Subroutines for context) (cait, 19:25:25)
    3. AGREED: New coding guideline for handling disagreements: If a community member has concerns with a patch that: * Are specifically about coding style (not stated functionality or regressions in other code) * Are not covered by an existing coding guideline - then the patch and concern should be brought up on the development mailing list and/or next development IRC meeting so a new coding guideline can be added. (Rationale: While it is reasonable for c (cait, 19:36:42)
    4. AGREED: New coding guideline: All methods and functions should take a single argument: either a database ID, arrayref, or hashref with named arguments. (cait, 19:52:42)
    5. Mirko Tietgen, broken internet connection (drojf, 19:53:13)
    6. General solution to prevent XSS problems (bug 13618) had to be reverted - other possible solutions to be discussed next time (cait, 19:57:01)
    7. ACTION: mtompset to add note about PERL12 (cait, 19:58:10)

  4. General development discussion (cait, 19:58:24)
    1. http://lists.koha-community.org/pipermail/koha-devel/2016-January/042207.html (cait, 19:58:48)
    2. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8926 (nengard, 20:02:28)
    3. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=8926 (nengard, 20:02:32)
    4. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13667 (nengard, 20:03:07)
    5. concerns about perfomance with one big table (cait, 20:03:58)
    6. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7021 (nengard, 20:04:54)
    7. concern, about having to change a lot of the code, sql queries etc to exclude deleted patrons etc. (cait, 20:05:10)
    8. plus: less complicated sql reporting (cait, 20:09:11)
    9. https://wiki.koha-community.org/wiki/Benchmark_for_3.22 (cait, 20:12:47)
    10. Please give some priority to performance related bugs - linked to the omnibus bug 15342 (cait, 20:15:54)
    11. ACTION: pianohacker to add 15350 to agenda for discussion at the next meeting (cait, 20:18:19)

  5. Date and time of next meeting (cait, 20:20:40)
    1. AGREED: Next developer meeting will be on March 1st at 15 UTC (cait, 20:21:44)


Meeting ended at 20:21:53 UTC (full logs).

Action items

  1. tcohen to write up a wiki page
  2. tcohen to write up a wiki page ... about using classes for handling Koha instances
  3. mtompset to add note about PERL12
  4. pianohacker to add 15350 to agenda for discussion at the next meeting


Action items, by person

  1. mtompset
    1. mtompset to add note about PERL12
  2. pianohacker
    1. pianohacker to add 15350 to agenda for discussion at the next meeting
  3. tcohen
    1. tcohen to write up a wiki page
    2. tcohen to write up a wiki page ... about using classes for handling Koha instances


People present (lines said)

  1. cait (185)
  2. pianohacker (73)
  3. mtompset (41)
  4. tcohen (30)
  5. nengard (29)
  6. barton (20)
  7. huginn (14)
  8. bag (11)
  9. jajm (7)
  10. talljoy (6)
  11. kidclamp (5)
  12. larryb (5)
  13. wahanui (4)
  14. mtj (3)
  15. kyr (2)
  16. magnuse (2)
  17. oleonard (2)
  18. drojf (2)
  19. pastebot (1)
  20. indradg (1)
  21. blou (1)
  22. fredericd (1)


Generated by MeetBot 0.1.4.