#koha: Development IRC meeting 19 October 2016

Meeting started by cait at 10:01:21 UTC (full logs).

Meeting summary

  1. Introductions (cait, 10:01:29)
    1. wahanui, a bot that has become sentient (wahanui, 10:01:29)
    2. Bob Birchall, Calyx, Sydney Australia (BobB, 10:01:46)
    3. https://wiki.koha-community.org/wiki/Development_IRC_meeting_19_October_2016 (cait, 10:01:52)
    4. Nick Clemens, ByWater Solutions (kidclamp, 10:01:56)
    5. Katrin Fischer, BSZ, Germany (cait, 10:01:57)
    6. Claire Gravely, BSZ, Germany (LibraryClaire, 10:02:00)
    7. petter, Oslo public library, Norway (petter, 10:02:02)
    8. Jonathan Druart, France (Joubu, 10:02:14)
    9. Benjamin Rokseth, Norway (bensinober, 10:02:31)
    10. Dimitris Antonakis, Athens, Greece (d_antonakis, 10:03:30)
    11. Kyle Hall, Bywater Solutions (khall, 10:04:13)

  2. Announcements (cait, 10:04:51)
    1. Irma, CALYX, Sydney Australia (irma, 10:04:53)
    2. https://wiki.koha-community.org/wiki/Roles_for_17.05 (cait, 10:05:44)
    3. ACTION: all Sign up for roles for 17.05 (cait, 10:06:48)
    4. Mirko Tietgen, Berlin, Germany (drojf, 10:07:59)

  3. Review of coding guildelines (cait, 10:08:10)
  4. Deadlines for 16.11 (cait, 10:08:57)
    1. Zeno Tajoli, CINECA (tajoli, 10:10:23)
    2. November 1st will be the feature slush, so only bug fixes will get pushed after that (cait, 10:10:42)
    3. November 3rd: first draft of the release notes for review (cait, 10:10:58)
    4. Novmeber 10th: second draft of the release notes (cait, 10:11:25)
    5. November 15th: String freeze, only bug fixes requiring no string changes to be pushed (cait, 10:14:28)
    6. November 17th: final draft of release notes (cait, 10:14:39)
    7. November 22nd: Release! (cait, 10:14:50)
    8. QA team to focus on enh/new features until the feature slush date (exceptions for bad bugs and security of course) (cait, 10:17:04)

  5. General development discussion (cait, 10:17:50)
    1. https://wiki.koha-community.org/wiki/Sandboxes (cait, 10:18:46)
    2. https://wiki.koha-community.org/wiki/Sandboxes (cait, 10:18:55)
    3. New 'Tester handbook' on the wiki, collecting pages with information important for beginners and testers (cait, 10:19:41)
    4. ACTION: all please add/suggest changes to the tester handbook (cait, 10:22:40)
    5. Use 'academy' keyword' in bugzilla for highlighting easily testable bugs (cait, 10:22:56)

  6. Updates from the QA team (cait, 10:23:32)
    1. ACTION: Joubu to send a 'post hackfest' email (cait, 10:24:48)

  7. Koha and Qvarn (cait, 10:25:28)
  8. Set date of next meeting (cait, 10:27:55)
    1. Magnus Enger, Libriotech, Norway (magnuse, 10:32:53)
    2. Martin Renvoize, PTFS Europe (ashimema, 10:33:05)
    3. Next meeting Novembe 9th, 19 UTC (cait, 10:34:19)


Meeting ended at 10:35:12 UTC (full logs).

Action items

  1. all Sign up for roles for 17.05
  2. all please add/suggest changes to the tester handbook
  3. Joubu to send a 'post hackfest' email


Action items, by person

  1. Joubu
    1. Joubu to send a 'post hackfest' email
  2. UNASSIGNED
    1. all Sign up for roles for 17.05
    2. all please add/suggest changes to the tester handbook


People present (lines said)

  1. cait (98)
  2. khall (15)
  3. Joubu (14)
  4. wahanui (4)
  5. BobB (3)
  6. kidclamp (3)
  7. huginn (3)
  8. LibraryClaire (2)
  9. ashimema (2)
  10. drojf (2)
  11. d_antonakis (2)
  12. irma (1)
  13. magnuse (1)
  14. bensinober (1)
  15. tajoli (1)
  16. petter (1)


Generated by MeetBot 0.1.4.