15:07:09 <cait> #startmeeting Development IRC meeting 20 April 2016
15:07:09 <huginn> Meeting started Wed Apr 20 15:07:09 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:09 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:09 <huginn> The meeting name has been set to 'development_irc_meeting_20_april_2016'
15:07:17 <cait> #topic Intorductions
15:07:25 <cait> please introduce yourself with #info
15:07:42 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
15:07:46 <drojf> #info Mirko Tietgen, Berlin, Germany
15:07:49 <cait> #chair drojf
15:07:49 <huginn> Current chairs: cait drojf
15:07:55 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:07:56 <cait> just a backup :)
15:08:04 <cait> #info Katrin Fischer, BSZ, Germany
15:08:06 <drojf> i am not a backup
15:08:10 <drojf> i have lousy internet
15:08:14 <drojf> and will likely drop off
15:08:15 <drojf> sorry
15:08:28 <drojf> i paid 5 euro for it, thansk deutsche bahn
15:08:31 <jajm> #info Julian Maurice, BibLibre
15:08:31 <cait> #chair oleonard
15:08:31 <huginn> Current chairs: cait drojf oleonard
15:08:38 <jajm> hi everyone
15:08:46 * oleonard has one, doesn't know how to be one
15:09:02 <cait> that's ok, I don't know either
15:09:29 <cait> ok, moving on?
15:09:38 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_20_April_2016
15:09:45 <cait> hm i notice, there is a typo
15:09:48 <oleonard> Did we lose khall already?
15:09:54 <cait> release 16.05
15:10:28 * cait fixes
15:10:32 <cait> #topic Release 16.05
15:10:36 <tcohen> is ficed already
15:10:45 <tcohen> we need bag
15:10:48 <tcohen> or khall
15:11:01 <cait> #info Feature freeze will be at the end of the day - April 28!
15:11:04 <khall> #info Kyle M Hall, ByWater Solutions
15:11:12 <cait> from the QAM a few notes too maybe
15:11:31 <cait> the Signed Off queue is currently at 61
15:11:44 <cait> this is quite high compared to numbers the last few weeks - everyone is busy!
15:12:08 <cait> that is good, but it is possible that we won't manage to get all through QA in time
15:12:11 <drojf> so qa is the bottleneck atm?
15:12:21 <cait> so everyone on QA team - please try and help get the numbers down
15:12:31 <tcohen> -.-
15:12:40 <cait> also others, please help with testing and pushing things back in queue with follow-ups when asked as fast as possible
15:12:42 <oleonard> 51 in the Passed-QA queue as well.
15:13:12 <cait> there are some things i need help with - for example ES and REST
15:13:43 <tcohen> I already signed on the ES branch
15:13:52 <tcohen> maybe khall?
15:13:58 <cait> maybe someone else could give it a test, so youcould count for qa?
15:14:06 <tcohen> that could work
15:14:47 <cait> #info Additional sign offs for ES requested to free QA tokens
15:14:57 <jajm> cait, what kind of help do you need for REST ? maybe I can help
15:15:08 <cait> jajm: i have no idea where to start and how to set it up atm :(
15:15:14 <khall> tcohen: I'm going to dedicate some time to making sure ES doesn't break Zebra at the very least
15:15:16 <cait> so i was hoping someone could take a look at those with a better backgroun
15:15:17 <cait> d
15:15:41 <tcohen> jajm: we still don't have REST on packages!
15:15:46 <cait> if you want me to - i need a really detailed documentation on how to get it to work - ideally for a git installation
15:16:51 <jajm> tcohen, why ? what is missing ?
15:17:01 <cait> #info 61 in Signed off - help needed for ES and REST related patches specifically
15:17:01 <tcohen> pm
15:17:28 <cait> bug 15126 - do we have a solution for this?
15:17:29 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15126 enhancement, P5 - low, ---, julian.maurice, Signed Off , REST API: Use newer version of Swagger2
15:18:14 <tcohen> cait: we need gmcharlt to weight in
15:19:44 <cait> ok
15:20:31 <cait> i'll put that on the list
15:20:37 <cait> so anythign else people want to add?
15:21:03 <tcohen> i'd like to mention
15:21:24 <bgkriegel> #info Bernardo Gonzalez Kriegel
15:21:31 <tcohen> that kohadevbox:ansible has been updated so it now accepts external repositories, handy for testing packaging stuff
15:21:52 <tcohen> and it includes Elasticsearch as an option switch
15:22:03 <tcohen> so it installs it and people can test the ES branch
15:22:08 <cait> #info Need info on status of Swagger2 packages for REST related patches
15:22:27 <cait> #info kohadevbox:ansible has been updated so it now accepts external repositories, handy for testing packaging stuff
15:23:00 <cait> ok, moving on?
15:23:20 <gmcharlt> I will look at feasiblity of porting the swagger package on Monday and Tuesday
15:23:52 <cait> #action gmcharlt to look into feasibility of porting the swagger package on Monday and Tuesday
15:24:07 <cait> coudl we qa them with a questionmark?
15:24:15 <cait> not sure how you'd install the dependencies atm
15:24:16 <tcohen> +1
15:24:27 <tcohen> just grab the .deb from testing
15:25:01 <cait> thx gmcharlt
15:25:46 <cait> ok, so anyone taking a look please keep in mind that a condition will be the package
15:26:06 <cait> #topic Review coding guidelines
15:26:13 <cait> there have been no new proposals on the wiki
15:26:37 <cait> and I think khall just got back, so probably no update on the revamp? :)
15:27:00 <khall> cait: afraid not ; ) I'm working on it though
15:27:08 <cait> does someone want to make a new proposal?
15:27:14 <khall> right now I'm building out a "table of contents" before I start adding anything to it
15:27:22 <khall> I do have one
15:27:34 <cait> #info khall is working on the draft for a revamped coding guidelines page
15:28:00 <khall> We should specify that form validation should use the jquery form validator we have
15:28:21 <cait> sounds sensible, are there limitations to it we shoudl note?
15:28:36 <khall> unless the form validation will not work with it's limitations
15:28:57 <khall> I can't think of any form in Koha atm that would not work with it
15:29:08 <oleonard> You *should* be able to define a custom validation rule for anything which isn't already built in.
15:29:21 <khall> even better!
15:29:22 <wahanui> even better is, like, what oleonard said just after that
15:29:24 * oleonard did so for Bug 16286
15:29:25 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16286 enhancement, P5 - low, ---, oleonard, Needs Signoff , Use validation plugin when adding or editing patron category
15:30:44 <cait> can we quickly compose a suggested wording?
15:30:45 <oleonard> I've been submitting patches as if that were already the rule, so of course you have my vote :)
15:30:47 <reiveune> bye
15:30:58 <cait> i'd also like if some examples could be added on the wiki later
15:31:09 <khall> I think it's been a defacto rule
15:31:15 * cait nods
15:31:43 <khall> cait: the new guidelines will definitely have examples for everything where possible!
15:31:46 <cait> hm i have also seen something on the bugs abut a 'global' confirm function or something?
15:33:08 <cait> wording?
15:33:08 <wahanui> i think wording is irritating me too indeed
15:33:09 <cait> :)
15:33:13 <cait> khall?
15:33:13 <wahanui> i heard khall was volunteering to come over and fix it for you, it seems. ;)
15:33:20 <oleonard> Yes, in staff-global.js. Many templates write a custom version of that.
15:33:45 <cait> maybe we shoudl also document those a bit - what's in staff-global.js
15:33:50 * khall think he's not understanding something
15:34:26 <khall> any form with the class 'validated' uses the validator, is that what you mean?
15:34:30 <oleonard> khall: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16281#c2
15:34:31 <huginn> 04Bug 16281: enhancement, P5 - low, ---, aleishaamohia, Failed QA , Remove the use of "onclick" from Reports module
15:34:31 <khall> that's in the global js
15:34:40 <oleonard> separate issue.
15:34:46 <cait> yes, separate
15:34:48 <khall> yes, there's already a guideline for that
15:34:49 <cait> maybe for next time
15:35:14 <khall> no, I'm thinking of the onload one
15:35:21 <khall> JS7
15:36:02 <cait> Proposal: Form validation should be done using the jquery form validator unless the form validation will not work with its limitations. Custom validation rules for anythign which isn't already built in can be defined.
15:36:15 <khall> sounds good!
15:36:37 <cait> #startvote Add coding guideline about use of jquery form validator as proposed? (yes,no)
15:36:37 <huginn> Begin voting on: Add coding guideline about use of jquery form validator as proposed? Valid vote options are , yes, no, .
15:36:37 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
15:36:39 <cait> #vote yes
15:36:43 <oleonard> #vote yes
15:36:52 <cait> #info Proposed wording: Form validation should be done using the jquery form validator unless the form validation will not work with its limitations. Custom validation rules for anythign which isn't already built in can be defined.
15:36:52 <bag> morning
15:37:15 <cait> khall: ?
15:37:31 <cait> anyone? :)
15:37:41 <khall> #vote yes
15:38:11 <bag> #info Brendan Gallagher Bywater
15:38:23 <cait> jajm? tcohen? bgkriegel?
15:38:23 <bag> (sorry to be late - slow bus driver this morning)
15:38:41 <jajm> #vote yes
15:38:41 <cait> drojf?
15:38:41 <wahanui> i heard drojf was from Germany and developing Koha on a raspberry pi!
15:38:46 <bgkriegel> #vote yes
15:39:04 <cait> ending voooote....
15:39:10 <cait> #endvote
15:39:10 <huginn> Voted on "Add coding guideline about use of jquery form validator as proposed?" Results are
15:39:10 <huginn> yes (5): oleonard, cait, jajm, bgkriegel, khall
15:39:19 <cait> khall: can you add it please?
15:39:33 <khall> will do!
15:39:38 <cait> #agreed Coding guideline will be added - yes (5): oleonard, cait, jajm, bgkriegel, khall
15:39:52 <cait> #action khall to add coding guideline about jquery form validation
15:39:59 <cait> ok, moving on
15:40:07 <cait> #topic Any bugs that are in discussion
15:40:14 <cait> we covered a bit of that already earlier I think
15:40:22 <cait> any bugs left? :)
15:40:49 <jajm> a lot of bugs are still in discussion :)
15:41:04 <cait> true
15:41:36 <cait> maybe we can start picking some after the release
15:42:02 <cait> and put them on the agenda regularly
15:42:10 <cait> moving on?
15:42:14 <oleonard> Wow... 213 in discussion!
15:42:28 <cait> yeah... scary
15:42:32 <cait> FQA is pretty high too
15:43:20 <cait> #topic General development discussion
15:43:24 <khall> maybe it's time to start triaging some of those. I imagine a good number  of ID bugs have been left for dead.
15:43:35 <cait> ID?
15:43:35 <wahanui> ID is in $0 and $9.
15:43:41 <khall> In Discussion
15:43:41 <wahanui> it has been said that In Discussion is probably good
15:43:47 <cait> but yah, probably worth starting to go through them, maybe in groups by ten or so
15:43:56 <khall> sounds good
15:44:42 <cait> joubu suggested a couple of topics
15:44:57 <cait> he also sent a list of bugs to the list - some of them performance related
15:45:01 <cait> that would be good to have in the next release
15:45:52 <cait> 16221 PQA   16140 In Discussion   16166 NSO (Improve L1 cache performance).   16105 NSO (Cache::Memory is loaded even if memcache is used)
15:45:58 <cait> hm bug was missing
15:47:07 <cait> from the topics listed, shoudl we pick one to discuss more deeply?
15:47:17 <cait> or concentrate on pending release issues for now?
15:47:47 <cait> #link http://lists.koha-community.org/pipermail/koha-devel/2016-April/042582.html
15:47:52 <cait> this was the e-mail with the bug lists
15:48:05 <barton> #info Barton Chittenden, bws
15:48:24 <cait> hm so quiet
15:48:26 <cait> i will move on
15:48:31 <pianohacker> hallo
15:48:36 <cait> i got no more updates for qa - said everything earlier :)
15:48:41 <cait> but i have something else
15:48:47 <tcohen> sorry, boss asked for me at his office :-/
15:48:55 <cait> #topic Nominations for release team 16.11
15:49:04 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_16.11
15:49:19 <cait> please take a look... think about it... and sign yourself up :)
15:49:42 <tcohen> can i add a comment about coding guidelines?
15:49:49 <cait> it's only 2 weeks to the may meeting - but we will try to have elections then I  think - as june will be too late
15:49:53 <cait> tcohen: yep
15:50:05 <tcohen> back in 2014, we added the .editorconfig file to the source tres
15:50:06 <tcohen> tree
15:50:23 <tcohen> we should have something about it on the wiki
15:50:25 <pianohacker> oh, hey, yes we did
15:50:31 <tcohen> most editors support it
15:50:36 <cait> what does it do?
15:50:37 <pianohacker> tcohen yes, including how to integrate it
15:50:45 <khall> indeed!
15:50:50 <tcohen> it configures the editor to match the coding guidelines!
15:50:53 <pianohacker> tcohen: all of the editor integrations require a plugin, correct?
15:51:07 <tcohen> pianohacker: yes
15:51:16 <cait> i think maybe have a separate page
15:51:20 <cait> and then later we can link it?
15:52:00 <tcohen> it is just a single line :-D, but yes
15:52:04 <khall> it comes to mind that we don't have a rule about tabs vs spaces, even though that is a defacto rule as well
15:52:15 * cait hides
15:52:24 <khall> we can just point to the .editorconfig as the rules to follow
15:52:32 <tcohen> # Unix-style newlines with a newline ending every file
15:52:32 <tcohen> end_of_line = lf
15:52:32 <tcohen> insert_final_newline = true
15:52:32 <tcohen> # 4 space indentation
15:52:33 <tcohen> indent_style = space
15:52:33 <tcohen> indent_size = 4
15:52:33 <tcohen> # New files charset should be UTF-8
15:52:35 <tcohen> charset = utf-8
15:52:40 <tcohen> that's what's inside of it
15:52:44 <cait> i think it was decided actually
15:52:46 <cait> the 4 spaces
15:52:56 <oleonard> 4 spaces... interesting...
15:52:59 <cait> at some irc meeting we probably would have a hard time to locate the logs for
15:53:06 <bag> I seem to remember 4 spaces too
15:53:12 <khall> PERL6
15:53:18 <pianohacker> khall: wait, what? tabs aren't codified?
15:53:22 <khall> just found it
15:53:23 <pianohacker> (not tabs rather)
15:53:27 <pianohacker> oh okay
15:53:33 <khall> baby brain ; )
15:53:35 <barton> do our perltidy rules match .editorconfig?
15:53:53 <tcohen> geany, sublime, atom, vim
15:53:57 <tcohen> all of them support it
15:54:01 <khall> barton: our perltidy is the default
15:54:04 <pianohacker> barton: editorconfig covers a much more narrow spectrum
15:54:15 <pianohacker> khall: well, not quite
15:54:23 <pianohacker> it doesn't have cuddled else, for one (thank god)
15:54:26 <barton> nod, but it would be a pain if there were a mis-match.
15:54:31 <pianohacker> or it does, rather
15:54:32 <tcohen> http://editorconfig.org/#download
15:55:08 <cait> hm is someone volunteering to write up something about use of editorconfig?
15:55:20 * tcohen volunteers
15:55:36 <cait> #action tcohen to write up some documentation about the use of editorconfig
15:55:38 <cait> thx!
15:55:59 <cait> anything else we should discuss ?
15:56:07 <barton> #link http://editorconfig.org/#download
15:56:13 <cait> thx barton
15:56:17 <khall> afk, brb
15:56:37 <cait> #topic Set time of next meeting
15:56:52 <cait> may 4th is the next genral meeting
15:57:08 <oleonard> Bring your light sabers.
15:57:12 <cait> 11th maybe?
15:57:18 <cait> hehe
15:58:17 <cait> UTC 19 doesn't work well, i tihnk partly because of daylight savings
15:58:24 <cait> it's ... 5 am? in nz
15:58:39 <cait> and quite late here too
15:58:47 <cait> 9pm
15:59:04 <bag> I’m not around on the 11th
15:59:16 <cait> bag:  would another day in this week wrk for you?
15:59:36 <bag> not 10-12th
15:59:39 <cait> hm 7am nz i think
15:59:41 <bag> 13 or 14 yes
15:59:47 <cait> i am so bad with timezones
15:59:49 <bag> but khall can be here for me
16:01:23 <cait> so for the time, any suggestions?
16:01:26 <barton> cait: you'd think that we'd all be excellent with timezones by now... but no. I'm right there with you.
16:01:45 <cait> I am playing with the meeting thing right now
16:01:45 <cait> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160413T09&msg=Koha%20Developers%20IRC%20Meeting&low=c
16:02:00 <cait> date is wrong, but lookign for an alternative time suggestion
16:02:34 <oleonard> UTC 19 is bad for me. UTC 9 is okay, terrible for anyone west of me in the US.
16:02:40 <barton> http://xkcd.com/1335/
16:02:52 <cait> 19 had very few poeple last time
16:03:01 <cait> so that's mostly why i am looking for an alternative
16:03:52 <cait> http://www.timeanddate.com/worldclock/fixedtime.html?iso=20160511T09&msg=Koha%20Developers%20IRC%20Meeting&low=c ?
16:04:13 <oleonard> Maybe we need to start using something like Doodle to plan meetings (http://doodle.com/)
16:04:33 <cait> always good for europe then maybe
16:04:43 <cait> well or some timezone with the most people
16:04:59 <pianohacker> I do remember trying to do that back in the day and watching the "okay" parts of the day nicely completely miss each other for western US, europe and NY
16:05:03 <pianohacker> *NZ
16:05:14 <cait> eah
16:05:19 <cait> i tried for one past qa team
16:05:23 <cait> ad it was impossible
16:05:43 <cait> so i have pretty much given up on the idea of qa team meetings online
16:06:17 <cait> bad for europe... but what if we tried 21 UTC?
16:06:51 * oleonard could make that work, probably.
16:06:56 <pianohacker> it'd get more of NZ in at least
16:07:03 <cait> shall we try?
16:07:11 <pianohacker> and it's perfect for me
16:07:11 <cait> for 11th now?
16:07:14 <pianohacker> sure
16:07:29 <cait> #agreed next meeting will be held on April 11, 21 UTC
16:07:34 <cait> argh
16:07:44 <cait> #agreed next meeting will be held on MAY 11, 21 UTC
16:07:50 <cait> not only bad with timezones :)
16:07:52 <cait> with dates too!
16:07:56 <cait> #endmeeting