#koha: Development IRC meeting 24 August 2016

Meeting started by cait at 07:01:34 UTC (full logs).

Meeting summary

  1. Introductions (cait, 07:01:37)
    1. wahanui, a bot that has become sentient (wahanui, 07:01:37)
    2. https://wiki.koha-community.org/wiki/Development_IRC_meeting_24_August_2016 (cait, 07:01:54)
    3. Mirko Tietgen, Berlin, Germany (drojf, 07:02:08)
    4. Katrin Fischer, BSZ, Germany (cait, 07:02:15)
    5. Nick Clemens, ByWater Solutions (kidclamp, 07:02:22)
    6. Jonathan Druart (Joubu, 07:02:47)
    7. Kyle M Hall, ByWater Solutions (khall, 07:03:53)

  2. Announcements (cait, 07:04:29)
    1. Tomas Cohen Arazi (tcohen, 07:06:01)
    2. AGREED: Friday, 9 September will be GBSD = Global Bug Squashing Day (cait, 07:08:06)
    3. ACTION: cait to update wiki and send info about GBSD to the mailing list (cait, 07:08:19)

  3. Review of coding guidelines (cait, 07:08:51)
    1. tcohen is working on the REST-related patches and suggests adding coding guidelines for the swagger files (cait, 07:10:44)
    2. ACTION: tcohen to send an email to the list about 'splitting the swagger files' - bug 16699 (cait, 07:14:17)

  4. General development discussion (cait, 07:15:22)
    1. Frédéric Demians (fredericd, 07:20:49)
    2. lots of REST related patches on bugzilla, focusing mostly on 2 things: 1) permission handling and documentation, 2) adding new endpoints (cait, 07:26:32)
    3. http://git.koha-community.org/gitweb/?p=koha.git;a=blob;f=Koha/REST/V1/Patron.pm;h=2851308e7c34d78925972959438c28f4aa0782e8;hb=HEAD (tcohen, 07:37:57)
    4. IDEA: don't backport REST API patches atm, until infrastructure is sorted out (cait, 07:44:28)
    5. IDEA: make new patches using REST in the GUI depend on the infrastructure bugs, especially bug 14868 (cait, 07:45:23)
    6. patrons will be able to use the REST API to do, what they can do in the OPAC, but not more (cait, 08:07:06)
    7. Martin Renvoize - PTFS Europe (ashimema, 08:15:04)
    8. REST api permissions can be reviewed in file, see https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=54767 (drojf, 08:19:06)

  5. Highlight easy to test bugs for beginners (drojf, 08:20:40)
    1. IDEA: instead of a keyword, add "testing complexity" to BZ (drojf, 08:29:48)
    2. ACTION: kidclamp to talk to rangi about adding new keywords as discussed in the meeting to indicate easy bugs for beginners and testing complexity (cait, 08:42:21)
    3. ACTION: kidclamp ... or make a suggestion for the next meeting (cait, 08:42:39)

  6. Updates from the QA team (cait, 08:43:19)
  7. Actions from last meeting (cait, 08:47:03)
    1. http://meetings.koha-community.org/2016/development_irc_meeting_13_july_2016.2016-07-13-14.08.html (cait, 08:47:23)
    2. namespace discussion is on http://lists.koha-community.org/pipermail/koha-devel/2016-July/042845.html (cait, 08:48:29)
    3. Start for benchmarks for QA tools: http://lists.koha-community.org/pipermail/koha-devel/2016-July/042844.html Please comment! (cait, 08:48:59)
    4. PERL24 was added after the last meeting: https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL24:_Performance_and_cache_related_patches_should_include_benchmarks_of_some_sort_to_prove_their_effects (cait, 08:51:07)
    5. ACTION: khall to add react and related topics to next dev meeting agenda (cait, 08:53:10)

  8. Set time of next meeting (cait, 08:54:07)
    1. AGREED: Next meeting will take place on September 28, 21 UTC (cait, 08:56:52)


Meeting ended at 08:56:56 UTC (full logs).

Action items

  1. cait to update wiki and send info about GBSD to the mailing list
  2. tcohen to send an email to the list about 'splitting the swagger files' - bug 16699
  3. kidclamp to talk to rangi about adding new keywords as discussed in the meeting to indicate easy bugs for beginners and testing complexity
  4. kidclamp ... or make a suggestion for the next meeting
  5. khall to add react and related topics to next dev meeting agenda


Action items, by person

  1. cait
    1. cait to update wiki and send info about GBSD to the mailing list
  2. khall
    1. khall to add react and related topics to next dev meeting agenda
  3. kidclamp
    1. kidclamp to talk to rangi about adding new keywords as discussed in the meeting to indicate easy bugs for beginners and testing complexity
    2. kidclamp ... or make a suggestion for the next meeting
  4. tcohen
    1. tcohen to send an email to the list about 'splitting the swagger files' - bug 16699


People present (lines said)

  1. cait (177)
  2. tcohen (108)
  3. drojf (76)
  4. khall (47)
  5. kidclamp (45)
  6. Joubu (31)
  7. ashimema (31)
  8. huginn (20)
  9. fredericd (6)
  10. eythian (4)
  11. wahanui (3)
  12. ashimema_ (3)
  13. reiveune (1)
  14. fridolin (1)
  15. gaetan_B (1)


Generated by MeetBot 0.1.4.