21:01:02 <cait> #startmeeting Development IRC meeting 28 September 2016
21:01:02 <huginn> Meeting started Wed Sep 28 21:01:02 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:02 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:02 <huginn> The meeting name has been set to 'development_irc_meeting_28_september_2016'
21:01:07 <cait> #topic Introductions
21:01:07 <wahanui> #info wahanui, a bot that has become sentient
21:01:12 <cait> today's agenda:
21:01:23 <rangi> #info Chris Cormack, Catalyst NZ
21:01:24 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_28_September_2016
21:01:30 <cait> #info Katrin Fischer, BSZ, Germany
21:02:30 <cait> noone else?
21:03:18 <rangi> heh
21:03:23 <Joubu> #info Jonathan Druart
21:03:33 <mkuhn> #info
21:03:34 <cait> cozy meeting
21:03:39 <Joubu> (more or less aroud)
21:04:31 <mkuhn> #info Michael Kuhn (will now keep quiet and listen only)
21:04:35 <cait> meeting with 4?
21:04:45 <rangi> just go super fast
21:05:06 <cait> ok
21:05:10 <Joubu> I don't have much to say and it's a bit late here ;)
21:05:19 <cait> #topic annoucnments
21:05:20 <drojf> if it only takes 5 minutes i am here too
21:05:21 <cait> same here
21:05:27 <cait> so introduce yourself!
21:05:32 <cait> any announcements?
21:05:35 <drojf> hm no i am afraid you will make me chair
21:05:37 <cait> not from me
21:05:38 <drojf> :P
21:05:40 <rangi> we are doing work on bug 17255
21:05:41 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17255 normal, P5 - low, ---, srdjan, ASSIGNED , Upgrade Elastic Search code to work with version 2.4+
21:05:48 <cait> cool!
21:05:51 <drojf> yay
21:06:07 <rangi> and have overdrive records being searched via elasticsearch now
21:06:09 <cait> #info Catalyst IT working on bug 17255 - updating Elastic Search code to work with version 2.4+
21:06:19 <cait> is there a timefame for it?
21:06:25 <cait> mostly wondering if it could be testable in marseile
21:06:26 <drojf> rangi: there is still a catmandu 1.x repo somehwere on my server
21:06:34 <rangi> which will be submitted as patches once elastic is upgraded
21:06:44 <rangi> before hackfest
21:06:57 <rangi> so people can use/test it there
21:07:00 <cait> nice
21:07:18 <cait> moving on?
21:07:20 <Joubu> would be cood to get a patch for the install process
21:07:29 <rangi> the only other thing is i wont be doing anymore 3.20.x releases except for security
21:07:31 <drojf> but for latest ES i think you need pretty late catmandu
21:07:51 <cait> #info No more 3.20.x releases except for security
21:07:51 <rangi> drojf: yup
21:08:02 <cait> moving on
21:08:09 <cait> we got nothing for the next topic
21:08:13 <rangi> nope
21:08:14 <cait> i am going to move to general dev
21:08:14 <drojf> there was a bug/feature grabbing underscore names
21:08:29 <drojf> which i thiunk catmandu fixed after i made the repo
21:08:33 <cait> #topic General development discussion
21:08:48 <cait> kidclamp is not here
21:09:04 <cait> i tihnk he wanted to propose some new keywords for makring easy bugs
21:09:06 <rangi> yeah i think its a good idea, marking them academy is fine
21:09:15 <cait> ok
21:09:28 <rangi> also there is a page on the wiki
21:09:32 <cait> #info marking easy bugs 'academy' for beginners is fine
21:09:34 <cait> hm?
21:09:42 <rangi> https://wiki.koha-community.org/wiki/I_want_to_help
21:09:47 <rangi> up date this too
21:10:02 <cait> #info you can also update https://wiki.koha-community.org/wiki/I_want_to_help
21:10:04 <rangi> eg weve done the OMGWTFBBQ one now
21:10:25 <cait> :)
21:10:29 <cait> we need a new one
21:10:47 <cait> ok
21:10:56 <cait> anyone interested in the discussion about minified files?
21:10:56 <drojf> a new search engine
21:11:10 * Joubu has been disconnected
21:11:16 <cait> nothing happened ;)
21:11:26 <cait> Joubu: interested in discussion about minified files?
21:11:29 <drojf> right in time for minified things
21:11:40 <rangi> yeah thats something we need to figure out
21:11:49 <cait> i have some concerns
21:11:58 <cait> I know that minified means that conflicts are hard to solve
21:11:59 <Joubu> not really cait
21:12:09 * drojf minifies awakeness
21:12:10 <cait> i think that's why some devs want to not have them in the repo
21:12:15 <cait> but when i understand correctly
21:12:20 <rangi> i think minify on release
21:12:22 <cait> that'd mean that the testers need to run some build tools
21:12:26 <rangi> make it part of the release process
21:12:32 <cait> and we would have to make that super easy
21:12:33 <rsantellan> huginn: I installed version 2.4 and with all debs and fails to create the index, I can provide testing for the bug 17255
21:12:34 <huginn> rsantellan: I've exhausted my database of quotes
21:12:49 <drojf> rsantellan: huginn is a bot
21:13:13 <cait> because easy for devs... hard for testers is bad
21:13:18 <rangi> yes
21:13:58 <rsantellan> awkward moment!!
21:13:59 <eythian> (git hooks that reminify on checkout?)
21:14:07 <drojf> rsantellan: happens every day
21:14:37 <cait> hm also need something for sandboxes
21:14:41 <rsantellan> so for anybody I can provide some help in elasticsearch matter
21:14:44 <cait> that's my main concern
21:14:57 <cait> we can move on now if people want to
21:15:35 <rangi> yup
21:15:37 <cait> #info cait is concerned about change in workflow for testers - should still be easy to test bugs, need tools/instructions for that
21:15:47 <cait> ok
21:15:54 <cait> #topic Updates from the QA team
21:16:04 <cait> Joubu: do you have sth?
21:16:43 <cait> i noted 2 bugs on the wiki
21:17:00 <cait> #info Bug 15434 - Make search results breadcrumbs human readable
21:17:00 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15434 normal, P5 - low, ---, srdjan, Signed Off , Make search results breadcrumbs human readable
21:17:10 <cait> there was some critique about this being client side
21:17:17 <cait> instead of server side
21:17:52 <cait> i am hoping we can get to a conclusion on this one
21:17:59 <cait> hm come to...
21:18:42 <cait> the other is
21:18:53 <cait> #info Bug 16126 - Display base-level amounts on the acquisition module home page (see screenshots attached)
21:18:54 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16126 enhancement, P5 - low, ---, remi.mayrand-provencher, Signed Off , Display base-level amounts on the acquisition module home page
21:19:08 <cait> which i'd like to get some opionions on
21:19:10 * Joubu has been disconnected again...
21:19:27 <Joubu> sorry but it seems that my box is gettting crazy
21:19:30 <cait> the question here is: should the acq funds table be the same on the funds and hte acq start page or should the latter be a more simplified version
21:19:37 * cait hands Joubu duct tape
21:20:43 <Joubu> about bug 15434, I don't really like it, and would like to see a ES version it is not compatible
21:20:54 <rangi> hmm yep
21:21:00 <Joubu> I don't remember the patch exactly actually
21:21:21 <Joubu> I'd be keen to make it in if it does
21:21:40 <Joubu> about 16126, I don't like it and I don't understand it
21:21:48 <Joubu> the complete view is on another page
21:21:54 <cait> sorry, not sure i got the point
21:21:56 <cait> can you rephrase?
21:22:11 <cait> for the first
21:22:18 <Joubu> which one? :)
21:22:25 <cait> the search breadcrumbs
21:22:51 <Joubu> iirc the breadcrumbs is zebra compatible only
21:22:55 <cait> ok
21:23:03 <Joubu> the breadcrumbs patch*
21:23:10 <cait> so what would be a path forward?
21:24:56 <Joubu> sorry but got disconnected again
21:25:08 <Joubu> I will need to have a look again
21:25:17 <cait> for the funds: maybe we shoudl check permissions - can somoene who can#<t edit funds still access the complete table?
21:25:24 <Joubu> if ES compatible, I can pass QA on it if nobody is against it
21:25:26 <cait> i amn not sure about that, but can check some other night
21:25:39 <Joubu> otherwise ask to the author if he is willing to provide a ES version
21:25:54 <cait> what about the discussion client/server side?
21:26:26 <Joubu> I don't like it, but don't have a counter patch to provide neither
21:26:32 <Joubu> so if it works...
21:26:38 <cait> k
21:26:43 <cait> similar for me
21:26:55 <cait> i can see server side might be nice... but this would still be an improvement
21:27:00 <cait> and it's a real long standing issue
21:27:49 <cait> #action Joubu to take a look at ES compatibility of bug 15434
21:27:50 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15434 normal, P5 - low, ---, srdjan, Signed Off , Make search results breadcrumbs human readable
21:27:58 <Joubu> about the funds, it would be good to get an answer from the author
21:28:11 <Joubu> he did not answered, and is not around
21:28:20 <cait> #action cait to check on permissions for fund views (bug16126)
21:29:24 <cait> true
21:29:25 <cait> ok moving on
21:29:36 <cait> #topic Koha and Qvarn
21:29:39 <cait> rangi: you turn :)
21:29:53 <rangi> i dont think there are enough people for that to be worthwhile today im afraid
21:31:27 <rangi> ill re add it, and maybe do a mail in the meantime
21:31:32 <cait> hm ok
21:31:45 <cait> #action rangi to readd or email about Koha and Qvarn
21:32:00 <cait> #topic Set time of next meeting
21:32:05 <cait> suggestions?
21:32:06 <wahanui> suggestions are still there
21:32:32 <rangi> probably something that works for europe next
21:32:49 <cait> thenext general meeting is 5 october
21:33:06 <cait> the week after is marseille
21:33:22 <cait> what abut the 19th?
21:34:12 <cait> 10 utc?
21:34:12 <wahanui> i guess 10 utc is a good time, but is very early on east coast USA
21:34:31 <cait> 14 utc?
21:35:10 <cait> the general one is at 10 https://wiki.koha-community.org/wiki/IRC_Meetings
21:35:43 <cait> Joubu: help?
21:35:44 <wahanui> hmmm... help is at http://koha-community.org/support/ if no-one here can help.
21:36:53 <rangi> 10utc i could make
21:36:58 <cait> ok
21:36:59 <rangi> 14utc i cant, but the USA can
21:37:10 <cait> 19th ok?
21:37:13 <rangi> yep
21:37:28 <Joubu> will be too late as well
21:37:39 <cait> Joubu: hm?
21:37:51 <Joubu> would have been good to have a dev meeting before the hackfest actually
21:38:02 <rangi> what about at the hackfest
21:38:05 <rangi> on the first day
21:38:10 <cait> we tired that before
21:38:15 <cait> i think it didn<#t really work so well
21:38:38 <Joubu> k
21:38:46 <cait> i think it was close to lunch break
21:38:51 <cait> might have been the problem :)
21:39:01 <cait> we could have a marseille pre meeting?
21:39:06 <cait> would you want to organize one?
21:39:33 <Joubu> not really
21:39:45 <cait> 10 utc ok then?
21:40:05 <cait> the work before hackfest i will be too busy to run a dev meeting
21:40:09 <cait> if someone else does, fine by me
21:40:19 <drojf> that is next week
21:40:19 <Joubu> it seems that these meetings don't bring a lot of people
21:40:29 <Joubu> so yes first day of hackfest could be ok
21:40:34 <cait> the rest api one was a bit better
21:40:37 <drojf> i'll be gone for "vacation"
21:40:38 <cait> maybe we need to have topic meetings
21:40:51 <cait> but can we go for 19th 10 utc for now?
21:40:59 <cait> rangi proposed a topic, so that would give him a chance to talk about it
21:41:22 <cait> #agreed next meeting will be on 19 October, 10 utc
21:41:29 <cait> i am falling asleep :)
21:41:32 <cait> we need to end here
21:41:39 <cait> #endmeeting