10:00:47 <cait> #startmeeting General IRC meeting 3 February 2016
10:00:47 <huginn> Meeting started Wed Feb  3 10:00:47 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:47 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:00:47 <huginn> The meeting name has been set to 'general_irc_meeting_3_february_2016'
10:00:53 <cait> Welcome all!
10:00:56 <cait> #topic Introductions
10:00:57 <wahanui> #info wahanui, a bot that has become sentient
10:01:08 <cait> Please follow wahanui's example and introduce yourself with #info
10:01:17 <bag> #info Brendan Gallagher - ByWater
10:01:49 <thd> #info Thomas Dukleth, Agogme, New York City
10:01:52 <cait> #info Katrin Fischer, BSZ, Germany
10:01:59 <cait> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_3_February_2016
10:02:01 <ikourmou> #info Giannis Kourmoulis - Aristotle University, Thessaloniki
10:02:42 <cait> jajm, thd, Joubu?
10:03:01 <cait> oh sorry, thd - overread your entry
10:03:02 <jajm> #info Julian Maurice, BibLibre, France
10:03:11 <jajm> thanks cait  :)
10:03:18 <Joubu> #info Jonathan Druart
10:03:39 <cait> quiet morning
10:03:41 <cait> let's move on
10:03:48 <cait> #topic Update on Releases
10:03:56 <cait> as bag is awake... I will hand over to him
10:04:01 <bag> cool
10:04:04 <bag> I’ll be quick
10:04:23 <bag> not much to report - I’m pushing
10:04:34 <bag> good dev meeting yesterady
10:05:06 <bag> next dev meeting in 2 weeks
10:05:28 <bag> that’s it - unless people have questions?
10:05:35 <cait> I will make changes to the coding guidelines as agreed on yesterday - please keep an eye on that page (hopefully before the end of the week)
10:05:41 <cait> not a question, just a note :)
10:05:45 <bag> :)
10:05:56 <Joubu> just a quick hint: there is a critical PQA, bug 15687
10:05:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15687 critical, P5 - low, ---, julian.maurice, Passed QA , Syntax errors in misc/translator/xgettext.pl
10:06:05 <Joubu> the translate script is broken on master
10:06:27 <bag> thanks!
10:06:34 <cait> If you are running master, there is a new dependency for the XSS fixes that needs to be installed from CPAN currently, but will hopefully be packaged soon as well - the web installer will prompt for it
10:06:38 <jajm> and in stable versions too I think (at least 3.22.2)
10:06:43 <bag> I looked at that the other day but didn’t finish
10:06:50 <drojf> #info Mirko Tietgen, Berlin, Germany
10:07:14 <cait> jajm: hm our 3.22.2 seems ok - how does it show?
10:07:35 <jajm> cait, you can't run ./translate update xx-XX
10:07:41 <gmcharlt> #info Galen Charlton, Equinox
10:07:42 <cait> hm i did
10:07:43 <cait> on git
10:08:05 <jajm> cait, hmm ok, so I'm probably wrong, which is a good thing :)
10:08:19 <cait> i can retest after the meeting - we update the po files on our branch for some changes in xslt
10:08:57 <cait> ok, moving on?
10:09:18 <Joubu> (confirmed, ok on 3.22.2)
10:09:19 <cait> jajm: any update on 3.22.2?
10:09:51 <cait> if not that's ok, writing the topic change line :)
10:10:29 <cait> #topic INSTALL.debian is outdated
10:10:41 <cait> #link http://koha.1045719.n5.nabble.com/INSTALL-debian-is-outdated-td5861347.html
10:10:53 <jajm> cait, nothing to report
10:11:21 <cait> If I see it correctly, this is about the instructions we ship with Koha
10:11:38 <cait> the current file was last changed in 2012
10:11:48 <cait> the proposal is to
10:12:16 <cait> 1) delete it
10:12:17 <cait> 2) replace it with content from the wiki page
10:12:17 <cait> 3) Include a link to the instructions on the wiki page
10:12:30 <ashimema> 3++
10:13:17 <cait> which wiki page would we link to?
10:13:25 <Joubu> 2++ :)
10:13:42 <Joubu> and sync it on releasing (RM job)
10:13:49 <cait> bag? :)
10:14:00 <bag> 3++
10:14:17 <bag> but I’d be fine with 2 :)
10:14:20 <cait> 0++ - don't have a clear preference, all are fine for me
10:15:05 <cait> it's a draw
10:15:19 <jajm> 1-- (no preference between 2 and 3)
10:15:20 <cait> ah, no, 2 then - anyone else here to vote? :)
10:15:22 <drojf> i don't have a preference either
10:15:31 <cait> ok, so not 1
10:15:34 <drojf> a link is probably best in my opinion
10:15:47 <cait> we will make this easier, who is going to make the change?
10:15:50 <drojf> or, well. no i say 2
10:15:51 <drojf> sorry .D
10:15:59 <drojf> otherwise offline install is impossible
10:16:07 <Joubu> that's the point, of course
10:16:12 <cait> ok, so 2.
10:16:27 <Joubu> and it seems easy to keep it up-to-date once every 6 months
10:16:46 <cait> #agreed Update the INSTALL.debian file with content from the wiki
10:16:48 <drojf> can we scrape the wiki page? that should not be too hard
10:16:49 <cait> who is going to do it?
10:17:08 <cait> it would be good to add it to some kind of pre-release list
10:17:26 <cait> update about page... update installation instructions... etc.
10:17:27 <bag> I can update that file in koha
10:17:36 <cait> #action bag to update the file in Koha
10:17:37 <cait> thx bag
10:17:56 <cait> hm i shoudl have specified which filee :)
10:18:13 * bag adds it to release notes checklist
10:18:15 <cait> #action bag to update the INSTALL.debian file in Koha from the wiki (scratch the other action item)
10:18:28 <cait> moving on
10:18:31 <cait> #topic Hackfest in Berlin
10:18:35 <cait> drojf?
10:18:35 <wahanui> drojf is from Germany and developing Koha on a raspberry pi!
10:18:45 <drojf> i just wanted to use the opportunity to say: there is a koha hackfest in berlin the week before kohacon, i'd propose 25--27 may as the the core time but i have the room from 23 to 27 may if that is not enough. i will be leaving to thessaloniki saturday afternoon.
10:18:58 <drojf> i suppose people are planning/booking their kohacon travels now so it's probably a good time to mention it. if you plan on coming, it would be good to know about it. some people have expressed interest but don't want to decide until others say they are coming. which is a bit problematic ;)
10:19:13 <drojf> there is a wiki page with some info here https://wiki.koha-community.org/wiki/Berlin_Kohacon_Warmup_2016 so think about it :)
10:19:31 <drojf> that's about it i think
10:19:46 <cait> thx drojf :)
10:20:05 <bag> cool it’s tempting
10:20:10 <drojf> HA!
10:20:29 <drojf> :)
10:20:32 <bag> :)
10:20:41 <cait> lots to see in Berlin - and good food
10:20:46 * cait can recommend :)
10:20:52 <cait> moving on to the next event
10:21:11 <cait> #topic KohaCon16
10:21:49 <ikourmou> hello everyone
10:22:01 <ikourmou> i think i should give some info
10:22:24 <ikourmou> we have the kohacon16 site up and running...
10:22:35 <ikourmou> http://kohacon2016.lib.auth.gr/
10:22:48 <ikourmou> with a lot of information already
10:23:11 <ikourmou> (should i copy this information to a wiki page also?)
10:23:25 <drojf> ikourmou: the page is fine
10:23:27 <cait> ikourmou++ kohacon16-team++ very nice website
10:23:32 <drojf> no need to dupicate
10:23:38 <cait> #link http://kohacon2016.lib.auth.gr/
10:23:47 <cait> if you'd want you could add a link maybe
10:23:48 <drojf> ikourmou++
10:24:05 <ikourmou> ok, i will do this. I would like to encourage everyone here to register...
10:24:35 <ikourmou> and submit presentation proposals.
10:24:36 <cait> maybe a kohacon16 page that points to your website - to help get it more visible
10:25:09 <magnuse> #info Magnus Enger, Libriotech, Norway
10:25:13 <ikourmou> also if you have any comments / suggestions on the presentation topics
10:25:23 <ikourmou> http://kohacon2016.lib.auth.gr/?page_id=29
10:25:35 <ikourmou> i will be happy to read them
10:26:07 <drojf> i have a question
10:26:14 <ikourmou> and general suggestions or comments - regarding kohacon
10:26:15 <drojf> is it possible to register without google forms?
10:26:28 <drojf> because there was a lot of personal information, like food allergies and stuff
10:26:51 <ikourmou> you can send an email, containing only the info you wanna give...
10:27:06 <drojf> cool
10:27:35 <cait> #info Please register and submit presentation proposals - forms are on the website
10:28:11 <cait> so if the form doesn't work, send an email?
10:29:05 <ikourmou> If anybody can't reach the form or doesn't want to fill in all that info, they can send an email
10:29:21 <cait> #info If anybody can't reach the form or doesn't want to fill in all that info, they can send an email
10:29:24 <cait> just clarifying for the minutes
10:29:40 <ikourmou> if there are no comments / suggestions, I would like to ask a few things...
10:29:58 <cait> please ask
10:29:59 <drojf> i had something else with the forms but i forgot, sorry
10:30:16 <drojf> i will send you an email if it comes up again
10:30:17 <ikourmou> do we need to define a keynote speaker / topic?
10:30:31 <ikourmou> do you have to suggest sth?
10:30:50 <cait> hm
10:31:03 <bag> hmm is right
10:31:04 <cait> trying to remember :)
10:31:08 <drojf> i think traditionally there is a koha history talk at the beginning? but that depends on people handing in a proposal for that
10:31:18 <cait> I think sometimes someone from the institution hosting it said a few words in the beginning
10:31:35 <cait> and sometimes the current release manager
10:31:58 <drojf> oh yes, bag, tell us a story :)
10:32:01 <cait> I think there is no strict rule
10:32:19 <bag> well I could have already released in May drojf
10:32:24 <cait> it's up to you on how you want to do it
10:32:28 <drojf> oh. true
10:32:37 <bag> and who knows if I’ll do a second one ;)
10:32:44 <ikourmou> ok, so depending on the presentation prposals we could choose the keynote speaker / topic.
10:32:44 <cait> good point heh
10:32:51 <drojf> i'd say wait for the proposals and see what you get
10:33:01 <bag> but I do love to talk :)
10:33:02 <cait> and if you have something you'd like to do - try it out :)
10:33:11 <ikourmou> ok, thanks
10:33:20 <cait> bag:  you could still talk about 3.24 - or the funding... or... lots of things :)
10:33:43 <bag> yeah I like the try whatever you want to try attitude
10:33:47 <drojf> funding is probably not a great warmup topic
10:34:00 <drojf> ask them once they love koha (in case they are new to it)
10:34:03 <drojf> ;)
10:34:13 <cait> maybe at the end ):
10:34:14 <cait> :)
10:34:17 <drojf> should be the case after three days :)
10:34:37 <cait> ikourmou: do you have another question?
10:34:42 <ikourmou> also, do you think it would be interesting to have some case studies with Koha implementations around the world?
10:34:59 <gmcharlt> +1
10:35:03 <bag> yes
10:35:18 <thd> ++
10:35:19 <drojf> yes. preferably done by librarians, not support providers
10:35:30 <magnuse> yes
10:35:31 <drojf> or library staff
10:35:50 <cait> +1, by libraries for libraries :)
10:36:24 <magnuse> the story of the public libraries in turkey might be an interesting one, for example
10:36:43 <drojf> if they release the code…
10:36:44 <drojf> :P
10:36:53 <ikourmou> i think we could ask some people (based on the list emails) to give presentations about their libraries (ie - I have Turkey and Saudi Arabia in mind)
10:37:02 <thd> Any suggestions on how to fly cheaply from the US?
10:37:05 <bag> thats cool
10:37:12 <ikourmou> @magnuse exactly!
10:37:12 <huginn> ikourmou: I've exhausted my database of quotes
10:37:15 <cait> ikourmou: i think Turkey would be great
10:37:24 <gmcharlt> would still be interesting (just as yet unclear whether good example or horrible warning of making customizations to a GPL project ;) )
10:38:04 <drojf> from my point of view, it is a fork with unclear license at the moment
10:38:30 <drojf> i'd prefer that to sort that out before they become the center point of a koha conference ;)
10:38:34 <magnuse> :-)
10:38:37 <cait> I think getting in contact with the project woud possible answer a lot of questions :)
10:38:39 <drojf> *to be sorted out
10:38:56 <drojf> but i'm curious too, of course :)
10:39:18 <thd> The horrible warning is also a lesson for projects about how to do better for managing contributors to avoid losing their contributions in an unnecessary fork.
10:39:47 <drojf> what about a nice agpl talk? *hides*
10:40:14 <drojf> ikourmou: do you need help with the proposals once the cfp is over?
10:40:17 <ikourmou> that;s a cmplication i haven't thought of
10:41:14 <ikourmou> I should see the detail before inviting anyone to present.
10:41:55 <drojf> i asked on the list, joann did too. there was no reply so far about the code changes
10:42:02 <cait> yeah :(
10:42:19 <cait> we have other known forks tho
10:42:24 <gmcharlt> hopefully somebody can make a personal contact
10:43:11 <cait> how do we want to proceed? could we do something to help clear this up?
10:43:56 <thd> The reasonable suggestion has been that if we had been using git much earlier we would have more contributors and fewer forks.
10:44:11 <cait> hm i don't believe that git is the issue
10:44:36 <cait> there are quite new forks, because people rapidly add features they need urgently
10:44:37 <bag> heh
10:45:55 <cait> i think sometimes the pace of a project makes people fork, possibly there are other reasons too
10:46:10 <gmcharlt> time for next agenda item?
10:46:23 <bag> thanks
10:46:30 <Joubu> The Turkey fork contain a lot of specific dev, Turkish related, not sure they are candidate for inclusion in master
10:46:30 <ikourmou> drojf: of course. as soon as cfp is over i will let you know
10:46:49 <ikourmou> just a couple of things:
10:47:00 <ikourmou> next step will be a call for sponsorships
10:47:11 <cait> sounds good
10:47:23 <ikourmou> we 'll have a page for that
10:47:46 <cait> #info Call for Sponsorships coming soon on the website
10:47:46 <bag> cool
10:47:51 <ikourmou> with all the budget planning etc
10:48:12 <thd> ikourmou: Do you have any special insight to low priced flights from the US?
10:48:55 <cait> Could you maybe discuss in PM and share results later?
10:48:57 <ikourmou> thd: I dont have atm, but i could take a look and send you an email
10:49:20 <ikourmou> cait: sure
10:49:29 <cait> thd: maybe share on the wiki what you find out?
10:49:34 <ikourmou> I would like to finish with this:
10:49:40 <thd> Certainly
10:49:41 <wahanui> it has been said that Certainly is confusing.. thanks for bringing ashimema's attention to it.
10:49:54 <cait> forget Certainly
10:49:54 <wahanui> cait: I forgot certainly
10:50:00 <drojf> i liked certainly :/
10:50:01 <ikourmou> any comments / suggestions are more than welcome (concernig every aspect of kohacon16)
10:50:14 <bag> :)
10:50:20 <cait> thx a lot ikourmou
10:50:22 <cait> ikourmou++
10:50:37 <cait> drojf: you can teach him something new :)
10:50:41 <ikourmou> please register and add your proposals for presentations!
10:50:48 <cait> heh, moving on now :)
10:50:59 <cait> #topic KohaCon17
10:51:05 <drojf> thanks ikourmou, looking forward to kohacon :)
10:51:17 <cait> there is currenty one proposal from the Philippines
10:51:48 <cait> shoudl we talk about setting an end date for the bidding already or does this have more time?
10:51:53 <drojf> i dont think there will be any more before next kohacon. we are very early with this now
10:52:03 <bag> more time
10:52:08 <drojf> much more time
10:52:21 <cait> ok
10:52:24 <drojf> just because we allow proposals immediately now does not mean we have to decide earlier
10:52:24 <cait> so not forcing this now :)
10:52:30 <cait> yep makes sense to me
10:52:37 <bag> :)
10:52:39 <cait> #info end of bidding date to be decided much later
10:53:03 <cait> #info currently only one proposal from the Philippines
10:53:16 <cait> so the voting process - any progress there?
10:53:36 <drojf> i tried to add some options we had to the wiki
10:53:37 <drojf> https://wiki.koha-community.org/wiki/Processes_for_KohaCons#How_to_conduct_the_vote
10:53:54 <drojf> they are pretty basic, but that is what we discussed last time, i think
10:53:57 <cait> #link https://wiki.koha-community.org/wiki/Processes_for_KohaCons#How_to_conduct_the_vote
10:54:27 <drojf> i think others should have look and add pros and cons
10:54:51 <cait> we have very low attendance today - shoudl we schedule a deifnite vote for the next meeting?
10:55:04 <cait> with a reminder on the mailing list maybe?
10:55:05 <drojf> i would say we vote around next kohacon?
10:55:16 <cait> or that, just before the bidding closes maybe
10:55:23 <thd> Would proposals 2 and 4 have some risk of a proximate if not actual tie?
10:55:24 <drojf> so we can discuss this once people thought about it
10:55:44 <cait> #info voting mechanism for next KohaCon vote to be decided - please take a look at pros and cons of methods listed on the wiki page
10:55:59 <drojf> and there is the problem of fakes
10:56:18 <thd> fakes is the more important issue.
10:56:41 <drojf> we had about 10% on each side last time. with a very clear result it does not matter, but if it were close…
10:56:47 <cait> #info please also take a look at the notes about handling fake votes
10:57:12 <cait> moving on?
10:57:29 <thd> The idea of giving personal names along with other info seems helpful as a control.
10:58:14 <cait> shall we add preferences to the wiki page as notes?
10:58:15 <drojf> i would not want to limit it to institutional email addresses really, but it would be an option (which excludes a lot of people)
10:58:42 <drojf> it would be nice if people add their thoughjts to the wiki
10:58:52 <drojf> so we can sum it up in one of the next meetings
10:59:17 <cait> #info Please add your thoughts directly to the wiki page for next meetings
10:59:20 <cait> #topic Update from the International Koha Fund Committee
10:59:23 <cait> gmcharlt?
10:59:24 <wahanui> gmcharlt is an expert in all things library technology.
10:59:36 <gmcharlt> wahanui: forget gmcharlt
10:59:37 <wahanui> gmcharlt: I forgot gmcharlt
10:59:46 <cait> i liked gmcharlt!
10:59:47 <gmcharlt> so, the fundraising committee last met on 27 January
11:00:24 <gmcharlt> and the main topic of discussion was draft rules for a Grants committee that will disburse money collected by the funds
11:00:57 <gmcharlt> the draft is still being discussed among the fundraising committee, but will be put out for general comment shortly after 10 February
11:01:20 <cait> #info last fundraising committee was on 27 January
11:01:55 <cait> #info draft rules for Grants committee still discussed but available for general comment shortly after 10 February
11:02:07 <cait> I see in the action items from last stime:      bag to ask how much has been raised so far
11:02:32 <gmcharlt> I believe we're awaiting an update from THT; we'll nudge again
11:02:46 <cait> ok thx
11:03:03 <cait> questions or comments?
11:03:22 <gmcharlt> one other point for an upcoming general meeting
11:03:37 <cait> yes?
11:03:58 <gmcharlt> is that we will be proposing a change to the terms of reference (https://wiki.koha-community.org/wiki/Fundraising) to allow majority vote rather than unaminty in article 4
11:04:31 <gmcharlt> the specific proposed change to the wording will be sent out well beforehand
11:04:48 * magnuse has to run off for a bit
11:05:15 <cait> #info  A proposed change to the terms of reference (https://wiki.koha-community.org/wiki/Fundraising) to allow majority vote rather than unaminty in article 4 to be decided at another meeting. Proposed change to the wording will be sent out well beforehand.
11:05:22 <gmcharlt> and our general aim is to attain community approval by April or thereabouts so that we'll be in a position (assuming that the money is there) to start a cycle of disbursing grants from the fund later this year
11:05:47 <cait> hm coudl you info that for me? :)
11:05:54 <gmcharlt> we are also refining some material to use to encourage poeple to donate
11:05:54 <wahanui> okay, gmcharlt.
11:05:55 <bag> and to do fundraisers too :D
11:06:12 <gmcharlt> heh
11:06:39 <bag> drojf: more time (I think is appropriate here)
11:06:41 <bag> :P
11:06:46 <gmcharlt> #info The fundraising committee aims to attain community approval of the procedures for collecting and disbursing funds by April (or so)
11:07:19 <gmcharlt> #info Tentative aim is to do a fundraising and grant disbursement cycle later in 2016
11:07:24 <cait> thx for the #info and thx to the committee
11:07:31 <gmcharlt> and, I think that's it unless bag cares to add anything
11:07:51 <bag> great job gmcharlt - you got everything :D
11:07:58 <bag> gmcharlt++
11:09:29 <cait> :) moving on then
11:09:41 * gmcharlt stumbles off in search of coffee
11:09:43 <cait> do we need more brainstorming?
11:10:00 <drojf> oh coffee
11:10:04 <drojf> good idea
11:10:52 <cait> ok,
11:10:55 <cait> i think no brainstorming :)
11:11:05 <cait> #topic Actions from last General meeting
11:11:19 <cait> funding committee met, asked for update about the current donations... that leaves
11:11:26 <cait> khall asked nicely to add another mock-up for an overview kind of page
11:11:49 <cait> khall, around?
11:11:58 <khall> somewhat ; )
11:12:46 <cait> see above ^
11:13:37 <cait> the topic was the issuing rules revamp from the last meeting
11:13:41 <khall> referring to the circ rules revamp? We haven't completed the mock-up yet
11:13:44 <cait> where a second page to the input page was discussed
11:13:45 <cait> ok
11:13:46 <khall> : \
11:13:50 <cait> i will action you again :)
11:13:59 <cait> #action khall asked nicely to add another mock-up for an overview kind of page
11:14:04 <cait> #topic Next meeting
11:14:26 <cait> hm wednedsy
11:14:35 <cait> March 2nd
11:14:53 <thd> 9th?
11:14:54 <Joubu> maybe another time? :)
11:14:57 <cait> 10 UTC
11:15:14 <drojf> we had 10 utc today
11:15:19 <cait> ah sorry
11:15:22 <cait> 20utc
11:15:28 <drojf> i don't mind, but others may :)
11:15:43 <cait> me and timezones... i can't be trusted
11:15:53 <drojf> if that works for you? i think you said its your birthday
11:16:00 <thd> What about 9th March.
11:16:04 <thd> ?
11:16:07 <cait> well... yes it is
11:16:16 <cait> 9th would work for me - but also somene else coudl chair :)
11:16:37 <drojf> i don't see why we should not take 9
11:16:41 <thd> I prefer not the first Wed of the month.
11:16:52 <cait> ok
11:17:01 <cait> so suggestion: Wednesday 9th, 20UTC
11:17:02 <cait> +1
11:17:05 <drojf> +1
11:17:07 <cait> March...
11:17:08 <wahanui> somebody said march was often the month with the most snow here...
11:17:09 <thd> +1
11:17:29 <cait> #agreed Next IRC meeting will be held on 9 March, 20 UTC
11:17:31 <cait> #endmeeting