10:14:43 <cait> #startmeeting General IRC Meeting, 8 June 2016
10:14:43 <huginn`> Meeting started Wed Jun  8 10:14:43 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:14:43 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:14:43 <huginn`> The meeting name has been set to 'general_irc_meeting__8_june_2016'
10:14:50 <cait> #topic introductions
10:14:50 <wahanui> #info wahanui, a bot that has become sentient
10:14:56 <cait> please introduce yourself with #info
10:15:05 <cait> today's agenda can be found at
10:15:07 <cait> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_8_June_2016
10:15:24 <cait> and davidnind++ for sending the reminder
10:15:47 <thd> #info Thomas Dukleth, Agogme, New York City
10:15:56 <davidnind> #info David Nind, Wellington, New Zealand
10:16:03 <schnydszch> #info Eugene Espinoza - Manila, Philippines
10:16:04 <cait> #info Katrin Fischer, BSZ, Germany
10:16:36 <mveron> @info Marc Véron, Koha Support Schweiz, Allschwil
10:16:36 <huginn`> mveron: Error: The command "info" is available in the Factoids and RSS plugins.  Please specify the plugin whose command you wish to call by using its name as a command before "info".
10:16:44 <mveron> #info Marc Véron, Koha Support Schweiz, Allschwil
10:16:47 <mveron> :-)
10:17:49 <cait> khall: ?
10:17:58 <khall> mornin!
10:18:27 <cait> drojf: ping
10:18:51 <cait> ok, moving on
10:18:51 <drojf> ah
10:18:56 <cait> ah or not
10:18:56 <drojf> so late, oops
10:19:22 <drojf> #info Mirko Tietgen, koha.abunchofthings.net, Berlin, Germany
10:19:22 <khall> #info Kyle M Hall, Bywater Solutions
10:19:27 <cait> ok
10:19:29 <cait> so moving on now :)
10:19:34 <cait> #topic Announcements
10:19:57 <indradg> #info Indranil Das Gupta, L2C2 Technologies, India
10:20:08 <cait> not much from me - QA queue is pretty full, hopefully it will normalize soon to a lower number again
10:21:01 <cait> any other announcements?
10:22:04 <cait> moving on
10:22:10 <cait> #topic Update on releases
10:22:27 <cait> hm no rm, any rmaints?
10:23:53 <cait> ok, 16.05 has been released
10:24:07 <cait> packages are available, but i think without the packages for elastic so far
10:24:54 <cait> there are quite a few problems when you try to install Koha on Ubuntu 16.04 right now - because of the newer MySQL version (5.6+) - but there are quite a few patches underway to help with that
10:25:10 <cait> does someone want to add something?
10:25:54 <cait> anyone still awake?
10:26:05 <cait> #topic KohaCon16
10:26:18 <davidnind> yep, still awake...
10:26:24 <cait> kohacon16_organizers++
10:26:31 <cait> auth_library++ ikourmu++
10:26:37 <drojf> good kohacon, would go again
10:26:39 <thd> Still not quite asleep but not quite awake here.
10:26:40 <mveron> streaming ++
10:26:59 <cait> overall very good organization
10:27:10 <davidnind> streaming+++ worked really well
10:27:22 <cait> lots of interesting presentations - I can recommend watching the videos! :)
10:28:32 <mveron> http://www.livemedia.com/kohacon16
10:28:40 <cait> #link http://www.livemedia.com/kohacon16
10:28:42 <drojf> #link http://www.livemedia.com/kohacon16
10:28:44 <drojf> hmpf
10:28:50 <cait> heh
10:28:52 <cait> ok
10:28:56 <cait> moving on?
10:28:56 <Diman> #info Dimitris Antonakis, Athens, Greece
10:29:03 * cait waves :)
10:29:18 <cait> #topic KohaCon17
10:29:34 <cait> #info drojf sent a reminder to the list asking for more bids
10:29:38 <cait> drojf++
10:29:49 <drojf> two bids, only one valid if we go with the continent switching thing
10:29:54 <cait> correct
10:30:05 <drojf> we need to set a deadline
10:30:10 <drojf> or have we done that already?
10:30:22 <cait> #info curently one bid for 2016: Manila, Philippines
10:30:26 <cait> no i think we haven't
10:30:46 <drojf> i think we used to do that septemberish?
10:30:55 <drojf> end of september, or is that too late?
10:31:05 <cait> the urrent bid is for september
10:31:11 <cait> so in that case it would probably be ok
10:31:14 <schnydszch> #info we can make it earlier
10:31:20 <cait> it depends if another would want to make it earlier
10:31:30 <cait> schnydszch: conf or vote?
10:31:49 <schnydszch> the 2017 conf, at least for our bid
10:31:53 <schnydszch> for the Philippines bid
10:31:59 <drojf> i think we had september last year and that worked fine for a conference in june
10:32:29 <mveron> Yes, last time was voting in september: https://wiki.koha-community.org/wiki/KohaCon16_Proposals
10:32:50 <cait> ij
10:32:57 <cait> sorry, fingers wrong on the keyboard
10:32:58 <schnydszch> June will be fine, still Summer during that time in the Philippines, well, climate change-thing
10:33:10 <drojf> thanks mveron, just looked it up
10:33:27 <drojf> so end of august maybe for deadline
10:33:28 <cait> which date are we discussing?
10:33:35 <cait> deadline for bids, deadline for vote?
10:33:42 <schnydszch> I'm speaking of our bid, sorry
10:33:56 <drojf> " bidding for Kohacon 2016 locations will end one week after the August 2015 general IRC meeting. If you want to host Kohacon 2016, add your proposal to the wiki[1] now and announce it on the general mailing list, so people know about it.  No proposals will be accepted after 12 August 2015, 22 UTC."
10:34:01 <drojf> from last year
10:34:18 <drojf> it was earlier than i thought
10:34:45 <drojf> we could just go with the "one week after august meeting"
10:34:56 <drojf> so we would have two more meetings before
10:35:10 <drojf> does that make sense?
10:35:22 <cait> ok
10:35:26 <mveron> I think so
10:35:29 <cait> but the date won't be set then until the meeting
10:35:35 <cait> maybe we should set an august date to make things easier
10:35:58 <cait> and with timezones... probably should be clear :)
10:36:18 <drojf> i don't think that is a problem really if we set it with the meeting date at the next meeting?
10:36:38 <cait> ok
10:36:44 <drojf> next meeting we agree on the general irc meeting date for august, plus one week for bids. should work?
10:36:51 <cait> i am logging an agreed if noone is against it?
10:36:53 <drojf> and its anounced > a month before
10:37:04 <drojf> we could vote on it
10:37:18 <cait> #agreed the deadline for bids will be one week after the august meeting - exact date to be set next meeting
10:37:23 <thd> Did my connection die again?
10:37:28 <cait> you didn't leave
10:38:28 <drojf> ok then we have to get the voring thing done soon :P
10:38:31 <drojf> voring
10:38:34 <drojf> arrrr
10:38:38 <drojf> voting
10:39:05 <cait> the decision? yes
10:39:07 <cait> next meeting
10:39:20 <cait> could we do a vote about the vote? ;)
10:39:34 <drojf> we should vote today for two general options
10:39:45 <drojf> so we have it easier next time
10:39:46 <cait> i don'rt care so much about the mechanism we choose, but it hink it shoudl be clear before the voting begins
10:39:50 <cait> ok
10:39:56 <cait> so can you presentt he 2 general options quickly?
10:40:03 <mveron> https://wiki.koha-community.org/wiki/Processes_for_KohaCons
10:40:11 <cait> #link  https://wiki.koha-community.org/wiki/Processes_for_KohaCons
10:41:01 <drojf> what we should decide today is: do we want to have a voring mechanism that distinguishes between "yes", "no" and "maybe", or only "yes" and "no"
10:41:15 <cait> hm ok
10:41:24 <cait> so we got 2 options: yes/no and yes/no/maybe ?
10:41:34 <drojf> and then choose the exact option next time. otherwise we will have 2 hours of discussions next time and nothing in the end. like always
10:41:51 <thd> That is a false distinction.
10:42:22 <drojf> you did not enter anything else. it is in the wiki and has been for at least two months
10:42:39 <thd> The options as described do not necessarily lead to the results presumed.
10:42:53 <drojf> i am not an expert in voting schemes, i just want to have some general rule how to set it up. before we start voting
10:42:59 <thd> I know, I have been helping a friend avoid eviction.
10:43:18 <thd> Where is slef when we need him?
10:43:42 <cait> he hasn't been around in quite a while
10:43:46 <drojf> and the only contribution from your side is that you say its not enough. and you helped a friend with their eviction. which is a very noble cause, but in no way related to koha and does not get us anywhere
10:43:48 <thd> I know :)
10:44:36 <drojf> sorry if that sounds rude, but the only person trying to get this anywhere is myself, because i might set upo the vote and THEN have people complaining they wanted a different scheme ;)
10:44:44 <mveron> IMO yes/no/maybe would work fine
10:44:51 <thd> All the options are underdescribed and thus prevent an informed vote on their face.
10:45:07 <drojf> nobody took the time to describe them any further
10:45:14 <drojf> its not going to happen until next time
10:45:22 <drojf> i brought that up right after the last vote
10:45:25 <drojf> and we never did
10:45:28 * cait nods
10:45:31 <cait> it's true
10:45:31 <wahanui> I saw it on Digg!
10:45:40 <cait> we have been discussing this since the last vote, we need to make a decision
10:46:03 <thd> I know I should have taken some time to at least link to a fuller discussion of comparable options on Wikipedia.
10:46:07 <drojf> the options i present are the basic options we discussed last time. or the main difference between them
10:46:25 <drojf> if you want to have other ones, there is plenty of time after the next vote :)
10:46:47 <drojf> no problem in making them better, but so far we have none
10:46:50 <drojf> and that is not enough
10:47:22 <thd> Reading the choices as described is not enough to understand how they work mathematically and omits how they are counted in every case.
10:47:58 <drojf> true, as that is not part of the choices atm
10:48:42 <cait> I don#t actually have the time to get into voting mechanisms to be honest
10:48:50 <drojf> nobody has
10:48:54 <cait> but it hink we need to be clear about what we will use, even if it's to the most ideal one
10:48:58 <drojf> that is why nobody has done it for a full year
10:49:02 <thd> Options 1, 2, and 4 are all score voting which can be easily gamed but would be good for building consensus over multiple votes.
10:49:47 <drojf> trust me, the more interesting gaming part is getting the fakes out of the votes
10:50:12 <drojf> the mechanism has not been relevant in both votes i managed
10:50:18 <drojf> but it could be of course
10:50:20 <thd> Option 3 is the only one although with many variants used in government elections.
10:51:16 <cait> hm whta i see would be like 3 options
10:51:23 <cait> y/n, y/n/m and rank
10:51:36 <cait> well rank all / don't rank all
10:51:37 <thd> There is no perfectly correct voting system possible but the problems of each should be at least linked.
10:52:19 <thd> If people are not forced to rank all then you have the equivalent of score voting.
10:53:29 <thd> If a significant number of 'fakes' would go undetected score voting may maximise the problem with fakes.
10:54:04 <thd> Forcing even 'fakes' to rank all options would reduce gaming.
10:54:40 <thd> However, If we would have only two options then there would be not much of an issue.
10:54:52 <drojf> so far we have 1
10:54:54 <drojf> lol
10:55:00 <cait> thd: the fakes are human
10:55:01 <cait> in our case
10:55:17 <cait> humans multiple voting
10:55:38 <cait> whatever scheme we choose, will be gameable, unless we remove fakes by ip/email address checking or similar
10:55:53 <thd> I know that the fakes we have had are humans ;)
10:56:56 <drojf> maybe a short question to the audience
10:57:02 <thd> The downside of score voting is if people do not vote honestly but vote strategically.
10:57:26 <davidnind> method first I think, then work out way to minimise fakes
10:57:27 <drojf> who here knows what they would choose, and who cares at all?
10:58:00 <thd> Strategic voting is most difficult with option 3 but would still need a counting method.
10:58:19 <cait> I feel like i might be missing something
10:58:31 * mveron has to leave - and would vote vor y/n/m
10:58:36 <cait> i am not sure what we try to prevent here
10:58:40 <mveron> Bye #koha
10:58:58 <cait> if i don't want to go to one locationand don't wnat to gvie it poitns - would that be strategic voting... and what is bad about it?
10:59:51 <thd> Have we always used some variant of option 3 in the past for KohaCon with the issue then being how we counted the votes?
11:00:31 <thd> The problem is only when some people vote strategically and others vote honestly.
11:00:44 <drojf> what does that mean?
11:01:10 <thd> It may be less of an issue if the range is only 1 and 0.
11:01:13 <davidnind> I don't really understand the nuance about 'strategic' voting, or voting 'honestly' -  vote is a vote?
11:01:14 <drojf> strategically vs honestly?
11:01:33 <LibraryClaire> hello
11:01:34 <magnuse> #info Magnus Enger, Libriotech, Norway
11:01:55 <drojf> hi LibraryClaire. we are in a meeting, you should introduce yourself
11:02:26 <thd> If I choose to vote strategically I would vote the maximum value permitted for my preferred choice and minimum for all others.
11:02:36 <LibraryClaire> #info Claire Gravely, UAL, UK
11:02:59 <cait> yeah.. but if you only woudl attend that one kohacon?
11:03:05 <cait> in that place?
11:03:12 <cait> i am not sure I understand why this is a bad thing in itself
11:03:30 <drojf> thd: yes, the question is kind of, do people want to have that or not. i am fine with all options, but we should have a rule. because so far, after the vote starts, people complain that it is the one way or the other
11:03:54 <drojf> and i dont see why i should not vote maximum for the one location i can go
11:04:01 <drojf> that is what people do
11:04:03 <thd> Honest voters who give every candidate due consideration have the strength of their vote diluted.
11:04:16 <drojf> what is honest about that?
11:04:24 <drojf> that term does not make any sense in that context
11:04:26 <bgkriegel> #info Bernardo Gonzalez Kriegel, Córdoba, Argentina
11:05:13 <drojf> hi bgkriegel
11:05:37 <thd> 'Honest' means in this case not disproportionately artificially lowering the vote given to lesser preferences.
11:05:44 <bgkriegel> hi drojf !
11:06:12 <cait> hi bernardo :)
11:06:31 <drojf> how is that more honest than vote for the place i wanna go and null for the others?
11:06:52 <thd> 'Strategic' voting boosts the overall strength of each strategic vote.
11:07:29 <thd> drojf: If that is your true position to give all weight to one candidate then voting that way is fine.
11:08:03 <cait> ok, so maybe first question is
11:08:05 <cait> do we want ranking?
11:08:13 <eythian> just use STV and be done with it unless there's only a couple of options in which case it doesn't matter anyway, it's not really a matter that requires so much wasted time discussing it.
11:08:16 <cait> or do we want to say yes/no/(maybe)
11:08:18 <thd> The problem comes when others do not express their vote as strongly and consequently have their vote diminished in the counting.
11:08:29 <cait> eythian: what is stv?
11:08:45 <thd> We have always used ranking in some form for voting on KohaCon.
11:08:50 <cait> not true
11:08:53 <cait> we had yes/no last time
11:08:59 <eythian> cait: order your preferences from 1 to n, or similar.
11:09:08 <thd> Almost always :)
11:09:28 <drojf> i am fine with ranking all, i just want a decision :P
11:09:37 <drojf> before the vote is conducted
11:09:52 <drojf> we can just choose to go with that if its what people prefer
11:10:12 <cait> eythian: so that's rank all then?
11:10:18 <drojf> and who wants to veto has to write a 20 page proposal for next year
11:10:28 <thd> I would like to suggest ranking with the same counting method used in the Debian community.
11:10:40 <drojf> what counting method may that be?
11:10:43 <eythian> cait: I think it's usually implemented as being allowed to skip, but it doesn't matter.
11:10:52 * thd checks.
11:10:56 <drojf> it does matter
11:11:04 <eythian> everyone loves bikeshedding voting discussions.
11:11:05 <drojf> because that will be the point people complain about then :P
11:11:15 <drojf> ok. proposal:
11:11:29 <cait> ok
11:11:41 <cait> so lets vote ranking or yes/no/(maybe) to limit this down a bit
11:11:51 <davidnind> my view - keep as simple as possible: either yes/no, or rank options from 1 to 3 for example if three proposals
11:11:57 <cait> #startvote Which voting method do you prefer? (rank, options)
11:11:57 <huginn`> Begin voting on: Which voting method do you prefer? Valid vote options are , rank, options, .
11:11:57 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
11:12:04 <drojf> two votes. first: yes/whatever/no or ranking. second: depending on first: yes/no or yes/maybe/no OR ranking/all or ranking/skip
11:12:06 <cait> #vote rank
11:12:31 <drojf> #vote rank
11:12:52 <LibraryClaire> #vote rank
11:13:00 <davidnind> #vote rank
11:13:05 <khall> #vote rank
11:13:06 <eythian> #vote rank
11:13:15 <thd> #vote rank
11:13:20 <Diman> #vote rank
11:13:22 <cait> waiting a few more seconds...
11:13:28 <schnydszch> #vote rank
11:13:38 <indradg> #vote rank
11:13:55 <cait> #endvote
11:13:55 <huginn`> Voted on "Which voting method do you prefer?" Results are
11:13:55 <huginn`> rank (10): LibraryClaire, davidnind, cait, eythian, khall, indradg, thd, drojf, Diman, schnydszch
11:14:05 <cait> #agreed the voting mechanism will be 'ranking'
11:14:06 <druthb> o/
11:14:14 <drojf> look, that was easy
11:14:15 <khall> hi druthb!
11:14:25 <cait> ok, now rank all or rank the one you want to go to?
11:14:26 <drojf> so do all vs skip and we are done :)
11:14:27 <thd> Debian uses the Condorcet method with a Schulze count if I am not mistaken.
11:14:29 <druthb> hiyas.
11:14:34 <cait> or all vs skip yep
11:14:53 <cait> #startvote Do you want to rank all (all) or be able to not rank those you wouldn't be able to attend (skip) (all,skip)?
11:14:53 <huginn`> Begin voting on: Do you want to rank all (all) or be able to not rank those you wouldn't be able to attend (skip) (all,skip)? Valid vote options are Yes, No.
11:14:53 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
11:15:00 <thd> If you do not rank all then you have score voting.
11:15:18 <thd> You do not have rank voting if you do not rank all.
11:15:24 <thd> https://en.wikipedia.org/wiki/Condorcet_criterion
11:15:43 <davidnind> #vote all
11:15:44 <cait> #vote all
11:15:48 <LibraryClaire> #vote all
11:15:51 <thd> #vote all
11:16:00 <schnydszch> #vote all
11:16:10 <Diman> #vote all
11:16:23 <thd> Ranking only one reduces to 'strategic' score voting.
11:16:53 <cait> ending vote in a quick moment
11:17:11 <cait> #endvote
11:17:11 <huginn`> Voted on "Do you want to rank all (all) or be able to not rank those you wouldn't be able to attend (skip) (all,skip)?" Results are
11:17:25 <cait> #agreed The ranking will require to rank all bidders/locations.
11:17:31 <thd> https://en.wikipedia.org/wiki/Schulze_method
11:17:34 <drojf> thanks
11:17:44 <drojf> that was easy. only took 8 months :P
11:17:52 <cait> shouldn't ask - but is the points given to each clear then?
11:18:13 <thd> The count is not clear without specifying.
11:18:16 <eythian> cait: what is your question?
11:18:18 <drojf> we have not discussed that. :P
11:18:51 <cait> eythian: how points will be given
11:19:09 <eythian> cait: ranking is not allocating points
11:19:09 <cait> i think we shoudl discuss counting at the nextmeeting tho
11:19:41 <drojf> eythian: you could count more points for rank 1 than rank 2.
11:19:44 <cait> eythian: how do you see who won?
11:20:10 <eythian> drojf: no, that's not how you do it
11:20:20 <eythian> a meeting is not the place for this though :)
11:20:32 <drojf> eythian: its possible and a thing people do
11:20:56 <drojf> but we reached the decision for today. if anyone wants to bring that up next time, alright. i would not ;)
11:21:26 <drojf> next topic? :)
11:21:54 <thd`> What just happened?  My connection dropped.
11:22:13 <thd`> We still need a counting system.
11:22:49 <thd`> I suggest https://en.wikipedia.org/wiki/Schulze_method which is used by Debian and some other software communities.
11:22:51 <cait> phone
11:22:55 <cait> #chair drojf
11:22:55 <huginn`> Current chairs: cait drojf
11:24:36 <davidnind> My opinion - way to complicated for what we are trying to achieve + we have  already voted
11:25:17 <davidnind> This is my summary with an example of what we voted for: example 3 choices (proposals) - rank 1, 2 and 3 for the 3 options however you choose (have to rank all), proposal with the highest count 'wins'?
11:26:03 <thd``> The counting method can actually change the outcome in ranked voting so it is important to use one which seems to give a fair result expressing people's actual preferences in as wide a range of actual circumstances as possible.
11:26:18 <drojf> oh why did i become chair? cait gone?
11:26:21 <drojf> ah phone
11:26:25 <drojf> ok next topic
11:26:25 <wahanui> hmmm... next topic is a tricky one...
11:26:27 <thd``> I am having real trouble staying connected today.
11:27:10 <drojf> we had a lot of fakes last time, and the question was, if we would take more info this time for people voting
11:27:49 <thd> Do we still lack a counting method for ranked voting?  Are we deferring the issue of counting method?
11:28:08 <drojf> so far we only had an email address (and ip addresses and referrers). do you consider it good or bad to also get the name and maybe institution of people voting?
11:28:36 <drojf> i would like to do that (if i conduct the vote), because its way more work for fakes. the will still be there of course
11:29:35 <drojf> but i would be interested in your opinion about it. any cons?
11:30:11 <thd> We should collect as much brief information as we can reasonably and privately without overburdoning the process for everyone.
11:30:19 <cait> institution would leave out people interested comeing 'themselves' maybe
11:30:25 <cait> still phone sorry
11:30:26 <eythian> just so long as it would be clear that it's OK for anyone not attached to an institution to have a procedure
11:30:50 <davidnind> some people are not part of organisations, so could be optional
11:31:07 <drojf> good point
11:31:18 <thd> A note would be needed for institution allowing none, blank, individual, or some equivalent.
11:31:44 <drojf> if it's ok to have none, it's probably not worth bothering some about it?
11:32:53 <eythian> could you check for a valid email, or does that then become a Lot More Work?
11:33:01 <thd> How advantageous might such a field be for identifying fakes or encouraging people to be honest and avoiding fakes in the first place?
11:33:02 <drojf> ok. i would not vote on that. if necessary we could do that next time. just think about it
11:33:32 <drojf> eythian: valid email format yes, valid email like click a link in the email probably not, and not worth it
11:33:43 <drojf> in my experience people just use work and private email
11:33:47 <drojf> or several of those
11:33:50 <eythian> true
11:34:13 <davidnind> the joys of 'online voting'!
11:34:25 <drojf> thd: if you can leave it blank, probably not so much. i can't assume somebody to be more of a fake for not filling a non-required field
11:34:42 <drojf> and they could just put whatever anyway
11:34:48 <drojf> i'll think about it for next time
11:34:56 <drojf> moving on?
11:35:03 <davidnind> yes please
11:35:42 <drojf> #topic Actions from General IRC meeting 6 April 2016 (deferred) and General IRC meeting 4 May 2016 (none)
11:35:44 <thd> However, would people be discouraged from faking or hesitate to fake from having the question of institution put to them?
11:35:45 <drojf> there seem to be none
11:35:52 <drojf> that was the last point on the agenda
11:36:02 <drojf> we need a date for next time
11:36:11 <drojf> #topic next meeting
11:36:35 <eythian> http://www.scientificamerican.com/article/how-the-illusion-of-being-observed-can-make-you-better-person/ <-- just put a giant eye on the page
11:36:36 <drojf> july 6, 20 UTC?
11:37:09 <drojf> please do a +1 or something ;)
11:37:50 <bgkriegel> +1
11:37:53 <drojf> waiting for another minute or its decided ;)
11:38:07 <davidnind> +1
11:38:20 <LibraryClaire> +1
11:38:33 <davidnind> something :)
11:38:38 <drojf> #agreed next meeting july 6, 20 UTC
11:38:41 <drojf> #endmeeting