20:01:33 <kidclamp> #startmeeting Development IRC meeting 11 January 2017
20:01:33 <huginn`> Meeting started Wed Jan 11 20:01:33 2017 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:33 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:33 <huginn`> The meeting name has been set to 'development_irc_meeting_11_january_2017'
20:01:45 <kidclamp> #info Nick Clemens, ByWater Solutions
20:01:56 <khall> #info Kyle M Hall, ByWater Solutions
20:01:59 <rangi> #info Chris Cormack, Catalyst IT
20:02:29 <thd> #info Thomas Dukleth, Agogme, New York City
20:02:32 <cait> #info Katrin Fischer, BSZ, Germany
20:02:53 <LibraryClaire> #info Claire Gravely, BSZ, Germany
20:02:53 <davidnind> #info David Nind, Wellington, New Zealand
20:02:56 <drojf> #info Mirko Tietgen, Berlin, Germany
20:03:05 <reed_> #info Reed Wade, prev Catalyst IT
20:03:12 <josef_moravec> #info Josef Moravec, Municipal LIbrary Usti nad Orlici, Czech Republic
20:03:32 <Joubu> #info Jonathan Druart, France
20:04:43 <nuentoter> #info
20:04:52 <kidclamp> seems like a full house
20:05:12 <kidclamp> #topic Announcements
20:05:15 <nuentoter> #info Justin Martin, Abel J. Morneault memorial library, United States
20:05:56 <kidclamp> #info PR koha-dashboard to display an "overall health status"
20:06:03 <kidclamp> want to explain Joubu?
20:06:06 <Joubu> I have just sent a PR to Chris for the dashboard
20:06:23 <cait> ah, PR = Pull request?
20:06:24 <Joubu> the goal is to have a new section to quickly display the "hot" bug report
20:06:32 <Joubu> cait: yep
20:06:37 <cait> Joubu++
20:06:40 <Joubu> the crit/blocker/maj
20:06:49 <Joubu> in NEW, NSO, SO, PQA
20:06:55 <kidclamp> Joubu++
20:06:57 <Joubu> to know what is important
20:07:00 <rangi> it seems good to me so far, ill probably merge it after/during the meeting
20:07:11 <Joubu> it's just a quick start, to get feedbacks
20:07:22 <cait> i have noticed the build statuses have been broken for a while
20:07:23 <josef_moravec> Joubu++
20:07:28 <LibraryClaire> Joubu++
20:07:29 <cait> not sure why and if someone has looked into it?
20:07:32 <rangi> yes
20:07:37 <rangi> its brokne on jenkins end
20:07:46 <Joubu> rangi: I have just tried it with a 6 months old DB, so had to tweak a bit
20:07:51 <cait> ah, that's not good then
20:08:21 <Joubu> The BibLibre server hosting Jenkins has not been correctly updated
20:08:28 <Joubu> If I understood correctly
20:08:31 <Joubu> je
20:08:37 <rangi> im not sure, tcohen knows
20:08:40 <Joubu> jenkins.theke.io is the good one
20:08:48 <Joubu> but we did not manage to get the status icons back
20:08:52 <rangi> yeah i think its pointing there now
20:09:07 <rangi> (the dns
20:09:08 <rangi> )
20:09:28 <rangi> https://jenkins.koha-community.org/  is jenkins.theke.io
20:09:31 <Joubu> ha yes indeed!
20:09:33 <rangi> i switched the dns
20:09:48 <Joubu> so it's just the badges plugin, we did not manage to configure it correctly apparently
20:09:56 <rangi> however this is still broken
20:09:58 <kidclamp> so it is broken tests then that need fixed/
20:09:59 <rangi> https://jenkins.koha-community.org/job/Koha_Master_D8//badge/icon
20:10:00 <kidclamp> ?
20:10:15 <Joubu> rangi: yep, this one :)
20:10:24 <rangi> kidclamp: there are failing tests too
20:10:33 <rangi> kidclamp: but this is more about the icons not showing on the dashboard
20:10:44 <Joubu> so yes, we have failures: https://jenkins.koha-community.org/job/Koha_Master_D8/lastCompletedBuild/testReport/
20:10:52 <cait> in 16.11. i might need some help to find the problem - usually the tests failing on jenkins are passing for me locally
20:10:57 <Joubu> but it's getting to far :)
20:11:05 <cait> same for the current one in decreaseloanperiod tests
20:11:39 <kidclamp> #info Badges are broken on Jenkins and there are some failing tests
20:12:03 <kidclamp> Anything to do here or just info?
20:12:36 <Joubu> just time and synchro with tcohen to fix the badges
20:12:43 <Joubu> I can take a look at the failing tests tomorrow
20:12:55 <rangi> Joubu: http://dashboard.koha-community.org/
20:12:56 <wahanui> http://dashboard.koha-community.org/ are the better stats to optimise
20:12:56 <Joubu> unless someone wants to do it...
20:13:09 <rangi> needs some styling, but otherwise works
20:13:15 <kidclamp> #topic Review of coding guidelines
20:13:19 <cait> Joubu++
20:13:35 <kidclamp> I didn't follow up on my action until today so tabling until next meeting
20:13:36 <Joubu> rangi: thanks. And so you can click on the "Overall health status" header
20:13:40 <Joubu> to open the details
20:13:56 <kidclamp> please comment on the list for discussion
20:14:56 <kidclamp> #topic Progress on next release (17.05)
20:15:12 <kidclamp> khall?
20:15:13 <wahanui> khall is, like, volunteering to come over and fix it for you, it seems. ;)
20:15:35 <khall> Same old, pushing patches as they pass qa
20:15:50 <barton> #info Barton Chittenden, BWS (Louisville, KY, USA, Earth, SOL)
20:15:52 <khall> we're making good progress on unifying all the payment subroutines!
20:16:50 <caboose__> #info Michael Cabus, BWS (Princeton, NJ, USA)
20:16:52 <khall> Of note, I imagine bug 16239 will trigger much patch rebasing once it is pushed
20:16:52 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16239 enhancement, P5 - low, ---, josef.moravec, Passed QA , Upgrade Bootstrap in the staff client
20:17:07 <khall> I think I will hold off until friday and make it the final push of the day
20:17:25 <khall> that is all ; )
20:17:38 <rangi> that will be nice to get in there
20:17:38 <kidclamp> #info Kyle will push bug 16239 on Friday - this will cause some other bugs to need rebasing - be aware
20:17:49 <kidclamp> Anything on 16.11 cait?
20:17:57 <cait> hm
20:18:01 <cait> string freeze is on Sunday
20:18:09 <cait> i will be sending an email to the mailing list
20:18:20 <kidclamp> #topic Progress on current release (16.11)
20:18:22 <cait> so 16.11.2 is already coming up fast again
20:18:35 <cait> I'd love to see the problem in catalouging with authorised values fixed
20:18:36 <kidclamp> #info string freeze coming, cait will email the lists
20:18:58 <cait> Joubu: do you happen to have the bug number?
20:19:13 <Joubu> 17817
20:19:17 <Joubu> bug 17817
20:19:17 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17817 critical, P5 - low, ---, jonathan.druart, Needs Signoff , Repeat this Tag (cloning) not working
20:19:18 <cait> thx!
20:19:34 <kidclamp> #help please look at bug 17817 before 16.11.2
20:19:40 <cait> there might be others, I have to catch up a bit with things pushed and reported
20:19:47 <josef_moravec> I am planning to sign off on 17817
20:20:20 <kidclamp> josef_moravec++
20:20:29 <kidclamp> #topic General development discussion
20:20:43 <kidclamp> #info Roadmap for The TT syntax for notices?
20:20:52 <Joubu> Yes, I'd like to know who is willing to help with that
20:21:05 <Joubu> we need a roadmap if we want everything ready for the next release
20:21:16 <josef_moravec> Joubu: what is needed?
20:21:26 <Joubu> if we do not get people to contribute, I will postpone
20:21:37 <khall> I am willing and able, of course
20:21:38 <LibraryClaire> what sort of help?
20:21:51 <rangi> we might be able to do something, but it all depends on whatever work falls on our plates
20:21:52 <Joubu> first need to know who wants to contribute :)
20:22:00 <Joubu> any kinds of help
20:22:00 <josef_moravec> I like the idea of TT syntax, so when I was able to help, I'd like to
20:22:09 <kidclamp> I would like to see it happen so willing to help
20:22:16 <cait> testing and documenting I can help with a bit
20:22:22 <Joubu> ok perfect :)
20:22:33 <cait> Joubu: i saw there is also a patch about translating notices
20:22:36 <LibraryClaire> I am willing to help if it is something I can help with
20:22:38 <Joubu> so we are too many now  :p
20:22:46 <barton> I created a notices and slips library: https://wiki.koha-community.org/wiki/Notices_and_Slips_Library
20:22:48 <cait> will they crash or can we make it both work?
20:23:09 <barton> ... I was thinking that would be a good place to put example TT notices.
20:23:35 <Joubu> yep definitely
20:23:50 <barton> I'll be happy to do some wiki wrangling.
20:23:53 <Joubu> both will work
20:24:01 <cait> cool
20:24:07 <kidclamp> is there a list of bugs to prioritize?
20:24:25 <Joubu> there is only 1 bug (not pushed yet) which provide a TT version of the notice
20:24:42 <Joubu> but it's not possible to make it work with our "old" syntax
20:24:59 <cait> hm?
20:24:59 <khall> basically, we need a bug/patch for each notice
20:25:09 <Joubu> kidclamp: yes, will do that next week
20:25:20 <rangi> whats the plan to deal with all the notices created locally?
20:25:40 <Joubu> no plan, they will still work
20:25:57 <rangi> so both syntaxes will work?
20:25:59 <Joubu> both syntaxes will be supported
20:26:05 <rangi> good
20:26:11 <Joubu> it's already like that actually :)
20:26:14 <cait> +1
20:26:17 <Joubu> we are just making it the default
20:26:40 <cait> that will us also give time to fix stuff we might have missed
20:27:54 <kidclamp> #info many willing to help on this, we need to convert all the default notices
20:27:55 <barton> khall -- your "bug/patch for each notice" ... that's essentially going to be adding new default notices to the database?
20:28:03 <kidclamp> #info more info on the list next week
20:28:11 <kidclamp> #topic Benchmark?
20:28:19 <khall_> Barton yep
20:28:20 <Joubu> barton: yes
20:28:39 <Joubu> yes, benchmarks, I'd like to get feedbacks
20:28:44 <Joubu> everybody complains where it's slow
20:28:48 <Joubu> but nobody when it's better
20:29:01 <Joubu> (ok it's the expected behavior :))
20:29:06 <drojf> you want people to complain?
20:29:23 <Joubu> but I make things really easy to replay the scripts
20:29:30 <Joubu> and see if my numbers are confirmed
20:29:33 <rangi> :)
20:29:45 <Joubu> I only have 1 laptop, I cannot play it on different machines
20:29:57 <thd> s/complain/report/g
20:30:03 <kidclamp> #info we need more people to replay the benchmarks and report results
20:30:18 <kidclamp> (or clone Joubu)
20:30:21 <Joubu> (it was a when, not where, typing to fast)
20:30:36 <Joubu> so basically, just try and follow the README
20:30:39 <cait> Joubu++ (again :))
20:30:47 <Joubu> I know nobody test because there is a bug I did not fix
20:30:50 <Joubu> (...)
20:31:32 <kidclamp> sneaky
20:31:33 <Joubu> If you are fine with my graphs, you can also trust me if you prefer
20:32:22 <Joubu> kidclamp: you can move on I think :)
20:32:28 <kidclamp> was just going to :-)
20:32:35 <kidclamp> #topic Updates from the QA team
20:32:45 <kidclamp> #info where are the QAers?
20:32:45 <Joubu> That way I can continue to complain
20:32:48 <rangi> i think what we have learned
20:32:58 <thd> Joubu: You seem to suggest that you trust yourself better with confirmation ;)
20:33:05 <rangi> is that having a QA manager (well having cait really) was incredibly useful
20:33:18 <kidclamp> 'tis true
20:33:28 <khall_> Indeed
20:33:47 <Joubu> thd: I have a laptop, not a dedicated server. Not the best env to benchmark
20:34:10 <Joubu> About the QA, I wanted to highlight that bug 17817
20:34:10 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17817 critical, P5 - low, ---, jonathan.druart, Needs Signoff , Repeat this Tag (cloning) not working
20:34:28 <Joubu> was waiting since 2017-01-03 for a QA
20:34:34 <Joubu> which was very easy
20:34:34 <nuentoter> Sorry, was busy, what do I need to do to help benchmark? I have 4 computers to spare
20:34:43 <Joubu> it is a critical one, and affect stable release
20:34:56 <Joubu> I don't think it is normal
20:35:23 <Joubu> (it's not the first time it happens)
20:35:55 <Joubu> I hope that the new stuff I added to the dashboard will permit to highlight that better
20:36:17 <Joubu> but QAers should be able to find the bugs which are important to QA
20:36:29 <kidclamp> #help QA team should be checking critical bugs frequently and keep them moving
20:37:54 <Joubu> nuentoter: the entry point is https://wiki.koha-community.org/wiki/Benchmark_for_16.11
20:38:04 <kidclamp> #info Help for refactoring
20:38:54 <kidclamp> Do you have anything specific to add Joubu or just a call on those bugs?
20:39:23 <Joubu> Well I did not want to monolog, I don't think it's useful to re-explain these bugs
20:39:41 <Joubu> they are omnibus or big refactoring
20:39:42 <rangi> i reckon
20:39:43 <Joubu> if you want to help
20:39:54 <kidclamp> 17196 I did a QA pass, only didn't mark because tcohen had said he was going to look so waited for him
20:40:05 <rangi> that we need to get master passing all tests cleanly and for a week or two
20:40:11 <kidclamp> and marcel is looking too now I believe
20:40:25 <rangi> before we push anymore refactoring
20:40:30 <Joubu> kidclamp: yes, better to get 2 on this one :)
20:40:31 <Joubu> even 3
20:40:47 <cait> bug 17196
20:40:47 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17196 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Move marcxml out of the biblioitems table
20:41:16 <kidclamp> that will break many reports, but should be an improvement in other areas
20:41:35 <rangi> if we cant have confidence in the tests, it makes it very hard for me to be confident in the refactored code
20:41:39 <Joubu> rangi: the 3 failures on master seems trivial to fix
20:41:40 <cait> hm could we mark reports breaking?
20:41:56 <cait> like ... amen dthe title?
20:42:02 <cait> or give a warning int he update process?
20:42:14 <rangi> also refactoring doesnt break things, so maybe just call it rewriting :)
20:42:30 <kidclamp> heh
20:43:09 <kidclamp> some of these want to get in early so we have time to fix before release though, so don't want to wait too long
20:43:16 <Joubu> what is broken?
20:43:16 <wahanui> it has been said that broken is not what we want.
20:43:21 <kidclamp> in case of anything we do miss
20:43:38 <rangi> (only half joking, refactoring should not change any functionality, sounds like we plan to change reports functionality, hence that is a rewrite)
20:43:43 <barton> cait: I think that it should be fairly easy to add warns on the update process.
20:43:53 <cait> yeah both would not be hard
20:44:17 <cait> i think it would be nice to have a visual clue, that the report needs to be fixed
20:44:22 <Joubu> we can also say that 17196 is a bug fix :)
20:44:29 <barton> FWIW, I think most of the broken reports should be pretty easy to fix.
20:44:41 <kidclamp> generally it just requires a join to the metadata table
20:44:56 <cait> i know
20:45:05 <cait> i just was wondering if we could make the work of fixing them easier for the library
20:45:12 <cait> like helping to spot the ones that need to be fixed
20:45:21 <drojf> thats a lot of magic for people that copied a report from the wiki once in their life
20:45:22 <barton> right... and in most cases, it's probably going to be a matter of s/biblioitems/metadata/g
20:45:25 <kidclamp> Add to release notes a report to find all reports containing 'marcxml'
20:45:58 <Joubu> kidclamp: that even should be added to the update DB entry
20:46:29 <cait> yeah, that was the kid of thing i was thinkig of :)
20:46:36 <cait> or we could add a FIXME in front of the report title?
20:47:03 <drojf> if we change the title we can just change the report
20:47:08 <cait> but the report is a good idea
20:47:09 <Joubu> FF tells me that there is more than 100 matches of "marcxml" on https://wiki.koha-community.org/wiki/SQL_Reports_Library
20:47:12 <cait> drojf: i tihnk we can't savely
20:47:14 <drojf> or make a copy that regexes it right
20:47:15 <cait> too many different ways to do it
20:47:21 <cait> you have to do a new join
20:47:26 <barton> we'll also need to update https://wiki.koha-community.org/wiki/SQL_Reports_Library
20:47:37 <drojf> we got a wiki curator for that, right
20:47:42 <cait> i don't think automatically rewriting the reports is an easy task
20:48:11 <drojf> i was not volunteering, that's for sure :P
20:48:14 <kidclamp> cait: agreed - everyone writes reports differently, trying to fix is likely to break more :-)
20:48:25 <barton> cait: in it's most generic form, I think you're right.
20:48:33 <kidclamp> I think a warning in release notes, database udpate, and on the wiki should cover things pretty well
20:48:52 <Joubu> how could we fix the wiki page?
20:49:09 <Joubu> if we have only 1 version, it won't work for older stables
20:49:26 <Joubu> if we have 2 versions, the wiki page will be...gigantic
20:50:00 <cait> we could move the catalouging reports out
20:50:07 <kidclamp> I think just add to the section for querying marc a pre17.05 and post 17.05 section
20:50:08 <cait> on a separate page - and say 17.05+
20:50:23 <cait> the page already loads forever, might be good to start splitting it up that way
20:50:31 <kidclamp> someone was moving all the reprt sections to their own pages weren't they?
20:51:10 <drojf> which is annoying for just searching through all of them. but maybe that is just my approach to mysql :P
20:51:16 <barton> kidclamp: yeah, there's a note from Brooke, but I don't know where the new pages are.
20:51:19 <cait> i think no progress there for a while
20:52:50 <barton> It wouldn't be hard to actually refactor the page into sections and just have https://wiki.koha-community.org/wiki/SQL_Reports_Library be a list of links to the pages...
20:52:59 <barton> but that's off topic.
20:53:02 <kidclamp> volunteering barton?
20:53:25 <kidclamp> I will put a call out on the list and see if we can enlist help/ideas
20:53:33 <kidclamp> (and I will do it sooner rather than later)
20:53:49 <barton> kidclamp: If we can figure out how we're going to handle the 17.05+ reports, yes.
20:54:10 <kidclamp> #action kidclamp will email the list for help in preparing reports affected by bug 17196
20:54:10 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17196 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Move marcxml out of the biblioitems table
20:54:14 <davidnind> I am happy to work on this, including putting  together some initial ideas and plan to address the current challenges
20:54:27 <cait> davidnind++
20:54:29 <LibraryClaire> i think adding a new page for 17.05+ reports and linking to them from the current ones isn't a bad plan
20:54:36 <kidclamp> you want to send out the note davidnind
20:54:37 <kidclamp> ?
20:54:50 <kidclamp> davidnind++
20:54:52 <davidnind> kidclamp: will do
20:55:15 <rangi> anyone know what happened with https://wiki.koha-community.org/wiki/Mana_central_database
20:55:21 <barton> davidnind: very good. Ping me when you've got a plan; I can copy the reports library into vim and hack and slash.
20:55:22 <kidclamp> #action nvm, davidnind will send out the note about reports
20:55:27 <kidclamp> (he is kidclamp's new favorite)
20:55:36 <rangi> because if the reports were going to end up in there, they could be versioned pretty easily
20:55:57 <kidclamp> I think Pual just announced a new staffer working on Mana
20:56:07 <Joubu> rangi: Paul announces the arrival of a new intern at BibLIbre for 6 months
20:56:08 <drojf> rangi: i think the new biblibre intern is going to work on it?
20:56:20 <rangi> id make sure you talk with them then, to make sure that they think about versioning reports
20:56:23 <cait> jinx? :)
20:56:26 <kidclamp> #topic Next Meeting
20:56:41 <davidnind> barton: thanks
20:56:42 <kidclamp> tcohen said he wanted more of these meetings, so two weeks out?
20:56:55 <Joubu> rangi: yes, we talked about that at the hackfest in Marseille
20:57:17 <kidclamp> January 25th at 13 UTC?
20:57:47 <LibraryClaire> fine by me
20:58:02 <Joubu> cal
20:58:05 <Joubu> oops
20:58:20 <Joubu> yep
20:58:51 <kidclamp> #info Next meeting is 25 January 2017, 13 UTC
20:58:58 <cait> kidclamp++
20:59:00 <kidclamp> #endmeeting