#koha: Development IRC meeting 13 December 2017

Meeting started by kidclamp at 14:00:42 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:00:48)
    1. wahanui, a bot that has become sentient (wahanui, 14:00:48)
    2. Jon Knight, Loughborough University (greenjimll, 14:00:58)
    3. Nick Clemens,ByWater Solutions (kidclamp, 14:01:05)
    4. Claire Gravely, BSZ Germany (LibraryClaire, 14:01:18)
    5. Jonathan Druart (Joubu, 14:01:41)
    6. Josef Moravec, Municipal Library UO, Czech Republic (josef_moravec, 14:01:55)
    7. Fridolin Somers, Biblibre France (fridolin, 14:02:39)
    8. Thomas Dukleth, Agogme, New York City (In California for the end of the year) (thd, 14:02:44)
    9. Victor Grousset, Biblibre, France (tuxayo, 14:02:59)
    10. Julian Maurice, BibLibre (jajm, 14:03:32)

  2. Announcements (kidclamp, 14:03:47)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_December_2017 (Joubu, 14:04:06)
    2. Alex Arnaud, Biblibre France (alex_a, 14:04:07)
    3. Katrin Fischer, BSZ, Germany (cait, 14:04:35)

  3. Update from the Release manager (18.05) (kidclamp, 14:05:36)
    1. Joubu is pushing all the things. QA more stuff, more stuff gets pushed. (kidclamp, 14:07:24)
    2. Claire Hernandez, BibLibre (clrh, 14:07:38)
    3. Owen Leonard, Athens County Public Libraries, USA (oleonard, 14:08:42)
    4. let Joubu know if you have projects so you can coordinate on what is needed (kidclamp, 14:09:06)
    5. https://wiki.koha-community.org/wiki/Elasticsearch_status#Elasticsearch_status_.28Updated_2017-12-07.29 ES status (kidclamp, 14:10:07)
    6. ES, JS updates, benchmarking, selenium tests are some golas for 18.05 (kidclamp, 14:12:02)
    7. also REST API and manual (kidclamp, 14:13:14)

  4. Updates from the Release Maintainers (kidclamp, 14:13:46)
    1. 17.11 string freeze on 15th, pushing things now (kidclamp, 14:14:45)
    2. 17.05 waiting on 17.11 and pushing some others (kidclamp, 14:16:00)

  5. Updates from the QA team (kidclamp, 14:18:07)
    1. QA needs help with auth testing and tutorials is an area where we need more people (kidclamp, 14:22:25)
    2. Reminder to hit majors and criticals before enhancements please (kidclamp, 14:22:47)
    3. Cait sent a questionaire to QAers, please respond so we can plan how to cover all topics (kidclamp, 14:23:07)
    4. if interested in joining QA please let cait know or add to the next meeting agenda (kidclamp, 14:23:48)
    5. looking for someone to help ease testing for Shibboleth, CAS and LDAP (cait, 14:24:29)
    6. Please rebase/answer questins from QA quickly, so things can be finished quickly once started (cait, 14:25:30)
    7. don't forget to assign yourself as QAer when looking at a bug (kidclamp, 14:26:36)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:26:59)
    1. ACTION: cait will try to arrange QA sprint before end of year (kidclamp, 14:30:48)
    2. ACTION: cait will add wiki page to list topics of interest/expertise to assist in SO and QA (kidclamp, 14:41:27)

  7. REST api (kidclamp, 14:43:19)
    1. general discussion is version change would be good for this proposal (kidclamp, 14:48:47)
    2. and a listing of naming on the wiki (kidclamp, 14:49:01)
    3. vote postponed to next meeting so can discuss versioning with tcohen and get a list of attributes (kidclamp, 14:54:04)

  8. SQL strict mode is not the default in MariaDB (kidclamp, 14:54:55)
    1. Koha has compatability issues withMySQL 5.7 so we suggested mariadb, but they now follow MySQL and same problem occurring (kidclamp, 14:57:20)
    2. https://wiki.koha-community.org/wiki/Koha_on_ubuntu_-_packages#Ubuntu_16.04_and_MySQL_5.7 (Joubu, 14:59:47)
    3. ping Joubu if you have time to dedicated to mariadb/mysql strict mode (Joubu, 15:01:05)
    4. ACTION: kidclamp Update the Koha_on_ubuntu_-_packages#Ubuntu_16.04_and_MySQL_5.7 section (Joubu, 15:01:35)
    5. ACTION: kidclamp will send an email to the list about the db issues (kidclamp, 15:02:28)

  9. Elasticsearch status (kidclamp, 15:03:03)
  10. Javascript in footer (kidclamp, 15:06:22)
    1. https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=17858 JS move status (kidclamp, 15:09:40)
    2. ACTION: josef_moravec add a new coding guideline about the JS move to the footer (Joubu, 15:12:31)

  11. Review of coding guidelines (kidclamp, 15:14:44)
    1. Don't use DBIX calls in updatedatabase (kidclamp, 15:14:51)
    2. see bug 19789 and bug 17292 (kidclamp, 15:15:16)
    3. ACTION: Joubu will write a coding guideline to not use DBIX in updatedatabase for voting at next meeting (kidclamp, 15:18:41)
    4. ACTION: Joubu write a coding guideline to forbid use of DBIX calls in updatedatabase (and C4/Koha ns?) (Joubu, 15:19:00)
    5. Reminder - git commit messages (kidclamp, 15:19:58)
    6. ('Bug 12345: ', '(follow-up)', '(QA follow-up)', see git log) + what the patch does vs what the bug is. (kidclamp, 15:20:31)
    7. ACTION: Joubu will write a coding guidline on commmit message formatting for voting next meeting (kidclamp, 15:22:01)

  12. Set time of next meeting (kidclamp, 15:27:36)
  13. Set time of next meeting (Joubu, 15:28:06)
    1. Next meeting: 27 December 2017, 20 UTC (Joubu, 15:29:27)


Meeting ended at 15:29:47 UTC (full logs).

Action items

  1. cait will try to arrange QA sprint before end of year
  2. cait will add wiki page to list topics of interest/expertise to assist in SO and QA
  3. kidclamp Update the Koha_on_ubuntu_-_packages#Ubuntu_16.04_and_MySQL_5.7 section
  4. kidclamp will send an email to the list about the db issues
  5. josef_moravec add a new coding guideline about the JS move to the footer
  6. Joubu will write a coding guideline to not use DBIX in updatedatabase for voting at next meeting
  7. Joubu write a coding guideline to forbid use of DBIX calls in updatedatabase (and C4/Koha ns?)
  8. Joubu will write a coding guidline on commmit message formatting for voting next meeting


Action items, by person

  1. cait
    1. cait will try to arrange QA sprint before end of year
    2. cait will add wiki page to list topics of interest/expertise to assist in SO and QA
  2. josef_moravec
    1. josef_moravec add a new coding guideline about the JS move to the footer
  3. Joubu
    1. Joubu will write a coding guideline to not use DBIX in updatedatabase for voting at next meeting
    2. Joubu write a coding guideline to forbid use of DBIX calls in updatedatabase (and C4/Koha ns?)
    3. Joubu will write a coding guidline on commmit message formatting for voting next meeting
  4. kidclamp
    1. kidclamp Update the Koha_on_ubuntu_-_packages#Ubuntu_16.04_and_MySQL_5.7 section
    2. kidclamp will send an email to the list about the db issues


People present (lines said)

  1. Joubu (117)
  2. kidclamp (92)
  3. cait (54)
  4. thd (20)
  5. greenjimll (18)
  6. fridolin (16)
  7. josef_moravec (14)
  8. huginn` (11)
  9. wahanui (8)
  10. oleonard (7)
  11. jajm (7)
  12. clrh (5)
  13. LibraryClaire (3)
  14. alex_a (3)
  15. tuxayo (2)
  16. tcohen (2)
  17. cc_ (1)
  18. ashimema (1)


Generated by MeetBot 0.1.4.