19:01:09 <tcohen> #startmeeting Development IRC meeting 8 March 2017
19:01:09 <huginn`> Meeting started Wed Mar  8 19:01:09 2017 UTC.  The chair is tcohen. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:09 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:09 <huginn`> The meeting name has been set to 'development_irc_meeting_8_march_2017'
19:01:19 <tcohen> #topic Introductions
19:01:32 <tcohen> please introduce yourselves using #info Name
19:01:39 <tcohen> #info Tomas Cohen Arazi
19:01:46 <alexbuckley> #info Alex Buckley
19:02:03 <Joubu> #info Jonathan Druart
19:02:18 <druthb> #info D Ruth Holloway
19:02:21 <cait> #info Katrin Fischer, BSZ, Germany
19:02:31 <cait> druthb: you need a new nick :)
19:02:36 <khall> #info Kyle M Hall, ByWater Solutions
19:02:39 * druthb is aware
19:03:12 * tcohen is not expecting people to flood the channel with stuff for the meeting
19:03:15 <tcohen> moving on?
19:03:46 <cait> yep
19:03:47 <tcohen> #topic Announcements
19:03:53 <tcohen> any announcements?
19:04:35 <tcohen> ok, moving on
19:04:50 <tcohen> #topic Update from the Release Managers (17.05)
19:04:52 <thd> #info Thomas Dukleth, Agogme, New York City
19:04:56 <tcohen> hi thd
19:05:01 <thd> hello
19:05:11 <tcohen> bag is attending Code4Lib, so I think it is your turn, khall
19:05:37 <khall> sorry, distracted ; )
19:05:50 <khall> So far nothing noteworthy to report
19:06:02 <bag> push all the things
19:06:07 <bag> fix all the bugs!
19:06:14 <bag> </report>
19:06:16 <bag> ;)
19:06:19 <khall> yep!
19:06:20 <tcohen> ha
19:06:29 <tcohen> sneaky bag
19:06:36 <tcohen> focus on the presentation, bag
19:06:38 <tcohen> :-P
19:06:44 <bag> coffee break :)
19:07:17 <tcohen> #topic Updates from the Release Maintainers
19:07:23 <tcohen> cait
19:07:47 <cait> same as always
19:08:00 <cait> i will be pushing patches early next week
19:08:05 <cait> string freeze will be 15th
19:08:08 <cait> release 22nd
19:08:11 <cait> :)
19:08:27 <tcohen> #info Katrin is sticking to the regular release schedule for 16.11.x
19:08:31 <cait> i feel we got a lot fixed in 16.11.04 - it seems to slow down a bit
19:08:32 <tcohen> mtj?
19:08:49 <tcohen> cait: do you mean Koha got slower?
19:09:00 <Joubu> no less bugs
19:09:01 <tcohen> jajm?
19:09:03 <cait> yep
19:09:06 <cait> Joubu got it :)
19:09:23 <tcohen> awesome, I actually updated a library to 16.11.04
19:09:25 <Joubu> less *known* bugs
19:09:33 <cait> shush :)
19:09:52 <tcohen> #info bug count for 16.11.x got lower with 16.11.04
19:10:07 <tcohen> jajm? mtj?
19:10:31 <tcohen> ok, we can come back to them if they show up
19:10:40 <tcohen> #topic Updates from Jonathan
19:10:42 <josef_moravec> #info Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic
19:10:43 <tcohen> :-P
19:10:59 <Joubu> nothing today :)
19:11:02 <Joubu> was off the last few days
19:11:11 <Joubu> I should send an email soon
19:11:24 <Joubu> and just posted bug 18235
19:11:24 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18235 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Elastic search - Configurable facets
19:11:29 <cait> ooh nice
19:11:45 <tcohen> #info Jonathan introduced bug 18235, which will gather lots of attention
19:11:46 <Joubu> it's a bit ugly but seems to work
19:12:37 <tcohen> kidclamp: we are on the 'updates from the QA team' topic, if you have something to add?
19:13:04 <tcohen> ashimema: ?
19:13:09 <Joubu> nothing else, unless my refactoring did not get lot of attention
19:13:20 <Joubu> TT syntax for notices and Hea neither
19:13:40 <cait> I tihnk rangi signed off on hea
19:13:47 <tcohen> #info important stuff like TT syntax for notices and the new HEA need signoffs and QA people to take care
19:14:14 <Joubu> cait: yes, but I would have expected several SO on this one
19:14:22 <cait> ok
19:14:42 <Joubu> I got a server setup to test
19:14:49 <Joubu> it is very very easy to test...
19:14:50 <tcohen> TT syntax requires real users to test it
19:15:02 <Joubu> must be fun, easy and quick
19:15:10 <tcohen> Joubu: talking about HEA?
19:15:14 <Joubu> yes
19:15:17 <tcohen> ok
19:15:39 <tcohen> #topic General development discussion
19:15:47 <alexbuckley> I am looking to try to push the onboarding tool project ahead, so we can get this useful feature out to Koha users in the May release. bug 17855, 18039 and 17942
19:15:47 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17855 enhancement, P5 - low, ---, alexbuckley, Signed Off , Updated Koha web installer and new onboarding tool feature to guide users through setting up Koha
19:16:17 <alexbuckley> Ifeel it has got a bit bogged down in trying to developand test it for all languages in one go, any thoughts about splitting it up?
19:16:19 <Joubu> bug 18039
19:16:19 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18039 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Move the mandatory and optional files for non-english languages into 'default' directory so bug 17855 permits use of other languages
19:16:22 <Joubu> bug 17942
19:16:22 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17942 enhancement, P5 - low, ---, oleonard, Signed Off , Update style of the web installer with Bootstrap 3
19:16:41 <cait> tcohen: you can action me for testing german, russian and ukrainian if you want - but next week
19:17:10 <tcohen> #info Alex Buckley needs feedback and signoffs for the new onboarding tool and web installer update
19:17:34 <tcohen> #actions Katrin offers to test German, Russian and Ukranian for the onboarding tool
19:18:06 <tcohen> irc://irc.oftc.net:6667/#actions Katrin offers to test German, Russian and Ukranian for the onboarding tool
19:18:09 <Joubu> alexbuckley: I am not againt it personally, but I think we will adapt some part not to make it breaks languages that are not supported yet, right?
19:18:22 <tcohen> #action Katrin offers to test German, Russian and Ukranian for the onboarding tool
19:18:23 <Joubu> erk, did not mean anything
19:18:46 * tcohen will learn to chair at some point
19:18:57 <cait> tcohen: i didn't in years ;)
19:19:25 <tcohen> moving on?
19:19:25 <Joubu> need a rephrase?
19:19:31 <alexbuckley> Joubu, yup so which patch do you think will need to be adapted?
19:19:32 <Joubu> nope
19:19:42 <Joubu> tcohen: alexbuckley is waiting for an answer :)
19:19:47 <tcohen> ok!
19:20:03 <Joubu> if we go first with english only, do the other languages will still work as before?
19:21:50 <cait> i think it would be good to have this plan in place - but i stlil hope we can resolve the issues pre release
19:21:59 <cait> it would be sad to add sucha nice feature english only
19:22:16 <Joubu> nobody is willing to test..
19:22:42 <cait> i will work on the languages i signed up for - just have to survive this week first :)
19:22:47 <Joubu> I can write patches, sign them off and QA + push if you like
19:23:18 <tcohen> I think we need to make a QA team meeting
19:23:21 <Joubu> so es, fr-FR, fr-FR are missing
19:23:37 <Joubu> nb-NO
19:23:40 <Joubu> pl-PL
19:23:57 <Joubu> (uk-UA ?)
19:24:14 <tcohen> why is it so language-specific?
19:24:24 <tcohen> is it outside our translation system?
19:24:29 <cait> yes
19:24:44 <tcohen> why?
19:24:45 <cait> i think the main problem is that people have not stuck to the same structure as en?
19:24:54 <Joubu> yes
19:25:03 <cait> they translated directoy names for example
19:25:06 <cait> because it shows in the installer
19:25:25 <tcohen> ah, yes, I always thought it should be translated
19:25:27 <cait> working out those glitched in the web installer is probably due
19:25:28 <tcohen> shipped
19:25:41 <tcohen> can't we copy&paste the en one?
19:25:44 <cait> nope
19:25:56 <cait> well we can resort  to have the same structure
19:25:59 <cait> and rename the files
19:26:01 <tcohen> stop reading me about this subject, I'd better take a look before
19:26:06 <cait> but the contents are specific of course
19:26:11 <Joubu> I think "rewrite the whole installer code" is out of the scope of the discussion :D
19:26:16 <cait> hehe yes
19:26:19 <cait> one step at a time
19:26:27 <cait> getting all the translations 'in line' again might be a first step :)
19:26:41 <alexbuckley> As I am still learning about the different language translations, so I am trying to think how I can help move it forward
19:26:50 <tcohen> I don't understand how having a translated list of templates for each language is related to directory structures
19:27:02 <cait> ?
19:27:04 <cait> those are ont the templates
19:27:09 <cait> we are talking about the sql files
19:28:07 <cait> but maybe shoudl discusss on the bugs?
19:28:12 <Joubu> alexbuckley: what you can do is: 1. provide a followup to make sure other languages are not broken if we push the patches without the changes to the sql files of other languages
19:28:27 <Joubu> 2. open a bug report by languages, to enable them 1 by 1
19:28:31 <thd> Why would directory names be translated?
19:28:34 <Joubu> per
19:29:17 <alexbuckley> Joubu: Do you mean check that other languages for web installer still work when bugs 17855, 18039 and 17942 are applied?
19:29:18 <Joubu> 3. Then wait for people to signoff, and if nobody care for a given language, they will not have the onboarding tool in 17.05
19:29:56 <Joubu> alexbuckley: nope, if you do that, you can sign off everything and a QA team member can QA everything in one go
19:29:59 <Joubu> that would be ideal
19:30:08 <Joubu> but nobody test the different languages
19:30:19 <cait> thd: because it showed up as a heading in the installer - bad design
19:30:28 <Joubu> so we need 17855 without the lang files (18039)
19:30:45 <Joubu> and confirm it works as before for translated interfaces
19:30:46 <cait> i like your suggestoin Joubu
19:30:57 <cait> but i am not sure what activating would work like
19:31:06 <cait> hopefully easy
19:31:42 <alexbuckley> So just to clarify we need to get 17855 through without worrying about the patches for 18039? Sorry just trying to understand
19:31:53 <Joubu> yes
19:32:01 <cait> bug 18039
19:32:02 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18039 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Move the mandatory and optional files for non-english languages into 'default' directory so bug 17855 permits use of other languages
19:32:07 <Joubu> but with a followup, not to break other languages
19:32:34 <alexbuckley> And those languages are for the installer not the translations in staff interface itself, correct?
19:34:18 <cait> hm yes
19:34:21 <cait> the files it selects
19:34:35 <cait> the sql files
19:34:46 <cait> translations for the .tt files should just work i tihnk
19:35:08 <alexbuckley> Ok I think I understand I will work on a followup patch to attach to bug 17855 this week :)
19:35:08 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17855 enhancement, P5 - low, ---, alexbuckley, Signed Off , Updated Koha web installer and new onboarding tool feature to guide users through setting up Koha
19:35:11 <alexbuckley> thanks
19:36:28 <cait> move on?
19:36:29 <tcohen> #info Jonathan and Buckley will coordinate on what's prioritary for the onboarding tool to be seamlessly integrated for the next release
19:37:00 <tcohen> #topic Review of coding guidelines
19:37:19 <tcohen> cait?
19:37:23 <cait> I have put a suggestion for a new coding guideline on the agenda
19:37:26 <cait> i will copy it here sec
19:37:36 <cait> Forbid use of HTML5 input type="number" as it causes problems with I18N.
19:37:58 <cait> so now trying to explain why:
19:37:59 <cait> Example: The behaviour of the input field will change with the language  you have selected for the GUI. When English is selected, you can enter  the amount as 0.00, but if German is selected, you are enforced to enter  as 0,00 - which causes trouble as Koha doesn't understand this.
19:38:10 <cait> One possible solution is to use a pattern match instead (<input  type="text" pattern="\d+(\.\d{2})?"...). The number type is currently  used for entering manual invoices and credits and should be removed.
19:38:18 <cait> this has been filed as bug 17098 a while ago
19:38:18 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17098 normal, P5 - low, ---, gmcharlt, NEW , Validation problems with form field type "number" (decimal separator)
19:38:26 <tcohen> so browsers represent numbers differently depending on the locale?
19:38:31 <cait> yes
19:38:46 <cait> if you switch to english gui, decimal dot, if you switch to swiss, both work, de-de comma
19:38:51 <cait> our code doesn't handle this
19:39:03 <cait> and the effect for the german users at th emoment is, that 'payments are broken'
19:39:30 <tcohen> english is the universal language, you know. switch
19:39:31 <cait> you try to pay something like 1.50 and it won't let you, you enter 1,50 and it pays 1 i think only
19:39:34 <cait> it's rather.. bad
19:39:53 <tcohen> what is the proposal?
19:40:14 <cait> the ideal solution would be to make Koha understand other monetary formats
19:40:33 <cait> but for the stable releases... i think avoiding/removing the type=number for now would be good
19:41:03 <cait> a pattern match works similarly, but it won't let you increase/decreate the amount using the arrow keys then
19:41:55 <tcohen> can't you use step='0.01'?
19:42:11 <cait> still ,
19:42:35 <cait> ok, i haven't tried it, but I think it will still outsmart you
19:42:47 <cait> i took the pattern match from a website after some googling
19:42:52 <cait> i think it's not only us running into this
19:43:18 <tcohen> is someone working on the bug?
19:43:28 <tcohen> because it seems that some research on how to handle this should be done
19:43:33 <tcohen> before imposing a guideline
19:43:51 * tcohen cannot volunteer this time
19:44:17 <Joubu> seems like we only have 2 occurrences
19:44:20 <cait> yeah
19:44:23 <cait> but those are central
19:44:26 <cait> and i don't want it to spread
19:44:30 <Joubu> so let's kick them
19:44:35 <cait> if I get the ok to do this
19:44:36 <cait> iw ill
19:45:00 <Joubu> bug 2542
19:45:00 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=2542 normal, P3, ---, jonathan.druart, CLOSED FIXED, Manual fine/credit fail on superfluous characters ( e.g. '$' )
19:45:01 <cait> i just thought it will need discussion first - because it will behave a little less nice
19:45:17 <cait> the arrow key stuff not working
19:45:39 <cait> i cannot figure out how to make Koha accept comma decimals
19:45:48 <cait> but i can certainly remove the input=number
19:45:57 <cait> and would like us not to add more of those until we have a good solution
19:46:00 <tcohen> try the step="0.1"
19:46:02 <cait> that's why I proposed a coding guideline
19:46:43 <cait> i will try it first to make you happy
19:46:48 <cait> but internet suggests it won't work
19:47:45 <tcohen> ok, I need to leave
19:47:50 <tcohen> picking manuel
19:48:11 <cait> so can we make this a temporary qa guideline at least?
19:48:14 <cait> no more input=number?
19:48:38 <tcohen> no strong opinion from me
19:48:55 <tcohen> I think a bug should remove it, and once someone figures how it should be used
19:49:02 <tcohen> then set it as a guideline
19:49:25 <tcohen> #chair cait
19:49:25 <huginn`> Current chairs: cait tcohen
19:49:30 <cait> just don't use it
19:49:31 <cait> for now
19:49:32 <Joubu> will take a look tomorrow
19:49:33 <tcohen> later #koha
19:49:46 <cait> thx Joubu
19:50:11 <cait> there is also a problem with plack doing weird stuff to numbera ccording to locale
19:50:25 <Joubu> splitter told me there is only 1 occurrence, on bug 17855 (bugzilla is small...)
19:50:25 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17855 enhancement, P5 - low, ---, alexbuckley, Signed Off , Updated Koha web installer and new onboarding tool feature to guide users through setting up Koha
19:50:37 <Joubu> but it's for "max number of holds" or something, so should not hurt
19:50:48 <cait> probably eah
19:50:52 <cait> but then we should step=1
19:51:03 <cait> to actively prevent people adding decimal
19:51:16 <cait> bug 18186
19:51:16 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18186 major, P5 - low, ---, koha-bugs, NEW , Amounts with decimal comma instead of decimal dot breaking payments
19:51:45 <cait> #info Please don't use input type=number for now as it causes headaches for some languages using decimal commas
19:51:52 <cait> i can at elast ask nicely
19:53:25 <cait> actually, all hta tis left is set the time of the next meeting
19:53:25 <thd> Can we not force plack to ignore locale for numeric data types?
19:53:41 <cait> i am not sure if it's something we can set in Koha
19:53:51 <cait> i just wnated to alert people for now that we have run into this
19:54:18 <cait> the effect is that it prefills input fields with comma amounts and that again... won't work and is really hard to track down
19:54:21 <cait> it#s an odd thing
19:54:34 <cait> #topic Set date and time of next meeting
19:54:39 <thd> Yet we have instructions for how to set up MySQL to avoid a host of character encoding problems.
19:54:44 <cait> are we on a biweekly schedule right now?
19:55:18 <cait> yeah, we wrote it up for it to be documented - but i am nto the person who fixed, some plack people might want to have a look
19:56:52 <cait> #chair kidclamp
19:56:52 <huginn`> Current chairs: cait kidclamp tcohen
19:57:27 <kidclamp> So 2 weeks would be the 22nd
19:58:05 <kidclamp> and next time would be 13UTC?
19:58:57 <kidclamp> next meeting Wednesday March 22 at 13 UTC unless objections or suggestions
19:59:34 <kidclamp> #info next meeting: Wednesday March 22, 13UTC
19:59:47 <kidclamp> tcohen++
19:59:49 <kidclamp> cait++
19:59:58 <kidclamp> apologies of rmissing the meeting :-)
20:00:14 <kidclamp> last call for any comments?
20:00:52 <kidclamp> #endmeeting