21:07:38 <LeeJ> #startmeeting Documentation IRC meeting 21 December 2017
21:07:38 <huginn> Meeting started Thu Dec 21 21:07:38 2017 UTC.  The chair is LeeJ. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:07:38 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:07:38 <huginn> The meeting name has been set to 'documentation_irc_meeting_21_december_2017'
21:07:58 <LeeJ> #chair LeeJ
21:07:58 <huginn> Current chairs: LeeJ
21:08:11 <LeeJ> #chair edveal
21:08:11 <huginn> Current chairs: LeeJ edveal
21:08:35 <LeeJ> #topic Introductions
21:08:36 <wahanui> #info wahanui, a bot that has become sentient
21:08:47 <BobB> #info Bob Birchall, Calyx, Australia
21:08:48 <LeeJ> #info Lee Jamison, Marywood University
21:08:53 <georgew> #info George Williams, Northeast Kansas Library System
21:09:09 <davidnind> #info David Nind, Wellington, New Zealand
21:09:13 <cait> #info Katrin Fischer, BSZ, Germany
21:09:36 <LeeJ> any other intros? :)
21:10:09 <LeeJ> moving on then!
21:10:12 <LeeJ> #topic What's been done so far
21:10:26 <LeeJ> cait: would you like to include your info now?
21:11:01 <cait> ye
21:11:01 <cait> s
21:11:06 <cait> one of it :)
21:11:08 <LeeJ> great!
21:11:09 <cait> #info the master branch now deploys to the https://koha-community.org/manual/18.05/en/html/ site each merge/push
21:11:34 <cait> so every time the manual is changed, it's regenerated
21:11:41 <LeeJ> :O
21:11:45 <cait> my other thing goes to the next topic
21:11:48 <LeeJ> cait++ Joubu++
21:11:49 <cait> rangi++
21:11:53 <LeeJ> rangi++
21:11:56 <cait> not me, rangi++ :)
21:12:05 <cait> was just asked to mention it
21:12:07 <LeeJ> oh well :P
21:12:30 <LeeJ> I'll mention the kanban in the next topic as well after you give your info :)
21:12:42 <LeeJ> #topic Workflows
21:12:54 <LeeJ> cait: after you :)
21:13:33 <LeeJ> alright..so some of you may have noticed my note in the reminder email about the kanban I created
21:13:52 <BobB> yep
21:14:05 <LeeJ> who has questions?
21:14:21 <cait> link?
21:14:22 <wahanui> link is probably both helpful/unhelpful
21:14:27 <LeeJ> sure :)
21:14:28 <BobB> how does it work? :)
21:14:49 <BobB> #link https://tree.taiga.io/project/ldjamison-kohadocs-1805/epics
21:14:57 <LeeJ> BobB++
21:15:33 <LeeJ> so basically we can use it in almost a bugzilla-type fashion..just used exclusively for documentation
21:15:54 <LeeJ> if anyone has not joined the project please do or let me know if you need help joining!
21:16:17 <LeeJ> the epics indicate the different Koha releases
21:16:48 <cait> #info Let LeeJ know if you need help joining the kanban board for ducumentation
21:17:26 <BobB> via 'Sign up' in the top right, I guess?
21:17:41 <LeeJ> #info the kanban itself breaks down into 3 general categories: epics are used to indicate individual releases, user stories are for specific components within each release that needs attention, and tasks are the actual things that need to be done
21:17:49 <LeeJ> BobB: correct
21:18:39 <LeeJ> #info LeeJ is continually updating the koha-docs kanban's wiki page to provide more help and information to new contributors
21:19:09 <cait> should we link to it from the wiki?
21:19:25 <BobB> ok, I have found the help page, which looks like it might help :)
21:19:28 <LeeJ> cait: yes..I'll do that before the weekend
21:19:37 <LeeJ> BobB: great!
21:20:00 <BobB> 'What's an Epic' is prolly a good place to start, eh
21:20:08 <LeeJ> #info contact LeeJ for any suggestions to contribute to the koha-docs kanban wiki
21:20:18 <LeeJ> BobB: noted :)
21:20:33 <BobB> So will the kanban replace the To Do list?
21:21:17 <LeeJ> BobB: that is correct...I've taken the liberty of migrating all documentation-related content from the To Do list to the kanban under appropriate epics/user stories
21:21:40 <BobB> ok, now I get it, cool
21:22:03 <LeeJ> anyone have any additional questions before moving on?
21:22:56 <LeeJ> okay! unless I forgot something, I think we're good
21:23:12 <LeeJ> #topic Next steps
21:23:30 <LeeJ> cait: you're up :)
21:23:39 <cait> ok
21:24:02 <cait> Joubu has been working on removing the help files in Koha in favour of either linking to the online manual or configuring a local manual to link to
21:24:13 <cait> so we will have one source of truth to maintain
21:24:17 <cait> the manual
21:24:18 <wahanui> the manual is probably in the code
21:24:27 <cait> and people will stlil have the option to use it without internt
21:24:38 <cait> while working on this, there are some questions
21:24:57 <cait> at the moment it's possible to edit the help pages in Koha
21:25:14 <cait> but if you make a local edit like that
21:25:22 <cait> it will be overwritten by the next update without warning
21:25:29 <BobB> yes
21:25:50 <cait> it wlil also be practically impossible to keep a local version of the manual current
21:25:59 <cait> the idea is to remove the ability to edit the pages
21:26:10 <cait> in favor of adding a way to add new local pages
21:26:11 <BobB> agree
21:26:18 <LeeJ> that makes sense
21:26:35 <cait> local additions we could call it maybe?
21:26:44 <cait> sec, need to check what Joubu send me
21:27:08 <cait> Joubu is asking for use cases and ideas for the gui/workflow
21:27:51 <LeeJ> cait: okay..and I'll let you add your info to the info tag for this content if you wouldn't mind :)
21:27:59 <cait> oh
21:28:01 <cait> yeah :)
21:28:29 <cait> #info Joubu is working on patches to remove the help files in koha in favor of linking to the online manual or a local version (configurable)
21:28:55 <cait> #info idea is to remove the possibility to edit the help pages as they are overwritten and can't be maintained in favor of a way to add local content separately
21:29:18 <LeeJ> cait: should we contact him directly if we come up with use cases or ideas for the workflow? or is there a bug to add comments to with suggestions?
21:29:19 <cait> #info Joubu is looking for workflows, use cases and ideas on how to make this work nicely
21:29:29 <cait> hm sec there is a bug
21:29:41 <davidnind> https://bugs.kohha-community.org/bugzilla3/show_bug.cgi?id=19817
21:29:41 <huginn> 04Bug 19817: new feature, P5 - low, ---, jonathan.druart, ASSIGNED , Merge local and online documentations
21:29:51 <cait> yes
21:30:02 <LeeJ> davidnind is on the ball tonight :)
21:30:10 <cait> so we generally agree that the current editing option is ok to go?
21:30:11 <indradg> davidnind++
21:30:17 <davidnind> :)
21:30:20 <LeeJ> hi indradg
21:30:25 <cait> hi indradg :)
21:30:38 <LeeJ> indradg: don't forget to add yourself under the info tag if you're here for the meeting :)
21:31:01 <LeeJ> cait: I'll make a note of it since it seems so
21:31:06 <LeeJ> since no one objected
21:31:19 <indradg> Kia ora #koha :-) Sorry i´m late. fell asleep, its 3:01 AM here
21:31:34 <cait> wow, that's a really bad time for a meeting, glad you made it
21:31:41 <indradg> #info Indranil Das Gupta, L2C2 Technologies, India.
21:31:56 <indradg> :)
21:32:22 <BobB> hi indradg
21:32:23 <LeeJ> #agreed the current local editing option can be replaced with the result of Bug 19817
21:32:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19817 new feature, P5 - low, ---, jonathan.druart, ASSIGNED , Merge local and online documentations
21:33:33 <LeeJ> #action anyone who comes up with ideas for the local and online documentation merge should refer to Bug 19817 or contact Joubu
21:33:43 <LeeJ> do we have anything else to add? :)
21:33:48 <cait> i think that was it :)
21:34:04 <LeeJ> indradg: just to quickly summarize what we went over...
21:34:41 <LeeJ> I created what's called a kanban to aid in organizing the documentation workflow
21:34:49 <LeeJ> https://tree.taiga.io/project/ldjamison-kohadocs-1805/epics
21:35:14 <LeeJ> at your convenience, you can sign up with the project and if there's any questions feel free to contact me :)
21:35:25 <indradg> LeeJ++
21:35:32 <LeeJ> I think that was the only major thing we went over before you arrived...
21:36:12 <LeeJ> unless anyone has anything else to add, shall we decide on next meeting?
21:36:58 <LeeJ> specifically if we can find a time so indradg can get a full night's sleep ;)
21:37:32 <indradg> heh
21:38:09 <BobB> whatever time is always bad for someone, best to rotate them
21:38:16 <LeeJ> BobB: I agree
21:38:25 <BobB> though this time is good for me :)
21:38:27 <indradg> BobB: +1
21:38:51 <LeeJ> indradg: what time would be reasonable for you? BobB had a good idea for us to rotate meeting times to do our best to be inclusive
21:39:02 <indradg> LeeJ, rotating is fine
21:39:41 <LeeJ> indradg: what UTC time would work for you?
21:40:41 <LeeJ> earlier? later?
21:41:17 <georgew> 6 hours from now would be 3:00, UTC, right?
21:41:28 <georgew> Why not rotate them by 6 hours each meeting?
21:41:30 <indradg> usually UTC 2PM onwards is better
21:41:45 <LeeJ> georgew: I like that idea
21:41:52 <georgew> 3, 9, 15, 21
21:42:06 <indradg> georgew: +1
21:43:06 <LeeJ> hi caboose :) we're just wrapping up
21:43:18 <caboose> I'm so sorry
21:43:30 <caboose> can we meet up at some point to go over the meeting topics?
21:43:49 <caboose> I thought I would be back at 4 :(
21:43:50 <LeeJ> caboose: no worries! sure
21:43:57 <BobB> of those times, only one is bad for me, so 3 are good - best one can expect, I think
21:44:04 <LeeJ> we're just trying to figure out next time
21:44:23 <LeeJ> we're discussing rotating meeting times between 3, 9, 15, 21 UTC
21:44:25 <georgew> same is true for me, BobB
21:45:23 <LeeJ> so how about January 21 at 3 UTC?
21:45:35 <cait> caboose: you can also read the logs - nothing is lost :)
21:45:43 <caboose> sweet!
21:45:46 <caboose> excited!
21:45:53 <cait> logs?
21:45:53 <wahanui> hmmm... logs is http://irc.koha-community.org/koha/
21:46:18 <cait> probably not going to make that one, but that's ok
21:46:18 <LeeJ> anyone opposed to January 21 @ 3 UTC?
21:46:36 <LeeJ> cait: I can always catch you up anyway :)
21:46:41 <cait> i will be travelling in indradg's direction
21:46:43 <georgew> +1 to January 21 @ 3
21:46:44 <cait> yep
21:46:45 <cait> np
21:47:17 <LeeJ> alright, since I consider silence as agreement then it appears it works for most people so we'll do that
21:47:24 <davidnind> https://www.timeanddate.com/worldclock/fixedtime.html?msg=Koha+Documentation+IRC+Meeting&iso=20180121T0300
21:47:37 <BobB> isn't january 21 a sunday?
21:47:44 <cait> heh it is
21:47:50 <LeeJ> #info we will try to rotate meeting times between 3, 9, 15, 21 UTC
21:47:57 <indradg> cait: yeah! LTC right around that time
21:47:58 <LeeJ> hah..didn't even realize that..
21:48:03 <LeeJ> how about the 22nd then?
21:48:27 <LeeJ> good catch
21:48:36 <georgew> I'm looking at 2019
21:48:52 <BobB> linuxConfAu starts on 22 :)
21:49:07 <LeeJ> then perhaps the week prior?
21:50:01 <BobB> how about Jan 17 or 18?
21:50:23 <LeeJ> 17th works for me.
21:51:03 <LeeJ> alright so then the 17th at 3 UTC
21:51:15 <caboose> sweet
21:51:26 <georgew> cool
21:51:31 <BobB> +1
21:51:34 <LeeJ> no objections heard so that's what we'll do
21:52:06 <BobB> thanks LeeJ
21:52:19 <LeeJ> #info Next Meeting: 17 January 2018, 3 UTC
21:52:23 <BobB> its the last business day of hte year for us, so I'll get going
21:52:28 <BobB> happy Christmas everyone
21:52:35 <LeeJ> take care BobB! Good luck!
21:52:42 <LeeJ> alright, and we're done!
21:52:46 <LeeJ> #endmeeting