20:03:58 <cait> #startmeeting Development IRC meeting 10 October 2018
20:03:58 <huginn> Meeting started Wed Oct 10 20:03:58 2018 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:58 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:03:58 <huginn> The meeting name has been set to 'development_irc_meeting_10_october_2018'
20:04:02 <cait> #topic Introductions
20:04:05 <ashimema> #info Martin Renvoize, PTFS Europe, UK
20:04:16 <thd> #info Thomas Dukleth, Agogme, New York City, [even two ISPs does not protect against power failure]
20:04:17 <cait> please introduce yourself using #info!
20:04:31 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_October_2018 today's agenda
20:04:38 <cait> #info Katrin Fischer, BSZ, Germany
20:05:05 <josef_moravec> #info Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic
20:05:41 <rangi> #info Chris Cormack, Catalyst, NZ
20:06:01 <cait> ah
20:06:04 <cait> #chair ashimema
20:06:04 <huginn> Current chairs: ashimema cait
20:06:11 <cait> moving on!
20:06:16 <cait> #topic Announcements
20:06:19 <cait> anyone anything? :)
20:06:41 <cait> ah i got something
20:06:47 <ashimema> :)
20:07:24 <ashimema> Lots of good pushes the last couple of weeks :).. but then I'm somewhat biases on that front
20:07:43 <cait> hm can't find the link, but next week is the swedish user group meeting and hack day
20:08:02 <cait> #info Next week is the Swedish user group meeting and hack day
20:08:09 <cait> so you might see some activity from there :)
20:08:29 <cait> ... and please keep the sandboxes alive!
20:09:06 <ashimema> #info KohaCon19 dates are finalized: Monday 20 May to Sunday 26 May 2019
20:09:25 <ashimema> :)
20:09:34 <ashimema> I can't think of any others.. anyone else?
20:10:11 <cait> moving on then :)
20:10:28 <cait> #topic Update from the Release manager (18.11)
20:10:42 <ashimema> Nick sends his apologies
20:10:46 <cait> #info Nick Clemens : Travelling, pushing things to master, dates have been sent to list, keep Qaing :-)
20:10:52 <cait> from his apologies for today
20:11:08 <cait> moving on?
20:11:17 <ashimema> yup.. that's pretty much it
20:11:24 <cait> #topic Updates from the Release Maintainers
20:11:28 <cait> Rmaints?
20:11:31 <cait> RMaints?
20:11:37 <cait> Release Maintainers?
20:11:39 <ashimema> oh.. that's me
20:11:50 <cait> wahanui never does his trick when I try it
20:11:50 <wahanui> cait: excuse me?
20:12:08 <ashimema> Just continueing to plod along :)
20:12:18 <ashimema> rmaints?
20:12:46 <ashimema> Fridolin also sends his apologies..
20:13:06 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA, late
20:13:30 <cait> moving on then :)
20:13:30 <ashimema> also, I've proposed to take on rmaint for 18.11 next cycle
20:13:33 <cait> ah
20:13:36 <ashimema> Fridolin Somers : Last release of 17.05.x is ready will be out in a few days. Proposed to continue on RMaint 17.11.
20:13:39 <ashimema> onwards
20:14:06 <cait> #info ashimema has proposed to be Rmaint for 18.11 for next cycle (19.05)
20:14:14 <cait> #info Fridolin Somers : Last release of 17.05.x is ready will be out in a few days. Proposed to continue on RMaint 17.11.
20:14:23 <ashimema> that leaves us with a gap for 18.05 rmaint for the next cycle at the moment
20:14:50 <cait> #info Still looking for a 18.05 Release maintainer for the next cycle
20:15:09 <cait> hm maybe something for announcements, but we shoudl send the roles page to ml i tihnk
20:15:44 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_19.05 Please sign up for the 19.05 release team
20:15:59 <cait> and schedule election for next general meeting?
20:16:04 <ashimema> good plan
20:16:52 <cait> #action cait to add elections to next general meeting
20:16:53 <josef_moravec> +1
20:16:57 <cait> someone volunteering to send the email?
20:17:22 <ashimema> I can send an email
20:17:56 <ashimema> #action ashimema to send an email reminding people to look at and add their names to 19.05 roles page
20:18:05 <cait> #action ashimema to send call for release team to mailing list
20:18:07 <cait> heh
20:18:19 <ashimema> haha
20:18:28 <cait> moving on?
20:18:59 <ashimema> go for it..
20:19:01 <cait> #topic Updates from the QA team
20:19:21 <cait> I'm still catching on things from the last few weeks but there has been quite a flurry of activity on bugzilla
20:19:54 <cait> numbers on the dashboard are slowly coming down - nso was under 200 this morning... no more
20:20:07 <cait> some long standing shibboleth patches have been pushed, also stock rotation
20:20:17 <cait> lots to do :) keep QA'ing!
20:20:42 <ashimema> feature slush is fast aproaching..
20:20:46 <cait> yes
20:20:48 <cait> #info November   2 - Feature slush - no enhancement/new features  that have not passed QA will be considered for release
20:20:51 <cait> was just looking it up
20:20:59 <cait> so we are ona deadline
20:21:05 <ashimema> :)
20:21:32 <cait> but great stuff happening, keep pushing :)
20:22:06 <cait> i'd love to see some omre progress on the ES patches
20:22:34 <cait> #info ES patches are a bit behind, would be great to see some work on those
20:22:37 <cait> moving on?
20:22:41 <josef_moravec> I like to start with testing ES more, hope I'll be able to make QA on them soon
20:22:51 <ashimema> i'm just getting myself up to speed on ES workings for qa
20:23:20 <cait> i tihnk we got some great stuff waiting there - but also not understanding it well enough right now
20:23:23 <ashimema> lacking in confidence for the bigger ES ones so far though..
20:23:31 <cait> we might have to just jump in :)
20:23:44 <cait> moving on? some more good topics ont he agenda tonight
20:23:56 <josef_moravec> move on
20:24:01 <cait> #topic General development discussion (trends, ideas,...)
20:24:12 <cait> ashimema: do you want to take over?
20:24:40 <ashimema> just trying to remember who suggested using git trailers
20:25:05 <oleonard> jajm?
20:25:13 <josef_moravec> juian?
20:25:14 <ashimema> ah yes..
20:25:31 <ashimema> loose agreement was reached on the mailing lists and the wiki has been updated with some examples: https://wiki.koha-community.org/wiki/Commit_messages#Other_trailers
20:26:16 <ashimema> I wondered if we wanted to go any further next cycle and encourage their use any more formally then
20:26:46 <ashimema> happy to save that one for a more corrate audience?
20:27:07 <cait> corrate?
20:27:21 <ashimema> more interested parties being around ;)
20:28:22 <ashimema> given the quietness lets save that one
20:28:29 <ashimema> so.. the second idea/suggestion was my own
20:28:41 <ashimema> the bugzilla status's
20:29:52 <ashimema> I've been in rmaint role for a few months now and feel I've managed to get the idea.. but one thing had been bugging me.. it always felt wrong that our process marked a bug as 'RESOLVED FIXED' the moment it was pushed into the lowest supported branch it was going to be ported to..
20:30:17 <ashimema> feels like that status should be saved for actual release of the fix to the wider public
20:30:20 <ashimema> as such..
20:30:34 <ashimema> I wanted to suggest a bit og bugzilla status tidy up
20:31:15 * ashimema sent a long message:  < https://matrix.org/_matrix/media/v1/download/matrix.org/aftKcYjGeeZfzgOpwIXgNZBe >
20:31:19 <ashimema> any objections by anyone
20:31:23 <ashimema> rangi perhaps as I'd be coming to you to ask for actual implimentation most likely?
20:32:03 <cait> ashimema: i didn't get your last
20:32:13 <cait> sent a long message it says (client problem maybe)
20:32:22 <cait> tidy up...
20:32:44 <rangi> https://matrix.org/_matrix/media/v1/download/matrix.org/aftKcYjGeeZfzgOpwIXgNZBe  cait
20:32:47 <rangi> thats the message
20:32:49 <rangi> from ashimema
20:32:58 <cait> i get an error there
20:33:14 <cait> M_NOT_FOUND
20:33:22 <ashimema> ooh.. sorry
20:33:33 <ashimema> it was just a copy/paste from https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_October_2018
20:33:38 <ashimema> the proposal details
20:33:41 <cait> hm odd, the first works
20:34:09 <cait> #idea Add Pushed to oldstable and Pushed to oldoldstable to get us in line with Debian package codenames and reserve RESOLVED FIXED for applying upon release
20:34:19 <cait> #idea Script for RMaints to mark all Pushed to branch as RESOLVED FIXED upon release.
20:34:27 <cait> #idea Remove Pushed for QA and Pushed by Module Maintainer as they aren't in active use.
20:34:31 <ashimema> thanks cait
20:34:34 <cait> i support all 3
20:34:40 <cait> i think Joubu might have something for 2
20:34:43 <ashimema> :)
20:35:07 <cait> or something similar, I think there was a script around to mark recently pushed for RM
20:35:16 <ashimema> I'm happy to write the release script side to automate changeing to RESOLVED FIXED (if joubu hasn't already done so)
20:35:26 <ashimema> indeed..
20:36:01 <cait> anyone else? :)
20:36:27 <ashimema> i chose codenames instead of version numbers so we're not stuck updating status's i bz every cycle
20:36:41 <ashimema> but am open to suggestions..
20:36:41 <oleonard> I am also happy for ashimema to write the release script
20:36:41 <wahanui> okay, oleonard.
20:36:46 <josef_moravec> i like this idea
20:36:50 <ashimema> lol
20:37:13 <ashimema> just feels like it brings us closer to the norm ;)
20:37:30 <josef_moravec> there was some discussion about code names in Koha some time before...
20:37:53 <cait> i vetoed cheese names i think
20:37:59 * oleonard does not care for code names
20:38:01 <cait> should we have a vote on all 3 points together?
20:38:10 <cait> or just 1 + 2 as those are the bugzilla changes?
20:38:24 <cait> rangi: are you ok with making the changes if we vote yes?
20:38:30 <ashimema> +1
20:38:43 <oleonard> I think code names are exclusionary because they obscure information from people who are new.
20:39:14 <ashimema> do you count stable, oldstable tc as codenames oleonard?
20:39:17 <rangi> yep
20:39:18 <josef_moravec> we could vote on all I think
20:39:35 <cait> #startvote Shall we add 2 new status: pushed to oldstable, pushed to oldoldstable and remove 2: pushed for qa, pushed by module maintainer? (yes,no,abstain)
20:39:35 <huginn> Begin voting on: Shall we add 2 new status: pushed to oldstable, pushed to oldoldstable and remove 2: pushed for qa, pushed by module maintainer? Valid vote options are , yes, no, abstain, .
20:39:35 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
20:39:47 <ashimema> they track the debian scheme.. and wiki documentation for the repo
20:39:51 <josef_moravec> #vote yes
20:39:53 <oleonard> #vote yes
20:39:54 <ashimema> and seemed the clearest to me
20:40:00 <ashimema> #vote yes
20:40:08 <cait> #vote yes
20:40:41 <ashimema> frido and kidclamp were both happy with the idea too
20:40:47 <thd> #vote yes
20:40:51 <cait> giving it another moment
20:41:18 <cait> #endvote
20:41:18 <huginn> Voted on "Shall we add 2 new status: pushed to oldstable, pushed to oldoldstable and remove 2: pushed for qa, pushed by module maintainer?" Results are
20:41:18 <huginn> yes (5): oleonard, ashimema, cait, josef_moravec, thd
20:41:42 <cait> #agreed we will make the suggested changes to bugzilla status (yes (5): oleonard, ashimema, cait, josef_moravec, thd)
20:41:44 <ashimema> :)
20:41:54 <cait> #action rangi to change bugzilla (plz)
20:42:17 <ashimema> #action ashimema to update release maintanence page to reflect the change
20:42:23 <cait> good :)
20:42:31 <cait> #topic Review of coding guidelines
20:42:42 <cait> nothing on agenda - anyone anything here?
20:43:19 <ashimema> nothing from me
20:43:24 <cait> moving on
20:43:27 <oleonard> everyone should code good
20:43:36 <cait> #topic Set time of next meeting
20:43:43 <cait> i think rhythm is still biweekly?
20:43:51 <cait> so 24th
20:43:53 <cait> ?
20:44:00 <cait> doest hat clash with another?
20:44:15 * ashimema checks diary
20:44:18 <oleonard> No
20:44:49 <josef_moravec> nothing in koha calendar so should be ok
20:44:52 <ashimema> 24th seems good
20:44:58 <cait> is biweekly right?
20:45:07 <ashimema> I think so
20:45:08 <josef_moravec> I think so
20:45:10 <cait> ok
20:45:17 <cait> looking up syntax, sec
20:45:45 <cait> which time?
20:46:09 <ashimema> today felt a tad late to me.. but.. we got rangi :)
20:46:14 <cait> 14utc?
20:46:33 <oleonard> rangi is a pretty big get
20:47:11 <cait> #info Next meeting: 24 October 2018, 14 UTC
20:47:17 <cait> so quiet
20:47:22 <cait> ending meeting :)
20:47:25 <cait> #endmeeting