15:01:10 <kidclamp> #startmeeting Development IRC meeting 11 July 2018
15:01:10 <huginn> Meeting started Wed Jul 11 15:01:10 2018 UTC. The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:10 <huginn> The meeting name has been set to 'development_irc_meeting_11_july_2018'
15:01:16 <kidclamp> #topic Introductions
15:01:22 <cait> #info Katrin Fischer, BSZ, Germany
15:01:28 <kidclamp> #info Nick Clemens, ByWater Solutions
15:01:40 <ashimema> #info Martin Renvoize
15:01:45 <cc_> #info Colin Campbell, PTFS-Europe
15:01:49 <barton> #info Barton Chittenden, , ByWater Solutions
15:02:07 <barton> s/, ,/,/
15:02:44 <thd> #info Thomas Dukleth, Agogme, New York City
15:03:29 <beatsforthemind> Hello!
15:04:10 <kidclamp> #chair Cait
15:04:10 <huginn> Current chairs: Cait kidclamp
15:04:47 <cait> hey, where did we stop? ah yep
15:04:52 <beatsforthemind> Is a meeting in progress here? Is this a bad time for questions?
15:04:53 <cait> #topic Announcements
15:05:12 <cait> beatsforthemind: we just started an IRC meeting, but i think it won't take too long, if you want to wait
15:05:21 <beatsforthemind> ok, can do, thanks!
15:05:30 <Joubu> #info Jonathan Druart
15:05:38 <cait> any announcementsà
15:05:39 <cait> ?
15:07:02 <Joubu> sounds like a "no"
15:07:57 <cait> ah sorry, handling too many things
15:07:58 <cait> moving on
15:08:09 <cait> #topic Update from the release manager 18.11
15:08:15 <kidclamp> that's me!
15:08:28 <kidclamp> [off] how did that happen? :-D
15:08:33 <ashimema> String freees on the 15th for maintanence releases :)
15:09:08 <kidclamp> I am working on pushing bugs and new features, trying to clear css changes to make way for testing SCSS patches
15:09:21 * ashimema is also juggling too much and missed the window
15:09:35 <kidclamp> #info RM pushign bugs and working towards SCSS patches
15:09:58 <kidclamp> please keep an eye on ES patches and discussion, we have some good movement, would like ot see that continue
15:10:23 <cait> it#s hard to QA when they are signed off but actually are in discussion
15:10:29 <cait> i think we need to make some decisions :)
15:10:35 <kidclamp> any other refactoring and large chanegs should be prioritized as well to give time for testing before release
15:10:37 <cait> and maybe fix them later if we went the wrong way ;)
15:10:55 <kidclamp> would really like to see stock rotation, recalls, mana
15:11:08 <cait> any updates from rmaints or just repeating? we coudl then skip to general development directly maybe
15:11:17 <kidclamp> if they are in discussion they shoudl be marked so we can weigh in
15:11:18 <cait> true
15:11:23 <ashimema> stock rotation ++ # it's ready for QA again
15:11:24 <cait> is anyone willing to tackle them?
15:11:37 <cait> with docs patches submitted as well
15:12:05 <cait> stock rotation is not a thing here, so i am not sure i am the best to qa
15:12:15 <cait> i didn't fully udnerstand the concept yet
15:12:26 <ashimema> I've been trying to get to the refactoring patches.. the blocker is next on my list.
15:12:54 <kidclamp> that's all form me :-)
15:13:26 <ashimema> I also wanted to ask what order we wanted the ES bugs reviewed.. feels like there's two lots of dev going on in parallel that will cause horrible conflicts (but i might be wrong there)
15:14:00 <ashimema> wow.. the last lot of messages just came through out of order for me there.. sorr if my replies didn't make sense
15:14:16 <reiveune> bye
15:14:29 <cait> not sure which blocker one
15:14:33 <cait> apart from that it makes sense
15:14:39 <kidclamp> I think 18316 is current blocker - others will rebase ointo that once it is done
15:14:43 <cait> i think we got something like a 'route' established now
15:14:50 <cait> bug 18316
15:14:50 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18316 enhancement, P5 - low, ---, alex.arnaud, Signed Off , Add weighting/relevancy options to ElasticSearch
15:14:53 <cait> is the next one
15:15:04 <ashimema> blocker one for refactoring bugs.. Joubu mentioned it in a qa email reply a week back.. it may have moved since I looked at it.
15:15:52 <ashimema> what topic are we on now.. I've lost track
15:16:22 <kidclamp> hehe
15:16:38 <ashimema> bug 19893 is the ES Bug I was thinking of.. looks like it may conflict lots ?
15:16:38 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19893 enhancement, P5 - low, ---, glasklas, Signed Off , Alternative optimized indexing for Elasticsearch
15:16:38 <kidclamp> #info ES bugs need 18316 for attention
15:16:55 <kidclamp> ah, yes, that one too, but is a different set it blocks :-)
15:17:28 <kidclamp> I think we can move to current releases and bring up more in QA discussion
15:17:36 <thd> I have not had time to comment properly but I humbly suggest that weighting is not merely an issue when the user does not specify indicies.
15:17:52 <cait> #info Next Elasticsearch bug for QA is bug 18316
15:17:53 <kidclamp> #topic Updates from the Release Maintainers
15:18:19 <cait> i hoped we could sdiscuss 19893 a big
15:18:20 <cait> bit
15:18:34 <thd> s/is not/need not be/
15:18:48 <cait> sorry, i can't type today
15:19:00 <kidclamp> can we do that in qa discussion cait?
15:19:07 <kidclamp> felt like we were creeping a bit :-)
15:19:21 <cait> i think the basic question is: catmandu yes/no
15:19:32 <cait> oh sorry
15:19:37 <ashimema> Lots of bugs pushed this month already, and cookie related gdpr enhancements and marc framework updates backported too.
15:19:38 <cait> i thought we had already changed topic tot hat...
15:19:42 <cait> *hides*
15:19:48 <kidclamp> heh
15:20:05 <kidclamp> #info string freezes for current release on 15th, and releases as normal
15:20:15 <ashimema> #info 18.05.x - Lots of bugfixes pushed already, cookie related gdpr enhancements and marc framework updates backported too.
15:20:19 <ashimema> haha.. hense my getting lost on the topics cait..
15:20:26 <kidclamp> #chair ashimema
15:20:26 <huginn> Current chairs: Cait ashimema kidclamp
15:20:28 <ashimema> miht have been my fault :&)
15:20:41 <thd> The bug explanation is detailed but then omits the underlying reason for the inefficiency of Catmandu.
15:20:43 <kidclamp> or can anyone info? today is confusing
15:21:26 <kidclamp> anything else ashimema, or move ot QA and continue :-)
15:21:50 <ashimema> [off] pass.. I 'think' anyone can info from memory.. it's been a long time since I hosted a meeting
15:22:00 <ashimema> I'd say move on :)
15:22:20 <thd> I think we lost the place in the agenda sequence.
15:22:28 <kidclamp> #topic Updates from the QA team
15:22:29 <ashimema> that's all I had to add.. and I've not seen frido this meeting ;)
15:22:45 <kidclamp> anything cait? I guess we have agenda spot for the catmandu discussion
15:23:05 <ashimema> go for qa team
15:23:11 <ashimema> then we can continue e chatter after
15:23:50 <cait> ah sorry
15:23:53 <cait> i got something for rmaints
15:23:57 <kidclamp> #info the QA team are much loved and praised, we thank them for their efforts and look forward to more :-)
15:24:02 <cait> can we consider bakcporting bug 20175?
15:24:02 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20175 normal, P5 - low, ---, jonathan.druart, RESOLVED FIXED, Set a correct default value for club_enrollments.date_created
15:24:10 * ashimema has been bad at qa this week but hopes to get a bumper lot done on Monday next week.
15:24:17 <cait> we just ran into trouble with that on an update to 17.11 and i think it causes trouble on the mailng list too
15:24:50 <cait> in other news just the same as before, we have lots bugs in NSO and NQA... we need to take care of them
15:24:57 <cait> and also some big new features we shoudl take care of early on
15:25:18 <kidclamp> @later tell fridolin please look at bug 20175
15:25:18 <huginn> kidclamp: The operation succeeded.
15:25:27 <ashimema> I'll tag it up for fridolin to bring his attention to it..
15:25:28 <ashimema> thanks cait
15:26:03 <kidclamp> #info nots in the queues and some big things to get moving early in release cycle
15:26:08 <cait> if you have something you want me to bring to attention of the qa team let me know
15:26:10 <kidclamp> #info lots in the queues and some big things to get moving early in release cycle
15:26:14 <cait> i am spamming them with emails regularly :)
15:27:00 <cait> thx ashimema
15:27:39 <cait> maybe a gbsd could give things a little push?
15:27:43 <ashimema> :)
15:28:00 <ashimema> keep the spamming coming cait.. really helps focus the mind each week :)
15:28:06 <Joubu> There is also a "Devs to highlight/promote?" section on https://annuel2.framapad.org/p/What_s_on_in_koha-devel
15:28:10 <kidclamp> I think calire was going to organize one at some point (GBSD)
15:28:29 <kidclamp> @later tell calire GBSD? (hint)
15:28:29 <huginn> kidclamp: The operation succeeded.
15:29:06 <cait> nothing more from me :)
15:29:24 <kidclamp> #topic General development discussion (trends, ideas, ...)
15:29:59 <kidclamp> #info dicsussion: Bug 19893 - Drop dependancy on catmandu for elastic search
15:29:59 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19893 enhancement, P5 - low, ---, glasklas, Signed Off , Alternative optimized indexing for Elasticsearch
15:31:53 <beatsforthemind> I am working with a non-profit group who has an instance of Koha that I am now working with, the Koha instace is 16.11.05 Community
15:31:55 <thd> The bug explanation is detailed but then omits the underlying reason for the inefficiency of Catmandu.
15:32:05 <kidclamp> So generally the reasoning here is that we can gain speed if not using catmandu
15:32:25 <kidclamp> I don't think we know the reason THD - mostly that it has more code, does more stuff I would assume
15:32:26 <beatsforthemind> When I try to log in with the username and password specified in /etc/koha/sites/library/koha-conf.xml
15:32:39 <beatsforthemind> I am getting the error Software error: Can't call method "is_debarred" on an undefined value at /usr/share/koha/opac/cgi-bin/opac/opac-user.pl line 93.
15:32:43 <ashimema> So yeah... that bug (and it's chain) looks to me like it'll conflict lots.. we need to think about how we want to work it through
15:32:56 <beatsforthemind> Does anyone know why I would be getting this error and if there is a fix for it?
15:33:05 <kidclamp> hi beatsforthemind, there is a dev meeting right now, you are very welcome to attend and ask for help after :-)
15:33:07 <thd> beatsforthemind: The meeting is still going on and would be over in a few more minutes.
15:33:23 <ashimema> does catmandu actually simplify much kidclamp.. is the performance payment worth it?
15:33:36 <ashimema> I'ts been long enough since I played with catmandu that I dont konw.. but when I did I felt it actually got in the way
15:33:37 <beatsforthemind> Sorry
15:34:16 <kidclamp> If i recall, we aren't removing it whoelsale - just not using it for indexing
15:34:28 <ashimema> no worries.. I'm sure we'll be finished fairly soon beatsforthemind
15:34:57 <kidclamp> it defines a marc fixer language - the question is really how much of its features we need, and I don't think we will really know until we are using more in production - who knows what people will want to do
15:35:12 <ashimema> It looked like the set removed it entirely to me.. not just that bug but the others ones attached to it?
15:35:14 <ashimema> perhaps not
15:36:10 <ashimema> do we not have a marc fixer language already developed for rancor
15:36:58 <ashimema> basically.. should I concentrate on getting that patchset through and then have the other ES bugs rebased on top.. or the other way around?
15:37:19 <ashimema> from a QAing perspective that is.
15:38:09 <kidclamp> reading/thinking
15:39:07 <cait> we could bring it to the mailing list with a deadline for the next dev meeting
15:39:09 <cait> and then have a vote there
15:39:17 <cait> if people can#t make it, put your vote on the wiki
15:39:29 <kidclamp> I think that makes sense cait
15:39:33 <cait> i think a deadline could help to make the decision
15:39:53 <cait> ashimema: would you be willing to take care of it?
15:40:08 <kidclamp> I think it can be QAed ashimema to at least keep it fresh - afaict it only remove Catmandu for indexing, and that is the scope of the question
15:40:23 <kidclamp> we stil have Catmandu for accessing es store and searchign etc
15:40:45 <ashimema> sure :)
15:40:59 <ashimema> cool..
15:41:22 <ashimema> i'll go ahead then :)
15:41:37 <kidclamp> #action ashimema will send a mail about bug 19893 for discussion and vote at next dev meeting
15:41:37 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19893 enhancement, P5 - low, ---, glasklas, Signed Off , Alternative optimized indexing for Elasticsearch
15:41:53 <ashimema> moving on then :)
15:41:57 <cait> got another quick one, would love to get some more eyes (devs and librarians) on Bug 20935
15:42:08 <cait> https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20935
15:42:08 <huginn> 04Bug 20935: enhancement, P5 - low, ---, oleonard, Signed Off , Redesign system preferences interface
15:42:36 <kidclamp> ooh, yes, been wanting to play with that
15:42:43 <cait> sandbox testable! (should have mentioned that at the other meeting too)
15:43:13 <jenkins> Yippee, build fixed!
15:43:13 <jenkins> Project Koha_17.11_D8 build #69: FIXED in 35 min: https://jenkins.koha-community.org/job/Koha_17.11_D8/69/
15:43:15 <jenkins> kyle: Bug 20977: Javascript vars used in confirm_deletion in catalog.js do not
15:43:15 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20977 major, P5 - low, ---, kyle, RESOLVED FIXED, Javascript vars used in confirm_deletion in catalog.js do not match strings in catalog-strings.inc
15:43:34 <kidclamp> moving on?
15:43:36 <ashimema> :)
15:43:56 <kidclamp> #info librarians please look at bug 20935
15:43:56 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20935 enhancement, P5 - low, ---, oleonard, Signed Off , Redesign system preferences interface
15:44:39 <kidclamp> #topic Review of coding guidelines
15:45:23 <kidclamp> Just a mention here - I have had soem discussion with a few people about handling data in tests - working with existing/creating your own/deleting tables wholesale before testing
15:46:16 <kidclamp> I don't think we have enough info for a guideline, it requires some judgement, but just a general note that I don't prefer tables being deleted for tests if it can be avoided and may ask for rewrites or do followups in those cases
15:46:28 <kidclamp> if others have opinions I am happy to discuss
15:46:29 <Joubu> 20935 should go to the mailing list, not sure librarians read meeting's minutes ;)
15:47:03 <kidclamp> thanks for volunteering Joubu :-)
15:47:12 <ashimema> ?
15:47:15 <Joubu> I am not :)
15:47:15 <thd> :)
15:47:42 <kidclamp> I will send that one out to the koha list serv
15:47:57 <kidclamp> #action kidclamp will send a note out about bug 20935
15:48:06 <cait> kidclamp++
15:48:54 <ashimema> kidclamp++
15:49:01 <kidclamp> Next meeting: July 25 2018, 20 UTC?
15:49:56 <kidclamp> hearing no ojections
15:50:01 <thd> +1
15:50:13 <kidclamp> #info Next meeting July 25 2018, 20 UTC
15:50:17 <kidclamp> #endmeeting