#koha: Development IRC meeting 13 June 2018

Meeting started by kidclamp at 14:01:23 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:01:31)
    1. wahanui, a bot that has become sentient (wahanui, 14:01:31)
    2. Nick Clemens, ByWater Solutions (kidclamp, 14:01:39)
    3. Jonathan Druart (Joubu, 14:01:46)
    4. Lee Jamison, Marywood University (LeeJ, 14:01:49)
    5. Owen Leonard, Athens County Public Libraries, USA (oleonard, 14:02:03)
    6. Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic (josef_moravec, 14:02:05)

  2. Announcements (kidclamp, 14:03:14)
    1. Thomas Dukleth, Agogme, New York City (thd, 14:03:25)

  3. Update from the Release manager (18.11) (kidclamp, 14:04:41)
    1. RM is pushing bugs for one more week, will begin on enhancements next friday (kidclamp, 14:05:32)
    2. https://wiki.koha-community.org/wiki/Working_with_staff_client_SCSS (oleonard, 14:08:14)

  4. Updates from the Release Maintainers (kidclamp, 14:09:59)
    1. Fridolin Somers, Biblibre, France (fridolin, 14:10:20)
    2. Martin Renvoize - PTFS Europe (ashimema, 14:12:08)
    3. 18.05.01 will stick to release on 22nd to get as many fixes as possible (kidclamp, 14:16:35)

  5. Updates from the QA team (kidclamp, 14:17:59)
    1. bugs 19817 and 20287, please QA for early pushing to allow thorough testing (kidclamp, 14:20:28)
    2. bug 20271 could use a second (or third) pair of eyes as it is a big (but necessary) change (kidclamp, 14:24:56)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:25:31)
  7. Accounts API: Vote the RFC (kidclamp, 14:25:47)
    1. https://wiki.koha-community.org/wiki/Patrons_account_lines_endpoint_RFC Accountlines endpoint RFC (kidclamp, 14:28:01)
    2. Kyle M Hall, ByWater Solutions (khall, 14:35:01)
    3. https://wiki.koha-community.org/wiki/Acquisitions_funds_endpoint_RFC (Joubu, 14:39:08)
    4. VOTE: Voted on "Should manager_id in the accountlines endpoint be referred to as staff_id, user_id, or manager_id?" Results are, staff_id: 4, user_id: 3 (kidclamp, 14:42:43)
    5. staff_id is preferred for API access to manager_id in the db (kidclamp, 14:43:18)
    6. the RFC is flexible and will be adjusted depending on further needs/discussions (kidclamp, 14:47:39)
    7. VOTE: Voted on "Should we accept the accountlines endpoint RFC with adjustment for manager_id -> staff_id?" Results are, Yes: 6 (kidclamp, 14:50:33)
    8. Accountlines RFC endpoint is accepted (kidclamp, 14:50:48)

  8. Review of coding guidelines (kidclamp, 14:50:58)
  9. Add a new coding guideline about maintaining the cookie documentation, see: Use of Cookies (kidclamp, 14:51:09)
    1. https://wiki.koha-community.org/wiki/Use_of_Cookies Use of cookies (kidclamp, 14:51:20)
    2. VOTE: Voted on "Should a codign guidline be added to require devs to maintin documentation on cookie use/expiration as required by GDPR and maintained on the wiki page Use of Cookies?" Results are, Yes: 6 (kidclamp, 15:05:45)
    3. agred, we shoudl add a coding guideline to maintain cookie documentation (kidclamp, 15:06:22)
    4. Joubu suggests also adding notes about cookies/gdpr to release notes (kidclamp, 15:06:40)
    5. ACTION: cait, please write a codign guideline for cookies (kidclamp, 15:06:55)
    6. Next meeting: 27 June 2018, 21 UTC (kidclamp, 15:08:59)


Meeting ended at 15:09:07 UTC (full logs).

Action items

  1. cait, please write a codign guideline for cookies


People present (lines said)

  1. kidclamp (94)
  2. Joubu (42)
  3. thd (29)
  4. huginn` (25)
  5. ashimema (16)
  6. LeeJ (16)
  7. wahanui (9)
  8. josef_moravec (6)
  9. oleonard (5)
  10. khall (5)
  11. fridolin (3)
  12. eythian (2)
  13. lavamind (2)


Generated by MeetBot 0.1.4.