14:05:31 <kidclamp> #startmeeting Development IRC meeting 21 November 2018
14:05:31 <huginn> Meeting started Wed Nov 21 14:05:31 2018 UTC. The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:31 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:31 <huginn> The meeting name has been set to 'development_irc_meeting_21_november_2018'
14:05:38 <kidclamp> #topic Introductions
14:05:47 <kidclamp> #info Nick Clemens, ByWaterSolutions
14:06:09 <barton> #info Barton Chittenden, ByWaterSolutions
14:06:13 <marcelr> #info Marcel de Rooy, Rijksmuseum NL
14:06:20 <greenjimll> #info Jon Knight, Loughborough University
14:07:21 <kidclamp> #topic Announcements
14:07:23 <kidclamp> anybody?
14:07:51 <greenjimll> nothing from me.
14:08:21 <tcohen> #info Tomas Cohen Arazi
14:08:47 <barton> morning tcohen
14:08:58 <kidclamp> #topic Update from the Release Manager
14:09:23 <kidclamp> #info Release is coming along - combing through the release notes and the majors and above in bugzilla to fix whatever we can
14:10:16 <kidclamp> #info possibly considering 21826/19365 - would be nice to fix this, but don't want to cause issues this close to release
14:10:27 <kidclamp> any exytra QA eyes on those bugs would be appreciated
14:10:36 <kidclamp> bug 21826
14:10:36 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21826 enhancement, P5 - low, ---, ere.maijala, Passed QA , Automatic authority record generation improvements
14:10:38 <kidclamp> bug 19365
14:10:38 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19365 major, P5 - low, ---, ere.maijala, Passed QA , link_bibs_to_authorities.pl doesn't work with Elasticsearch
14:10:48 <ashimema> #info Martin Renvoize - PTFS Europe
14:10:52 * ashimema got the time confused
14:11:00 <kidclamp> thanks to all for lots of hard work, looking forward to sending this one out the door
14:11:13 <kidclamp> that's all from me, just thank you again to all
14:12:18 <kidclamp> #topic Updates from the Release Maintainers
14:12:25 <kidclamp> ashimema: fridolin
14:12:25 <wahanui> well, fridolin is indeed, but maybe not on Rmain 18.11
14:12:50 <ashimema> I have a test failing (selenium) which I'm working on a fix for
14:13:07 <ashimema> otherwise, we're not in bad shape for the next (and my final) 18.05.x release
14:13:36 <ashimema> I'm steady at 50 commits behind master right now.. bit I think the majority of those are enhancements
14:13:37 <fridolin> yep
14:13:49 <fridolin> #info Fridolin Somers, Biblibre, France
14:14:24 <ashimema> #info 18.05.x branch has one current failing test.. I believe it's the test rather than the feature that's failing
14:14:57 <greenjimll> I hate it when tests do that!
14:14:58 <ashimema> #info 18.05.x is currently 50 commits begind master, but the majority of those are enhancements and as such won't be backported
14:15:17 <ashimema> #info 18.05.x is otherwise on target for release next week
14:15:38 <fridolin> I have selenium not configured in Jenkins for 17.11.x
14:15:45 <thd> #info Thomas Dukleth, Agogme, New York City
14:15:59 <fridolin> otherwise its OK, a bit late on 18.05 backports
14:16:30 <kidclamp> thanks guys, anything else?
14:16:39 <ashimema> not from me :)
14:16:39 <fridolin> I'm ok
14:17:00 <kidclamp> #inf 17.11 is a bit behind but coming along, releases on target for release next week
14:17:10 <kidclamp> #topci Updates from the QA team
14:17:16 <kidclamp> #topic Updates from the QA team
14:17:22 <kidclamp> cait around?
14:17:56 <kidclamp> Joubu: marcelr Josef_moravec alex_a jajm
14:17:59 <marcelr> no updates
14:18:09 <kidclamp> khall tcohen
14:18:51 <kidclamp> #info The QA team is awesome, bugs get QAed, things get fixed, the people are happy
14:19:02 <kidclamp> moving on
14:19:07 <kidclamp> #topic General development discussion (trends, ideas, ...)
14:19:09 <tcohen> .-D
14:19:09 <kidclamp> anything?
14:19:20 <greenjimll> I like bz-splitter!
14:19:33 <marcelr> bug 21336 needs SO
14:19:33 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21336 enhancement, P5 - low, ---, m.de.rooy, Needs Signoff , GDPR: Handle unsubscribe requests automatically by optional (administrative) lock, anonymize and remove
14:19:35 <barton> greenjimll++
14:19:48 <ashimema> bz-splitter needs a little love to stop it from crashing frequently..
14:20:32 <greenjimll> Going to be useful for bug-wrangling though to easily spot bugs that might need a nudge.
14:20:38 <kidclamp> #info bug 21336 could use attention GDPR
14:20:58 <kidclamp> #info splitter is an amazing tool, could use some attention to keep it running
14:21:11 <kidclamp> what does it need ashimema - code work or server help?
14:21:19 <greenjimll> I take it 21336 will be a 19.05 thing now?
14:21:30 <kidclamp> indeed
14:22:04 <greenjimll> Be good to get bug 20028 sorted out for the same release (other side of GDPR coin)
14:22:04 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20028 enhancement, P5 - low, ---, J.P.Knight, Failed QA , Export all patron related personal data in one package
14:22:49 <ashimema> code work
14:23:06 <ashimema> seems to crash whenever an ipv6 address hits it
14:23:28 <ashimema> Joubu and I are both aware but haven't been able to personally replicate
14:23:39 <ashimema> and neither of us have time at the minute to investigate further.
14:23:48 <ashimema> we'll get to it at some point ;)
14:24:01 <kidclamp> cool
14:24:04 <kidclamp> moving on?
14:24:12 <ashimema> yup
14:24:17 <kidclamp> #info bug 20028 is a good candidate for 19.05 too
14:24:26 <kidclamp> #topic Review of coding guidelines
14:24:34 <kidclamp> barton?
14:24:42 <barton> right.
14:25:26 <barton> So I wrote the notices and slips wiki page, and that's sort of been the backbone of the notices and slips documentation for a while.
14:25:52 <cait> sorry, almost missed the meeting
14:26:02 <cait> #info Katrin Fischer, BSZ, Germany
14:26:17 <barton> you made it for the good part ;-).
14:27:00 <barton> anyway, I entered bug 21858 to move my work off the wiki into POD.
14:27:01 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21858 enhancement, P5 - low, ---, koha-bugs, Needs Signoff , RFC: Notices and slips documentation
14:27:47 <barton> ... and I'd like to create a coding guideline that says that any new notices need to be documented.
14:27:55 <greenjimll> POD is good. Literate programming.
14:28:00 <cait> I'd like to suggest not using POD in favor of manual patches
14:28:14 <cait> POD is used in our files atm, but not as standalone separte from methods like this suggestion
14:28:26 <cait> it would require manual people to replicate for the manual reading the POD file
14:28:31 <ashimema> I like POD for within modules and aimed at developers... for user facing stuff a manual patch
14:28:35 <ashimema> that's my opinion
14:28:48 <ashimema> if POD is just feeding Manual.. then it's always going to get out of sync
14:28:57 <marcelr> yeah pod may not be the best place here
14:29:04 <cait> we are terribly at keeping thing in sync
14:29:36 <barton> I've got 5 people at bywater who are *itching* to get notices stuff into the manual. I'm not worried about carrying that over.
14:29:51 <ashimema> but I certianly DO like the idea of it being a guideline to state manual merge requests should accompany bugzilla submissions (whenever apropriate)
14:30:01 <barton> getting devs to document the intent of the notices is the hard part.
14:31:10 <ashimema> we already require POD updates for changes to and additions of methods/subs
14:31:19 <ashimema> so how is this different to that..
14:31:22 <marcelr> managing devs is hard
14:31:35 <cait> getting devs to documet is hard, but I think it's not too much to ask
14:32:00 <kidclamp> I would agree, manual is a better place
14:32:05 <koha-jenkins> Project Koha_Master_D9 build #616: SUCCESS in 27 min: https://jenkins.koha-community.org/job/Koha_Master_D9/616/
14:32:12 <ashimema> needs to continue to be something easy for QA'ers to spot and fail patches for.. having an entirely separate POD file that collates notices docs is going to be hard to spot when missing..
14:32:18 <ashimema> or did I misunderstand the request?
14:33:00 <kidclamp> this pod could all go into the individual scripts/module too, no? Then it would need to be maintained by devs without being a sepearate file?
14:33:11 <cait> not os easily
14:33:21 <ashimema> that's where I would aim for
14:33:44 <barton> Ok, so I created a separate file, *mostly* so that I had something to show people.
14:33:49 <cait> i mean it's pretty spread out in the code right no
14:33:50 <cait> w
14:33:53 <cait> but methods shoudl be documented
14:34:00 <ashimema> if a Dev adds a notice then there's going to be an associated method/sub somewhere for that notice.. that's where the POD documentation should go..
14:34:10 <cait> yep
14:34:14 <barton> ... but I'm not stuck on the pod. As long as it's documented somewhere, and we have a coding guideline, I'm happy.
14:34:40 <cait> i think converting your work already done for the manual would be great
14:35:03 <cait> it's a good template too
14:35:05 <greenjimll> I get the feeling that the proliferation of syntaxes is also an issue in this case, because individual devs haven't necessarily seen what others have done? Or am I misunderstanding?
14:35:06 <ashimema> that is then something manual maints can use to construct the manual updates from (and that's actualy where a new guideline would be good encouraging devs to at least setup a stub manual merge request for the needed docs update)
14:35:18 <koha-jenkins> Project Koha_Master_U18 build #105: SUCCESS in 30 min: https://jenkins.koha-community.org/job/Koha_Master_U18/105/
14:35:40 <kidclamp> we don't have a guideline requiring manual patches, but I think QA at least suggests for new features, no?
14:35:56 <barton> ^^ what greenjimll said.
14:36:13 <ashimema> I know I do ;)
14:36:29 <barton> The documentation *needs* to be centralized.
14:36:35 <greenjimll> How do we submit a manual patch for something that hasn't yet been signed off/passed QA (and so may change radically)
14:37:00 <cait> you can do it and mark it WIP
14:37:05 <ashimema> well.. for 'Stock Rotation' for example I marked it with WIP
14:37:14 <cait> or you could write up a note on the release notes that is nice and clear for a start
14:37:25 <greenjimll> OK, is that process documented?
14:37:26 <ashimema> and noted it was awaiting final QA of the bug
14:37:34 <ashimema> not that I know of..
14:37:41 <ashimema> that's where a new guildeline could come in
14:38:03 * ashimema would love to automate some of it somehow.. but hasn't got that far
14:38:14 <koha-jenkins> Project Koha_Master_D8 build #114: SUCCESS in 35 min: https://jenkins.koha-community.org/job/Koha_Master_D8/114/
14:38:52 * ashimema actually submitted a WIP merge request with just titles to start with.. then got his customer services team to write the human facing first draft (which I then maintained whilst the bug went through QA)
14:39:52 <cait> :)
14:40:13 <cait> would someone be willing to write up the pod to a manual merge request?
14:40:25 <cait> some of it might already be documented
14:40:39 <cait> i think we at least have an explanation for the notices code
14:40:40 <cait> s
14:40:51 <kidclamp> sounds like consensus is move this bug to master, consider a guideline for manual patches when submitting new features/ changing existing features?
14:41:16 <cait> +1
14:41:39 <ashimema> +1
14:41:47 <greenjimll> Er, I thought I was in the minority in liking POD in a file (which is what this bug does at the moment)?
14:41:47 <kidclamp> Does someone want to draft that for next meeting and send out to lists for opinion?
14:41:56 <barton> I can talk to bywater's education team; jzairo or donna.
14:42:34 <ashimema> +1
14:43:01 <barton> +1
14:44:12 <greenjimll> I'm not clear what folk are +1'ing? Getting 21858 pushed to master?
14:44:15 <kidclamp> #action Barton will see about getting a guideline for manual patches drafted and send to community
14:44:26 <thd> greenjimll: While I do not know where the majority stands, I think past difficulties have been about outdated POD not being updated.
14:44:41 <kidclamp> greenjimll: I think to move it to manual and consider a guideline to require manual changes
14:44:58 <marcelr> yes, move it to the manual
14:45:15 <greenjimll> kidclamp: Ah, you said, " move this bug to master" and confused me.
14:45:40 <kidclamp> hah, I meant manual
14:45:49 * kidclamp looks around for more coffee
14:45:51 <greenjimll> In which case, +1
14:46:17 <marcelr> first write a proposed guideline ?
14:46:52 <barton> I'll take care of that.
14:46:58 <kidclamp> barton++
14:47:32 <ashimema> barton++
14:47:52 <ashimema> it's great having manual improvements happening again :)
14:48:05 <kidclamp> #agreed bug 21858 will be converted a patch for manual, barton will get a guideline for manual submissions drafted
14:48:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21858 enhancement, P5 - low, ---, koha-bugs, Needs Signoff , RFC: Notices and slips documentation
14:48:13 <marcelr> barton++
14:48:20 <kidclamp> anything else? or set next meeting?
14:48:59 <barton> I'm good. Veni Vidi Documentii
14:49:21 <kidclamp> #topci Set time of next meeting
14:49:27 <kidclamp> #topic Set time of next meeting
14:50:07 <kidclamp> December 12? is three weeks, but avoids general meeting overlap, or combine the two on december 5th?
14:50:15 <kidclamp> two meetings is too many
14:50:21 <marcelr> not on same date
14:50:57 <greenjimll> 12th works for me (I assume this will be an evening one in UTC)?
14:51:03 <kidclamp> December 12, 20 UTC?
14:51:08 <greenjimll> +1
14:51:08 <kidclamp> yup, we alternate
14:51:45 <ashimema> +1
14:52:41 <kidclamp> #info Next meeting: 12 December 2018, 20 UTC
14:52:45 <kidclamp> #endmeeting