#koha: Development IRC meeting 22 August 2018

Meeting started by kidclamp at 20:00:43 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 20:00:53)
    1. Martin Renvoize, PTFS Europe (ashimema, 20:01:02)
    2. Nick Clemens, ByWater Solutions (kidclamp, 20:01:02)
    3. Jon Knight, Loughborough University (greenjimll, 20:01:03)
    4. Brendan gallagher Bywater (bag, 20:01:22)
    5. Josef Moravec, Municipal Library Usti nad Orlici (josef_moravec, 20:01:32)
    6. Katrin Fischer, BSZ, Germany (cait, 20:03:00)

  2. Announcements (kidclamp, 20:03:25)
    1. https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client SCSS for staff and OPAC (kidclamp, 20:03:54)
    2. https://wiki.koha-community.org/wiki/Coding_Guidelines#HTML9:_filter_all_the_variables Global XSS fix (kidclamp, 20:04:07)
    3. https://wiki.koha-community.org/wiki/Development_IRC_meeting_22_August_2018 Agenda (cait, 20:04:28)
    4. Thomas Dukleth, Agogme, New York City (thd, 20:05:33)

  3. Update from the Release manager (18.11) (kidclamp, 20:07:11)
  4. Updates from the Release Maintainers (kidclamp, 20:09:06)
    1. releases delayed for coordinated release, holidays (kidclamp, 20:10:48)

  5. Updates from the QA team (kidclamp, 20:11:07)
    1. HACKFEST!!! kidclamp is running the show - please help him out and bring ideas for what to do (kidclamp, 20:11:17)
    2. email kidclamp if you have things you want done or ideas (kidclamp, 20:11:35)
    3. queue is in reasonable shape, can always be better, but bugs are being taken care of fast, enh a little slower (cait, 20:13:23)
    4. QA team is looking for QA topic experts - sign off counting for qa, additional code review from qa team as needed, volunteers welcome - please also feel free to suggest people (cait, 20:15:51)
    5. ACTION: bag to volunteer as QA topic expert for LDAP and SIP (cait, 20:17:38)
    6. other topics: RDF, authentication (cait, 20:18:44)

  6. General development discussion (trends, ideas, ...) (kidclamp, 20:21:14)
    1. [VOTE] REST API: public vs. private API. how do we handle (kidclamp, 20:21:39)
    2. VOTE: Voted on "Should we adapt current API as 'private' and build new '/public' namespace for simple information endpoints (as outlined in agenda)?" Results are, Yes: 6 (kidclamp, 20:29:20)
    3. It's unanimous - do that thing (kidclamp, 20:29:43)
    4. ACTION: Tomas will do that thing (kidclamp, 20:29:52)
    5. AGREED: We want the current api to be private and add a public namespace for needed info endpoints (kidclamp, 20:30:37)

  7. Review of coding guidelines (kidclamp, 20:30:48)
    1. https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL9:_Subroutine_naming_conventions Coding guideline for soubroutine naming conventions (cait, 20:32:04)
    2. VOTE: Voted on "Should we adapt the PERL9 guideline to state us of snake_case for subroutines in the Koha namespace and the use of CamelCase for modules?" Results are, Yes: 4 (kidclamp, 20:44:01)
    3. AGREED: PERL9 will (has been) be updated to reflect Koha namespace capitlization guidelines (kidclamp, 20:44:33)

  8. Set time of next meeting (kidclamp, 20:44:49)
    1. Next meeting: 19 September 2018, 14 UTC (kidclamp, 20:49:14)


Meeting ended at 20:49:20 UTC (full logs).

Action items

  1. bag to volunteer as QA topic expert for LDAP and SIP
  2. Tomas will do that thing


Action items, by person

  1. bag
    1. bag to volunteer as QA topic expert for LDAP and SIP


People present (lines said)

  1. cait (91)
  2. kidclamp (82)
  3. ashimema (22)
  4. greenjimll (16)
  5. huginn` (16)
  6. bag (13)
  7. thd (11)
  8. josef_moravec (8)


Generated by MeetBot 0.1.4.