#koha: Development IRC meeting 8 August 2018

Meeting started by Joubu at 14:01:20 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 14:01:37)
    1. Jonathan Druart (Joubu, 14:01:44)
    2. Katrin Fischer, BSZ, Germany (cait, 14:01:47)
    3. Owen Leonard, Athens County Public Libraries, USA (oleonard, 14:01:51)
    4. Martin Renvoize, PTFS Europe, UK (ashimema, 14:01:58)
    5. Colin Campbell, PTFS-Europe, UK (cc_, 14:02:11)
    6. Victor Grousset, BibLibre, France (tuxayo, 14:02:15)
    7. https://wiki.koha-community.org/wiki/Development_IRC_meeting_8_August_2018 (Joubu, 14:02:27)
    8. Andrew Isherwood, PTFS Europe, UK (AndrewIsh, 14:02:29)

  2. Announcements (Joubu, 14:03:49)
  3. Update from the Release Manager (18.05) (Joubu, 14:04:53)
    1. RM was in holiday, back this week and will push all the things (Joubu, 14:05:07)
    2. ACTION: kidclamp push all the things (Joubu, 14:05:17)

  4. Updates from the Release Maintainers (Joubu, 14:05:30)
    1. Tomas Cohen Arazi (tcohen, 14:05:34)
    2. 18.05.x: I have been pushing a fair bit this week after a backlog after vacation.. I'm all up to date and awaiting kidclamps next set of pushes (ashimema, 14:06:33)
    3. If you plan to use 18.05.x in production, pick 18.05.02 or later (Joubu, 14:07:56)

  5. Updates from the QA team (Joubu, 14:09:21)
    1. qa queue is in an ok shape, slowly going down, below 40 now (cait, 14:10:32)
    2. Needs Signoff is way too high with lots of bugs waiting for testers - please sign-off! (cait, 14:12:32)
    3. next step for Elasticsearch is BugĀ 18316 - Add weighting/relevancy options to ElasticSearch. Additional testing/sign offs might make it move faster! (cait, 14:13:28)
    4. Thomas Dukleth, Agogme, New York City (thd, 14:18:44)

  6. General development discussion (trends, ideas, ...) (Joubu, 14:19:32)
  7. Bug 13618 - Prevent XSS in the Staff Client and the OPAC (Joubu, 14:20:03)
    1. input needed on how to best make BugĀ 15836 - Labels: Offer configuration option for splitting call numbers secure. (cait, 14:23:23)

  8. Bug 21010 - Add a script to search for data inconsistencies (Joubu, 14:25:26)
    1. Martin Renvoize to SO 13618 and discuss next steps with Jonathan (ashimema, 14:25:57)
    2. if you have ideas for data consistencies to look out for, file a bug and link it to bug 21010 (cait, 14:29:00)

  9. Bug 20443 - Move C4::Members::Attributes to Koha namespace (Joubu, 14:29:35)
  10. Bug 18252 - Move C4::Items code to the Koha namespace (Joubu, 14:35:55)
    1. Martin and Tomas are going to schedule a paired QA for bug 20443 (ashimema, 14:36:10)
    2. ACTION: ashimea and tcohen to review bug 20443 together (cait, 14:36:10)
    3. Bug 15836 - Labels: Offer configuration option for splitting call numbers (Joubu, 14:38:29)
    4. ILS-DI GetRecords (see ML) (Joubu, 14:46:43)
    5. https://old.diglib.org/architectures/ilsdi/DLF_ILS_Discovery_1.0.pdf (Joubu, 14:52:53)
    6. Last projects to move to gitlab/k-c (should contrib be split?) (Joubu, 14:58:52)
    7. https://gitlab.com/koha-community/release-tools (Joubu, 15:00:19)

  11. Set time of next meeting (Joubu, 15:06:40)
    1. Next meeting: 22 August 2018, 20 UTC (Joubu, 15:08:04)


Meeting ended at 15:08:06 UTC (full logs).

Action items

  1. kidclamp push all the things
  2. ashimea and tcohen to review bug 20443 together


Action items, by person

  1. kidclamp
    1. kidclamp push all the things
  2. tcohen
    1. ashimea and tcohen to review bug 20443 together


People present (lines said)

  1. Joubu (131)
  2. cait (80)
  3. ashimema (60)
  4. tcohen (31)
  5. huginn (13)
  6. oleonard (10)
  7. tuxayo (10)
  8. jajm (8)
  9. thd (4)
  10. AndrewIsh (1)
  11. cc_ (1)
  12. seafarmer (1)
  13. kidclamp (0)


Generated by MeetBot 0.1.4.