21:05:37 <LeeJ> #startmeeting Documentation IRC meeting 9 May 2018
21:05:37 <huginn> Meeting started Wed May 9 21:05:37 2018 UTC. The chair is LeeJ. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:05:37 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:05:37 <huginn> The meeting name has been set to 'documentation_irc_meeting_9_may_2018'
21:05:58 <LeeJ> #topic Introductions
21:05:58 <wahanui> #info wahanui, a bot that has become sentient
21:06:07 <cait1> #info Katrin Fischer, BSZ, Germany
21:06:07 <LeeJ> #info Lee Jamison, Marywood University
21:06:15 <caroline_> #info Caroline Cyr La Rose, inLibro
21:06:16 <davidnind> #info David Nind, Wellington, New Zealand
21:06:16 <georgew> #info George Williams, Northeast Kansas Library System
21:06:36 <LeeJ> #topic What's been done so far
21:07:03 <LeeJ> alright, as of this morning I've gotten tasks created for everything current per the release notes
21:07:34 <cait1> LeeJ++
21:07:38 <davidnind> LeeJ++
21:07:38 <LeeJ> #info the kohadocs Taiga project is current as of Release Notes 17.12.00.044
21:08:20 <LeeJ> #info currently in queue to be added to the documentation are 11 new features, 257 enhancements, and 19 new system preferences
21:08:34 <LeeJ> yes I did, in fact, count them all ;)
21:08:43 <caroline_> hehe!
21:09:17 <LeeJ> caroline_: would you like to mention the work that you and your team have accomplished for documentation so far? I saw you've been very busy
21:09:23 <LeeJ> and cait1 your work too :)
21:09:43 <caroline_> um... Well, I'm the only one doing doc on my team
21:09:57 <LeeJ> caroline_: I meant in general :)
21:10:05 <caroline_> Ah ok!
21:10:26 <caroline_> Yes, Every friday afternoon the whole team does what we call "community work"
21:10:51 <caroline_> So I either translate of doc, and the devs work on bugs or sign offs
21:11:02 <caroline_> translate OR doc, I meant
21:11:19 <LeeJ> caroline_++
21:11:20 <cait1> Inlibro++
21:11:25 <LeeJ> Inlibro++
21:11:30 <caroline_> thanks! :D
21:11:48 <LeeJ> cait1: care to share with everyone all the "restructuring" you've been working on? :)
21:11:59 <cait1> I've been working on restructuring a bit
21:12:04 <cait1> one of the goals being to make the files smaller
21:12:23 <cait1> which will also help translators I think
21:12:41 <cait1> another thing is that the TOCs get easier to handle
21:13:05 <LeeJ> cait1++
21:13:09 <cait1> like by splitting administration into system preferences and 'rest' we lost one level of headings
21:13:22 <LeeJ> which is a BIG deal :D
21:13:24 <cait1> which i think helps to make them a little more readable/easier to navigate
21:13:35 <cait1> or i hope so :)
21:13:36 <LeeJ> and less syntax to remember :)
21:13:47 <cait1> next i've been working on splitting the next big chapter
21:13:52 <cait1> misecellanous
21:14:00 <cait1> let me find a link quickly
21:14:09 <georgew> smaller chapters will be a lot easier on end users
21:14:18 <LeeJ> I agree georgew
21:14:37 <cait1> i hope my changes so far are agreeable :)
21:14:40 <LeeJ> especially since a lot of small, specific sections have been buried deep in larger files
21:14:53 <cait1> miscellanous was not linked from Koha
21:15:06 <LeeJ> cait1: I agree with them! Otherwise they wouldn't get pushed ;D
21:15:09 <cait1> but we also removed the numbering from the file names (to not have to renumber them all the time)
21:15:18 <cait1> so I needed to fix the links in Koha
21:15:24 <cait1> bug 20706
21:15:24 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20706 enhancement, P5 - low, ---, katrin.fischer, Needs Signoff , Fix links to help files for changed file structure (removed numbering on files)
21:15:43 <cait1> we need to make one more change there and add back the en language codes int he files for the time being
21:15:47 <LeeJ> cait1: would you mind adding some quick info tags for the notes? :)
21:15:48 <cait1> otherwise links won't work right
21:16:07 <LeeJ> *notes/minutes
21:16:13 <cait1> #info bug 20706 needs sign-off / qa - It's to adapt the links in Koha to the new file structure
21:16:24 <cait1> #info administration has been split into prefs and rest
21:16:48 <cait1> #info miscellanous has been split into multiple files now, like links, faq, extending_koha
21:16:54 <cait1> i need some more help there
21:17:06 <LeeJ> what help do you need?
21:17:07 <cait1> 1) can we lose the serials sample ins favor of the wiki page caroline started?
21:17:41 <LeeJ> cait1: have a link to that wiki page? never knew about it
21:18:00 <cait1> 2) Move 'OCLC connextion gateway', 'Talking Tech' and 'MarcEdit' into a new chapter 'Using third party software wit Koha' ?
21:18:03 <caroline_> Didn't we already have this conversation a while back?
21:18:11 <cait1> 3) Move SIP2 and LDAP sections into a new chapter 'Other APIs and protocols' right below the 'Web services' chapter?
21:18:15 <caroline_> We voted on wiki vs manual for something
21:18:18 <cait1> caroline_: i was not sure how to proceed, maybe i forgot
21:18:22 <cait1> ah for faq
21:18:27 <cait1> we decided on the manual i tihnk
21:18:32 <georgew> The vot on wiki vs manuals was for faq
21:18:40 <caroline_> ah ok thanks!
21:19:00 <cait1> we could also imagine moving them into the serials chapter
21:19:22 <caroline_> I would move the link to the wiki in the serials chapter
21:19:40 <LeeJ> I think caroline_ has a good idea
21:19:49 <cait1> sorry, can you epxlain?
21:19:50 <caroline_> number 2 and 3 are fine by me
21:20:04 <caroline_> well removing the serials sample section
21:20:07 <cait1> was not sure about the naming of the chapters, 2) and 3) has a patch ready to go then :)
21:20:28 <caroline_> and just putting the link "for examples see ..." in the serials chapter
21:20:36 <caroline_> the link to the wiki I mean
21:20:41 <cait1> #link https://wiki.koha-community.org/wiki/Serial_Pattern_Library Serial pattern library
21:20:47 <cait1> ok
21:20:48 <cait1> :)
21:20:59 <cait1> one reason i'd remove it righ tnow is i am not sure if all the examples are still correct
21:21:13 <cait1> i think the wiki is the better source atm
21:21:13 <LeeJ> didn't know about that serial wiki...
21:21:16 <KSorbo[> Question on Server Specs:
21:21:20 <caroline_> I can check that friday if you want
21:21:42 <caroline_> check if the samples are still ok
21:21:47 <LeeJ> KSorbo[: we're in the middle of a meeting...if you can wait a few minutes we'll be happy to help you
21:21:48 <cait1> caroline_: I am pretty sure yours are correct, meant te ones in the manual :)
21:22:01 <caroline_> that's what I meant!
21:22:05 <cait1> ah sorry
21:22:10 <caroline_> I will check and copy them to the wiki
21:22:16 <cait1> my brain is a little tired tonight :)
21:22:21 <cait1> caroline_: thx!
21:22:30 <KSorbo[> I have a Ubuntu 16.04 test server with 512M and 1 CPU with 1G swapfile. Koha is very slow, taking 10-15 secs on any screen. What am I doing wrong? Does perl require more cpu/memory than this?
21:22:31 <caroline_> and then I'll remove the chapter
21:22:33 <LeeJ> #topic Workflows
21:22:39 <cait1> ok
21:22:41 <cait1> last one
21:22:41 <wahanui> rumour has it last one is the first one if you look backwards
21:22:43 <KSorbo[> (SORRY)
21:22:59 <cait1> the chapter with the isbd defualts
21:23:02 <cait1> is that helpful?
21:23:07 <cait1> could we move it?
21:23:21 <LeeJ> cait1: I honestly have no opinion on it
21:23:29 <cait1> https://koha-community.org/manual/18.05/en/html/miscellaneous.html
21:23:37 <cait1> hm didn't quite link
21:23:50 <cait1> i think i ciould get that somewhere i have all 'misc' sorted out
21:24:13 <cait1> the isbd defaults and Koha XSLT Item Types
21:24:21 <caroline_> https://koha-community.org/manual/17.05/html/18_miscellaneous.html#isbd-defaults
21:24:25 <cait1> yep
21:24:39 <cait1> if you got a good idea, let me know please :)
21:24:42 <caroline_> I have no idea what those mean...
21:25:03 <caroline_> Is it for the sys prefs when they say to use default or leave blank?
21:25:24 <caroline_> if we put default it's going to use this?
21:26:13 <caroline_> nooo! cait come back! ;)
21:26:23 <cait> sorry, had to restart the laptop:(
21:26:36 <cait> frozen
21:27:01 <caroline_> can you see the history or do you need me to copy/paste my questions?
21:27:13 <cait> just checed history
21:27:29 <cait> it's the default values for the ibsd sysprefs
21:27:30 <LeeJ> cait caroline_are there any other "stray" or "out of place" sections in the manual that could be grouped with the ISBD defaults?
21:27:34 <cait> when you install koha out of the box
21:27:49 <cait> the xslt item types ones maybe
21:27:53 <cait> lost all my tabs now :(
21:28:13 <cait> but i am not even sure if the defaults are current, i am not checking content much right now, just trying to sort
21:28:41 <caroline_> could we just make a page for those defaults and link them from the sys prefs chapter?
21:28:43 <cait> https://koha-community.org/manual/18.05/en/html/miscellaneous.html#koha-xslt-item-types
21:29:11 <cait> we could move them into a new chapter, but htat would mean a very small one :)
21:29:20 <caroline_> that way, they wouldn't be a "chapter", but still accessible for ppl who want to know what the defaults are
21:29:32 <cait> i am not sure if that works with the way the manual is
21:29:45 <cait> as soon as you add a file to the index.rst it appears in the table of contents
21:29:54 <cait> adding a hidden page might be problematic
21:30:01 <caroline_> ah, then it won't work.
21:30:18 <cait> we could slip then into faq?
21:30:22 <cait> them
21:30:41 <cait> the itemtypes could also go under cataloguing maybe
21:30:42 <caroline_> is that where the db codes are?
21:30:48 <caroline_> in the faq?
21:30:51 <cait> i haven't checked closely yet
21:31:29 <cait> hm i will suggest something
21:31:36 <cait> i think i got some ideas now
21:32:19 <tcohen> @later tell Joubu maybe we can promote timezone per-instance as a new feature? same for 'supporting emojis'. It feels like they are hidden in the release notes, but very important though
21:32:19 <huginn> tcohen: The operation succeeded.
21:33:23 <cait> tcohen: you are disrupting a docs meeting ;)
21:33:26 <cait> LeeJ: move on?
21:33:28 <LeeJ> cait caroline_: it seems we have a bit of discussion to do for it, but since they've been in the same place for so long, what say we bench the discussion until next docs release and leave ISBD as is
21:33:30 <LeeJ> ?
21:33:44 <caroline_> ok
21:34:30 <LeeJ> #action some documentation section moves (specifically ISBD) will be benched until next release cycle
21:34:31 <georgew> Sorry, I had to answer an emergency phone call, but are there any other big unweildy defaults like the ISBD defaults? Is there a potential for putting default settings like that in a chapter of ther own?
21:34:43 <cait> i'd just wanted to try and reach some kind of 'stable' files number so the translations can be fixed for it :)
21:34:59 <georgew> And leaving them where they are till the next version is a great idea too, LeeJ
21:35:03 <cait> georgew: i couldn't come up with others so far
21:35:15 <LeeJ> alright, if no one has anything else let's move on
21:35:29 <georgew> It almost seems like something you'd see in an appendix or endnotes if this were a physical book
21:35:34 <cait> the issue is that I'd like to kill the misc chapter, but i will work out a suggestion
21:35:40 <LeeJ> #topic Next steps
21:36:09 <LeeJ> alright, now that my final exams concluded as of this morning I can dedicate 100% of my time to documentation until the release date
21:36:28 <caroline_> LeeJ+ congrats!
21:36:30 <LeeJ> so I'm going to send out an email sometime on Sunday regarding a sprint week for next week
21:36:34 <cait> woohoo and congrats!
21:36:36 <LeeJ> caroline_: thanks!
21:36:56 <LeeJ> sound good to everyone?
21:37:09 <cait> yes
21:37:12 <georgew> yes
21:37:13 <davidnind> sounds good
21:37:21 <LeeJ> nice!
21:37:28 <caroline_> I don't know what awaits me next week, but I'll try!
21:37:33 <cait> I should be able to spend a lot of a day next week
21:37:44 <LeeJ> caroline_: no worries! you've been a great help this whole time :)
21:37:51 <georgew> if we do it after Tuesday I'll devote an entire workday to it
21:37:57 * tcohen is sorry
21:38:29 <LeeJ> #action LeeJ will be sending out an email Sunday about the week of May 13 - 19 as a sprint week
21:38:41 * LeeJ thinks tcohen should be ashamed of himself ;)
21:39:02 <LeeJ> alright, I think that about wraps up everything :)
21:39:22 <tcohen> LeeJ: hhe
21:39:51 <LeeJ> #topic Set time of next meeting
21:40:40 <LeeJ> how does June 16th or 17th at the same time work for everyone? if anyone is still interested in helping after the release ;)
21:41:13 <georgew> June 17 would be awesome
21:41:17 <cait> this is quite late, but i can mak eit work
21:41:39 <cait> could we do an hour earlier maybe?
21:41:40 <LeeJ> perhaps we can do 14 UTC instead?
21:41:52 <LeeJ> I don't have classes now so I can do whenever now :)
21:41:55 <cait> 10pm instead of 11pm :)
21:41:58 <caroline_> isn't june 17 a sunday?
21:42:06 <rangi> morning
21:42:10 <cait> lol
21:42:14 <LeeJ> hahah whoops..was looking at may's calendar :P
21:42:24 <LeeJ> 14th?
21:42:24 <wahanui> rumour has it 14th is fine
21:42:27 <cait> you are so bad with dates :)
21:42:39 <LeeJ> :(
21:42:46 <cait> we like you anyways :)
21:42:53 <LeeJ> :D
21:42:58 <cait> 14th is fine by me
21:42:59 <caroline_> 13 would be better for me or 14 earlier
21:43:04 <cait> next meetings?
21:43:04 <wahanui> well, next meetings is https://wiki.koha-community.org/wiki/Next_IRC_meetings
21:43:27 <cait> no conflicts for both dates
21:43:41 <LeeJ> how about June 14th at 14 UTC?
21:43:52 <cait> maybe 13th?
21:44:02 <LeeJ> ah right
21:44:09 <LeeJ> 13th at 14 UTC it is!
21:44:20 <georgew> see you then
21:44:20 <caroline_> works for me
21:44:37 <cait> thx LeeJ
21:44:38 <LeeJ> #info Next meeting: 13 June 2018, 14 UTC
21:44:43 <cait> LeeJ++
21:44:44 <LeeJ> #endmeeting