#koha: GDPR IRC meeting 26 February 2018

Meeting started by josef_moravec at 19:04:49 UTC (full logs).

Meeting summary

  1. Introductions (please use "#info" in front of your introduction to have it show up in the automatic minutes) (josef_moravec, 19:05:14)
    1. Jon Knight, Loughborough University (greenjimll, 19:05:30)
    2. Katrin Fischer, BSZ Germany (cait, 19:05:32)
    3. Magnus Enger, Libriotech, Norway (magnuse, 19:05:39)
    4. Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic (josef_moravec, 19:05:50)
    5. Michal Denar, Municipal Library Ceska Trebova, Czech Republic (m23_kohaCZ, 19:06:02)
    6. Pasi Korkalo, Koha-Suomi Oy, Finland (janPasi_, 19:08:07)

  2. Debate about improvements in Koha code that we collected https://wiki.koha-community.org/wiki/Improve_data_protection_and_patron_privacy (josef_moravec, 19:09:05)
    1. https://wiki.koha-community.org/wiki/Improve_data_protection_and_patron_privacy (josef_moravec, 19:09:12)

  3. Wiki page record 1 ;) (josef_moravec, 19:10:31)
    1. Jonathan Druart (Joubu, 19:12:58)
    2. Koha need an option for deleting patron record instead moving, and an option to anonymize patron record - this should be configurable. (josef_moravec, 19:21:44)
    3. ACTION: josef_moravec add bugs and describe it (josef_moravec, 19:22:09)

  4. Wiki page record 2 (josef_moravec, 19:22:45)
  5. Wiki page record 3 (josef_moravec, 19:32:33)
    1. ACTION: josef_moravec added notes to wiki page and will fill a bug (josef_moravec, 19:44:26)

  6. Wiki page record 4 (josef_moravec, 19:45:28)
  7. Wiki page record 6 (josef_moravec, 20:02:05)
    1. https://en.wikipedia.org/wiki/Cryptography_law (greenjimll, 20:07:23)

  8. Wiki page record 7 (josef_moravec, 20:17:55)
    1. ACTION: josef_moravec file bug for adding age to statistics table (josef_moravec, 20:21:16)
    2. ACTION: josef_moravec fill a bug (josef_moravec, 20:26:33)

  9. Wiki page record 8 (josef_moravec, 20:27:59)
  10. Wiki page record 9 (josef_moravec, 20:37:33)
    1. https://screenshots.firefox.com/7IYEz32V51HxxHEK/hea.koha-community.org (josef_moravec, 20:46:15)
    2. ACTION: more investigatin of 2FA needed, we will collect information on bug reports (josef_moravec, 20:50:59)

  11. Wiki page report 10 (josef_moravec, 20:51:51)
    1. https://ico.org.uk/for-organisations/guide-to-the-general-data-protection-regulation-gdpr/individual-rights/right-to-data-portability/ (greenjimll, 21:00:31)
    2. ACTION: josef_moravec will add a short comment to bug report 20028 about this (josef_moravec, 21:05:27)

  12. Wiki page record 11 and 12 (josef_moravec, 21:06:04)
  13. Wiki page record 13 (cait, 21:22:49)
  14. wiki page record 14 (josef_moravec, 21:30:52)
    1. https://serverfault.com/questions/358398/how-do-i-remove-ip-addresses-from-log-files (Radius_CZ, 21:40:27)
    2. ACTION: janPasi_ will investigate how to remove/mask IP from older log when logrotate (josef_moravec, 21:42:01)

  15. General discussion, questions, and answers about General Data Protection Regulation (GDPR) and Koha (josef_moravec, 21:47:32)


Meeting ended at 21:48:29 UTC (full logs).

Action items

  1. josef_moravec add bugs and describe it
  2. josef_moravec added notes to wiki page and will fill a bug
  3. josef_moravec file bug for adding age to statistics table
  4. josef_moravec fill a bug
  5. more investigatin of 2FA needed, we will collect information on bug reports
  6. josef_moravec will add a short comment to bug report 20028 about this
  7. janPasi_ will investigate how to remove/mask IP from older log when logrotate


Action items, by person

  1. janPasi_
    1. janPasi_ will investigate how to remove/mask IP from older log when logrotate
  2. josef_moravec
    1. josef_moravec add bugs and describe it
    2. josef_moravec added notes to wiki page and will fill a bug
    3. josef_moravec file bug for adding age to statistics table
    4. josef_moravec fill a bug
    5. josef_moravec will add a short comment to bug report 20028 about this


People present (lines said)

  1. cait (173)
  2. josef_moravec (149)
  3. greenjimll (68)
  4. m23_kohaCZ (65)
  5. janPasi_ (53)
  6. Joubu (23)
  7. magnuse (21)
  8. Radius_CZ (17)
  9. eythian (9)
  10. huginn (7)
  11. jenkins (1)


Generated by MeetBot 0.1.4.