#koha: General IRC meeting 10 January 2018

Meeting started by kidclamp at 14:01:58 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:02:06)
    1. wahanui, a bot that has become sentient (wahanui, 14:02:07)
    2. Nick Clemens, ByWater Solutions (kidclamp, 14:02:20)
    3. Marcel de Rooy, Rijksmuseum (marcelr, 14:02:25)
    4. Jonathan Druart (Joubu, 14:02:48)
    5. Owen Leonard, Athens County Public Libraries, USA (oleonard, 14:03:10)
    6. Fridolin Somers, Biblibre, France (fridolin, 14:03:24)
    7. Katrin Fischer, BSZ, Konstanz (cait, 14:03:30)
    8. last meeting was http://meetings.koha-community.org/2017/development_irc_meeting_27_december_2017.2017-12-27-20.08.html - votes on coding guidelines have been made (Joubu, 14:03:35)
    9. Julian Maurice, BibLibre (jajm, 14:03:42)
    10. https://wiki.koha-community.org/wiki/General_IRC_meeting_10_January_2018 (Joubu, 14:03:45)
    11. https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_January_2018 (Joubu, 14:03:50)
    12. both general and dev meetings now (Joubu, 14:04:05)
    13. Alex Arnaud, Biblibre, France (alex_a, 14:04:18)
    14. Eric Bégin, inLibro, Canada (ebegin, 14:04:25)
    15. Caroline Cyr La Rose, inLibro, Canada (caroline, 14:04:41)

  2. Announcements (kidclamp, 14:05:27)
    1. Nick Rosasco - (back after a >12 year absence?!) - who might be able to scare up some free labor if the right thing can be found - Indiana, USA (nickr, 14:05:40)
    2. Jessie Zairo, ByWater Solutions, USA (jzairo, 14:05:53)
    3. Josef Moravec, Municipal library Usti nad Orlici, Czech Republic (josef_moravec_, 14:07:26)
    4. Happy belated birthday bag and paul_p (kidclamp, 14:07:46)
    5. Nate Curulla, ByWater (NateC, 14:08:05)
    6. Lee Jamison, Marywood University (LeeJ, 14:08:08)
    7. Happy non birthday tcohen (Joubu, 14:08:21)
    8. Mark Tompsett (mtompset, 14:08:22)
    9. Michael Cabus, ByWater (caboose, 14:08:30)

  3. Update from the Release manager (18.05) (kidclamp, 14:08:53)
    1. announcement - Hackfest in Marseille, registrations open ! http://lists.koha-community.org/pipermail/koha-devel/2018-January/044244.html (Joubu, 14:10:11)
    2. refactoring still in progress, see email to koha-devel - http://lists.koha-community.org/pipermail/koha-devel/2018-January/044242.html (Joubu, 14:10:53)
    3. annoncement - I want to let you know that francharb (former inLibro and BibLibre) has left the Koha community to work with multiple universities in Quebec in order to help them pick their next ILS. We will miss him :-( Thanks Francois for what you did for Koha ! (kidclamp, 14:11:58)
    4. I am waiting for Bernardo's answer to improve update of the manual po files (pottle <=> git repo) (Joubu, 14:13:18)
    5. I am waiting for drojf[m]'s answer to improve our packages building infrastucture (Joubu, 14:14:07)
    6. Kyle Hall, ByWater Solutions (khall, 14:14:22)
    7. I am waiting for QA team to QA all the things (Joubu, 14:14:46)

  4. Update on releases (kidclamp, 14:15:12)
    1. 17.11 pushing patches now - will announce string freeze for 15th and release on 22nd (kidclamp, 14:15:30)
    2. 17.11.01 (and other stable) were released late but should be all set (kidclamp, 14:15:47)
    3. thanks all for help on my first release! (I didn't break all the Kohas!) (kidclamp, 14:16:21)

  5. Updates from the QA team (kidclamp, 14:20:04)
    1. QA Team had a QA Sprint day on 21 December, queue went down from 154 to 118, currently around 90 (cait, 14:20:49)
    2. https://wiki.koha-community.org/wiki/2017-12-21_QA_Sprint_Day QA Sprint Day 21 December (cait, 14:20:58)
    3. Andreas Hedström Mace, Stockholm University Library (andreashm, 14:21:31)
    4. New info page for QA on the wiki: https://wiki.koha-community.org/wiki/How_to_QA - read if you want to join us or to learn how the QA team works! (cait, 14:22:25)
    5. QA team is looking for tutorials on: Authentication - how to set up LDAP, CAS, Shibboleth, testing translatability (cait, 14:23:47)
    6. ... and a test database with a good amount of acq and/or subscription data (cait, 14:24:05)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:28:02)
    1. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17015 (ebegin, 14:37:00)
    2. bug 19817 (Joubu, 14:38:31)

  7. Set time of next meeting (kidclamp, 14:49:06)
  8. Koha student projects (cait, 14:52:31)
    1. nickr is looking for Koha projects to assign to temas of CS students, email him with suggestions (kidclamp, 14:58:31)
    2. nickr will email the lists with more info (kidclamp, 14:58:48)

  9. Review of coding guidelines (kidclamp, 15:01:37)
    1. tcohen is not around. "New rule SQL12: Booleans" vote is postponed (Joubu, 15:01:54)
    2. Reminder to all - please add topics to the agenda :-) (kidclamp, 15:02:59)
    3. "New rule "No DBIx::Class in atomic updates"" is postponed (Joubu, 15:03:03)
    4. ACTION: cait cait improve the coding guidelines related to the use of SQL queries (Joubu, 15:03:10)
    5. IMPORTANT - no need to add new subroutines to C4 namespace, it will be rejected (Joubu, 15:06:55)
    6. IMPORTANT - no need to add or update methods without test coverage, it will be rejected (Joubu, 15:07:13)

  10. Set time of next meeting (kidclamp, 15:10:02)
    1. ACTION: clrh Add a "important check before committing/submission" to the wiki page (Joubu, 15:11:57)
    2. Next meeting: 7 February 2018, 20 UTC (kidclamp, 15:15:01)


Meeting ended at 15:15:34 UTC (full logs).

Action items

  1. cait cait improve the coding guidelines related to the use of SQL queries
  2. clrh Add a "important check before committing/submission" to the wiki page


Action items, by person

  1. cait
    1. cait cait improve the coding guidelines related to the use of SQL queries
  2. clrh
    1. clrh Add a "important check before committing/submission" to the wiki page


People present (lines said)

  1. Joubu (108)
  2. kidclamp (55)
  3. cait (55)
  4. nickr (23)
  5. ebegin (21)
  6. fridolin (12)
  7. huginn (11)
  8. wahanui (11)
  9. LeeJ (10)
  10. mtompset (6)
  11. marcelr (6)
  12. oleonard (5)
  13. clrh (3)
  14. alex_a (3)
  15. caboose (2)
  16. andreashm (2)
  17. jzairo (1)
  18. NateC (1)
  19. jajm (1)
  20. khall (1)
  21. caroline (1)
  22. josef_moravec_ (1)


Generated by MeetBot 0.1.4.