13:01:40 <kidclamp> #startmeeting General IRC meeting 5 September 2018
13:01:40 <huginn`> Meeting started Wed Sep  5 13:01:40 2018 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:40 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:40 <huginn`> The meeting name has been set to 'general_irc_meeting_5_september_2018'
13:01:49 <kidclamp> #topic Introductions
13:02:18 <kidclamp> #info Nick Clemens, ByWater Solutions
13:02:46 <cc_> #info Colin Campbell, PTFS Europe
13:03:01 <calire> #info Claire Gravely, BSZ
13:03:25 <thd> #info Thomas Dukleth, Agogme, New York City
13:04:09 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
13:04:28 <ashimema> #info Martin Renvoize, PTFS Europe, UK
13:05:49 <kidclamp> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_5_September_2018 Agenda
13:05:57 <kidclamp> #topic Announcements
13:06:12 <kidclamp> KohaCon! It is soon! Huzzah!
13:06:17 <kidclamp> anyone else :-)
13:06:37 <calire> \o/
13:07:19 <oleonard> \o\ \o/ /o/
13:08:02 <ashimema> :(
13:09:27 * ashimema wonders if his irc connection has gone bad again
13:09:35 <marcelr> #info Marcel de Rooy
13:09:36 <kidclamp> #link https://wiki.koha-community.org/wiki/Kohacon18/Social kohacon social info
13:09:44 <kidclamp> no ashimema , just distracted
13:09:47 <kidclamp> :-)
13:09:58 <ashimema> phew
13:10:01 <kidclamp> #topic Update on releases
13:10:13 <kidclamp> Frido said all things are happy for him
13:10:19 <kidclamp> ashimema?
13:10:20 <wahanui> somebody said ashimema was RMaint for 18.05 ?
13:11:19 <mtompset> #info Mark Tompsett
13:11:33 <ashimema> all good here.. just catching up after a weeks leave.
13:11:54 * ashimema thanks kidclamp for covering the final release bits in his absence last week
13:12:05 <kidclamp> ashimema++
13:12:17 <cait> #info Katrin Fischer, BSZ
13:12:44 * oleonard thanks ashimema for not dying in a terrible IRC-related road accident
13:12:44 <ashimema> that's it from me
13:13:01 <kidclamp> I am getting the queue as clean as possible before Kohacon
13:13:01 <ashimema> lol
13:13:29 <kidclamp> there are several majors /critical/blockers that could use attention
13:13:42 <cait> my theory is that it will fill quickly at the hackfet, recommend the qa team to clean up too :)
13:13:49 <kidclamp> pushing ES work along, would still like to see Mana and Stock Rotation move forward
13:13:59 * ashimema is also happy he didn't fall off his bike (into a canal or otherwise) whilst irc'ing on his bike.
13:14:12 <kidclamp> yes, everyone should get things setup for fast movement at kohacon
13:14:35 <ashimema> SR is moving forward nicely now.. thanks tcohen
13:14:36 <kidclamp> the SCSS and XSS patches mean many rebases and we are slowly cleaning up issues caused by those
13:14:37 <cait> yes, rebase, update test plans, etc.
13:14:38 <ashimema> (and bag)
13:14:55 <kidclamp> thanks to all, I am excited for this release :-)
13:14:57 <oleonard> Oh my god the rebases.
13:15:08 * calire prepares for sign-offs
13:15:23 <kidclamp> #info Stable branches are good, master is coming along, please see majors and prepare patches before kohacon
13:15:24 <ashimema> poor oleonard.. but you'd prefer it this way than the other ;)
13:15:49 <oleonard> Idea: new Koha Academy, 100% rebasing.
13:15:57 <kidclamp> poor ashimema has to deal with all the rebases for backports :-)
13:16:22 <ashimema> I knew what I was getting into when I started QAin'g them ;)
13:16:32 <ashimema> lead by example aye :S
13:17:17 <kidclamp> moving on :-)
13:17:21 <kidclamp> #topic Updates for the About page
13:17:46 <cait> that was me
13:18:00 <cait> there was a request from bulac to be added to the about page that led to some dicussion
13:18:13 <jenkins> Project Koha_18.05_D8 build #56: SUCCESS in 22 min: https://jenkins.koha-community.org/job/Koha_18.05_D8/56/
13:18:19 <cait> at themoment we have different sections on the page
13:18:30 <cait> we add new devs, but not libraries
13:18:51 <cait> we've got a special thanks at the very top
13:19:15 <cait> then the release teams, the devs, then contributing companies and institutions and additional thanks
13:19:27 <cait> so the question was mostly about how we want to handle instiutions and where they shoudl go
13:19:28 <jenkins> Yippee, build fixed!
13:19:28 <jenkins> Project Koha_18.05_D9 build #56: FIXED in 25 min: https://jenkins.koha-community.org/job/Koha_18.05_D9/56/
13:19:50 <ashimema> that page is a bit of a mess..
13:19:57 <ashimema> been ages since I've properly looked at it.
13:20:05 <cait> one ideas was to add all the libraries from the release notes that used the sponsored-by line
13:20:15 <cait> maybe a little messy, but i think important
13:20:22 <cait> recognition is about the only thing the community can offer
13:20:50 <ashimema> totally agree we should add them
13:21:04 <tuxayo> New tab?
13:21:30 <ashimema> sponsored by used to go into the timeline..
13:21:47 <ashimema> not seeing any mentions since 2009 though
13:22:31 <oleonard> I think using "sponsored by" in the future to add to "Contributing companies and institutions" is a good idea
13:22:43 <ashimema> would be nice to get that up to date with appropriate features and their sponsorship in my opinion.
13:22:43 <cait> +1
13:22:51 <oleonard> I wonder though what to do with "special thanks" and "additional thanks"
13:23:17 <cait> ashimema: i don't think it did - only for big stuff at the beginning, but not continuiously (timeline)
13:23:27 <ashimema> not sure I like the 'Special thanks' section to be honest... are those contributor still more special than any other contributors?
13:23:40 <cait> hlt? sure
13:23:43 <ashimema> it would be nice to have it in there though cait :)
13:23:51 <thd> What counts as "special" and why do we need a distinction between "special" and "additional"?
13:23:53 <cait> i thnk without the early adopters we wouldn't be here now
13:24:39 <andrew_> Hey all. Can anyone explain why calls to KohaTable that previously worked, now need a .api() call preceding them? For example, something like: var table = KohaTable('#selector', {...}; table.search('').....   would have worked fine, but now it needs .api() between table & search, i.e. table.api().search('').... I've tried to track back the relevant change, but failed :(
13:24:46 <oleonard> Maybe we should have only HLT under special and move other orgs under "Contributing companies"
13:24:56 <oleonard> andrew_: IRC meeting now
13:25:10 <andrew_> Doh, of course, sorry
13:25:39 <thd> I prefer something like "initial work sponsored by".
13:25:40 <ashimema> I dunno.. I'd say 'Special' has a place for regularly sponsors/contributors over a certain level or something?
13:25:52 <cait> hard to measure that something
13:26:01 <cait> it's a bit of a possible mine field
13:26:12 <oleonard> Yeah, and brings ongoing maintenance of a different kind
13:26:22 <cait> maybe we just move up the instiuttions and merge?
13:26:34 <cait> hm oh
13:26:37 <cait> i think i see a schema
13:26:38 <ashimema> just seems odd the ones that are in there.. the OPAC star ratings sponsorship one for example.. that seems a relatively small contribution to warrant an up the top mention.. maybe I'm just being a bit harsh
13:26:43 <cait> move the libraries up
13:26:47 <cait> and leave the companies below
13:26:50 <ashimema> indeed
13:26:54 <cait> most of the contributing are companies
13:26:57 <ashimema> Yeah.. that could work for me
13:27:23 <cait> ok so we have
13:27:38 <cait> add sponsored-by libraries to the top from release notes
13:27:45 <cait> add libraries from contributing to top
13:27:51 <mtompset> Perhaps monetary/hardware vs. software changes?
13:27:57 <cait> leave companies at the bottom
13:28:07 <cait> too hard
13:28:18 <mtompset> Yes, probably is too hard.
13:28:21 <cait> i think if someone wants to have what they sponsored it's ok, but often it would be too hard to track
13:28:37 <kidclamp> maybe link to a wiki page "Special thanks" and anyone who wants can go crazy there
13:28:38 <ashimema> what about sponsored features in the timeline.. should that be covered in such a decision?
13:29:08 <kidclamp> I like adding sponsored by tot he timeline, someone will need to script or be patient to make it retroactive
13:29:10 <mtompset> -- Hmmm.... I'm not really for that.
13:29:30 <ashimema> why so mtompset?
13:29:40 <mtompset> the wiki idea, that is.
13:29:48 <ashimema> oh.. did you mean the wiki link?
13:29:53 * ashimema has caught up
13:30:03 <mtompset> Sorry for not being clear. :)
13:30:44 * ashimema wonders how the 'Translations' tab is kept up to date whilst we're talking this stuff
13:30:49 <oleonard> I think "sponsored by" in the timeline doesn't make sense now that we're putting "sponsored by" in bugzilla -- we get into judgement about what is a big enough sponsorship to put in the timeline
13:31:40 <kidclamp> would it not just be the first?
13:31:45 <mtompset> oleonard, true. Though, counting the number of sponsored-by bugs for a given sponsor doesn't require judgments.
13:31:50 <cait> not for the wiki idea either
13:31:50 <kidclamp> devs get in for any patch, any sponsorship can go in
13:31:56 <cait> i like that the abotu page gets qa
13:32:00 <kidclamp> the overhead cost is low for adding
13:32:12 <ashimema> indeed
13:32:17 <cait> i think the sponsoring int he timeline is not happening anyway
13:32:21 <cait> so we can ignore that
13:32:42 <mtompset> kidclamp, the problem with the wiki idea is that it is open to more abuse. There are parties which may add themselves for every single bug patch they submit.
13:33:30 <mtompset> But we could have another sponsored-by timeline?
13:33:50 <cait> i think keep it out of timeline
13:33:55 <ashimema> I'd prefer to see what feature was sponsored in the timeline myself.. rather than 'first feature'.. anywho.. that's just another piece of fun to add
13:34:15 <cait> it's nto a good place, because of dates and all
13:34:24 <kidclamp> Sure, I don't like the idea of having to judge who gets what special thanks
13:34:27 <thd> Sponsorship could also be added to attribution comments in file headers, although, the audience who would see those is small.
13:34:32 <kidclamp> so wiki would be more of a fun page
13:34:39 <kidclamp> would allow for low level thanks
13:34:56 <ashimema> wow.. there's been 200 new devs since I joined the effort
13:34:58 <ashimema> blimey
13:35:11 <kidclamp> "Kidclamp thanks cait for touring german castle"
13:35:27 <cait> the last entry in timeline is dec 2017... it needs more work
13:35:33 <cait> ?
13:35:35 <cait> oh
13:35:36 <cait> lol
13:35:41 <cait> you are welcome?
13:35:54 <ashimema> huh
13:36:01 <cait> oftn it might be a bug fix that is sponsored
13:36:05 <cait> relaly hard to keep updated
13:36:06 <ashimema> April 16th 2018 is the last entry I see in the timeline
13:36:12 <cait> i think just the name still, we are not good with updating stuff
13:36:23 <cait> ashimema: ... right. looking at 17.11 *hides*
13:36:44 <kidclamp> #chair cait
13:36:44 <huginn`> Current chairs: cait kidclamp
13:36:49 <mtompset> Does that make you feel old now, ashimema? ;)
13:37:26 <cait> so do we have a decision?
13:37:32 <marcelr> :)
13:37:38 <mtompset> on what exactly again?
13:37:41 <cait> are we ok with adding BULAC at least? to special thanks for elastic etc
13:37:51 <kidclamp> +1
13:37:51 <cait> updates for the about page
13:38:01 <marcelr> no objection to thank somebody
13:38:03 <kidclamp> but I don't want to have this conversation every time we want to add someone :-)
13:38:07 <mtompset> Were they the ones that pushed it?
13:38:12 <marcelr> its just 20 mins kidclamp
13:38:21 <mtompset> pushed for it, that is.
13:38:23 <thd> +1
13:38:27 <kidclamp> :-b
13:38:39 <calire> +1
13:38:41 <mtompset> If so, yes.
13:38:58 <ashimema> +1
13:39:01 <cait> they've tested a lot and are users... so no objection from me
13:39:05 <jenkins> Project Koha_18.05_U18 build #54: SUCCESS in 41 min: https://jenkins.koha-community.org/job/Koha_18.05_U18/54/
13:39:05 <cait> financial side i can't tell
13:39:11 <kidclamp> they did extensive testing are using in production and sponsored biblibre mtompset
13:39:31 <mtompset> Then, why are we even discussing this? It should be a +1 obviously.
13:39:42 <cait> ok, so special thank for bulac and add sponsored by at least to contributing?
13:39:50 <ashimema> yup.. throw them in
13:39:52 <cait> ok
13:39:59 <cait> so ewe can move on with that bug, all I want :D
13:40:06 * cait dreams of empty queues sometimes
13:40:20 <cait> moving on? i got something about kohacon
13:40:39 <kidclamp> Whose job to add to Contributing? RM? We can figure that later, or just allow those who care to do so
13:40:56 <cait> could be a good academy task too
13:40:58 <cait> for kohacon
13:41:38 <kidclamp> #info Agreed to add BULAC to special thanks and begin adding entities that sponsor devs to teh 'Contributing' section
13:41:46 <kidclamp> move on cait ;-)
13:41:49 <cait> thx
13:42:02 <cait> I just noticed that we had another bid added for KohaCon19
13:42:02 <cait> https://wiki.koha-community.org/wiki/KohaCon19_Proposals
13:42:17 <cait> it's too late as we already are in voting phase
13:42:31 <cait> how should we handle it? undo and move to a new page? but can't assume they want to bid for 2020 too
13:42:31 <ashimema> ooh
13:42:41 <ashimema> that page looks messed up to me now
13:42:45 <marcelr> yeah
13:42:55 <marcelr> restore older one?
13:43:10 <cait> yeah it looks like they accidentally added to the header row
13:43:27 <cait> i really have my hands full, would someone be willing to send an email maybe?
13:43:47 <mtompset> We were already in voting phase... restore old page, put them up on KohaCon2020 page, and then ask them if they are willing to do it for 2020.
13:43:50 <cait> i can undo the wiki change i think
13:44:22 <ashimema> not even sure I can actually work out who they are
13:44:31 <cait> there is email addresse
13:44:35 <cait> addresses
13:44:42 <ashimema> ah yes.. it's merged into the heading
13:44:46 <thd> I can create a new wiki page for 2020 and ask them to contribute their.
13:44:51 <kidclamp> thanks thd
13:44:54 <ashimema> 'Islamic University Islamabad Pakistan'
13:44:54 <cait> thx thd
13:44:58 <ashimema> yeah.. go for the thd
13:45:00 <cait> thd will you undo the changes to 19 when done?
13:45:01 <ashimema> thanks
13:45:05 <cait> then i won't touch it
13:45:14 <thd> Yes
13:45:18 <cait> thd++
13:45:32 <kidclamp> #action thd will contact International Islamic University  about moving their kohacon bid to 2020 as it was submitted after voting phase began
13:46:01 <cait> all from me now thx!
13:46:02 <kidclamp> Anyone else have topics before we set next meeting?
13:46:25 <kidclamp> #topic Next meeting
13:46:41 <kidclamp> October 3rd, 20 UTC?
13:46:53 <cait> hm maybe check if the docs meeting is there
13:47:02 <cait> sec
13:47:25 <kidclamp> i don't see it on calendar (yet anyways)
13:47:30 <cait> it's 2 October 2018, 21:00 UTC - all good
13:47:34 <cait> we had discussed several dates yesterday
13:48:04 <kidclamp> #info Next meeting: 3 October 2018, 20 UTC
13:48:13 <cait> kidclamp++
13:48:21 <kidclamp> #endmeeting