14:00:05 <kidclamp> #startmeeting Development IRC meeting 10 April 2019
14:00:05 <huginn`> Meeting started Wed Apr 10 14:00:05 2019 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <huginn`> The meeting name has been set to 'development_irc_meeting_10_april_2019'
14:00:14 <kidclamp> #topic Introductions
14:00:28 <kidclamp> #info Nick Clemens, ByWater Solutions
14:00:29 <cait> #info Katrin Fischer, Germany
14:00:37 <khall> #info Kyle M Hall
14:00:42 <kidclamp> #chair cait
14:00:42 <huginn`> Current chairs: cait kidclamp
14:00:45 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:00:58 <thd> #info Thomas Dukleth, Agogme, New York City
14:01:01 <AndrewIsh> #info Andrew Isherwood, PTFS Europe, UK
14:01:14 <josef_moravec> #info Josef Moravec
14:01:48 <ashimema> #info Martin Renvoize, PTFS Europe
14:01:58 * ashimema randomly has an irc timeout at the wrong moment
14:02:05 <kidclamp> #topic Announcements
14:02:08 <kidclamp> anyone?
14:02:27 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_April_2019 Agenda
14:02:58 <wizzyrea> hi
14:03:02 <ashimema> I'm ahead of schedule this month and have release timelines for the end of the month already :)
14:03:17 <ashimema> but I think I'd just confuse people if I anounced them now ;)
14:03:24 <kidclamp> heh, you get a chance
14:03:37 <wizzyrea> #info Liz Rea, doer of things
14:03:59 <ashimema> hehe
14:04:11 <kidclamp> #topic Update from the Release manager (19.05)
14:04:14 <kidclamp> that's me!
14:04:14 * oleonard inscribes that on a shield for wizzyrea
14:04:32 <kidclamp> Release dates were sent out, thank you for patience everyone
14:04:32 <ashimema> ack.. I just thought of an anouncement too
14:04:38 <ashimema> oh well
14:05:02 <kidclamp> we are releasing after kohacon so that hackfest can include cleanup and discussiona dn leave things nice and tidy for the next Rm
14:05:13 <kidclamp> I am going to start pushing my (large) queue today
14:05:16 <oleonard> hackfest++
14:05:18 <ashimema> kidclamp++ release dates
14:05:26 <kidclamp> And then will be working on bugs and cleanup
14:05:30 <wizzyrea> pushing_the_queue++
14:05:40 <ashimema> workshops++ ;)
14:05:44 <oleonard> gleaming_the_cube++
14:05:44 <cait> talking about next RM
14:05:48 <kidclamp> release is going well I think, we definitely have bugs to shake out
14:05:53 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_19.11 Roles for 19.11
14:06:05 <kidclamp> yes, please put your names in if interested
14:06:24 * ashimema has started to switch focus to fixing, soing and qaing bugs now.. but still has a few enhancements he'd love to see make the cut
14:06:39 <oleonard> ashimema++ # RM proposal
14:06:40 <cait> should we send an mai lto the list too? voting shoudl be next general meeting
14:07:09 <ashimema> yup.. well volunteered cait ;)
14:07:19 <kidclamp> hehe, just what I was going to say
14:07:38 <kidclamp> that's all from me
14:07:51 <cait> hey not fiar, had to check on the rice cooking
14:07:58 <ashimema> or I could I suppose.. I sent a few last cycle getting people to sign up so have a template
14:08:10 <kidclamp> #topic Updates from the Release Maintainers
14:08:20 <kidclamp> mr martin?
14:08:23 <cait> @action ashimema to send an meail to the mailing list about sighing up for 19.11 release team
14:08:24 <huginn`> cait: I've exhausted my database of quotes
14:08:32 <cait> hm.
14:08:58 <ashimema> #info 18.11.x has been coming along nicely, the team are all working really well.
14:08:58 <cait> @action ashimema to send an meail to the mailing list about sighing up for 19.11 release team
14:08:59 <huginn`> cait: I'll give you the answer just as soon as RDA is ready
14:08:59 <wahanui> i already had it that way, huginn`.
14:09:02 <cait> weird
14:09:17 <oleonard> cait: # not @?
14:09:20 <kidclamp> #action ashimema to send an meail to the mailing list about sighing up for 19.11 release team
14:09:30 <kidclamp> :-)
14:09:35 <cait> oh
14:09:39 <cait> #action ashimema to send an meail to the mailing list about sighing up for 19.11 release team
14:09:40 <cait> thx
14:09:54 <kidclamp> people do sigh when thinking of volunteering
14:09:57 <ashimema> nothing else really to say from rmaint perspective
14:10:18 <kidclamp> JesseM: lukeg?
14:10:36 <ashimema> fridolin:
14:10:46 <fridolin> yep
14:10:48 <kidclamp> wow, is 17.11 still going?
14:10:57 <kidclamp> fridolin++
14:11:07 <fridolin> it will be last release 17.11.18
14:11:20 <fridolin> version is very stable and translation is great
14:11:26 <kidclamp> #info 17.11.18 will be final release
14:11:29 <fridolin> so i propose to let it go
14:11:48 <fridolin> dont hesitate to contact me it something is mandatory
14:11:54 <kidclamp> #info 18.05 is going steady, no notes at the moment
14:12:03 * fridolin thinking about next release cycle
14:12:04 <fridolin> :D
14:12:12 <ashimema> #info Next Maint release dates are set: 29th for release, with String Freeze on 22nd (attempting to avoid Easter)
14:12:36 <kidclamp> moving on?
14:12:45 <ashimema> go for it
14:12:57 <kidclamp> #topic Updates from the QA team
14:13:01 <kidclamp> cait?
14:13:01 <wahanui> hmmm... cait is really good at running into things
14:13:04 <cait> here
14:13:24 <cait> with sign-offs going up the queue is getting fuller, a lot of great big new shiny things still waiting
14:13:36 <cait> @actoin QA Team to qa all the things
14:13:37 <huginn`> cait: I'll give you the answer just as soon as RDA is ready
14:13:37 <wahanui> i already had it that way, huginn`.
14:13:54 <cait> every little bit helps
14:14:13 <cait> there is also quite a big number of criticals, majors and blockers that we really want to have fixed before release
14:14:50 <cait> #info 2 blockers, 1 critical and 20 majors waiting to be written, tested and QA'd
14:14:53 <kidclamp> #action QA Team to qa all the things! And then they get cookies
14:15:10 <cait> i am not good with the actions today :)
14:15:18 <cait> ashimema: josef_moravec anything to add?
14:15:29 <cait> oh khall too of course - sorry everyone i forgot
14:15:48 <ashimema> nothing really from me..
14:15:50 <josef_moravec> cait: nope, it is all for now I think
14:16:05 <ashimema> I've already said I'm slowly starting to shify my focus from 'Oh shiny new' to 'Hey, squash that bug'
14:16:20 * kidclamp says 'Joubu', maybe he'll appear :-)
14:16:24 <cait> i still hope for some of the big stuff to make it
14:16:31 <cait> because it won't get better with a lot of rebasing usually :)
14:16:44 <cait> but yeah, there is really not much time now for that
14:16:58 <wizzyrea> we do have that one urgent acquisitions bug
14:17:07 <cait> bug 22669
14:17:07 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22669 blocker, P2, ---, koha-bugs, NEW , Cannot edit received item in acquisitions with acqcreateitem set to "when placing an order"
14:17:10 <wizzyrea> yep
14:17:33 <cait> ... also we need kidclamp to push things :)
14:17:52 <kidclamp> indeed, will begin today
14:17:58 <wizzyrea> thanking you good sir
14:18:00 <kidclamp> they queue definitely started growing faster ;-)
14:18:04 <cait> ah
14:18:15 * wizzyrea whistles innocently
14:18:15 <cait> and there is an ongoing discussion on usability of the new cash change feature
14:18:20 <cait> does someone have the bug number?
14:18:22 <ashimema> cait and I have been competeing with each other ;)
14:18:46 <cait> it helps that i have time on my hands this week - won't be able to keep that up next week
14:18:46 <ashimema> but as fast as we QA, wizzyrea in particular fills the queue again
14:18:51 <ashimema> team++
14:18:54 <cait> team++
14:18:54 <wizzyrea> sorry not sorry
14:19:26 <ashimema> :)
14:19:30 <cait> i see it as competiton, but calling for reinforcements
14:19:36 <thd> wizzyrea++
14:19:44 <cait> moving on?
14:20:22 <ashimema> +1
14:20:57 <kidclamp> #topic General development discussion (trends, ideas, ...)
14:21:12 <kidclamp> #info REST API
14:21:30 <kidclamp> #link https://wiki.koha-community.org/wiki/Checkouts_endpoint_RFC#Update_-_Circulation_history_aka_old_checkouts Checkouts RFC
14:22:36 <kidclamp> tcohen?
14:22:36 <wahanui> tcohen is the man you want to thank
14:22:43 <kidclamp> thanks tcohen!
14:22:45 <kidclamp> :-)
14:23:02 <josef_moravec> Just needed feedback on the updated rfc
14:23:29 <kidclamp> anyone have feedback? looks like just the option for old_checkouts added?
14:24:12 <josef_moravec> kidclamp: that is the only addition
14:24:32 <josef_moravec> patch proposed here:
14:24:33 <josef_moravec> https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17005
14:24:33 <huginn`> 04Bug 17005: enhancement, P5 - low, ---, josef.moravec, Signed Off , REST API: add routes to list checkouts history
14:24:38 <thd> Difficulties with earlier versions seem to have been addressed in my examination.
14:24:51 <ashimema> seems sane enough to me
14:25:38 <kidclamp> vote?
14:26:03 <josef_moravec> +1 ;)
14:27:03 <cait> would we want to give a date range for retrieving these?
14:27:03 <kidclamp> #startvote should we accept the amendment to the checkouts api rfc to allow for retrieving historical circulation info? Yes, No, Abstain
14:27:03 <huginn`> Begin voting on: should we accept the amendment to the checkouts api rfc to allow for retrieving historical circulation info? Valid vote options are Yes, No, Abstain.
14:27:03 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
14:27:14 <kidclamp> too slow cait :-)
14:27:15 <cait> #vote yes
14:27:16 <cait> yep
14:27:21 <cait> no blocker, was just wondering when reading
14:27:23 <kidclamp> #vote Yes
14:27:35 <oleonard> #vote abstain
14:27:45 <kidclamp> I wondered that too, it gives only issue ids, so I think further enhancement would be that maybe?
14:27:48 <ashimema> #vote Yes
14:27:50 <wizzyrea> #vote abstain
14:28:22 <thd> #vote Yes
14:28:31 <kidclamp> last call
14:28:49 <kidclamp> #endvote
14:28:49 <huginn`> Voted on "should we accept the amendment to the checkouts api rfc to allow for retrieving historical circulation info?" Results are
14:28:49 <huginn`> Yes (4): kidclamp, cait, thd, ashimema
14:28:49 <huginn`> Abstain (2): oleonard, wizzyrea
14:29:17 <josef_moravec> cait: we will have pagination available in checkouts endpoint thanks to bug 17003
14:29:17 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17003 enhancement, P5 - low, ---, josef.moravec, Signed Off , REST API: add route to get checkout's renewability
14:29:36 <kidclamp> #info amendment to checkotus rfc accepted
14:29:45 <thd> cait: You should propose some range limit else there will eventually be trouble for someone.
14:29:48 <kidclamp> can you add info on the voting to the wiki josef_moravec ?
14:29:59 <josef_moravec> kidclamp: I'll do
14:30:03 <kidclamp> #link https://wiki.koha-community.org/wiki/Illbackends_endpoint_RFC Illbackends RFC
14:30:10 <kidclamp> another one :-)
14:30:29 <ashimema> AndrewIsh still here?
14:30:34 <AndrewIsh> Yes
14:30:35 <ashimema> I hadn't spotted that one ;)
14:30:44 <AndrewIsh> I've already commented on the bug
14:31:10 <ashimema> coolios
14:31:40 <josef_moravec> bug 22615
14:31:40 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22615 enhancement, P5 - low, ---, josef.moravec, ASSIGNED , Add /ill_backends endpoint
14:33:28 <ashimema> looks reasonable enough to me
14:33:32 <kidclamp> any questions? or vote?
14:34:13 <josef_moravec> What do you think about the returned structure? What if the internal implementation of $backend->capabilities change?
14:34:58 <AndrewIsh> We'll have far bigger problems if that happens! :-)
14:35:13 <josef_moravec> AndrewIsh: thanks for info!
14:35:37 <AndrewIsh> But, if you wanted to abstract against that eventuality, it might be a nice idea
14:36:17 <AndrewIsh> But I don't think we'll be changing anything any time soon
14:37:30 <josef_moravec> I think as far as there we'll be test for that, it is OK,  I am going to write some anyway
14:38:11 <AndrewIsh> josef_moravec++
14:38:25 <kidclamp> vote time?
14:39:06 <thd> The structure returned is not specified in the wiki.
14:41:52 <kidclamp> it refers tot he structure on the bug, doesn't it thd?
14:42:10 <thd> ... or maybe structure is specified sufficiently if carefully enough compared to other behaviour where functionality is evident
14:42:57 <thd> yes, the wiki page fits the bug and more importantly other behaviour with sufficient specificity.
14:43:02 <kidclamp> calling for vote
14:43:03 <kidclamp> #startvote Should we accpt the Illbackend endpoint RFC as proposed on the wiki? Yes, No, Abstain
14:43:03 <huginn`> Begin voting on: Should we accpt the Illbackend endpoint RFC as proposed on the wiki? Valid vote options are Yes, No, Abstain.
14:43:03 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
14:43:07 <kidclamp> #vote Yes
14:43:13 <cait> #vote Yes
14:43:14 <oleonard> #vote abstain
14:43:15 <thd> #vote Yes
14:43:20 <AndrewIsh> #vote Yes
14:43:31 <ashimema> #vote Yes
14:44:12 <wizzyrea> #vote abstain
14:44:28 <kidclamp> last call
14:44:59 <kidclamp> #endvote
14:44:59 <huginn`> Voted on "Should we accpt the Illbackend endpoint RFC as proposed on the wiki?" Results are
14:44:59 <huginn`> Yes (5): AndrewIsh, kidclamp, cait, ashimema, thd
14:44:59 <huginn`> Abstain (2): oleonard, wizzyrea
14:45:21 <kidclamp> #topic
14:45:26 <kidclamp> #topic #startvote Should we accpt the Illbackend endpoint RFC as proposed on the wiki? Yes, No, Abstain
14:45:34 <kidclamp> #topic Review of coding guidelines
14:45:38 <kidclamp> yeesh
14:46:06 <kidclamp> #info bug 22407 OMNIBUS: Use DBIC relations to fetch related object rather than searching for the object
14:46:06 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22407 enhancement, P5 - low, ---, koha-bugs, NEW , OMNIBUS: Use DBIC relations to fetch related object rather than searching for the object
14:46:29 <kidclamp> I think we just need to propose a guideline here?
14:46:32 <fridolin> oh nice
14:46:36 <thd> kidclamp: Did you just undo the vote?
14:46:56 <ashimema> I added a quick proposal a moment ago: https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22407#c7
14:46:56 <huginn`> 04Bug 22407: enhancement, P5 - low, ---, koha-bugs, NEW , OMNIBUS: Use DBIC relations to fetch related object rather than searching for the object
14:46:57 <kidclamp> no, i just messed up the topic :-)
14:47:22 <ashimema> that should be enough to get it going I reckon?
14:49:14 <kidclamp> sounds good to me, any discussion or objections before vote?
14:50:31 <ashimema> should we be going back and retrospectively updating relations?
14:51:09 * ashimema still find's it a tad crazy that we have to add these manually when dbic gives us them for free for anything that has a proper relationship defined in the db
14:51:16 <kidclamp> eventually yes, tie them to the omnibus bug
14:51:19 <ashimema> but that's a different annoyance
14:51:39 <kidclamp> vote?
14:51:40 <thd> In the absence of a retrospective update, the code will be providing bad examples.
14:52:01 <ashimema> I reckon go for the vote.. get whats there in and refine it with another vote later if we find we need a further example ;)
14:52:09 <ashimema> indeed
14:52:13 <kidclamp> ashimema++
14:53:39 <kidclamp> #startvote do we accept the new coding guideline as proposed on bug 22407comment #7?
14:53:39 <huginn`> Begin voting on: do we accept the new coding guideline as proposed on bug 22407comment #7? Valid vote options are Yes, No.
14:53:39 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
14:53:39 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22407 enhancement, P5 - low, ---, koha-bugs, NEW , OMNIBUS: Use DBIC relations to fetch related object rather than searching for the object
14:53:46 <kidclamp> #vote Yes
14:54:08 <ashimema> #vote Yes
14:54:15 <josef_moravec> #vote yes
14:54:22 <thd> #vote Yes
14:54:25 <oleonard> #vote abstain
14:55:32 <kidclamp> last call
14:56:48 <wizzyrea> #vote abstain
14:57:28 <kidclamp> #endvote
14:57:28 <huginn`> Voted on "do we accept the new coding guideline as proposed on bug 22407comment #7?" Results are
14:58:16 <kidclamp> I didn't specify abstain, I think huginn got confused
14:58:32 <kidclamp> results are yes(4) abstain(2)
14:58:40 <kidclamp> #info guideline accepted
14:58:44 <ashimema> :)
14:58:50 <kidclamp> #action ashimema will add the guideline :-)
14:59:03 <kidclamp> #topic Review of coding guidelines
14:59:10 <kidclamp> #topic Set time of next meeting
14:59:12 <ashimema> #info guideline added :)
14:59:35 <kidclamp> April 24th 19UTC?
15:00:40 <kidclamp> #info Next meeting: 24 April 2019, 19 UTC
15:00:42 <thd> yes
15:00:45 <kidclamp> #endmeeting