#koha: Development IRC meeting 6 November 2019

Meeting started by ashimema at 13:04:01 UTC (full logs).

Meeting summary

  1. Introductions (ashimema, 13:04:22)
    1. Magnus Enger, Libriotech, Norway (magnuse, 13:04:26)
    2. Katrin Fischer, BSZ, Germany (cait, 13:04:36)
    3. Marcel de Rooy, Rijksmuseum. Netherlands (marcelr, 13:04:38)
    4. Martin Renvoize, PTFS Europe (ashimema, 13:04:39)
    5. Jonathan Druart (Joubu, 13:04:56)
    6. Thomas Dukleth, Agogme, New York City (thd, 13:04:58)
    7. Fridolin Somers, Biblibre, France (fridolin, 13:05:18)
    8. https://wiki.koha-community.org/wiki/Development_IRC_meeting_6_November_2019 Agenda (cait, 13:05:45)

  2. Announcements (ashimema, 13:06:38)
    1. We have now been in Feature Slush for the 19.11 release for a week and will be progressing to Feature Freeze as of this evening (UK time) (ashimema, 13:07:09)
    2. Feature Freeze means we will only be considering bugfixes for the release past tonight, if you're enhancement isn't already pushed by the end of today it will not be pushed this cycle. (ashimema, 13:08:13)

  3. Updates from the release manager (ashimema, 13:10:34)
    1. The last few weeks the pace has picked up and allot has been pushed (ashimema, 13:11:16)
    2. I am concentrating on any last straggler enhancements untill the end of the day and then will switch fully to bugs only tomorrow. (ashimema, 13:11:53)

  4. Update from the release maintainers (ashimema, 13:11:59)
    1. Work commitments for our stable branch rmaint have lead to no release during October. (ashimema, 13:14:00)
    2. Focusing on a well polished November release now instead. (ashimema, 13:14:22)
    3. fridolin will be stepping down from the rmaint roles come the 20.05 cycle. I wanted to thank him for his efforts as various rmaint roles the past years and personally thank him for his support onboarding me when I became an rmaint. (ashimema, 13:22:09)
    4. a big hole to fill, we still need volunteers for rmaint of 19.11 and 18.11 for the 20.05 cycle :) (ashimema, 13:22:50)

  5. Updates from the QA team (ashimema, 13:25:49)
    1. Please take a look at the discussion on bug 19809 about use of Koha::Objects::find calls in list context (cait, 13:29:08)
    2. Lots of 'Major' and 'Critical' bugs still in the queue, please focus on those (ashimema, 13:35:16)
    3. About 120 open bugs for major, critical and blocker on bugzilla - help in review appreciated (cait, 13:37:51)
    4. ACTION: Update 'Overall bug tracker health' link on the dashboard to be more clearly a link (ashimema, 13:38:40)

  6. General development discussion (ashimema, 13:38:56)
  7. Dropping support for Debian Jessie (ashimema, 13:39:10)
    1. ACTION: Document differences between MySQL and MariaDB syntaxes, versions etc. on the wiki (cait, 14:02:13)
    2. ACTION: Add a note somewhere that koha-remove does not work on D8 with MySQL5.5 right now and likely won't unless we find a developer who is still running D8 (ashimema, 14:05:44)
    3. ACTION: Check release note generator for supported versions list and update accordingly for SQL servers (ashimema, 14:06:15)
    4. ACTION: Continue the deprecation of D8 conversation on the lists and come up with a clear plan (ashimema, 14:06:50)
    5. ACTION: Continue work on supporting D10 (ashimema, 14:07:11)
    6. ACTION: Further the work to test against more DB server versions in our CI process. (ashimema, 14:07:49)
    7. ACTION: Promote bug 23914 more so we can get a better idea of what's actually in use in our userbase (ashimema, 14:08:25)

  8. Objects->find - Bug 23914 (ashimema, 14:10:54)
    1. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19809 bug 19809 (ashimema, 14:11:33)

  9. Review of coding guidlines (ashimema, 14:12:01)
  10. Set time of next meeting (ashimema, 14:13:42)
    1. Next meeting: 20 November 2019, 20:00 UTC (ashimema, 14:23:41)


Meeting ended at 14:23:56 UTC (full logs).

Action items

  1. Update 'Overall bug tracker health' link on the dashboard to be more clearly a link
  2. Document differences between MySQL and MariaDB syntaxes, versions etc. on the wiki
  3. Add a note somewhere that koha-remove does not work on D8 with MySQL5.5 right now and likely won't unless we find a developer who is still running D8
  4. Check release note generator for supported versions list and update accordingly for SQL servers
  5. Continue the deprecation of D8 conversation on the lists and come up with a clear plan
  6. Continue work on supporting D10
  7. Further the work to test against more DB server versions in our CI process.
  8. Promote bug 23914 more so we can get a better idea of what's actually in use in our userbase


People present (lines said)

  1. ashimema (141)
  2. cait (70)
  3. fridolin (45)
  4. marcelr (33)
  5. Joubu (26)
  6. thd (16)
  7. huginn (10)
  8. wahanui (3)
  9. koha-jenkins (3)
  10. magnuse (1)
  11. eythian (1)


Generated by MeetBot 0.1.4.