#koha: Development IRC meeting 9 October 2019

Meeting started by ashimema at 15:00:51 UTC (full logs).

Meeting summary

  1. Introductions (ashimema, 15:01:16)
    1. Martin Renvoize, PTFS Europe (ashimema, 15:01:26)
    2. Thomas Dukleth, Agogme, New York City (thd, 15:01:56)
    3. Owen Leonard, Athens County Public Libraries, Ohio (oleonard, 15:02:47)
    4. Kyle Hall, ByWater Solutions (khall, 15:04:02)

  2. Announcements (ashimema, 15:04:04)
    1. Cori Lynn Arnold, DGI (lurking) (corilynn, 15:04:23)
    2. Brendan Gallagher, ByWater (bag, 15:04:51)
    3. Freeze dates email will be going out tonight, provisional dates are already in the calendar (ashimema, 15:05:53)
    4. https://koha-community.org/calendar/ Calendar (ashimema, 15:06:07)
    5. If you noticed an issue with the git repositories over the last 24 hours, please be aware the issue should now be resolved. (ashimema, 15:06:45)
    6. https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_October_2019 Agenda (ashimema, 15:06:59)
    7. Update from the Release manager (ashimema, 15:10:02)
    8. The release is starting to take shape and provisional dates are now set (ashimema, 15:10:33)
    9. Feature slush is scheduled for the 30th November - Thats three weeks today (ashimema, 15:10:56)
    10. Feature freeze is scheduled for the 6th November - One week later (ashimema, 15:11:23)
    11. String freeze is scheduled for the 13th November - One week later again (ashimema, 15:11:47)
    12. Fridolin Somers, Biblibre, France (fridolin, 15:11:52)
    13. Release all being well will be the 27th November - Giving two weeks for translations. (ashimema, 15:12:20)

  3. Updates from the Release Maintainers (ashimema, 15:15:11)
    1. 19.05.x is at 19.05.05 presently and is feeling reliable and stable (ashimema, 15:17:54)

  4. Updates from the QA team (ashimema, 15:18:23)
    1. Pace seems to have picked up the last week, keep it up :) (ashimema, 15:18:40)

  5. General development discussion (ashimema, 15:18:50)
    1. oleonard notes that there is a large number of bugs that appear to need updating to 'RESOLVED FIXED' (ashimema, 15:19:21)
    2. ACTION: ashimema will look into this prior to the next cycle starting (ashimema, 15:19:46)
    3. We should have Joubu back for the next cycle, which should get the numbers back on track (ashimema, 15:20:08)
    4. Fridolin raises that pootle still contains a number of officially unsupported koha versions.. perhaps we should tidy up there too. (ashimema, 15:22:51)
    5. I'm contemplating a 'fail fast' attitude early next cycle.. still to be fleshed out and discussed.. but the initial thoughts are that I will push some more experimental bugs (on developer request and my own judgement) early in the release with the expectation of getting quick followups for any breakage. Idea being it helps alleviate some of the QA backlog of the most technical bugs where we don't have so many people capable of (ashimema, 15:25:29)

  6. Review of coding guidelines (ashimema, 15:27:26)
    1. tcohen raises the question of whether we should start officially deprecating the /svc api namespace. (ashimema, 15:29:00)

  7. Set time of next meeting (ashimema, 15:38:56)
    1. Next meeting: 23 October 2019, 21:00 UTC (ashimema, 15:43:40)


Meeting ended at 15:43:56 UTC (full logs).

Action items

  1. ashimema will look into this prior to the next cycle starting


Action items, by person

  1. ashimema
    1. ashimema will look into this prior to the next cycle starting


People present (lines said)

  1. ashimema (73)
  2. oleonard (13)
  3. fridolin (13)
  4. bag (10)
  5. thd (10)
  6. huginn (3)
  7. wizzyrea (1)
  8. corilynn (1)
  9. khall (1)
  10. reiveune (1)
  11. koha-jenkins (1)


Generated by MeetBot 0.1.4.