13:05:03 <caroline_> #startmeeting Documentation IRC meeting 14 November 2019
13:05:03 <huginn> Meeting started Thu Nov 14 13:05:03 2019 UTC.  The chair is caroline_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:05:03 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:05:03 <huginn> The meeting name has been set to 'documentation_irc_meeting_14_november_2019'
13:05:25 <caroline_> #topic Introductions (please use "#info" in front of your introduction to have it show up in the automatic minutes)
13:05:44 <caroline_> #Caroline Cyr La Rose, inlibro, Montréal, Québec
13:06:16 <thd> #info Thomas Dukleth, Agogme, New York City
13:08:00 <Marie-Luce> #info Marie-Luce Laflamme, inLibro, Montréal, Québec
13:08:32 <caroline_> ashimema, cait ?
13:10:43 <caroline_> #topic Review of action points
13:11:14 <caroline_> First is review of Manager role
13:11:26 <caroline_> #link https://wiki.koha-community.org/wiki/Documentation_management
13:12:15 <ashimema_> 
13:12:20 <caroline_> ashimema and I started documenting the role
13:12:36 <caroline_> if you have anything to add, please do :)
13:13:05 <caroline_> Yesterday at the general meeting, we voted on the new team
13:13:20 <caroline_> However, anybody who wants to join the team mid-cycle is welcome!!
13:13:57 <caroline_> Send me an email or a @later if you're not sure how to contribute
13:14:00 <ashimema_> #info Martin Renvoize, PTFS Europe
13:14:23 <caroline_> davidnind and I will be sharing the docs manager role
13:14:34 <ashimema_> If people do join caroline_, let me know and I can add them into the release notes that get generated
13:14:55 <caroline_> davidnind will continue the stellar job he has been doing for orienting the docs strategy
13:15:14 <caroline_> davidnind++
13:15:27 <ashimema_> I'm excited by the two of you working it between you.. we benefit from both your strengths :)
13:15:49 <caroline_> and I will do the nitty gritty, like populate Taiga and merging requests
13:16:00 <ashimema> #info Martin Renvoize, PTFS Europe
13:16:03 <ashimema> #info Martin Renvoize, PTFS Europe
13:16:20 <caroline_> lol ashimema I think you have a problem with your IRC client again XD
13:17:02 <caroline_> branching off for a second
13:17:11 <ashimema_> [off] I'll say.. I killed it but it's still sending messages :(
13:17:12 <thd> changing identity should give a problem
13:17:21 <caroline_> thd has taken the role of wiki curator
13:17:45 <caroline_> and will continue his hard work of updating the wiki
13:17:53 <caroline_> thd++
13:18:47 * thd has long been secret curator except for a long bout of spending all his time helping elderly neighbours and friends with serious problems.
13:18:57 <caroline_> I'm not very technical, but if there is anything I can do to help, I'm happy to (I can test)
13:19:16 <thd> Testing should be very soon.
13:19:18 <caroline_> :( I hope your neighbours are better...
13:19:40 <Marie-Luce> I've some spare time, but I'm not too sure how can I help
13:19:51 <thd> Sadly my neighbour passed on which gives me time for Koha again.
13:20:12 <caroline_> :(
13:20:34 <Marie-Luce> sorry to hear this
13:20:42 <thd> I kept her going eight years when her diagnosis was six months.
13:21:30 <caroline_> back to DM role, ashimema_ has also been documenting the DM transition workflow
13:22:33 <sev_q> Hello #oha !
13:23:43 <caroline_> davidnind and I have both been dm before, so I'm not sure this applies for this cycle, but we will have to test it eventually
13:24:03 <caroline_> #topic Project updates
13:25:28 <caroline_> current ongoing projects are : content development guide
13:25:49 <caroline_> #link https://wiki.koha-community.org/wiki/Documentation_-_Content_Development_Guide
13:25:57 <thd> I hope that many tests for wiki migration and then updating will be automated with diffs etc.
13:27:09 <caroline_> Wiki update and curator role is also an ongoing project
13:27:19 <caroline_> :)
13:27:57 <caroline_> also Git guide for non-developers (Marie-Luce, maybe you could help with this as you are new to git)
13:28:16 <caroline_> #link https://wiki.koha-community.org/wiki/Git_guide_for_documentation
13:28:39 * ashimema_ will read that one and see if anything stands out.. not looked at it in a while
13:28:56 <caroline_> also Automated screenshots, Joubu and davidnind were both working on this independently I think
13:29:06 <caroline_> Not sure there's been any progress
13:29:50 <caroline_> And finally, three other of davidnind's babies, Installation guide, Getting started guide and Reorganising manual contents
13:30:41 <Marie-Luce> I can work on git guide for documentation. It will be a good way to learn
13:31:24 <caroline_> It was not mentionned in the agenda, but davidnind also worked on a documentation strategy plan, which I'm in love with
13:31:27 <caroline_> #link https://wiki.koha-community.org/wiki/Documentation_-_Plan
13:31:55 <caroline_> It's a complete rethinking of the documentation for Koha
13:32:24 <ashimema_> Interesting.. I'll have a read of that shortly
13:32:51 <caroline_> He talked a bit about it in his talk at KohaCon19
13:33:29 <ashimema_> I was leading an alternate talk I think during that one :(
13:33:32 <ashimema_> so missed it.
13:33:53 <caroline_> aw... :(
13:34:02 <caroline_> Wasn't it during the conference part?
13:34:08 <ashimema_> Translation workflow is slowly starting to come together too
13:34:16 <ashimema_> I think it was one of the workshops
13:34:24 <ashimema_> I might be wrong
13:34:47 <caroline_> he did a workshop too, but he did a talk
13:35:28 <caroline_> anyway, I'm conscious of the time... Translation workflow was a subtopic in What's been done so far
13:35:36 <caroline_> which we're getting to
13:36:23 <caroline_> #topic What's been done so far
13:36:56 <caroline_> lucyvh, myself and cait have been submitting merge requests for the manual
13:37:03 <caroline_> keep up the good work team!!
13:37:26 <caroline_> Now we'll embark on the changes for 19.11 and I hope we can do 20.05 at the same time
13:37:34 <caroline_> we're a bit behind
13:37:59 <ashimema_> have you guys got a process worked out for maintaining the different versions?
13:38:17 <ashimema_> I'm still a little out of touch on the docs flow front.
13:38:26 <caroline_> I wanted to ask, from now on, since we'll be working in several versions at the same time, make sure to write which version(s) your change applies to so I can merge it on the right manual
13:38:57 <caroline_> #action caroline_catlady will work on a system for managing several manual branches at the same time
13:39:17 <ashimema_> I 'think' gitlab will let you do that at the merge request end.. i.e. ask to merge into branch x instead of merge into master
13:39:24 <caroline_> #info when submitting merge requests, please indicate which koha version it applies to
13:39:33 <caroline_> It does
13:39:43 <caroline_> And I can also cherry pick on to another branch
13:39:57 <caroline_> technically, everything should go on master
13:40:03 <ashimema_> do you tend to do all your work in gitlab, or do you have a local copy of git which you use for managing ?
13:40:10 <caroline_> unless something was removed
13:40:14 <ashimema_> brill
13:40:35 <caroline_> I work on the manual from a local repo, but the managing stuff I do on gitlab
13:41:10 <ashimema_> I'm happy to give some lessons on cherry-picking and things if you like
13:41:41 <caroline_> gitlab makes it very easy (there's litterally a button that says cherry pick and you choose which branch)
13:41:53 <ashimema_> [off] I now have access to the translate server so can help move that automated process forward.
13:41:56 <caroline_> but I'm open to learning how to do it command line to :)
13:42:02 <ashimema_> great :)
13:42:22 * ashimema_ isn't so familiar with gitlab ui.. :)
13:42:24 <caroline_> ok, about the translation workflow!
13:42:37 <caroline_> what did we decide?
13:42:54 <cait> oops, missing hte meeting?
13:43:02 <caroline_> hi cait!
13:43:05 <cait> hi
13:43:09 <cait> too late?
13:43:17 <caroline_> we're getting to the translation workflow for the manual
13:43:41 <caroline_> I saw the discussions, but I don't know if we decided anything yet
13:44:41 <cait> I didn't get any feedback on the paper Martin and I wrote - ashimema, have you touched base with bernardo since?
13:45:16 <ashimema_> well, initially I just wanted to try and make sure the regular rebuilds of the manual were working for the various branches.. at the moment I think the only 'living document' is the master branch.. but it's been getting pushed regularly to the 19.05 manual
13:45:17 <cait> one thig maybe to discuss is when to branch out the manuals
13:45:45 * cait has to keep an eye on her lunch cooking
13:45:49 <ashimema_> once I've got that side of it sorted I wanted to look at automating pulling in translations from translate.koha-community.org
13:47:01 <ashimema_> I'm currently reading the scripts on the translate server to get a better understanding of how it all fits together before proposing next steps ;)
13:47:32 <caroline_> for the manual branches, I suggested that we create one as soon as the cycle begins so we can work on it as the developpers add things
13:47:44 <ashimema_> I think 19.11 should be branched off on the day of the release (same time as I branch the koha code branch off)
13:48:04 <caroline_> but it means more work on managing branches for the dm
13:48:27 <ashimema_> then the 'master' manual branch effectively follows 20.05
13:48:45 <ashimema_> that's how we work in koha code development
13:49:35 <ashimema_> so 'master' == 20.05 before it's released.. then 20.11 once 20.05 is released.. then 21.05 etc etc.
13:49:53 <caroline_> ok makes sense
13:50:25 <ashimema_> so master is the living document.. then things that aught to be backported (i.e are 'fixes' and not 'additions/enhancements/new features') get cherry-picked into the 'stable' docs branches
13:50:55 <ashimema_> the issue I see here is that if I'm not mistaken you guys generally are a few months behind on documentation?
13:50:56 <caroline_> ok so right now, we should have master and 19.11 and before
13:51:05 <caroline_> yes -_-
13:51:10 <ashimema_> so in effect you're rapidly playing catch up for the first few months of each cycle
13:51:25 <caroline_> I'd like us to be more up to date...
13:51:32 <ashimema_> that would be great
13:51:44 <caroline_> That's why I want to work on getting the release notes in taiga for everyone to work on
13:51:49 <caroline_> asap
13:52:20 <ashimema_> is there's anything we can do with bugzilla or whatever to help track what 'bugs' get backported into the stable branches.. so you know better what manual changes also need corresponding backports?
13:52:55 <ashimema_> what do you mean 'getting the release notes in taiga'?
13:53:13 <caroline_> oh I hadn't thought of that part... but the bugs that usually get backported don't need documentation since theyre fixing things that should already work
13:53:26 <ashimema_> well.. usually ;)
13:53:45 <ashimema_> but sometimes a fix clarifies some usage or changes wording
13:53:53 <caroline_> I read through the release notes diffs and add tasks in taiga for bugs that mean changes in the manual
13:53:58 <ashimema_> cait , any comments on there..
13:54:09 <ashimema_> once a release is done should the manual be pretty much static?
13:54:29 <caroline_> I think so, unless were behind like right now
13:54:34 <ashimema_> oh cool.. I'm still working on tidying up the release notes btw ;)
13:54:37 <cait> i think we are not quite there yet
13:55:14 <cait> but in the future maybe - we could have a 'docs' freeze :)
13:55:28 <ashimema_> trying to go through every bug and traige it to make sure it's labelled correctly in terms of component, severity, enhancement/new feature or bug etc and then add small summaries for enhancements and new features.
13:55:33 <cait> howhard is it to cherry-pick with the gitlab giu?
13:55:48 <caroline_> not hard at all
13:55:53 <cait> cool
13:55:57 <caroline_> I can do it :)
13:56:02 <cait> i think there are some 'pros' to branching
13:56:12 <ashimema_> agreed
13:56:13 <cait> - help links from Koha go to the manual - so if there is no 19.11 manual... do they work?
13:56:30 <cait> - we could publish a link to the 19.11 manual in the release notes
13:57:16 <cait> - we will have a 19.11 manual on the website...
13:57:25 <cait> so a lot of pros to branching out i think
13:57:36 <thd> On many large projects documentation is somewhat behind the code which is almost inevitable.  A docs freeze if it could work would not realistically work at the same time as a code freeze.
13:57:44 <ashimema_> For a cycle a few cycles back we did have a development version of the manual running.. that was cool as, as a developer you could look at the manual for new features to see if they existed or not (and links worked I believe)
13:57:44 <caroline_> Can we branch out on the day of feature freeze?
13:58:29 <ashimema_> branching at feature freeze would be fine by me.. though I'm not sure if it would win you much...
13:58:37 <cait> it would win some time maybe
13:58:44 <cait> for bernardo to set up the manual po projects etc
13:59:07 <ashimema_> if you're still expecting the workflow to be 'merge to master -> backport to branches' then you'd just be making that 'backport to branches' step a requirement a few weeks earlier in the process
13:59:19 <ashimema_> that is certainly true cait..
13:59:37 <ashimema_> that makes allot of sense actually..
13:59:59 <ashimema_> we could branch 19.11 manual now so that translation can start now..even if the manual isn't complete yet?
14:00:16 <thd> If only all code patches required complete documentation for the manual.
14:00:23 <cait> usually, when the strings don't change, you don't have to retranslate, only changes
14:00:46 <cait> so you can start translating and most of it will stay the same
14:01:11 <caroline_> we do do a lot of de-capitalization and review (anyway, I do)
14:01:15 <ashimema_> I do think that a monthly string freeze anouncement for the manual would be good... I imagine the first 2 maybe 3 months of a new stable the manual for that version gets updated a lot (doing catch up).. having translators know they need to go and translate the updates once a month is likely going to yield better results that expecting they'll be watching the repo and translating as you go.
14:01:29 <cait> i think ideally a change to a stable branch should trigger a po file update
14:01:32 <ashimema_> haha.. funny you should say that thd.. that's been on my list for a while.
14:01:59 <ashimema_> I've actually added some bugzilla searches to try and encourage the big commiters to keep up with documenting their new features.
14:03:16 <caroline_> I don't want to interrupt this conversation, but I'm aware that we are over our hour
14:03:21 <cait> whatever we do, let's write up the process :)
14:03:29 <cait> caroline_diplomatic! :)
14:03:41 <ashimema_> +1
14:03:46 <caroline_> I was going to suggest to write it up and discuss next meeting?
14:03:48 <cait> ok, do we have something to #info or #agreed?
14:04:18 <caroline_> I don't feel like we've agreed on anything
14:04:26 <ashimema_> indeed
14:04:49 <caroline_> cait, can you write the pros to branching and ashimema_ can you write the cons?
14:04:49 <cait> so .. next step?
14:05:19 <cait> hm
14:05:27 <cait> I can try to writ eup something and Martin can add to it
14:05:37 <cait> but I will take a bit - i have some errands to run first
14:05:39 <cait> where shoudl we put it?
14:05:47 <caroline_> During this cycle, I will see how hard it is to manage several branches, and I will be better able to make a decision
14:05:59 <ashimema_> Joubu is around now.. I think he's also got allot to input in that area.. we can get his input a bit too
14:06:18 <caroline_> yes, much expertise stored in Joubu :)
14:06:29 <cait> wiki?
14:06:36 <ashimema_> +1
14:06:40 <caroline_> wiki or google docs, whatever is fine
14:06:44 <cait> ok
14:06:50 <caroline_> it's just a working document
14:06:55 <cait> ashimema: can oyu set up a page and send me the link maybe?
14:07:07 <thd> google docs is non-free software eating your soul.
14:07:08 <Joubu> about the translation, we are dealing with it on the issue. Bernardo, Chris and me. We will write down how it works, when we will remember :D
14:07:28 <Joubu> https://gitlab.com/koha-community/koha-manual/issues/13
14:07:50 <caroline_> thd framapad then? :)
14:07:57 <thd> :)
14:08:24 <cait> start something please :) I am willing to add to whatever
14:08:35 <Joubu> Something else, I am certainly off topic, sorry:
14:08:39 <caroline_> #action ashimema_ will create a wiki page to discuss branching out the manual
14:08:43 <ashimema_> stick it on the wiki
14:09:00 <caroline_> #action cait will discuss branching out on the wiki
14:09:16 <ashimema_> I'll catch you up in PM Joubu
14:09:40 <Joubu> k
14:09:50 <caroline_> I will skip the next steps as that is pretty much what we just did and go to final topic
14:09:56 <caroline_> #topic Set time of next meeting
14:10:36 <caroline_> 11 december is already taken up by general meeting I think
14:10:48 <caroline_> do we want 12 december?
14:11:19 <caroline_> could we do it later so david can join?
14:11:32 <ashimema_> sounds good to me.
14:11:37 <thd> I may miss a mid December meeting while travelling to California for a couple of weeks.
14:11:56 <ashimema_> December meetings are always challenging.. that time of year and all
14:12:07 <ashimema_> I'd just schedule it and hope people can attend ;)
14:12:37 <caroline_> yeah parties and stuff :)
14:12:55 <ashimema_> yup
14:13:00 <thd> I will definitely attend if the electricity is working and I can otherwise.
14:13:33 <caroline_> #info Next meeting: 12 December 2019, 19 UTC
14:13:48 <caroline_> #endmeeting