13:02:07 <davidnind> #startmeeting Documentation IRC meeting 4 July 2019
13:02:07 <huginn`> Meeting started Thu Jul  4 13:02:07 2019 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:07 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:07 <huginn`> The meeting name has been set to 'documentation_irc_meeting_4_july_2019'
13:02:32 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_4_July_2019
13:02:45 <davidnind> #topic Introductions
13:03:00 <davidnind> #info David Nind, New Zealand
13:03:01 <caroline_catlady> #info Caroline Cyr La Rose, inLibro
13:04:31 <AndyBoze> #info Andy Boze, University of Notre Dame, USA
13:05:18 <davidnind> That looks all of us for today I think!
13:05:51 <davidnind> #chair caroline_catlady, AndyBoze
13:05:51 <huginn`> Current chairs: AndyBoze caroline_catlady davidnind
13:06:03 <davidnind> #topic Action points
13:06:21 <caroline_catlady> this is the meeting with the highest chair/participant ratio XD
13:06:21 <ashimema> sorry, in a company meeting (in person) today
13:06:26 <ashimema> have a good meeting
13:06:46 <ashimema> #info Apologies, Martin Renvoize PTFS-E
13:06:55 <davidnind> no worries ashimema - you can read the minutes later!
13:07:14 <davidnind> Nothing to report really on all my action points...
13:07:30 <caroline_catlady> do you want to delegate?
13:08:16 <caroline_catlady> I could work on style guide and/or git guide
13:09:11 <davidnind> Help with the git guide would be great, I was just about to add a page to the wiki with an outline, so will do that after this
13:09:17 <davidnind> ..meeting
13:09:35 <caroline_catlady> ok I will flesh it up after
13:10:00 <davidnind> Thanks caroline_catlady!
13:10:18 <caroline_catlady> #action davidnind will create wiki page for git guide
13:10:28 <caroline_catlady> #action caroline_catlady will work on git guide
13:10:30 <davidnind> I sent an email to the docs list just before on easy, medium and hard tasks - don't expect anyone to have read it yet
13:11:16 <caroline_catlady> I got all the taiga emails but I don't see the docs email...
13:11:17 <davidnind> I've tagged a small number of tasks I think fit the criteria
13:11:28 <AndyBoze> I've been looking them over. I'll try to tackle at least some easy ones.
13:11:45 <caroline_catlady> AndyBoze++
13:12:56 <davidnind> #info Initial attempt at easy, medium and hard tasks http://lists.koha-community.org/pipermail/koha-docs/2019-July/000251.html
13:13:41 <caroline_catlady> cool! I like the use of tags
13:13:52 <davidnind> We can see if that helps, let me know AndyBoze
13:14:27 <davidnind> I'm not sure how well the tags will work, as it picks up items with those words in them, including closed items
13:14:34 <AndyBoze> Will do, davidnind
13:14:36 <davidnind> But I guess it is a start
13:14:38 <cait> @info Katrin Fischer, BSZ
13:14:38 <huginn`> cait: Error: The command "info" is available in the Factoids and RSS plugins.  Please specify the plugin whose command you wish to call by using its name as a command before "info".
13:14:38 <wahanui> i already had it that way, huginn`.
13:14:47 <cait> #info Katrin Fischer, BSZ
13:14:58 <davidnind> Hi cait!
13:15:23 <davidnind> If it doesn't work I can do a wiki page!
13:15:52 <cait> sorry for being late - I think this might be missing from the official calendar?
13:16:10 <caroline_catlady> I think it is there... no?
13:16:45 <cait> it is - https://koha-community.org/calendar/
13:16:49 <cait> all good then, it's me :)
13:17:00 <caroline_catlady> no worries!
13:18:03 <davidnind> it has been one of the weeks for the last few weeks at work, so will try and progress the other things over the next week or so
13:18:21 <davidnind> #topic What's been done so far
13:19:22 <davidnind> There was an education meeting, which went very well - do you want to provide an update caroline_catlady, or just refer to your highlights?
13:19:48 <caroline_catlady> well the highlghts is pretty much all the notes I took ^_^;;
13:20:10 <caroline_catlady> But there was interest to participate in the community, which I thought was great
13:20:24 <caroline_catlady> but people didn't know how to go about it
13:20:51 <caroline_catlady> I think that's a recurring theme...
13:21:01 <davidnind> #info Education meeting highlights https://lists.katipo.co.nz/pipermail/koha/2019-June/053227.html
13:21:29 <caroline_catlady> Other things non-education related that I noted : we need a how-to setup Koha for newbies
13:22:09 <caroline_catlady> ok, that was just one thing, I thought I had more hehe!
13:22:34 <caroline_catlady> The koha-US group did a page that reorganizes the manual more visually
13:22:52 <caroline_catlady> #link https://koha-us.org/learn-from-koha-us/
13:23:02 <davidnind> I thinks so too, it is a daunting thing I think when you are starting out - so many areas and things to consider
13:23:32 <davidnind> #action Add task for getting started with Koha
13:23:56 <cait> caroline_catlady: there is a very old one from Brooke
13:24:04 <cait> (setup for newbies)
13:24:18 <cait> but it's in dire need for an update
13:24:32 <cait> #link https://wiki.koha-community.org/wiki/Newbie_guide
13:24:55 <davidnind> Thanks cait, I was trying to find it!
13:25:00 <cait> np
13:25:02 <caroline_catlady> I think the need was how to install?
13:25:11 <cait> as a non native speaker i suggest to keep language simple and consistent
13:25:32 <cait> not too simple, but trying to have not too long paragraphs etc
13:25:48 <davidnind> There are normally two challenges I think
13:25:49 <caroline_catlady> I feel like we could link from there to the manual, but how do we keep the links up to date?
13:25:56 <davidnind> One is installing Koha
13:26:03 <davidnind> The other is what do I do now?
13:26:50 <caroline_catlady> that is one long wiki page @_@
13:26:58 <davidnind> There is the installation guide for packages on Debian and Ubuntu, so we could at least link to the correct ones
13:27:26 <davidnind> it is, and i think will always be a challenge...
13:28:31 <koha-jenkins> Project Koha_Master_D9 build #807: STILL UNSTABLE in 29 min: https://jenkins.koha-community.org/job/Koha_Master_D9/807/
13:28:45 <davidnind> So, should we link to these, or add some tasks and work through creating some content that is ideally less daunting?
13:29:33 <cait> could we have a checklist for starters in the manual?
13:29:37 <cait> that would help with linking to sections
13:29:44 <cait> and with the version changes
13:29:45 <caroline_catlady> I need to think about it
13:30:38 <davidnind> personally I think we should have an official installation guide and then some sort of guide on how to setup Koha for the first time
13:31:02 <davidnind> but starting at least with a checklist and linking would be a great start
13:31:33 <caroline_catlady> I thought there was an implementation checklist
13:32:29 <davidnind> There is, at the nearly very end https://koha-community.org/manual/19.05/en/html/implementation_checklist.html
13:33:25 <caroline_catlady> Is the term "implementation" not clear enough?
13:33:42 <cait> hm so maybe an update
13:33:49 <cait> i also feel data migration doesn't describe the first part well
13:33:56 <caroline_catlady> We could rename it "getting started" checklist?
13:34:02 <cait> i'd like that
13:34:18 <davidnind> Switching that around to near the start some way, rather than getting straight into a 1000 or so system preferences might help
13:34:29 <caroline_catlady> yes I think so too
13:35:29 <caroline_catlady> It could act a a sort of table of contents, like "here's what you need to know to start, a) xxx (link to a), b) xxx (link to b)"
13:35:55 <davidnind> I'm happy to have a go at reorganising/rewording the structure a bit, and publishing in a test place for feedback if that would help
13:36:51 <davidnind> AndyBoze: any thoughts on this and your experiences
13:37:08 <davidnind> (hope you don't think we're ignoring you!!)
13:38:06 <koha-jenkins> Project Koha_Master_U18 build #300: UNSTABLE in 37 min: https://jenkins.koha-community.org/job/Koha_Master_U18/300/
13:38:46 <AndyBoze> davidnind: Not feeling ignored! Interesting conversation, but nothing really to say. I agree with all.
13:39:19 <davidnind> thanks AndyBoze!
13:40:53 <davidnind> #action davidnind to reorganise/reword structure and open up for feedback
13:41:19 <davidnind> Should we raise at the general meeting next week to see if they have any thoughts?
13:41:34 <davidnind> #chair cait
13:41:35 <huginn`> Current chairs: AndyBoze cait caroline_catlady davidnind
13:41:41 <cait> oops
13:41:57 <cait> what did I do? :)
13:42:00 <davidnind> 100% coverage for chairs now!:)
13:42:04 <caroline_catlady> maybe they could help with the installation guides. I think there is a lot of clean up to do in the wiki
13:42:05 <davidnind> nothing...
13:43:12 <caroline_catlady> Is there a way to archive things in MediaWiki? There are some installation guides for very old versions, but I didn't want to erase anything
13:43:18 <davidnind> I think the last thing we want to do is confuse people when they are just starting, and remove as much as the 'barriers to entry' as is possible
13:43:35 <caroline_catlady> +1
13:43:37 <cait> sounds good about the installation guides
13:43:41 <cait> might be due with new OS versions
13:45:05 <davidnind> There should be in wikimedia, will have a look - as a minimum you want to make sure they get the current stuff, and can refer to archived material if required
13:45:19 <caroline_catlady> exactly
13:45:50 <koha-jenkins> Project Koha_Master_D8 build #317: UNSTABLE in 42 min: https://jenkins.koha-community.org/job/Koha_Master_D8/317/
13:46:32 <davidnind> Ideally we would want google to show they most current and up-to-date installation and getting started guide, but might take a bit with all the material out there!
13:47:10 <cait> caroline_catlady: we have only marked/tagged some as obsolete... you can't really delete pages right now :(
13:47:24 <cait> I feel the wiki needs an update
13:47:35 <caroline_catlady> wiki = always needs an update
13:47:41 <cait> some thigns are not working quite right and we need a way to remove old content better
13:47:47 <cait> meant the software
13:48:01 <cait> our mediawiki has been stuck on a very old version due to some extensions (that I feel we don't really make use of)
13:48:06 <cait> a fresh start there might do wonders
13:48:06 <caroline_catlady> ah ok! but the content too hehe!
13:48:15 <cait> yep the content too
13:48:29 <cait> here some examples for 'obsolete' marked pages:
13:48:33 <cait> #link https://wiki.koha-community.org/wiki/Koha_Virtual_Appliances obsolete 1
13:48:43 <caroline_catlady> I know there is a spot open for wiki curator
13:48:45 <cait> #link https://wiki.koha-community.org/wiki/Htp-to-tt-conversion obsolete 2
13:48:47 <davidnind> I've raised a bugzilla request for an update - bug 23073
13:48:47 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23073 normal, P5 - low, ---, gmc, NEW , wiki.koha-community.org needs updating to a later version
13:48:48 <caroline_catlady> I think it is still open
13:48:59 <caroline_catlady> Is that the kind of thing this person would do?
13:49:07 <cait> gmcharlt: trying a summon :) did you happen to see bug 23073?
13:49:20 <cait> i think the curator position is not super clearly defined
13:49:36 * caroline_catlady draws symbols on the floor in chalk to help with the summoning
13:50:06 <cait> thd had planned to do updates but I think never got around to it - it's something I think a volunteer could pick up
13:50:19 <davidnind> he may be on a different plane...
13:50:23 <cait> but i might not be the easisest task given we have an old version with custom things (not sure how much really)
13:50:39 <cait> davidnind++ caroline_catlady++
13:50:41 <caroline_catlady> I tried to sign up for that on one of the last cycles, but the wiki is so scary when you look at all of it
13:51:18 <davidnind> I think it will be a challenge (both updating the wiki software and curating the content!)
13:52:03 <davidnind> you would think with some librarians around the pace we would be reasonably good at organising it ;-)
13:52:11 <davidnind> pace = place
13:52:20 <caroline_catlady> wikis get out of hand, that's the problem
13:52:31 <cait> the problem is that it's often hard to tell wht's otu of date with the more technical stuff
13:52:32 <davidnind> yep!
13:52:36 <caroline_catlady> it's a tool for anarchists, not librarians ;)
13:52:36 <cait> you need to grab one or more of the devs
13:53:07 <davidnind> the developer guide gets some attention and is well organised
13:53:29 <davidnind> anyway...
13:53:51 <davidnind> what do we do with all that?
13:54:20 <cait> hm
13:54:21 <caroline_catlady> - define what the responsibilities of wiki curator are
13:54:27 <cait> i am at the moment not the most reliable person with action items :(
13:54:42 <cait> but othewise it hink getting in touch with galen maybe to see what would be needed to update/migrate?
13:54:57 <caroline_catlady> - get someone to be wiki curator, and whip gmcharlt to update
13:55:31 <cait> not sure he would be the person, my understanding is they mainly just host, but i might be mistaken
13:55:36 <davidnind> me neither (with action items) :-(
13:55:39 <cait> too bad the summoning failed :)
13:55:56 <caroline_catlady> - ask the devs at general meeting or dev meeting to guide us for the installation guides
13:56:20 <davidnind> #action Followup on wiki software update - bug 23073
13:56:20 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23073 normal, P5 - low, ---, gmc, NEW , wiki.koha-community.org needs updating to a later version
13:57:10 <davidnind> #action Request input from community at dev or general meeting on installation guide
13:57:35 <caroline_catlady> I will add this to the agenda
13:58:00 <cait> thx!
13:58:12 <davidnind> #action Add tasks for implementation/getting started sections
13:58:38 <davidnind> #action caroline_catlady to add to dev or general meeting
13:59:17 <caroline_catlady> Is one of you going to be at the next meeting? I'm giving a training, so I'm not 100% sure I will make it
13:59:45 <cait> general?
13:59:53 <caroline_catlady> yes general, sorry
14:00:01 <cait> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_10_July_2019
14:00:24 <cait> i think i should be
14:00:26 <davidnind> I should be at the general one so should be okay
14:01:07 <davidnind> Right, the only other thing I think to mention for what's been done so far is caroline_catlady 's work on reviewing the acquisitions chapter
14:01:13 <caroline_catlady> I also added to define responsibilities for wiki curator
14:01:23 <caroline_catlady> Yes, I started
14:01:29 <caroline_catlady> But haven't had time
14:02:31 <davidnind> it's a great start!
14:02:36 <davidnind> #topic Workflow
14:03:14 <davidnind> AndyBoze: do you need any help with figuring out the workflow for editing the manual
14:03:34 <davidnind> conscious that I haven't been much help so far!
14:03:47 <AndyBoze> davidnind: I don't think so, but I'll let you know if I do.
14:04:29 <davidnind> great, happy to do something over video or audio to help you get setup, or walk through making a change if that will help
14:05:01 <AndyBoze> Thanks!
14:05:44 <davidnind> conscious of the time, so..
14:05:47 <davidnind> #topic Set time for next meeting
14:06:13 <davidnind> 1st of August or the 8th of August?
14:06:48 <cait> i thin 8 of august i am on vacation, but that shouldn't stop you
14:07:26 <AndyBoze> 1 August works best for me. I have a meeting at this time on the 8th.
14:08:26 <davidnind> does it work ok for you caroline_catlady?
14:09:01 <davidnind> #info Next meeting 1 August 2019 13:00 UTC
14:09:26 <davidnind> can change if we need to, will check with Lucy about the time
14:09:30 <davidnind> #endmeeting