14:00:38 <ashimema> #startmeeting General IRC meeting 11 December 2019
14:00:38 <huginn> Meeting started Wed Dec 11 14:00:38 2019 UTC.  The chair is ashimema. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:38 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:38 <huginn> The meeting name has been set to 'general_irc_meeting_11_december_2019'
14:00:39 <ashimema> #topic Introductions
14:00:56 <ashimema> #info Please introduce yourselve with an #info to appear in the minutes.
14:01:04 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:01:08 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:01:18 <Joubu> #info Jonathan Druart
14:01:45 <ashimema> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_11_December_2019 Today's agenda
14:02:10 <davidnind> #info David Nind, Wellington, New Zealand
14:02:29 <ashimema> We'll wait a few minutes for any straggler to arrive :)
14:03:44 <oleonard> C'mon stragglers
14:05:41 <ashimema> #topic Announcements
14:05:57 <magnuse> #info Magnus Enger. Libriotech, Norway
14:06:21 <ashimema> #info The 19.11 release happened, all be it a little late. Thanks go out to Mason for stepping in and doing the packaging at the last minute.
14:06:30 <kidclamp> #info Nick Clemens, BYWater Solutions
14:06:57 <magnuse> mtj++
14:06:58 <ashimema> #info 19.11, 19.05.x and 18.11.x releases all included security patches this recent release
14:07:01 <oleonard> ashimema++
14:07:04 <oleonard> mtj++
14:07:11 <ashimema> community++
14:07:16 <ashimema> it's a team effort
14:07:50 <ashimema> as our lone nz representative this afternoon.. any kohacon updates to pass along davidnind ?
14:08:09 * ashimema is always impressed you make the meetings at these crazy times
14:08:15 <davidnind> #info Extended closing date for  Kohacon20 proposals for talks is 13 December
14:08:30 <ashimema> :)
14:08:38 <ashimema> glad you do.. I'd totally forgotten that one
14:08:47 <davidnind> :)
14:09:05 <ashimema> I think we can move on
14:09:06 <ashimema> #topic Update on releases
14:09:29 <ashimema> #topic 20.05 (next release)
14:10:01 <ashimema> #info 19.11 have been branched and master is now the working version for the next feature release, 20.05
14:11:09 <ashimema> #info As is the pattern, we will be sticking to bugfixes only up until the end of the month, but then I hope to start pushing enhancements early January, focusing on the more experimental one's first to give us a large a section of the release cycle to fix any subsequent bugs before release.
14:11:53 <ashimema> #info `fail fast` and `experiment and stabalise`
14:11:54 <Joubu> which ones do you have in mind?
14:12:21 <ashimema> I need to go through the list, but I'm open to suggestions ;)
14:12:37 <oleonard> Bug 15522?
14:12:37 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , New interface for revamped circulation rules
14:12:38 <Joubu> you have my suggestions already ;)
14:12:38 <ashimema> architectural ones are up there, mojolicious too
14:12:55 <ashimema> yup, that's on my list oleonard
14:13:32 <caroline_catlady> #info Caroline Cyr La Rose, inlibro
14:13:37 <ashimema> I hope to send out a mail over xmas asking people to line up their ducks for January pushes... setting out some bugs I hope to focus on and setting some rough deadlines to see them moving.
14:13:44 <caroline_catlady> [off] sorry I'm late
14:14:38 <ashimema> we don't have any rmaints? present do we :(
14:14:43 <oleonard> [off] Gotta be careful with those ducks, people are trigger-happy around here
14:14:57 <davidnind> #info koha-US is planning an online conference (Koha-a-thon) for 24 April, call for talks closes 10 January
14:15:02 <ashimema> #info Rmaints are tentatively starting to push bugs to their respective branches.
14:15:09 <davidnind> #info Details for the Koha-a-thon https://lists.katipo.co.nz/pipermail/koha/2019-December/053991.html
14:15:56 <ashimema> thanks david.
14:16:08 <davidnind> #info The dates for the BibLibre Koha Hackfest in Marseille are 23-27 March 2020
14:16:09 <Joubu> ha yes, paul_p annonced the hackfest on the list
14:16:18 <Joubu> heh, that!
14:16:22 <ashimema> hackfest is in the community calendar :)
14:16:29 <ashimema> shall I add some of the other events?
14:16:41 <Joubu> yup
14:17:01 <jzairo> some more information for koha-US and the kohathon (they changed the name) to make it easier https://bywatersolutions.com/news/kohathon-call-for-proposals
14:19:01 <ashimema> added it to the community calendar
14:19:14 <ashimema> thanks jzairo for the update
14:19:24 <jzairo> :)
14:19:38 <ashimema> ok.. onto the next topic
14:20:06 <ashimema> #topic Any Other Business
14:20:20 <ashimema> #topic Proposal to try rocket.chat as an alternative/compliment of IRC
14:20:27 <davidnind> #info the 3rd Koha Pakistan International Conference is 16-18 April 2020 http://2020.kohapakistan.org/
14:20:42 <davidnind> (sorry, a bit slow!)
14:21:06 <tcohen> hola
14:21:09 <tcohen> sorry
14:21:50 <ashimema> #info I've discussed with a few people the prospect of adding an alternative to IRC as it seems to be a barrier to entry for some.
14:22:30 <Joubu> source? :)
14:23:49 <ashimema> #info After a little research I'm proposing the creation of a rocket.chat server (I'll try to take on setting one up for a trial) and having it bridge to the existing IRC room.
14:23:51 <ashimema> sources.. our customers, bywater customers, various developers I've spoken to
14:24:31 <Joubu> they said that IRC is a barrier to entry?
14:24:48 <ashimema> I'm interested in hearing opinions in this public forum
14:24:53 <oleonard> I agree that IRC is a barrier to entry
14:25:20 <oleonard> I think rocket.chat looks very interesting
14:25:37 <ashimema> #info After a little research I'm proposing the creation of a rocket.chat server (I'll try to take on setting one up for a trial) and having it bridge to the existing IRC room.
14:25:37 <ashimema> sources.. our customers, bywater customers, various developers I've spoken to
14:25:38 <ashimema> I'm interested in hearing opinions in this public forum
14:25:38 <tcohen> Joubu: http://cbs-news.us/2019/12/11/Koha-users-have-difficulties-with-IRC/9S29oYSB1c2VycyBoYXZlIGRpZmZpY3VsdGllcyB3aXRoIElSQw==.Q29uc3VsdGVkIHBvdGVudGlhbCB1c2VycyBoYXZlIGV4cHJlc3NlZCBJUkMgaXMgYSBiYXJyaWVyLg==.aHR0cHM6Ly9saXZlLnN0YXRpY2ZsaWNrci5jb20vMTgxMi80MjA2MjUzNjU4MF9hYTQ3ZDBlOWQ2X3ouanBn
14:26:11 <caroline_catlady> tcohen: lol! XD
14:26:17 <caroline_catlady> #link https://rocket.chat/
14:26:22 <davidnind> I think Catalyst chose it for use internally - post from 2016 https://www.catalyst.net.nz/blog/bleeding-edge-chat
14:27:08 <davidnind> not sure whether things have changed..
14:27:15 <oleonard> I'll vote to approve any chat solution which will tell me the weather
14:27:23 <ashimema> we've already lost a number of developers from the irc space to slack.. just saying ;)
14:27:43 <davidnind> yeah weather!
14:28:10 <caroline_catlady> would bots still work?
14:28:26 <Joubu> @wunder Madrid
14:28:26 <caroline_catlady> I would miss wahanui saying random things
14:28:26 <huginn> Joubu: Error: Failed to load Wunderground API. Check the logs for more information.
14:28:54 <ashimema> that's the main reason i want to bridge it to the irc channel, at least in the short term.. so we can continue to use the existing bots
14:28:55 <Joubu> stupid bots, change bots
14:29:38 <ashimema> I certainly don't want to cut off existing workflows.. just add an option for less technically adept people
14:29:43 <Joubu> ashimema: lost developers? who?
14:29:56 <Joubu> tcohen has a link for that I guess
14:29:58 <Joubu> :)
14:30:08 <ashimema> irc isn't 'that' technical to be honest.. but it looks outdated to many and doesn't support allot of the modern communication expectations.
14:30:09 <tcohen> I do
14:30:30 <ashimema> well.. I often poke people who are missing via slack to get them to come here.. khall is a good example
14:30:38 <caroline_catlady> gifs ftw ;)
14:30:39 <Joubu> I am not against the idea, but the reasons are not the good ones in my opinion
14:30:57 <Joubu> khall: you are here, right?
14:31:02 <ashimema> ok.. what would be a good reason then Joubu
14:31:11 <oleonard> I think there's no reason at all not to give rocket.chat a try if ashimema is willing to spend some time on it
14:31:35 <ashimema> I can't see a better reason than to enable more people to join the community.
14:31:37 <ashimema> but hey
14:31:39 <oleonard> The rocket.chat solution is designed specifically to continue IRC support
14:31:41 <Joubu> paste/videoconf/code sharing in the same app
14:31:46 <Joubu> for instance
14:32:03 <Joubu> but "too complicate" and "we lost developers" sound wrong to me
14:32:17 <ashimema> and those are all the things I mean by 'but it looks outdated to many and doesn't support allot of the modern communication expectations.'
14:32:22 <ashimema> rocket.chat support all of those
14:33:21 <oleonard> Joubu: What is your argument for not trying rocket.chat?
14:33:27 <ashimema> moving on.. there seems to be no hard objections so I'll spend a little time getting something setup for a trial.
14:33:52 <Joubu> oleonard: I never said that. I am not the one who is trying to convince people
14:34:08 <Joubu> ashimema: what's the proposal then?
14:34:30 <Joubu> I mean, who, when, where?
14:34:38 <oleonard> Joubu: You've offered only arguments against the idea, none in support of the status quo
14:34:40 <ashimema> #action ashimema is going to investigate setting up a bridged rocket.chat server to allow a more modern form of instance communication for the community.
14:34:52 <Joubu> I guess we will want to host it somewhere
14:35:41 <ashimema> to start with I was going to personally host it and see what sort of adoption it gets
14:35:52 <magnuse> if ptfse can't host it i think libriotech can (on linode)
14:35:55 <ashimema> I'm suggesting a lightweight trial of it to start with
14:36:34 <Joubu> oleonard: I did not say I was against the idea, sorry if it is what has been understood
14:37:00 <Joubu> not*
14:37:03 <ashimema> OK.. I think we can probably move onto my next controvertial topic ;)
14:37:21 <ashimema> oh.. actually, the next one isn't controvertial
14:37:39 <Joubu> yes it is, you will need to setup a date
14:37:39 <ashimema> #topic Shall we bring back an internation bug squashing day?
14:37:48 <ashimema> haha..
14:37:59 <ashimema> who used to take on organising them.. I don't remember?
14:38:19 <magnuse> i did, back in the day
14:38:19 <ashimema> but.. I'd like to suggest we get one in the diary and publicise it..
14:38:51 <ashimema> I'm all about trying to get more people looking at bugzilla and helping each other move bugs on at the moment.. such a day seems like a good idea
14:39:03 <magnuse> yup, worth a try
14:40:02 <ashimema> I'm thinking early to mid january for a rough date.. once xmas is someone out of the way but whilst people are hopefully fresh and rested still from the holidays
14:40:15 <davidnind> https://wiki.koha-community.org/wiki/Category:Global_bug_squashing_days
14:40:16 <ashimema> s/someone/somewhat
14:40:31 <davidnind> excellent idea!
14:40:41 <oleonard> When is Catalyst Academy? Anyone know?
14:40:58 * ashimema was about to ask that next :)
14:41:06 <davidnind> is in January
14:41:15 <cait> sorry for missing the meeting... was in another lengthy meeting
14:41:42 <ashimema> magnuse do you have any recollection as to whether end of week or beggining generally got mroe attendance?
14:41:50 <ashimema> we're still going cait
14:42:11 <ashimema> just working out the logistics of organising a bug squashing day
14:42:37 <davidnind> 6-17th January, last week is the project week where they work on projects https://www.catalyst.net.nz/open-source-academy
14:42:47 <ashimema> currently I have 10th Jan in my head as a proposal
14:42:51 <Joubu> Project week: 14-17 January 2020
14:42:56 <Joubu> https://wiki.koha-community.org/wiki/Catalyst_Academy
14:43:04 <cait> ah nice
14:43:06 <cait> i like bug squashing :)
14:43:13 <ashimema> aha..
14:43:22 <ashimema> perhaps delay to 17 or 16th perhaps then...
14:43:34 <cait> could we have a december bug sqhash?
14:43:41 <ashimema> that would be a nice way to make sure we pick off at least a few academy bugs
14:43:46 <cait> as we are focusing on bugs at the moment until beginning of january
14:43:57 <cait> we can put little christmas hats on the bugs...
14:44:07 <ashimema> lol
14:44:31 <ashimema> I'm thinking I'll have a triaging session during december ready to get action in a squashing day early Jan
14:44:59 <ashimema> my gut says allot of people are already winding down for xmas and it's a bit late to organise a gbsd this month
14:45:01 <magnuse> ashimema: nah, can't say i do
14:45:05 <ashimema> I may be wrong.. let me know :)
14:45:39 <magnuse> yeah, i'd say january is better
14:45:46 * oleonard settling in for a long winter's nap
14:45:51 <magnuse> hehe
14:46:11 <ashimema> 17th suit people then?
14:46:58 <tcohen> \o/
14:46:59 <magnuse> +1
14:47:00 <ashimema> it's a friday to correspond with inLibros' friday community slot (and I think Bywater has a similar Friday for community stuff slot)
14:47:01 <magnuse> sorry, gotta run
14:47:12 <davidnind> +1
14:47:21 <caroline_catlady> I will make sure our staff is on it
14:47:22 * ashimema tihnks we should volunteer magnuse to organise it as he's running away now..
14:47:33 <ashimema> ok.. I'll send out a mail and start the process
14:47:55 <ashimema> #action ashimema to send out a global bug squashing day announcement email
14:48:08 <oleonard> [off] Y'all can give me a day-early birthday present and sign off on all my patches
14:48:12 <ashimema> #info Next global bug squashing day to take place 17th January
14:48:17 <ashimema> hehe
14:48:20 <davidnind> there is a template for the wiki as well
14:48:29 <ashimema> brill
14:48:39 <magnuse> ashimema: i'll do it if noone else wants to have a go
14:48:44 <cait> ok with january too :)
14:48:45 <ashimema> moving onto my last controvertial topic..
14:49:02 <ashimema> #topic Are we happy with the existing release process and cycle?
14:49:16 <ashimema> Broad question I wanted to raise to get wider audience
14:49:57 <ashimema> lots of chatter on WhatsApp and in Twitter land after verious acquisitions having taking place this month and the ever increasing focus on Folio
14:50:30 <ashimema> do we think as a community we are remaining competative or do we need to make any changes to try and continue to be
14:50:40 <oleonard> I'm concerned that the `fail fast, experiment and stabilize` process won't have time enough for the stabilize step if we speed things up
14:50:52 <ashimema> I have my own concerns which I'm sure people have heard before
14:51:23 <ashimema> well.. I'm not really envisaging much change this cycle really.. it's more of a wider question and setting up idea's and plans for subsquent cycles
14:52:30 <ashimema> Ubuntu for example has a flip/flop cycle which spans 12 months.. their two releases a year have an experimental 6 months followed by a stabalisation 6 months
14:52:50 <caroline_catlady> I know here (and I think in most support companies?) we only upgrade every 2 versions (for us it's every .05)
14:53:30 <ashimema> mm.. so I think we still need some sort of long term support idea
14:53:39 <cait> we are on the .11
14:53:42 <talljoy> we upgrade every release on the point .06 usually
14:53:44 <ashimema> but do we need to support 3 versions simultaneosly?
14:53:46 <cait> or at least at the moment target those
14:54:03 <ashimema> it's allot to ask to find 3 rmaints every 6  months
14:54:27 <cait> i think I could imagine an LTS version
14:54:39 <cait> but having one version for 1.5 years is good
14:54:42 <ashimema> and.. are the .05/.06 releases actually stable if the majority of users aren't looking at a release until that point..
14:54:51 <ashimema> i.e are we not just shifting the bugs down
14:55:26 <wizzyrea> #info liz rea
14:56:01 * ashimema isn't being deliberately obtuse.. I just want to get opinions
14:56:25 <davidnind> have some sort of survey - get the views of support providers, self-hosters, etc
14:56:27 <talljoy> #info Joy Nelson
14:56:39 <caroline_catlady> I'm just wondering what would be the repercussions of changing the cuycle
14:56:39 <ashimema> I've worked in a few different cycles over the years and they all have their own benefits and problems
14:56:52 <talljoy> most bugs are fixed in .03 and .04 of every release.  but i'm not sure when they are actually found to be included in those stable point releases
14:57:08 <oleonard> davidnind++
14:57:09 * talljoy has graphs
14:57:10 <davidnind> tricky bit might be the actual questions to ask
14:57:21 <cait> talljoy: can you share? it sounds interesting
14:57:28 <ashimema> be interested in seeing those graphs talljoy
14:57:34 <cait> I have a feeling that our latest 2 have been a bit ... less stable
14:57:35 <talljoy> i can clean up a bit and send on the list.  yes!
14:57:45 <ashimema> yeah.. hense the open floor here.. so I have some help coming up with questions ;)
14:57:53 <talljoy> i wanted to dig a big deeper if i can and may need khall to help with the pulling data from bz
14:58:12 <cait> talljoy++ thx!
14:58:19 <ashimema> I have stats for numbers of bugs fixed at various points in cycles.. the general trend I've spotted is that bugs are getting reported later
14:58:32 <cait> we have some early adopters
14:58:40 <talljoy> do you have data on who is reporting those bugs ashimema ?
14:58:44 <ashimema> also.. the gap between being reported and being fixed varies allot
14:58:50 <cait> but tbh we sit it out pretty long too - preparation takes a while as well, as we have to write up Gemran resoruces etc. too
14:59:02 <ashimema> not in a particularly meaningful format yet no..
14:59:13 <ashimema> would be happy to collaborate on picking out some stats..
14:59:26 <talljoy> we have played with the idea of getting 'really early' adopters to help flush bugs.  i.e. roll a 20.01 and get bugs fixed in the 20.05
14:59:36 <talljoy> that's just us internally 'spit-balling'
14:59:43 <ashimema> we certainly have two types of customer here.. those who want their new feature asap..
14:59:52 <talljoy> <and paid for it too>
14:59:55 <ashimema> and those who want stability over functionality and want to wait 2 years
15:00:01 <cait> yeah, i think the might be the motivation to go on a new verson - there are features needed/wanted
15:00:25 <cait> I think there might be benefits of having a regular LTS, but also needs a maintainer
15:00:51 <cait> talljoy: are you doing 1 or 2 updates a year?
15:00:56 <talljoy> 2
15:01:03 <cait> :)
15:01:08 <talljoy> our goal is to make upgrades a 'non issue' for our libraries
15:01:16 <talljoy> not always successful, but we try!
15:01:23 <ashimema> so.. the best proposal I've spitballed here is to have two tracks.. a LTS which gets a feature update once every 18 months or something like that.. and is maintained with bugfixes only throughout it's life
15:01:49 <ashimema> and a continious integration track which is release monthly and contains bugfixes and new feature as soon as they're ready
15:01:59 <cait> hm
15:01:59 <talljoy> CI for the win!
15:02:07 <cait> wonder if there is some middle gruond to be found
15:02:08 <ashimema> CI + CD
15:02:16 <cait> between those 2
15:02:32 <ashimema> CD is what all the 'big boys' are moving too.. I fear if we don't offer it we will loose out.
15:02:34 <talljoy> stay a couple of tracks back but a couple ahead of LTS?
15:02:37 <cait> maybe longer support but a big one every year instead of 18 months
15:03:06 <ashimema> CI = Continious Integration (we do this with Jenkins).. CD = Continious Deployment (monthly releases would be close to this)
15:03:26 <talljoy> yearly does make a bit more sense from a library's perspective.  "we upgrade every year in August" for example
15:03:27 <cait> i think biblibre and us target once a year for update, so that would be nice to maintain, monthly with translations and everything woudl be too much
15:03:53 <talljoy> We are moving towards CD as much as we can.
15:04:10 <talljoy> that's what the U.S. market is about now.
15:04:41 <ashimema> how do you do CD if you only upgrade once a year?
15:04:55 <talljoy> we do 2x a year with monthly point release upgrades
15:05:09 <talljoy> we are upgrading continually, but it is a logistical problem for us.
15:05:15 <eythian> CD is not monthly, CD is more like every commit gets deployed
15:05:19 <talljoy> right
15:05:23 <ashimema> yeah, it isn't easy
15:05:27 <talljoy> that's more what we're aiming for.
15:05:30 <cait> bywater is the biggest player right now - I think it makes sense, but for the smaller ones might be harder to keep that pace
15:05:33 <talljoy> i mean, aim high, right?
15:05:34 <ashimema> indeed.. CD is exactly what eythian said..
15:05:37 <cait> especially if you don't have in-house devs for hotfixing
15:05:49 <ashimema> I don't think we're ready for that yet.. but I'd love to see it happen
15:05:51 <talljoy> true.
15:05:55 <cait> it woudl never work for translations
15:05:58 <caroline_catlady> + docs and translations
15:06:02 <cait> yep
15:06:04 <talljoy> cait i like your yearly LTS idea instead of 18 months
15:06:09 <eythian> (having monthly/nightly use-at-your-own-risk auto snapshot releases could be an easy approach too.)
15:06:12 <ashimema> but I don think monthly release could be possible
15:06:25 <ashimema> we already do such a scheme for rmaint
15:06:44 <ashimema> well.. we do have the nightly build bot which builds package nightly
15:06:53 <ashimema> so you 'can' do watch that
15:07:00 <Joubu> I don't think our codebase is robust enough to provide a (relatively) master-based stable release every month
15:07:19 <Joubu> Or I did not get what you are talking about
15:07:24 <talljoy> we are not yet brave enough to put our libraries on master.  so the reality is that we are expecting a modified CI/CD pipeline
15:07:38 <ashimema> it may not be.. but shouldn't we be asking the question of "why isn't it" ;)
15:07:43 <talljoy> for us internally.  We will adapt to what the community does.  This is just input about what is going on in our heads
15:08:51 <ashimema> I believe if we set out a goal to get there, we could improve out practice over a few cycle to go from 6 monthly feature releases down to 3 monthly, then monthly perhaps
15:09:03 <caroline_catlady> we just went through the upgrades with our clients and while it was not nightmarish, there were still bugs in 19.05.04
15:09:07 <ashimema> it's just about getting better at spotting and fixing bugs quicker
15:09:18 <talljoy> yes.
15:09:23 <kidclamp> yeah, smaller bites, less bugs, found faster
15:09:25 <caroline_catlady> and the preparation is long too, I can't imagine doing this more often
15:09:44 <talljoy> that is what our educators say also!
15:09:44 <ashimema> I have an issue with code going in, then often not getting used in real life for nearly 18 months and then trying to remember what I was doing all that time ago to fix a bug in it is really hard
15:09:56 <kidclamp> we have been discussing that with trainers to figure out a different model
15:10:08 <oleonard> That's a good point ashimema
15:10:11 <kellym> yes @caroline_catlady, it would get a bit dicey!
15:10:30 <talljoy> ashimema, we also have that issue.  along with devs that folks pay for that they don't see for 6-12 months
15:10:32 <ashimema> totally.. I'm a dev.... we deffo need to get opinions from users, trainers and inf people
15:10:46 <ashimema> yup
15:11:02 <kellym> but good question, how far in advance would release notes come prior to doing the upgrade ?
15:11:15 <kidclamp> for devs too I like the idea of not having a 6 month window of missing getting a dev in
15:11:19 <ashimema> well.. it sounds like we certianly have the apetite to consider alternatives at least
15:11:22 <TGoat> don't forget the RM's to whom this will all fall on
15:11:31 <ashimema> we just need to work out what those are
15:12:06 <ashimema> it doesn't really all fall on the RM..
15:12:32 <ashimema> we still have a SO/QA process.. and releaseing is pretty streamlined already in reality
15:12:36 <davidnind> kellym: has ideas about release notes vs what's new
15:12:43 <ashimema> we could do better on the packaging front I think
15:12:57 <ashimema> translation and documentation need thought though..
15:13:18 <caroline_catlady> release notes, what's new and what you have to change
15:13:23 <ashimema> but then.. perhaps they would also benefit from a smaller amount to do each month rather than a mamoth task once every 6 months
15:13:35 <caroline_catlady> like the fines reports for 19.05
15:13:53 <davidnind> kellym: release notes are continuous https://gitlab.com/koha-community/koha-release-notes
15:14:04 <ashimema> indeed kellym
15:15:01 <cait> please keep in mind that not all people are using Koha in English
15:15:05 <cait> we need to put more work in
15:15:10 <caroline_catlady> database changes are all fine and good, but they f up a bunch of stuff when we upgrade (sorry for the big words I just spent a whole day redoing circ rules for 20+ clients)
15:15:11 <kellym> yes, so would it be beneficial to produce a what’s new outside of a release notes doc? showing only features?
15:15:22 <cait> we also have things specific to our environment that need to be tested... we need an option for slower updates too
15:15:31 <talljoy> good point cait.  bag mentioned this in our meeting yesterday as an important consideration
15:15:47 <cait> we need to make our own documentation etc. it's a big task for smaller teams
15:15:53 <cait> and we don#t have educators... we are all in one people
15:15:54 <TGoat> just thinking..  assuming that our developer numbers stay strong and we have a willing pool of RM's
15:16:24 <wizzyrea> I really think a feature flagging function in Koha would be great
15:16:37 <ashimema> experienced dev numbers aren't all that strong at the moment.. or rather volunteers to do the rmaint roles aren't at least
15:16:38 <caroline_catlady> I agree cait we are two who do tests and docs here and it's a lot
15:16:44 <ashimema> that's part of what braught me to this set of questions
15:16:55 <davidnind> kellym: would like to do that - what's new summary, details in documentation portal/manual
15:17:04 <cait> in theory we are 4... but we also do migrations /project work all the time
15:17:14 * wizzyrea whispers "feature flagging in the interface..."
15:17:24 <caroline_catlady> davidnind++
15:17:29 <kidclamp> so I think this is good discussion, but maybe we need to think a bit and come back with a clearer idea of the issue we are solving
15:17:31 <ashimema> I've been slowly working on a changelog type approach davidnind kellym
15:17:35 <wizzyrea> like slaaack does with the little present
15:17:40 <ashimema> our release notes aren't all that great
15:17:53 <kidclamp> like collect thoughts on wiki and in the mailing list?
15:17:58 <ashimema> feature flagging is good
15:17:59 <talljoy> it does feel like we need a bit more clarification on the needs of community/libraries/dev before deciding on what some specifics are
15:18:03 <cait> we pick and translate from them, they are mostly useful for people like us i guess
15:18:12 <cait> we pick what our libraries use
15:18:45 <cait> not every library loves CD... it could also be a selling poit to offer different clearly defined routs
15:18:47 <ashimema> How about I try to summarise what we've said today on a wiki page and invite comment via the lists
15:18:50 <cait> not force people to do updates often
15:18:58 <cait> or not get bugs fixed/security fixes
15:19:02 <ashimema> this has served it's purpose.. it's got people thinking and talking about it :)
15:19:06 <kellym> yes @davidnind highlight and direct to more information.  I love @wizzyrea idea- even an added note on the news tools could be useful.
15:19:12 <davidnind> balance between a cloud like service controlled by one vendor with continuous deployment  vs multiple providers, supported versions and stability for clients/libraries
15:19:20 <georgew> I was late to the meeting and then I've had to jump in and out while dealing with some other issues, but I think libraries would definitely want some input on these release issues
15:19:21 <wizzyrea> ubuntu does this well, with LTS and "I like punishment" releases
15:19:22 <cait> kellym: translation issues :(
15:19:52 <kellym> ah yes!  We did talk about that earlier! @cait
15:20:04 <cait> maybe solvable, but to keep in mind
15:20:07 <ashimema> wizzyrea.. it's the Ubuntu LTS + Punishment model I'm really trying to suggest ;)
15:20:11 <georgew> koha-US is having a meeting today and I'll bring this issue up and see if I can get some library peopel to read the minutes so they know what's going on
15:20:11 <talljoy> ashimema i would like a synopsis and some suggested steps forward.
15:20:14 <wizzyrea> I figured :)
15:20:33 <ashimema> ok
15:20:54 <oleonard> [off] georgew I don't see the meeting on the calendar
15:21:13 <ashimema> #action ashimema will summarise the release cycle discussion on a wiki page and invite people to contribute/comment via as many comms methods as he can muster.
15:22:03 <talljoy> ashimema++
15:22:07 <kellym> @ashimema++
15:22:07 <huginn> kellym: downloading the Perl source
15:22:20 <ashimema> thanks everyone.. a really good discussion I feel
15:22:38 <ashimema> right.. last topic then
15:22:53 <ashimema> #topic Time of next meeting
15:23:12 <ashimema> the later time but same date next month?
15:23:32 <ashimema> does the 8th work for people?
15:23:53 <davidnind> +1
15:23:54 <talljoy> yes
15:23:57 <talljoy> +1
15:23:58 <oleonard> +1
15:24:27 <caroline_catlady> ok
15:24:29 <cait> +1
15:24:33 <ashimema> davidnind.. remind me what time works well for NZ
15:25:29 <davidnind> daytime..:)
15:25:36 <ashimema> 20:00 UTC?
15:25:55 <ashimema> that's 09::00 Wellington and 15:00 New York
15:26:10 * ashimema isn't sure why he picked new york.. america spans too many time zones ;)
15:26:19 <davidnind> 20:00 (9 am is good), but not sure how ot suits others
15:26:54 <caroline_catlady> 20 UTC is good for east coast
15:26:54 <oleonard> '15:00 Athens, OH' is how most Americans refer to it I think
15:27:06 <ashimema> #info Next meeting: 8 January 2020, 20 UTC
15:27:13 <ashimema> brill.. we have a winner :)
15:27:17 <ashimema> #endmeeting