14:05:38 <Joubu> #startmeeting General IRC meeting 6 March 2019
14:05:38 <huginn`> Meeting started Wed Mar  6 14:05:38 2019 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:38 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:38 <huginn`> The meeting name has been set to 'general_irc_meeting_6_march_2019'
14:05:41 <ashimema> haha.. easily done
14:05:46 <huginn`> kidclamp: Error: Can't start another meeting, one is in progress.
14:05:58 <Joubu> #topic Introductions
14:06:01 * kidclamp let's Joubu drive :-)
14:06:03 <ashimema> #info Martin Renvoize, PTFS Europe
14:06:12 <kidclamp> #info Nick Clemens, BWS
14:06:13 <koha-jenkins> Project Koha_Master_D9 build #671: STILL UNSTABLE in 27 min: https://jenkins.koha-community.org/job/Koha_Master_D9/671/
14:06:14 <josef_moravec> #info Josef Moravec, Municipal Library Ústí nad Orlicí, Czech Republic
14:06:17 <Joubu> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_06_March_2019
14:06:19 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
14:06:21 <Joubu> #info Jonathan Druart
14:06:21 <cc_> #info Colin Campbell, PTFS Europe
14:06:33 <cait> #info Katrin Fischer, BSZ, Germany
14:06:50 <Joubu> #chair cait kidclamp ashimema
14:06:50 <huginn`> Current chairs: Joubu ashimema cait kidclamp
14:06:53 <calire> #info Claire Gravely, BSZ, Germany
14:06:53 <davidnind> #info David Nind, Wellington, New Zealand
14:07:14 <thd> #info Thomas Dukleth, Agogme, New York City
14:07:20 <Charles_Quain> #info Charles Quain Interleaf Technology Dublin
14:07:43 <Joubu> #topic Announcements
14:07:49 <Joubu> Anyone have something?
14:08:05 <magnuse> #info Magnus Enger, Libriotech, Norway
14:08:18 <fridolin> #info Fridolin Somers , Biblibre, France
14:08:37 <kidclamp> Koha New England Summit friday: https://bywatersolutions.com/news/2019-new-england-koha-summit
14:08:38 <ashimema> good turn out today
14:08:51 <cait> #info There will be a Koha user meeting at the German library congress in 2 weeks
14:09:34 <kidclamp> #info Koha New England Summit on Friday March 8th
14:09:38 <Joubu> cait: Is there an agenda?
14:09:38 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:09:40 <cait> #link http://www.professionalabstracts.com/bid2019/iplanner/#/session/30
14:10:02 <kidclamp> #link https://bywatersolutions.com/news/2019-new-england-koha-summit
14:10:10 <cait> #link http://lists.koha-community.org/pipermail/koha-de/2019-February/000194.html
14:10:12 <ashimema> cool
14:11:17 <Joubu> great, lot of things :)
14:11:27 <Joubu> moving on?
14:11:39 <koha-jenkins> Project Koha_Master_U18 build #162: STILL UNSTABLE in 31 min: https://jenkins.koha-community.org/job/Koha_Master_U18/162/
14:12:00 * kidclamp nods
14:12:01 <ashimema> go for it..
14:12:02 <Joubu> thanks jenkins, that's not a good announcement
14:12:06 <Joubu> #topic Update from the Release Manager (19.05)
14:12:13 <Joubu> kidclamp: your turn
14:12:45 <kidclamp> Pushing some things today - we (Joubu) is working on clearing the failures from 18925
14:12:56 <kidclamp> rental fees by time period is next target
14:13:03 <kidclamp> and working through the queue
14:13:11 <kidclamp> ES has made soem good progress, happy about that
14:13:22 <kidclamp> Manan needs some attention, please help there if possible
14:13:34 <kidclamp> s/Manan/Mana/
14:13:37 <Joubu> there was movements on the "fix calculation - 2" bug
14:14:01 <koha-jenkins> Project Koha_Master_D8 build #179: STILL UNSTABLE in 35 min: https://jenkins.koha-community.org/job/Koha_Master_D8/179/
14:14:01 <Joubu> I think we need more people involved in the fix/test process
14:14:10 <kidclamp> indeed, I will try to update rounding error 18736 as well
14:14:14 <Joubu> that sounds quite critical for stable releases
14:14:19 <cait> bug 18925
14:14:19 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18925 enhancement, P5 - low, ---, jonathan.druart, Pushed to Master , Move maxissueqty and maxonsiteissueqty to circulation_rules
14:14:32 <Joubu> how do we get the needed attention on Mana?
14:14:46 <josef_moravec> bug 18736
14:14:46 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18736 critical, P5 - low, ---, nick, Failed QA , Problems in order calculations (rounding errors)
14:15:01 <kidclamp> big issue is search results - not sure if problem is on Koha end or Mana end
14:15:23 <kidclamp> in general release does feel lie it is moving well
14:15:24 <Joubu> ping alex_a: Mana fixes are needed
14:15:41 <kidclamp> I have been very lax about requesting selenium tests, but I feel we are going to need mroe inthe future
14:16:02 * kidclamp coughs and looks at ashimema
14:16:06 <cait> Joubu: we threaten to remove it? ;)
14:16:09 <Joubu> there are more in the queue! :)
14:16:25 * ashimema is trying to find someone to run a "writing selenium tests" workshop at kohacon
14:16:27 <vfernandes> hi #koha
14:16:52 <khall> #info Kyle M Hall, ByWater Solutions
14:16:54 <kidclamp> Thanks to everyone for hard work and keeping QA queue coming my way :-)
14:16:57 <kidclamp> enough from me
14:16:59 <Joubu> ashimema: "writing useful and maintanable selenium tests" is much more tricky ;)
14:17:03 <josef_moravec> regarding mana search, see bug 22222, patch just added
14:17:03 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22222 major, P5 - low, ---, josef.moravec, Needs Signoff , Mana subscription search always returns all results
14:17:05 <alex_a> Joubu, bug #id ?
14:17:19 <ashimema> #info it would be great if anyone fancied volunteering to run a workshop focusing on how to write selenium tests (or writing a bunch of them as a team) at kohacon
14:17:26 <Joubu> alex_a: it's on the main Mana report, in comments or related bugs
14:17:30 <kidclamp> josef_moravec++
14:18:14 <alex_a> Joubu, think i'll need help
14:18:47 <Joubu> alex_a: let's see that after the meeting, we can help :)
14:18:48 <Joubu> #topic Updates from the Release Maintainers
14:18:55 <Joubu> rmaints?
14:18:55 <wahanui> i think rmaints is ashimema and fridolin are the rmaints
14:19:03 <Joubu> rmaints?
14:19:03 <wahanui> rmaints is probably ashimema and fridolin are the rmaints
14:19:08 <fridolin> yep
14:19:10 <Joubu> well, I thought I updated you
14:19:11 <cait> the bugs are more urgent, but I'd also like us to revisit how to register - right now it asks for a person, i think it would be better if it asked for an institution
14:19:11 <kidclamp> jessem
14:19:14 <cait> (mana)
14:19:23 <fridolin> we add a quick second release v17.11.16
14:19:42 <cait> I filed a bug for that - 22210
14:19:50 <cait> sorry for being too late
14:19:57 <ashimema> 18.11 is running smoothly, last release was clean
14:20:00 <fridolin> because of major bug 21986 reverted
14:20:00 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21986 major, P5 - low, ---, jonathan.druart, Pushed to Stable , Quotation marks are wrongly escaped in several places
14:20:15 <ashimema> #info 18.11 is ticking along nicely
14:20:50 <Joubu> fridolin: not released yet, or I missed it?
14:21:01 <fridolin> tag is pushed
14:21:06 <ashimema> #info 18.11 was unaffected by a bug instroduced by bug 21986
14:21:07 <fridolin> packages are done
14:21:39 <ashimema> #info 18.05 and 17.11 both recieved a fast tracked release to resolve issues caused by bug 21986
14:21:53 <ashimema> I don't think I saw them announced
14:21:56 <Joubu> #info If you are using 18.05.08 or 18.05.09 you should update quickly to 18.05.10 that is going to be released very soon
14:22:07 <Joubu> hope I did not mess with the version numbers
14:22:37 <fridolin> same for 17.11.15 to 17.11.16
14:22:38 <Joubu> #info If you are using 17.11.14 or 17.11.15 you should update quickly to 17.11.16 that is going to be released very soon
14:22:40 <tcohen> 18.05.10 is already for upgrading
14:22:50 <tcohen> we upgraded last friday
14:23:18 <Joubu> should we add/update the news fields on the website?
14:23:54 <cait> hm links to latest release?
14:24:00 <Joubu> #action fridolin JesseM maybe add an update on the website?
14:24:02 <Joubu> #topic Updates from the QA team
14:24:03 <ashimema> I think we should.. and we aught to have the fix anounced on the lists
14:24:04 <davidnind> I assume there will be the normal announcement?
14:24:26 <fridolin> yep i'll do an anconcement
14:24:28 <ashimema> I think we've done all the work and made the releases.. just not done the anouncements
14:24:33 <ashimema> fridolin: JesseM does that sound about right?
14:24:35 <ashimema> brill
14:24:40 <Joubu> so nobody can know :)
14:25:08 <fridolin> i think we can do a post on WP
14:25:14 <fridolin> no pb
14:25:31 <ashimema> brill
14:25:34 <cait> ml too please?
14:25:42 <cait> maybe reply to the other email
14:26:14 <fridolin> there is a mail "Critical bug fix to prevent data loss (Bug 22395)"
14:26:14 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22395 critical, P5 - low, ---, koha-bugs, RESOLVED FIXED, Data in 245 field (subfield a or b) will be deleted if it has Quotation Marks
14:26:34 <fridolin> i will reply on it
14:26:55 <Joubu> moving on?
14:26:59 <Joubu> qa_team?
14:26:59 <wahanui> i guess qa_team is cait alex_a jajm khall josef_moravec ashimema Joubu marcelr tcohen rangi
14:27:13 <cait> special thanks to the busy QA team members
14:27:35 <cait> queue is mostly under control, but it's a never-ending battle
14:27:52 * ashimema would like to thank josef_moravec in particular.. he's been great going through the ILL pile
14:27:57 <cait> #info queue is under control and moving, but as always work never ends
14:28:07 <cait> and the Elasticsearch pile
14:28:20 * ashimema will be taking up arms against the QA queue again soon.. needed a few days break after a busy month
14:28:29 <cait> the dashboard shows quite a few of major bugs with the numbers slowly rising, not all in qa queue yet
14:28:49 <cait> #info Please take a look at major bugs that await fixing, testing or QA (see dashboard)
14:29:54 <cait> Joubu and others, do you have to add something?
14:30:15 <Joubu> We need help on misc4dev and QA tools, there are PR waiting for testing
14:30:47 <Joubu> it's not a dev meeting actually :)
14:30:52 <Joubu> #topic KohaCon 2019 update
14:31:41 <ashimema> I'll take a look at the qa tools Joubu.. sorry I hadn't spotted the merge requests open
14:31:58 <Charles_Quain> good progress on Kohacon. speaking slots filling up nicely - 24 proposals so far
14:32:12 <Charles_Quain> 75 delegates have registered
14:32:42 <Charles_Quain> looking to have Ken Chad - Library Consultant as Keynote speaker.
14:33:27 <Charles_Quain> Martin Renvoize is looking to get an Elastic Search presence to do a long workshop
14:33:35 <ashimema> I'm still tying down people to run workshops.
14:34:36 <ashimema> We've got an ES guy booked pending confirmation from myself, and a couple of perl pros (dbic and mojolicious in particular)
14:35:06 <Joubu> names? :)
14:35:18 <ashimema> I'm still looking for volunteers to help run 'Hands on with X' sessions.. to encourage librarians to participate in the workshops as well as the conference
14:35:58 <oleonard> What kind of travel expenses are you covering for volunteers ;)
14:36:05 <ashimema> I need to firm up names.. but Matt Trout is a possible, Jan Henning Thorsen is another
14:36:21 <ashimema> Tim Bunce a third
14:36:28 <ashimema> all well respected perl 'gurus'
14:36:51 <Joubu> whaou, that would be awesome
14:37:15 <Charles_Quain> Sponsorship of volunteers will depend in part on donations received. Donation page went live last week, and "begging letter" send in latest Koha_l update.
14:37:20 <ashimema> I'd love to get Sabastian but he seems to always be busy ;)
14:37:51 <Charles_Quain> waiting for the cash to roll in :-)
14:37:59 * ashimema can't spell today.. it's Sebastian.. not Sab ;)
14:39:25 <ashimema> I think that covers it from me..
14:39:38 <ashimema> but do ask questions or catch me any time if you want to chat Kohacon
14:39:58 <Charles_Quain> ditto
14:40:03 <davidnind> let me know if you want anything posted on Twitter - have posted from updates and retweets
14:40:25 <Charles_Quain> do keep an eye on https://www.interleaf.ie/kohacon19/
14:40:52 <Charles_Quain> we are using #kohacon19 for twitter
14:40:57 <Joubu> #info Do keep an eye on the KohaCon19 website https://www.interleaf.ie/kohacon19/
14:41:09 <Joubu> #info and use #kohacon19 for social networks
14:41:19 <Joubu> #topic General
14:41:41 <Joubu> Another topic to add to this meeting?
14:41:51 <ashimema> found the ES guys name.. Philipp Krenn
14:42:38 <Joubu> I am gonna end the meeting then
14:42:52 <ashimema> +1
14:42:53 <Joubu> #topic Set time of next meeting
14:43:33 <Joubu> Next meeting: 4 April 2019, ? UTC
14:44:04 <Joubu> 14/21?
14:44:04 <wahanui> 0.666666666666667
14:44:11 <oleonard> Documentation meeting at 14:00 UTC that day
14:44:41 <Joubu> Same day or postpone to the week after?
14:44:48 <ashimema> shall we follow it?
14:45:04 <Joubu> 4 April 2019, 15 UTC?
14:45:27 <ashimema> anyone else got any preference
14:45:31 <davidnind> Day before?
14:45:44 <Joubu> better to stick on Wednesday I think
14:46:07 * ashimema is confused
14:46:12 <ashimema> 4th is thurs isn't it?
14:46:16 <oleonard> Yes
14:46:32 <Joubu> we are not in 2018 anymore, sorry :)
14:46:38 <calire> :D
14:46:40 <davidnind> depends which tz you are in
14:46:49 <oleonard> 3 April 2019, 14 UTC?
14:46:49 <ashimema> so 3 April 2019, 14 UTC
14:46:50 <Joubu> Next meeting: 3 April 2019, 14 UTC then?
14:46:55 <ashimema> that works for me
14:47:01 <oleonard> +1
14:47:02 <Charles_Quain> works for me
14:47:06 <davidnind> +1
14:47:09 <thd> Is that not the same TZ as now?
14:47:21 <Joubu> #info Next meeting: 3 April 2019, 14 UTC
14:47:27 <thd> Should we not be alternating meeting times?
14:48:56 <thd> ... I prefer this time but that is just me.
14:49:26 <Joubu> meetings on 21UTC are usually postponed because of the lack of attendees
14:49:50 <Joubu> would be 21 or 20?
14:50:11 <thd> I happily favour any consensus for 14 UTC or so if there is such.
14:50:49 <oleonard> Let's stick with 3 April 2019, 14 UTC
14:51:04 <Joubu> #info Next meeting: 3 April 2019, 14 UTC
14:51:10 <davidnind> +1
14:51:11 <Joubu> will be better to get KohaCon updates
14:51:17 <Joubu> #endmeeting