14:00:05 <Joubu> #startmeeting Development IRC meeting 12 August 2020
14:00:05 <huginn> Meeting started Wed Aug 12 14:00:05 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <huginn> The meeting name has been set to 'development_irc_meeting_12_august_2020'
14:00:10 <Joubu> #topic Introductions
14:00:15 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_12_August_2020
14:00:20 <Joubu> #info Jonathan Druart
14:00:24 <marcelr> #info Marcel de Rooy
14:00:53 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:01:00 <Joubu> hi marcelr, good to see you around :)
14:01:04 <marcelr> :)
14:01:25 <Joubu> rmaints?
14:01:25 <wahanui> lukeG, aleisha, and tuxayo, I SUMMON THEE!!
14:01:26 <Joubu> qa_team?
14:01:27 <wahanui> qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
14:01:55 <kidclamp> #info Nick Clemens
14:01:55 <wahanui> i guess #info Nick Clemens is working on testing the circulations rules rewrite
14:02:10 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:02:27 <Joubu> #topic Announcements
14:02:31 <Joubu> Anyone have something?
14:02:47 <ashimema> It's too hot ;)
14:02:52 <tcohen> SMTP is ready for testing
14:03:09 <ashimema> bug number and link tcohen ;)
14:03:20 <tcohen> bug 22343
14:03:20 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22343 new feature, P5 - low, ---, tomascohen, Needs Signoff , Add SMTP configuration options to Administration
14:03:22 <marcelr> smtp is around for a while now :)
14:03:26 <Joubu> # info bug 22343 is ready for testing (SMTP config)
14:03:52 <Joubu> anything else?
14:03:52 <wahanui> i guess anything else is necessarily going to be incremental.
14:04:13 <Joubu> hey oleonard!
14:04:13 <wahanui> oleonard is, like, happy for ashimema to write the release script
14:04:26 <oleonard> #info Owen Leonard, Athens County Public Library, Ohio, USA
14:04:29 <Joubu> oleonard: do you have something to announce?
14:04:57 <marcelr> any feedback on bug 24544
14:04:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24544 enhancement, P5 - low, ---, m.de.rooy, In Discussion , Add a script for inserting persistent identifiers to MARC records
14:05:14 <oleonard> I would like to announce that I'm still looking for testers of Bug 20168 :)
14:05:14 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20168 enhancement, P5 - low, ---, oleonard, Needs Signoff , Update of the OPAC bootstrap template to bootstrap v4
14:05:54 <Joubu> yes oleonard, that's a good one. I will get back to it
14:06:23 <Joubu> #info Marcel sent an email about 24544 on the dev ML - more feedback welcome!
14:06:35 <ashimema> generally it looked good oleonard.. I just didn't like the increase in default whitespace myself.. but that's likely a personal thing
14:06:55 <Joubu> #info Update from the Release manager (20.11)
14:07:06 <Joubu> Everything goes well, but I'd like to see more big things tested
14:07:27 <Joubu> we really need to focus *now* on those, to have them into master in the last couple of weeks
14:07:31 <Joubu> max 1 month!
14:07:51 <Joubu> you will make the RM happy if you track the RM priority list: https://frama.link/koha_bz_RM_priority
14:07:51 <marcelr> and discourage things too big
14:08:06 <Joubu> The main 3 things in the queue right now, that I really want for 20.11 are:
14:08:24 <Joubu> bug 20168
14:08:32 <Joubu> bug 22417
14:08:32 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22417 new feature, P5 - low, ---, jonathan.druart, Signed Off , Add a task queue
14:08:50 <Joubu> and, ofc bug 20271
14:08:50 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20271 enhancement, P1 - high, ---, jonathan.druart, Signed Off , Merge deleted biblio, biblioitems, biblio_metadata, and items tables
14:09:12 <Joubu> #info Focus must be on bug 20168, bug 22417 and bug 20271 for the next couple of weeks
14:09:30 <Joubu> #info Bookmark https://frama.link/koha_bz_RM_priority
14:09:31 <ashimema> +1
14:09:55 <Joubu> any questions about those 3?
14:10:14 <Joubu> any remarks, doubts?
14:10:20 <tcohen> they need to be pushed ASAP :-D
14:10:21 <Joubu> fears?
14:10:39 <marcelr> 20271 will have bugs..
14:10:48 <marcelr> so push fast
14:10:50 <Joubu> yes
14:10:55 <oleonard> tcohen: Some of them need patches ASAP then...
14:11:01 <tcohen> I didn't find bugs in it
14:11:11 <marcelr> when pushed we will :)
14:11:12 <Joubu> yes did not, but there will be
14:11:15 <tcohen> but yeah, statistically
14:11:35 <ashimema> Tomas and I have given 20271 a fairly solid set of testing.. I think really we now need to push it to 'force' wider testing by devs in daily use
14:11:38 <Joubu> so, actions maybe?
14:11:52 <Joubu> volunteers?
14:12:05 <ashimema> I have a few area's I'd like to play with in it.. like how quickly could we end up filling the table when using staged imports + rollbacks
14:12:15 <marcelr> if two qaers had a look, just push now ?
14:12:32 <Joubu> one more is always good
14:12:47 <ashimema> I think we should stick to the current table names.. drop the views and work on a basic report migration + alert displayed in the reports area to get people updating their reports
14:12:50 <Joubu> and I'd like to avoid bypass the QA step for such big changes
14:13:25 <ashimema> I was hopeing cait would look at the import/rollback/matching stuff as they use it allot for their union cat
14:14:42 <Joubu> "stick to the current tables", it's what we did, right?
14:14:51 <Joubu> about the report warnings there is bug 25921
14:14:51 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25921 enhancement, P5 - low, ---, koha-bugs, NEW , Merge biblio* and items table - Update reports
14:14:54 <Joubu> happy to collect ideas there
14:15:07 <ashimema> great Joubu :)
14:15:40 <Joubu> ok moving on if we don't get volunteering
14:15:44 <tcohen> what about bug 25260?
14:15:44 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25260 enhancement, P5 - low, ---, tomascohen, Needs Signoff , Add a new 'holds' table
14:15:44 <Joubu> #info Updates from the Release Maintainers
14:15:57 <tcohen> its similar-ish
14:16:05 <ashimema> I didn't find anything broken when working through the OPAC for bug 20168.. perhaps I should just set my SO on it at this point.. encourage the next step people
14:16:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20168 enhancement, P5 - low, ---, oleonard, Needs Signoff , Update of the OPAC bootstrap template to bootstrap v4
14:16:25 <Joubu> yes ashimema!
14:16:25 <wahanui> it has been said that ashimema is literally just writing up the release anouncement ;)
14:16:38 <marcelr> tcohen holds versus reserves ?
14:16:39 <Joubu> #action ashimema is going to add his stamp on 20168
14:17:17 <tcohen> with amoyano we decided to try introducing a new table, for the same merge process
14:17:35 <marcelr> ok it is a merge (title does not say that)
14:18:07 <Joubu> yes it's the same idea as 20271 but for the *reserves tables
14:19:00 <Joubu> no rmaints around, moving on
14:19:17 <Joubu> #topic Updates from the QA team
14:19:39 <marcelr> come back cait
14:20:01 <Joubu> NQA queue is quite ok with 78 bug reports (27 bugs)
14:20:02 <ashimema> The queue is fairly high.. 78 NQA
14:20:05 <Joubu> lol
14:20:16 <marcelr> <100
14:20:23 <Joubu> different point of views :)
14:20:27 <ashimema> less then 100 is good
14:20:36 <ashimema> but I'd love to see us at 50 ;)
14:20:36 <Joubu> less than 50 is better ;)
14:21:10 <ashimema> a fair number fof 'Majors' in the pipe
14:21:28 <Joubu> yes, good point
14:21:45 <ashimema> 5 majors waiting qa, 13 majors waiting for SO.. and loads without patches :(
14:22:04 <Joubu> #info There is a bunch a major waiting for SO or QA, would be good to prioritize them
14:22:11 <ashimema> If I can find a moment I will try to work through some of the ones missing patches
14:22:31 <Joubu> I did a bit the last 2 weeks, but some are very hard
14:22:39 <Joubu> or not that hard, but cannot be done easily
14:22:42 <ashimema> yeah..
14:22:43 <ashimema> agreed.. some are evil
14:23:05 <Joubu> #topic Actions from last meeting
14:23:17 <Joubu> #topic ashimema will get back to qa bug 15522
14:23:17 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, jonathan.druart, Signed Off , New interface for revamped circulation rules
14:23:30 <Joubu> do you want to update that ashimema?
14:24:28 <ashimema> #info I've left a note on the bug.. I'm generally happy with the way it all works from an end user perspective.. We had the PTFS-E educators have a chat with the ByWater educators to work through it.. they're all happy.
14:25:11 <ashimema> #info My next move is to start digging into the code.. I'd love to see a vue alternative submitted somewhere so we could do a comparison for code clarity between the two frameworks...
14:25:44 <ashimema> #info This bug shouldn't be blocked by a lack of decision on framework.. but also feels like if it gets pushed as is, it makes the implicit decision for us.
14:25:46 <Joubu> ashimema: I don't find your note
14:25:51 <Joubu> which comment?
14:26:15 <ashimema> 144
14:26:24 <ashimema> I confirm the branch works
14:26:25 <Joubu> ok
14:26:28 <Joubu> "Written feedback here to follow."
14:26:30 <Joubu> :)
14:26:34 <ashimema> and confirm that we've been testing it rigorously..
14:26:58 <ashimema> the guys here are writing up their notes.. but the general consensus was it's a big improvement.
14:27:17 <ashimema> tl:dr; still pushing hard on this one
14:27:28 <Joubu> do you think you will have time to review the code soon?
14:27:54 <ashimema> I hope I'll have some early next week
14:28:24 <Joubu> #action ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code
14:28:24 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, jonathan.druart, Signed Off , New interface for revamped circulation rules
14:28:25 <ashimema> though I have little experience with react.. I'm not sure we have anyone well placed to review that side :(
14:28:48 <Joubu> #topic ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
14:28:55 <Joubu> did you write that guideline?
14:29:03 <ashimema> Totally forgot about that one :(
14:29:12 <Joubu> #action ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
14:29:12 <marcelr> "postponed"
14:29:21 <Joubu> #topic tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page
14:29:23 <marcelr> thats what it is
14:30:08 <Joubu> not done
14:30:15 <Joubu> #action tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
14:30:34 <Joubu> #topic davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this
14:30:43 <Joubu> certainly too late for Dvic
14:30:46 <Joubu> oops David
14:31:00 <Joubu> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)
14:31:11 <Joubu> #topic General development discussion (trends, ideas, ...)
14:31:24 <Joubu> Something not on the agenda you would like to discuss?
14:32:19 <Joubu> 3, 2, 1?
14:32:20 <Joubu> #topic Set time of next meeting
14:33:14 <Joubu> #info Next meeting: 26 August 2020, 14 UTC
14:33:47 <Joubu> we did not get much attender in the last 19 UTC
14:34:07 <Joubu> so no sure if we should stick to 19 or 20 or 21?
14:35:10 <Joubu> #info If you prefer another hour of the meeting, like 19, 20, 21, please contact Joubu on IRC and we will modify it
14:35:16 <Joubu> #endmeeting