15:00:39 <Joubu> #startmeeting Development IRC meeting 16 December 2020
15:00:39 <huginn> Meeting started Wed Dec 16 15:00:39 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:39 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:39 <huginn> The meeting name has been set to 'development_irc_meeting_16_december_2020'
15:00:54 <Joubu> #topic Introductions
15:00:57 <Joubu> #info Jonathan
15:00:58 <ashimema> #info Martin Renvoize, PTFS Europe
15:01:00 <Joubu> #info Jonathan Druart
15:01:01 <Joubu> even
15:01:08 <kidclamp> #info Nick Clemens, ByWater Solutions
15:01:08 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_16_December_2020
15:01:14 <AndrewFH> #info Andrew Fuerste-Henry, ByWater Solutions
15:01:22 <tuxayo> #info tuxayo/Victor Grousset, France
15:01:36 <lukeG1> #info Lucas Gass, ByWater Solutions
15:01:54 <inlibro> blou: #info Philippe Blouin, Solutions inLibro
15:02:57 <Joubu> #topic Announcements
15:03:02 <Joubu> Anyone have something?
15:03:58 <Joubu> #topic Update from the Release Manager (21.05)
15:04:05 <Joubu> I have some stuffs to tell you
15:04:09 <Joubu> I am waiting one more week before pushing new enhancements to master.
15:04:17 <Joubu> It would be nice to have some patch ready for 20.11.01, have a look at the rel_21_05_candidate bz keyword - https://frama.link/koha_bz_rel_20_11_candidate
15:04:21 <Joubu> (There is a critical one)
15:04:48 <Joubu> #info Please follow https://frama.link/koha_bz_rel_20_11_candidate for the urgent things to backport into the next 20.11.x
15:05:07 <Joubu> Consider this list as the "most urgent" ones
15:05:18 <Joubu> We lost connection to the git server yesterday. Gitea got OOM killed. No idea what happened exactly but we created a swap file. Will see if it fixes the problem otherwise we will have to add more RAM.
15:05:53 <Joubu> #info A 4G swap file has been added to the Git server, hopefully it will fix OOM
15:06:12 <Joubu> We also dropped ES5 support in 20.11.00 AND 20.05.07 (not released yet) on bug 27252
15:06:12 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27252 major, P5 - low, ---, nick, ASSIGNED , ES5 no longer supported (since 20.11.00)
15:06:20 <Joubu> IMO we should revert it and not drop ES5 support in a minor release (ping AndrewFH).
15:06:40 <Joubu> wrong bug, its bug 27070
15:06:40 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27070 major, P5 - low, ---, nick, Pushed to oldstable , Elasticsearch - with Elasticsearch 6 searches failing unless all terms are in the same field
15:06:52 <Joubu> #info ES5 support dropped by bug 27070
15:07:06 <AndrewFH> agreed, that's a big change to accidentally sneak into a point release
15:07:07 <kidclamp> I think we should make that search option a syspref or something
15:07:18 <kidclamp> so that ES6 can work in 20.05
15:07:24 <Joubu> We should also add a warning on the about page for 20.11 (bug 27252), kidclamp can you deal with that?
15:07:29 <kidclamp> otherwise we have to wait until 20.11
15:07:30 <Joubu> or a pref, yes good idea
15:07:43 <Joubu> couldn't we guess the ES version instead?
15:07:51 <kidclamp> that's the other option
15:08:26 <Joubu> ok so either the warning on the about page for 20.11 and we announce we dropped ES5 support
15:08:36 <fridolin> #info Fridolin Somers, Biblibre, France
15:08:40 <fridolin> sorry im late
15:08:44 <Joubu> or, if possible, we guess the ES version and turn on the ft if ES6 is installed
15:08:53 <Joubu> that's certainly the best option actually
15:08:53 <AndrewFH> @kidclamp you wanna pick an option and let me know?
15:08:53 <huginn> AndrewFH: I'll give you the answer as soon as RDA is ready
15:08:53 <wahanui> i already had it that way, huginn.
15:09:01 <kidclamp> even if we make cross_fields optoinal, I think we should drop ES5 support
15:09:38 <Stefan> hello all! a question. I replaced the branch for our test library but when checking out book the old branch code is used. I think Koha uses value from `userenv`. What is userenv? Can I reset it somehow?
15:09:47 <Joubu> kidclamp: so a version check for 20.05 and we drop support for 20.11?
15:09:47 <kidclamp> the only reason I like a pref rather than automatic switch is that I don't know if we know everything cross_fields does and we should tend toward allowing users to configure how they want
15:10:14 <kidclamp> Joubu: yes, something for 20.05 and drop support 20.11
15:10:26 <Joubu> ok!
15:10:35 <Joubu> will you have time in the next days to provide something?
15:10:36 <kidclamp> I will work on that today
15:10:42 <Joubu> great
15:10:54 <Joubu> CC me and AndrewFH if you open a new bug report
15:11:00 <fridolin> kidclamp++ master of elastics
15:11:03 <tuxayo> Haven't we dropped Debian 8 support in a point release? Though the difference was we didn't have known breakage with D8.
15:11:11 <tuxayo> kidclamp++
15:11:38 <Joubu> I also wanted to note that I have started some benchmarks to compare each Koha version between 16.11 to 20.11. Results are not very nice so far. I will investigate and see if I can found some bottlenecks
15:12:13 <Joubu> And, finally, today I have been fighting some old ghosts^W bugs (8XXX) and will continue a bit the next couple of days, see the NSO queue.
15:12:19 <fridolin> maybe impact of ORM
15:12:26 <Joubu> that's all for me
15:12:28 <Joubu> any questions?
15:12:39 <tuxayo> Thanks for this kind of perf investigation Joubu
15:12:47 <fridolin> What did you ask Santa ?
15:12:49 <Joubu> fridolin: yes, but apparently it's coming from 19.11 specifically
15:12:49 <fridolin> ^^
15:12:56 <fridolin> oh interesting
15:13:01 <fridolin> let us know
15:13:01 <Joubu> so maybe something specific in this release
15:13:13 <Joubu> will need time to find out what's going on
15:13:16 <fridolin> UTF8-mb4 ?
15:13:46 <Joubu> I hope not
15:14:10 <ashimema> 18.11 did mb4 upgrade
15:14:54 <Joubu> it's really early findings, I need to rerun the benchmarks to confirm
15:14:58 <Joubu> I will keep you in touch :)
15:14:58 * ashimema racks brains to try and remember if anything Koha::Object went in in 19.11 that might play into this
15:15:09 <Joubu> yes, that's certainly that
15:15:18 <Joubu> maybe something we need to cache
15:15:38 <Joubu> #topic Updates from the Release Maintainers
15:15:46 <fridolin> Yep
15:15:58 <fridolin> Since its end of year fiestas
15:16:10 <fridolin> we dicided to go until 24 for string freeze
15:16:24 <fridolin> and plan release around 5 january
15:16:52 <fridolin> gives time to build a better "first release of cycle" version
15:17:52 <tuxayo> Yep, if nothing very urgent already releasable in 20.11.01, we can wait.
15:17:55 <Joubu> I don't expect much activities in the last 2 weeks however :)
15:19:09 <Joubu> ok, moving on
15:19:10 <Joubu> #topic Updates from the QA team
15:19:19 <Joubu> I should have info that
15:19:47 <Joubu> #info Next minor releases are planned for beginning of the year, on Jan 5th
15:20:57 <Joubu> QAers? All good?
15:21:30 <Joubu> well, that silence reflects QA activites in the last 2 weeks :D
15:21:33 <tuxayo> I'm able to find enough QA that I can do so good news. Though some simple changes can have implications that I'm totally oblivious to ^^"
15:22:31 <Joubu> yes, there are some easy stuffs in the queue :)
15:22:46 <oleonard> [off] Stuck in another meeting, sorry!
15:23:01 <Joubu> #topic Actions from last meeting
15:23:18 <Joubu> Postponing the first action
15:23:31 <Joubu> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this - feel free to reallocate)
15:23:40 <Joubu> #action amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
15:23:45 <Joubu> and same for the second one
15:23:50 <Joubu> I will ping Agustin
15:24:02 <Joubu> #topic General development discussion (trends, ideas, ...)
15:24:32 <Joubu> davidnind added a topic:
15:24:39 <Joubu> Release notes: I would like to suggest that patch authors as a matter of course add the release notes summary before it goes to sign off (or at a minimum after QA and before pushed). This would provide a nice summary for those reviewing, would save a massive effort at the end of the release cycle, and help the documentation team so we don't have to wade through the bug history to work out whether
15:24:45 <Joubu> documentation changes are required (particularly for very long bugs). davidnind
15:25:02 <Joubu> that's basically what I have announced on the ML last week
15:25:21 <Joubu> #link https://lists.koha-community.org/pipermail/koha-devel/2020-December/046177.html
15:25:41 <Joubu> #info The release notes are a requirement for 21.05
15:26:06 <Joubu> #info If you have patches that reach the "Passed QA" status and that the bug report does not have release notes, RM will add the "release-notes-needed".  The patches won't be reviewed and pushed until
15:26:10 <Joubu> release notes have been correctly added.
15:26:18 <Joubu> #info release notes have been correctly added.
15:26:36 <Joubu> any questions about that new rules?
15:26:47 <ashimema> Joubu++
15:26:49 <Joubu> it's not really a new rule actually, just an enforcement of an existing one :)
15:26:58 <tuxayo> For all patches? Or just features and enh?
15:26:59 <ashimema> something I wanted to introduce in my tenure, but never managed to quite achieve
15:27:08 <Joubu> for the "big things"
15:27:14 <tuxayo> ok
15:27:17 <Joubu> so "new ft", yes
15:27:27 <Joubu> "new enh", it depends on how big it is
15:27:33 <ashimema> I would say "at qa/rm's discretion"
15:28:01 <Joubu> but the idea is: if your patch is PQA WITH the bz keyword and nothing in the release notes fields, it won't get pushed
15:28:07 <Joubu> (or even reviewed)
15:29:01 <caroline> it's especially useful if anything in the user interface changes
15:29:19 <Joubu> and feel free to submit screenshots!
15:29:32 <caroline> or if the user can do new things or has to do something differently
15:30:43 <Joubu> Anything you would like to discuss before I end the meeting?
15:31:55 <tuxayo> about sysreq
15:32:23 <Joubu> hum? sysreq?
15:32:53 <tuxayo> the system recommendations and requirements are out of sync between the release notes and the CI, I'll send an email to ask what is the current state
15:33:11 <tuxayo> What to settle for
15:33:29 <Joubu> I updated the notes for 20.11
15:33:41 <Joubu> the release tools generate outdated info
15:33:55 <Joubu> RMaints need to keep them up-to-date depending on the Koha version
15:34:18 <Joubu> we could, however, centralized them
15:34:29 <Joubu> ie. a wiki page (of website) to list the different Koha versions
15:34:34 <Joubu> that would be easier to maintain IMO
15:34:43 <Joubu> and so we link to this page from the src
15:34:50 <Joubu> src and release notes
15:34:59 <ashimema> or add it to the release-tools config options..
15:35:01 <tuxayo> the src?
15:35:06 <Joubu> source of Koha
15:35:23 <tuxayo> ok like the Readme or other doc file
15:35:29 <Joubu> yes
15:35:29 <ashimema> but I agree.. that's a better idea
15:36:01 <Joubu> tuxayo: are you willing to discuss with David?
15:36:19 <Joubu> This task has been waiting for several months and we keep postponing it
15:36:34 <Joubu> would be good to help David :)
15:36:52 <tuxayo> I tried to contact them but I fear my email went to spam ^^"
15:37:06 <tuxayo> Maybe using @later is more reliable :P
15:37:49 <tuxayo> I'll get in touch with david and the RMaints to see what to advertise in the next point release
15:37:57 <Joubu> thanks
15:38:12 <Joubu> #topic Set time of next meeting
15:38:41 <tuxayo> Thanks for the new ideas for this topic.
15:38:42 <Joubu> on dec 30th for a last 2020 meeting, or we try to forget 2020 and enjoy 2021?
15:39:11 <Joubu> #info Next meeting: 30 December 2020, 20 UTC
15:39:15 <ashimema> lol
15:39:35 <Joubu> sticking to 2 weeks otherwise we will overlap with the general meeting at some point
15:39:47 <Joubu> #endmeeting